Current Features

From Audacity Wiki
Jump to: navigation, search
Audacity has hundreds of features: this page was an attempt to document all of them, but is no longer actively maintained.

Contents

Running Audacity

  • Current Audacity and legacy 1.3 series run on any version of Windows 2000 or later, OS X 10.4 or later, Linux and other operating systems. 2.0.0 ANSI is the final version available for Windows 98/ME.
  • Audacity 1.2.x versions run on Windows 98/ME/2000/XP, Mac OS X 10.0 to 10.3, Linux and other operating systems. If you are on OS 9 or earlier, you can only run the legacy Audacity 1.0.0 version.

Importing Existing Files

  • Audacity imports the following uncompressed audio FileFormats using libsndfile :
    • WAV (Windows Wave)
    • AIFF (Audio Interchange File Format)
    • AU/SND (Sun / DEC / Next)r
    • PAF (Paris Audio File)
    • IFF/SVX (Commodore Amiga)
    • Sphere / Nist WAV
    • SF (IRCAM)
    • VOC (Creative)
    • W64 (Sound Forge)
    • MAT (Matlab / Octave mat4 and mat5)
    • PVF (Portable Voice Format)
    • XI (Fasttracker 2)
    • HTK (HMM Toolkit)
  • Audacity does not care what the extension of the file is for any of the above formats. If the file is well-formed, libsndfile will correctly detect the format and import the file appropriately. Audacity fully supports 24-bit and 32-bit samples and almost unlimited large sample rates.
  • Audacity also supports virtually any uncompressed format using the Import Raw function. With this function you can also import SoundDesigner-II Files (used in the Mac-World).
  • You can import multiple files at once by shift-clicking or control-clicking on multiple files in the Open or Import dialog boxes. Alternatively, drag multiple files to your Audacity window. (On Windows, drag the files to the Audacity project window, and on Mac OS X, drag the files to Audacity's icon in the Finder or in the Dock)
  • Audacity supports MP3 and other MPEG audio files (including MP2 DVD audio) using libmad .
    • Hint: Audacity may not realize the file is an MPEG file unless it has an appropriate extension. To be sure, try renaming it so that it ends in ".mp3", and then if libmad can open it, it definitely will.
    • Audacity imports ID3 tags from MP3 files, which give the Artist, Title, Album, and other song info, using libid3tag . You can see these tags by selecting "Edit ID3 Tags..." from the Project menu. Audacity will let you save these tags if you export an MP3 file. You can write either ID3V1 tags or ID3V2.3 tags. (Audacity 1.1.1 through 1.2.0-pre1 wrote ID3V2.4 tags, which are not widely supported, so we reverted to ID3V2.3 tags.)
  • Audacity fully supports importing Ogg Vorbis files.
  • Audacity 1.3.2 and onwards supports the FLAC  lossless compression format.
  • For import and export of additional formats in Audacity 1.3.6 and later, add the FFmpeg library.

Recording audio

  • Audacity can be used to record from your computer's sound card or other audio device.
    • To select the recording device, for example if you have more than one sound card, or an external USB audio device, open the Preferences and go to the Audio I/O tab.
    • On many systems, you can choose the recording input source (e.g. microphone, line in, audio CD) from Audacity's Mixer Toolbar .
  • Audacity can record up to 2 channels (stereo) on all systems, and 4 or more channels on some systems. Audacity records only a single channel (mono) by default. Set the number of channels to record in the Preferences (on the Audio I/O tab).
  • Audacity records directly to disk, and it will record as long as you want. The approximate length of time remaining is displayed in the status bar at the bottom of the display.
  • The Pause button allows you to temporarily stop recording, but it keeps Audacity ready and waiting, so that it will begin recording again instantly when you click it again.
  • Be sure to read the Recording Tips .


Displaying the audio

  • Audacity has four main types of audio displays
    • Waveform
    • Waveform (dB) (logarithmic scale)
    • Spectrogram (shows energy in different frequencies)
    • Pitch (attempts to follow the frequency of a musical line)
  • To set the type of display for each track, use the Track pop-down menu .
  • You can resize  a track by clicking near the bottom and dragging it up or down.
  • You can zoom into a track vertically (to make quiet parts larger) by clicking in the vertical ruler.
  • You can zoom into tracks horizontally (to see more detail about less time) using the Zoom tool.
  • You can view the frequency response of a selection using the Plot Spectrum command in the View menu.


Playing audio

  • Audacity supports most sound cards and audio devices. Choose your device in the Preferences dialog, in the Audio I/O tab, then set the playback volume using the control in the toolbar. Note that the control is independent of your system's master volume control. Use your operating system to set this volume.
  • Audacity mixes down to mono or stereo. You can work with as many tracks as you want, but Audacity plays everything through either the left or right speaker.
  • Audacity automatically mixes multiple tracks and resamples all tracks to match the project rate (in the lower-left corner of the window).
  • Loop the current selection by shift-clicking the Play button or pressing 'L'.
  • If you have multiple tracks, you can listen to only some of them using the Mute and Solo buttons in each track.


Editing audio

  • Unlimited Undo lets you revert actions all the way back to when you first opened the project.
  • Undo History window lets you see all of the changes you've made, and quickly jump back to a previous point.
  • Audacity splits tracks into small blocks internally, so large cut and paste operations are quick because they don't require rewriting the entire track each time a change is made. This is different than the Edit Decision List system used by many other editors, but the effect is similar: editing is quick, and it's easy to Undo.
  • Audacity displays the current cursor position or selection bounds in a status bar in the bottom of the project window. You can change the units using the "Set Selection Format" option in the View menu.
  • Lots of basic editing operations:
    • Cut
    • Copy
    • Paste
    • Trim (delete everything except selection)
    • Delete
    • Silence
    • Split
    • Duplicate
    • Find Zero Crossings
  • Save/restore selection
  • Modify cursor and selection using arrow keys (modify with Shift and Control)
  • Envelope editor lets you adjust the relative volume of tracks over time. Just select the envelope tool (the one with the two white diamonds pointing towards a center control point) and click on a track
  • Drawing tool has three options to edit individual samples (zoom in first):
    • Click: change samples
    • Alt-click: Smooth
    • Ctrl-click (and drag): change just one sample
  • Multi-mode tool lets you select, modify envelopes, edit individual samples, and zoom, all from one tool. Which tool is active is based on the exact location of the mouse.


Mixing, panning, and warping

  • As mentioned above, Audacity automatically mixes when you have more than one track open. It automatically resamples as necessary.
  • Each track is designated as either Left, Right, or Mono. When you see a stereo track (two tracks joined together), the top one is the Left Channel, and the bottom one is the Right Channel. To change this, use the track pop-down menu.
  • Each track has a gain control that you can use to adjust its volume.
  • Each track also has a panning control that lets you give it relatively more volume in the left or the right channel.
  • Adding a Time Track lets you warp the speed of playback over time.


Generating audio

  • Built-in generators:
    • Silence
    • Tone (Sine, Square, Sawtooth)
    • White Noise
  • Plug-in generators included with Audacity:
    • Click Track (like a metronome)
    • Pluck


Applying effects

See EffectsTips for useful tips on some of the below

  • Audacity has many built-in effects and also supports plug-in effects in the LADSPA, VST, and Nyquist formats.
  • Repeat most recent effect easily with an option in the Effect menu.
  • Built-in effects include:
    • Amplify (including automatic normalization/peak calculation up to clipping value)
    • Bass Boost
    • Change Pitch (without changing tempo)
      • Audacity automatically computes the pitch of the selection and enters that frequency into the dialog. This only works for a single note, not for chords or harmonies.
    • Change Speed (changes both pitch and tempo together, like speeding up or slowing down a record player)
    • Change Tempo (without changing pitch)
    • Compressor (dynamic range compressor)
    • Echo
    • Equalization
    • Fade In (changing the volume: from no volume to actual volume)
    • Fade Out (changing the volume: from actual volume to no volume)
    • FFT Filter
    • Invert
    • Noise Removal
    • Normalize
    • Phaser
    • Repeat
    • Reverse
    • Wahwah

Managing projects

  • Audacity projects consist of a project file (.aup) and a corresponding data directory. Audacity project files are just XML, so you can read them using any text editor or XML reader. The file format is intended to be specific to Audacity, but open so that others can work with it if they're interested. Audacity projects store everything that you see in the Audacity window. They open and save very quickly, so you can continue your work where you left off.

Audacity project files are not intended to be used as a portable format, or as the primary way to store your audio. Export as a common supported format like WAV, AIFF, or MP3 for that.

  • When you create a new project, Audacity writes data to a temporary directory. You can set the location of this directory (folder) in the Preferences dialog.
  • To save time, Audacity doesn't make a copy of files when you import them - instead, it saves a reference to the original file in the project. If you prefer Audacity projects to be self contained, you can choose to always make copies in the Preferences dialog on the File Formats tab.


Exporting

  • Audacity exports to many file formats - most of the formats listed above, plus Ogg Vorbis.
  • Exporting to MP3 is supported if you download the LAME MP3 encoder separately. (LAME cannot be distributed with Audacity because the MP3 encoding algorithm is patented.)
  • Exporting to multiple files, if you have parallel label track. Note that you will get an error message "Failed to export to <path/file1.wav>", unless you:
    • Label selections, not just time points. (You can correct this manually by editing the t1-points in the XML in the project.aup-file.)
    • Adapt the sample rate prior to exporting (equal to your preference-settings).
    • The "Export location" directory/folder has to exist.


Customizing

  • All keyboard shortcuts can be customized in the Preferences dialog.
Personal tools

Donate securely by PayPal, using your credit card or PayPal account!