File Management Tips

From Audacity Wiki
Jump to: navigation, search

Contents

Project files and folders

What is an Audacity project?

Saving an Audacity project lets you save unfinished work and re-open it later in Audacity exactly as it was, with all edits and recorded/imported tracks preserved. This is a different process from using one of the Export commands in the File Menu. Export creates an audio file like WAV or MP3. Use Export whenever you want to hear your work in media players or to burn CDs, because no other programs can open Audacity project files.

There is no need to save a project. If you don't, the necessary audio data is stored in the temporary folder specified in the Directories tab of Preferences until exiting the program. At that point, Audacity offers the choice of saving a project or not.

Some benefits of saving a project:

  • No need to re-import or re-record files
  • Fast loading, even of multiple long tracks
  • Audio data always preserved in lossless quality. This is useful if you have already exported to a lossy audio format like MP3 but decide to edit the file further. Editing and re-exporting the project saves the additional quality loss of re-editing the exported MP3.

When you save an Audacity project, it creates two items inside the folder you specified for the project:

  • a _data folder bearing the name of the project, containing its audio data (in the form of many 1 MB-sized uncompressed .au files).
  • an .aup project file bearing the same project name, which is merely a text file that references the _data folder.
Warning icon Before closing a project, it is good practice to Export a WAV file which will provide a backup in case of any problems. If you have multiple tracks above each other in the project, select each track in turn (by clicking above the Mute / Solo buttons in the track), then Export the selection as WAV.

To reopen a saved Audacity project, click File > Open and open the saved .aup file (not the .au files in the _data folder). In the event of there being no saved .aup file (for example, because of a crash or power outage), see our crash recovery page.

When you have saved a project and exited Audacity more than once, legacy versions of Audacity 1.3.7 or earlier will also save an *.aup.bak backup project file and will reopen a project using the aup.bak file. This backup references the state of the project the previous time you saved and exited.

Although the .aup.bak file provides some insurance if the .aup file is accidentally deleted or corrupted, it's important if you need to use Audacity 1.3.7 or earlier that you always open the .aup file if you have it, not the .aup.bak file. Otherwise, serious Audacity internal file errors can occur.

Although you can share Audacity projects with people on other computers, it's necessary to send the other user both the .aup file and the _data folder, and the _data folder must contain a full copy of any imported files that the project contains. As the _data folder can become very large, it's often better to export a compressed file like MP3 and send that instead.

Audacity projects should not be used for long-term storage of audio. When you are completely satisfied with your exported file(s) and are certain you won't need to export further files from the project, delete the .aup file. the .aup.bak backup file (if there is one), and the _data folder, to save disk space.

Moving and renaming project files and folders

As the .aup file references the _data folder, both must be kept together inside the same folder in which you created the project. If you want to move either the .aup file or the _data folder, you must move both to the same new location.

For the same reasons, you should not rename the _data folder, even if you leave it in the same folder it was created in.

If you want to rename an existing project, the safest way is to do it in Audacity. This creates a new .aup file and matching _data folder with your chosen name:

  1. Click File > Save Project As...
  2. In the "Save Project As:" dialogue, enter the new name for the project in the "File name" box. Audacity will offer you the current name of the .aup file, so overwrite it with your new chosen name.
  3. Click the "Save" button.

To avoid confusion between the differently named versions of the same project, delete the previous .aup file and .aup.bak file (if any), together with the previous _data folder. The only legitimate reason for keeping the original project file and folder would be if you wanted to retain a snapshot of your project at a particular point in time before making further edits in the renamed project. If you do this, we recommend giving the renamed project the same name, but differentiating it by including a version number in the name.

Note that if you absolutely know what you are doing, you *can* rename the project manually. It is possible to just rename the .aup file and not rename the _data folder, but this is strongly discouraged and means you cannot make further changes to the project later on.

To rename the project manually so you can save further changes to it, you must follow these steps:

  1. Rename the .aup file for example, "renamed.aup"
  2. Rename the _data folder to the same name as the .aup file, for example, "renamed_data"
  3. Make a copy of the .aup file to be on the safe side
  4. Open the copy of the .aup file in a text editor such as Notepad
  5. Turn "wordwrap" off, look for the second line near the top of the file that starts
    <audacityproject projname=""

    and change the projname inside the quotes to point to the correct _data folder; for example, if you renamed your .aup file to "renamed.aup", the start of the second line of the .aup file should be changed to:

    <audacityproject projname="renamed_data"
    .

Making a backup copy of a project

As with a rename, the safest way to make a backup copy of a project is to use File > Save Project As....

  1. Click File > Save Project As....
  2. In the "Save Project As:" dialogue, enter the name for the backup copy of the project in the "File name" box. Audacity will offer you the current name of the .aup file, so overwrite it with the new name. It is recommended to include the date and time of the backup in the file name, without slashes; for example, type:
    backup_of_song_project_12Jan2012_10_33_AM

    which will save "backup_of_song_project_12Jan2012_10_33_AM.aup" and "backup_of_song_project_12Jan2012_10_33_AM_data".

  3. Click the "Save" button.

If you must make manual copies of projects, please do it this way:

  1. Make a new folder to contain the backup
  2. Select and copy the original .aup and _data folder
  3. Navigate into the new folder and paste the copied .aup and _data folder.

Because the copied .aup and _data folder are now in a different folder, Windows (or you) do not have to rename them. This way, the .aup file will always reference the correct _data folder.

Avoiding loss of project audio due to missing dependent file

The following issue does not arise if importing compressed data such as an MP3 or OGG file, as Audacity automatically makes a copy upon import.

Legacy 1.2.x and 1.3.0 versions of Audacity.

By default, Audacity imports uncompressed files such as WAV or AIFF by reading them directly from the file. This is normal practice with media editors and both speeds up the import considerably and avoids the rapid consumption of disk space that copying the file would involve. However, this means you need to keep the imported WAV or AIFF file available for Audacity to use, in the exact file path it existed in when you imported it.

Therefore the project will have either no sound, or sound only in places, if you do any of these:

  • move the WAV or AIFF file to another location
  • delete it
  • rename it
  • disconnect the removable source it resides on
  • open the project on another computer without copying the dependent WAV or AIFF to the same path on that computer

This is true even though the waveform is visible on the screen, because the waveform is only a representation of the audio made when it was first imported. Any regions that do have sound will be those edited while the original audio file was still in place.

To correct this situation, open the .aup Project file in a text editor such as Notepad. The file(s) originally used to read data into the project are marked in the .aup file as "aliasfile". Use the text editor's "Find" function to search for "aliasfile" (without quotes), and note the full path to these files that is stated in the .aup file e.g. aliasfile='C:\My Music\Music22.wav'

Restoring the files noted as aliasfiles to the exact path noted in the .aup file will restore full sound to the project.

To avoid this problem in future when importing uncompressed files, either retain the original audio file (in its correct location) or set Audacity to make a copy of the file, which will then be stored in the Project's _data folder when the Project is saved. To set Audacity to make a copy of the imported file, go to the File Formats tab of Preferences, find "when importing uncompressed audio...." then check the radio button Image of selected radio button make a copy of the file before editing (safer). Click OK to save the change.


Current 2.0.x and legacy 1.3.2 + Audacity versions

In all these versions you still need to keep the imported WAV or AIFF file available for Audacity to use, in the exact file path it existed in when you imported it, if you do not copy the file in.

However in current 2.0.x versions onwards (and also in 1.3.13 and 1.3.14 before that), Audacity will by default warn you when importing WAV or AIFF files and give you a choice to copy them in to the project or not. It is strongly recommended to copy the files in, which will then be the default choice offered when you import WAV or AIFF files next time.

In any version from 1.3.2 onwards, you can check if you have dependent files at any time by choosing File > Check Dependencies.

Also in 1.3.2 onwards, if you exit a project that depends on imported WAV or AIFF files, Audacity will by default show a dialog providing the option to copy the files into the project to make it self-contained. The dialog also gives options to always copy data into the Project, never do so, or always ask what to do. These three options can also be accessed in the Import / Export Preferences (or in the File Formats Preferences in legacy 1.3.2 to 1.3.4).

See Audacity Projects in the current Manual for more information.

File and folder errors

Directory write-protected or disk full error when writing WAV/AIFF

This tip applies to legacy 1.2.x and legacy 1.3.0/1.3.1 versions of Audacity.

You will receive the above error if you both:

  • when importing uncompressed audio data such as a WAV or AIFF file, use Audacity's default behaviour of reading the data directly from the original file, and
  • export your Project's audio data to the same file name and directory as the file you imported

The problem occurs because Audacity cannot delete the original file in order to overwrite it when it is already reading it. (This issue does not arise if importing a compressed audio file such as an MP3 file, because in the case of compressed audio Audacity automatically makes a copy upon import.)

To avoid this problem in legacy 1.2.6, either

  • save the exported WAV or AIFF to another file name or another directory, or
  • set Audacity to make a copy of the imported file: go to the File Formats tab of Preferences, find "when importing uncompressed audio...." and check the radio button "make a copy of the file before editing (safer)". Click OK to save the change.


In current Audacity, this problem is handled differently, and the steps needed in legacy 1.2.6 are not needed. If Audacity is set to make a copy of the original file, you can overwrite the original file just as in legacy 1.2.6. If Audacity is set to read directly from the original file, it will rename the original file by appending "-old1" to its file name, allowing you to export the edited audio as the original filename. Once you are happy with the newly exported file, delete the original file with the "-old1" suffix.

Context menus

A context menu is the menu of options accessible when you right-click over a file in the operating system's file manager (for example, Explorer in Windows). The following information applies to Windows, but similar principles apply to other operating systems.

Open with

This context menu item allows you to open the file with programs other than the default program associated with that file type. You can add a program to the "Open with" menu and choose if that program will now be the default program to open that file type when you double-click it.

Once a program has been added to the "Open with" menu, it will be listed when you hover over "Open with". If you add Audacity to "Open with", this provides a way to open files with Audacity when it isn't already running, but retain the default double-click action to play the file with Windows Media Player. If a track is already open in Audacity when you execute "Open with", your file will be opened in a new project window.

Warning icon On Windows, the Audacity executable cannot be added to Explorer's "Open with" menu if there is already a Registry entry pointing to another "audacity.exe". This is a Windows limitation. It could arise when you update from legacy Audacity 1.3.x (which had its own installation folder) to current Audacity. Try any of the following workarounds.
  • Use the Open with > Choose default program... dialogue to browse to the required executable each time.
  • Rename one executable to a unique name such as "audacity_2.exe", then use Open with > Choose default program..., browse to the renamed executable then enable "Always use the selected program to open this kind of file".
    • If you update Audacity again, you must rename the new audacity.exe to the same name you used before, or add a new association to the new executable renamed to another name.
  • Download and run this registry file as administrator. Rename it to "AudacityAssociationCleaner.reg" (without quotes) before running it.
  • Install CCleaner and run its Registry cleaner as administrator.

Custom context menus

To give more direct context menu access to Audacity, Windows lets you add a custom context menu item of your own for a file type, such as "Edit WAV in Audacity".

To create a custom context menu item in Windows 98, ME, 2000 or XP:

  1. Click Windows Start button > (Settings) > Control Panel > Folder Options, or Tools > Folder Options from inside Explorer
  2. Click on the File Types tab
  3. Navigate to the file extension for your context menu item, such as WAV, and click "Advanced"
  4. In the window that appears, click "New" to add a new context menu item (or to change an existing item, click "Edit")
  5. In the "Action" box, type or change the entry as you wish it to appear in the menu (for example, Edit WAV in Audacity)
  6. In the "Application used to perform action" box, type the full path to the Audacity executable inside quotes, followed by %1 inside quotes, for example:
    "C:\Program Files\Audacity 2.0.0 (Unicode)\audacity.exe" "%1"
  7. Click OK, OK and Close.

Windows Vista and 7 lack any direct way to either create or edit custom context menu items. You can use a free third-party application called Default Programs Editor for this purpose.

Warning icon File names including spaces:

Don't forget the "%1" after the path to Audacity. If this is missing, Audacity will think file names including spaces are separate files, and give an error for each one, or not open the file at all. As a quick alternative to editing an incorrect context menu entry, replace the spaces in the filename with an underscore, for example:
C:\Multimedia\audio_files\very_beautiful_melodies.wav

Opening multiple files from the context menu

"Open with" on Windows only supports opening one file at a time.

Using legacy 1.2.x versions of Audacity under Windows, you cannot right-click and open multiple files, or right-click and open any files if Audacity is already running; this will give an "Audacity already running" error. This is fixed in the the current version of Audacity. Each file will open in a new project window.

Other ways to open a file or files without having to launch Audacity first are to select them and then press Enter; or select them then drag them onto the Audacity icon (for example, on your desktop or in your Program Files folder).

Reopening large projects in Audacity 2.0.5 or earlier

Gale 28Nov13: ToDo-2 Can be tweaked to refer to "current Audacity" not having this problem after 2.0.6 release.
  • Peter 14Apr14: Surely we can just remove this section after (2.0.6 release *AND* Wiki-split for the Non-legacy Wiki).

Audacity 2.0.5 or earlier cannot re-open saved projects where an individual clip or track reaches or exceeds 2^31 samples in length (just over 13.5 hours at 44100 Hz track rate). At higher rates, this equates to less than 13.5 hours. At lower rates you can reopen tracks or clips longer than 13.5 hours. If the track limit is breached, the entire project will reopen with with silenced audio and "orphaned block files" errors.

You can save projects containing multiple tracks which have less than 2^31 samples or audio, even if the total audio in the project exceeds 2^31 samples. So for example, three 44100 Hz tracks of 13 hours each can be saved as a project.

Official advice

  • To avoid tracks of 2^31 samples or longer failing in Audacity 2.0.5 or earlier: Export WAV files before closing the project, ideally as soon as you press "Stop" after recording.

    WAV files should not exceed 2 GB in size for practical purposes, and the absolute maximum is 4 GB. For longer lossless files you can use FLAC on Mac or Linux (there is a 2 GB size limit in Windows). On any platform in Audacity 1.3.13 or later you can export larger lossless files up to about 16 exabytes in size using RF64. RF64 will be about the same size as WAV files (that is, about twice as large as FLAC). To export as RF64, choose "Other uncompressed files" then click Options....

    If you must save a project, copy-paste sections not exceeding the length limit to new Audacity project windows then save each window as a separate project.

  • To fix a saved project that is at or in excess of the 2^31 samples limit:
    • Open the project in the latest 2.0.6-alpha. The project should open correctly in that build if it does not have any other problems. Or using your current version of Audacity, try either of the following procedures.
    • Split the project into smaller projects, adjusting each AUP file so that the "h" value is zero, the correct _data folder is pointed to and the "numsamples" and "waveblock start" values are corrected (a script must be used to perform this correction because thousands of values will be involved). See http://forum.audacityteam.org/viewtopic.php?p=214543#p214543.
    • Do not use the AUP file but split the data into smaller _data folders. Each folder should not exceed 1 GB in size. If the project was created in Audacity 1.3 or later, time-sort the AU files in each folder then rename the files into a consecutive sequence. Use the Audacity 1.2 Recovery Utility to recover each folder to a separate WAV file (one WAV per stereo channel), then import the WAV files into Audacity and join them together.

      This method may cause some sections of left and right stereo channels to be transposed on Windows FAT32, Mac OS X and Linux (ext3 or earlier) file systems due to their limited timestamp granularity. Also, only unedited recordings can be recovered in correct timeline position by this method. See the Crash Recovery page for details.

User experience in legacy Audacity 1.3.7

Warning icon Note that the user-supplied procedure documented below to split a large project will not recover the complete project in Audacity 2.0.5 or earlier in the case of a recording whose length reaches or exceeds the 2^31 samples limit. Since this limit is just over 13.5 hours at 44100 Hz, the problem described below appears to be something else, possibly an old Audacity bug.

Contrary to the information below, additional checks for faulty sequence tags have been introduced into current Audacity. The "numsamples" value is required in the sequence tag and the "waveblock start" values must be adjusted to start from "0" in each split project. Audacity will automatically attempt these repairs until it encounters a "numsamples" or "waveblock start" value of or in excess of 2 147 483648. Audio after that point cannot be displayed.

Recently I ran into a problem where audacity just wouldn't open my 11GB gigantic project. I did a recording of a radio show for about 9 hours. What i did was to divide the project into smaller ones - each about 2 hours. My recording was in stereo, 44100kHz, 16Bit. HowTo
  1. - make a backup copy of your .aup file (name it project_orig.aup).
  2. - make a template copy of your .aup file (name it project_templ.aup).
  3. - open project_templ.aup and delete the contents between the <sequence ...></sequence> tags, contained in <wavetrack>. Note that there are 2 <wavetrack> tags in a stereo file!. You'll use this template to copy <waveblock> tags into.
  4. - copy project_templ.aup to project.aup, open it and find the attribute "numsamples" in the <sequence ...> tag you already know. divide numsamples value by the number of parts you will divide your project into. i got something like 309000000. i rounded it off to 300.000.000. delete this numsamples="xxx" attribute of the <sequence ...> tag in both channels. audacity seems not to need it.
  5. - copy the <waveblock ...> tags until their start attribute value exceed 300000000(x count of repetition) between each <sequence ...> </sequence> tags. note, for a stereo file you'll have to do this twice because there are two separate channels (contained in wavetrack)... but i already mentioned this.
  6. - bhu.. quite large file.
  7. - open this project.aup file
  8. - When audacity ask you "Project check found XXXX orphaned blockfile[s]. ..", answer with "Continue without deleting" - because this was just intended.
  9. - edit as you need. best thing is to export the file to a new aup project, flac, ogg or whatever.
  10. - repeat the steps 5-9 until you're done.
  11. - praise audacity because you wouldn't be able to record such a huge project with wavelab on windows.
System information:
  • Audacity 1.3.7 (from Ubuntu repositories)
  • Ubuntu 9.04 Gnu/Linux
  • ext4 Filesystem
Personal tools