Mixer Toolbar Issues

From Audacity Wiki
Jump to: navigation, search
Peter 15Mar14: ToDo-2 Potentially this page could be deprecated? Gale wrote of this page in an email on 14Mar14: "A lot of that material at the top of that is "legacy" but if the legacy version is 1.3.13 or later. then much of the page applies. Perhaps that means we just leave the page "as is" for sending a copy to a legacy Wiki ?"
  • Gale 02May14: The Windows sections for the control panels vistacp and xpcp are linked to every day from Forum answers.
  • Peter 4May14: A fair point Gale - but is it linked to for users of current Audacity or users of obsolete versions? If it's for current version users than this page could be moved to the manual - the obsolete legacy users can be pointed to the parallel page in the Legacy Wiki - that is what the Legacy Wiki is for, supporting obsolete users surely.

    The advice note below states "is mainly for users who need to use legacy Audacity 1.2.x or 1.3.x." that's why I was inferring this page could be deprecated from the main Wiki, which is for the current version of Audacity.

  • Steve 12May14: I would suggest leaving this page as is for the legacy wiki, and severely trimming it down for the current wiki. My impression is that if we remove the information that no longer applies, then the "Alerts" for modern Windows can be moved into the normal text flow. The "Windows Control Panel" section is very heavily linked to on the forum, though could perhaps be updated to put more emphasis on using WASAPI for recording sounds playing on the computer and much less emphasis on "Stereo Mix".
    • Peter 15May14: Of course it remains (and will remain) in Legacy Wiki - that is what the "Legacy Wiki" is for - users of legacy/obsolete versions of Audacity. My point here is that this looks like an entirely legacy page and can thus be deleted from current Wiki. Or am I wrong and there are sections of this page that should remain for current Audacity users?
      • And I'm not sure why we're still talking about XP now that Microsoft have discontinued support. It is some thing that imo we should actively discourage (as Gale does on the Forum). Effectively XP is now a legacy/obsolete operating system - so its presence in Legacy Wiki would be ok - but in current Wiki should be deprecated if this page remains here.
    • Gale 18May14: I changed this to PS. As Steve says, the #vistacp and #xpcp anchors here are linked to every day to give support for current Audacity. My suggestion is that this page becomes a Windows-only page called "Windows System Mixer" (though if we want to move the page, the #xpcp and #vistacp anchors will need redirecting in the .htaccess file on the server). I will need to go though the page above the Windows Control Panel sections and see what if anything to retain (so please don't just delete that content).

      The #xpcp anchor is mandatory while Audacity officially supports XP. My Forum dissuasions about it are only about security, nothing else.

      The Mac section is outdated and could be moved to Mac OS X or whatever becomes of that. I've rewritten the Linux section to be relevant to current Audacity, but Steve can check it over. That Linux section can then be moved to Linux Issues.

  • Peter 10Jun14: I transferred the Mac section to Mac OS X as Gale suggests. I have asked Steve to take a look ot the Linux section.


Warning icon This page contains important information for users of current Audacity on Windows about enabling inputs in the Windows Control Panel.

Contents

Mixer Toolbar issues and input device selection

In current Audacity, all available inputs are selected in Device Toolbar or Devices Preferences.

However one of the common problems encountered with the Mixer Toolbar in legacy Audacity 1.3.12 or earlier is that its input selector can appear greyed out or lacking the expected choices, thus apparently preventing the user choosing the required recording source. The purpose of the selector (as with Device Toolbar) was to link to the current mixing device (assuming this device offers a choice of input sources) and thus save the user going through a series of system menus to choose the source.

Recording Device

It is often assumed that Audacity controls the input sources displayed, but in fact the sources offered are governed by the drivers of the sound device that is currently selected in the Audacity Preferences. Drivers are a big issue on Windows machines, and it often happens that machines purchased new will only be supplied with generic Microsoft drivers. This may prevent the audio device linking properly to the system mixer, so you may end up always recording from line-in, or cannot apparently record at all (whatever input source you choose). Another issue may be that you won't see all the inputs that your device potentially offers.

So the first step towards rectifying input problems is to open the Preferences and choose Devices ( Audio I/O tab of Preferences in legacy Audacity 1.3.7 or earlier ). Find out what inputs are available and ensure that the playback and recording devices are explicitly set to the correct device you want to use. For example you may have multiple sound devices such as built-in sound and an external USB device, so you need to choose between them. If you are on Windows and experiencing problems, choose your sound device explicitly, not Microsoft Sound Mapper (which is intended to map to the currently selected default Windows sound device, but may not always do so correctly).

Warning icon Note that on Windows Vista, Windows 7 and later, initial driver setup typically disables all the inputs except for the built-in microphone. It is strongly recommended to use the Sound Control Panel to show and enable all disabled devices so that recording programs like Audacity can see them.

Device selection for inbuilt devices on Windows

Note that some sound devices have individual analog to digital converters (ADC's) for the different inputs such as microphone and line-in. Where this is the case, these inputs are treated as separate recording devices on Windows XP and earlier (for example, "Line-In: Realtek" or "Microphone: SoundMax"). These inputs can be most conveniently selected in Device Toolbar in current Audacity but in legacy Audacity before 1.3.13 they must be selected in the Audio I/O or Devices tab of Preferences and not in the Mixer Toolbar selector which will be greyed out.

Windows Vista and later always treat recording sources as separate "devices", so on these systems the Mixer Toolbar selector in legacy Audacity will be greyed out and inputs must be chosen in the Audio I/O or Devices Preferences.

Warning icon For Windows Vista and later it is particularly important that you use current Audacity otherwise Audacity may crash when you stop recording. In current Audacity, all input devices are conveniently located in Device Toolbar.

USB and Firewire recording devices

Note that if your selected recording device is a USB or Firewire device, these normally do not have multiple input sources to choose from, so Device Toolbar or Preferences will only list the device as a single choice and the input selector in legacy Audacity will grey out. This is normal, and just means that input choices must be made in the device itself, or in any control software that comes with it. Examples of devices which will normally not allow input selection in Audacity are the Griffin iMic, USB turntables or USB cassette decks and a wide variety of USB and Firewire mixers and interfaces.

Multi-channel recording devices do allow limited input channel selection in Audacity where the drivers support this, though only a few devices on Windows allow recording more than a pair of two channels at once unless you compile Audacity with ASIO support.

Device already in use

Also check your sound device is not already in use. If you are on OS X or Linux and the sound device is already being used by another application, Audacity may not be able to access it for recording. As a result, Device Toolbar, Preferences or the legacy Mixer Toolbar input selector may be empty of devices. Generally, this is not a problem on Windows as long as you choose MME host in Audacity, though issues with some applications are known. For example, speech recognition in Word, Skype or the Fraps screen capture software may prevent other applications from using the sound device to record from a microphone.

Further help

If you've got this far and the problem is not solved, go to the appropriate section below your operating system:

and then if you still have problems, go to our page on Updating Sound Device Drivers.

Windows Problems

Card Not Supported

Some high-end multi-channel cards on Windows systems don't use the standard Windows mixer interface and volume control, but instead supply a custom mixer application which Audacity can't hook in to. In these cases you need to select the recording settings and levels using the custom mixer application shipped with the sound card. Recording should work as normal with the card however.

Windows Vista / Windows 7 / Windows 8

Warning icon We strongly suggest you obtain the current version of Audacity then read our further information about Windows Vista, Windows 7 and Windows 8.

The most recent Windows operating systems (Vista and later) treat individual recording sources such as line-in, microphone and "stereo mix" as recording devices in their own right. As a result, in legacy Audacity 1.3.12 or earlier, the Mixer Toolbar input selector will be always be greyed out by default.

If you absolutely need to use 1.3.12 or earlier on Windows Vista or later, you may be able to make input sources appear in the input selector by running Audacity in compatibility mode for Windows XP. To do this, right-click over audacity.exe in Windows Explorer, then click Properties, then the "Compatibility" tab. This isn't a generally recommended solution.

Otherwise, in current Audacity select recording inputs at Edit > Preferences: Devices tab, in the "Recording Device" drop-down (this drop-down is in the "Audio I/O" tab in legacy Audacity 1.2.x). In current Audacity, recording devices can also be viewed in Device Toolbar. To enable this toolbar, click View > Toolbars > Device Toolbar. Here is an example of recording inputs in Preferences for two different physical devices (an inbuilt sound device and an external USB sound card):

  • Microphone: Realtek HD Device
  • Line-In: Realtek HD Device
  • Microphone: USB Audio
  • Line-In: USB Audio
  • Stereo Mix: USB Audio

If selecting a particular input does not work, or you don't see the input you want, try selecting it in the Windows Control Panel (see the next section below).

Using the Control Panel

Accessing the system mixer in the Windows Control Panel and trying to select your required input there may often allow you to record into Audacity, even if the input you want isn't in Device Toolbar or Devices Preferences (Mixer Toolbar or Audio I/O Preferences in legacy Audacity), or isn't recording properly.

HELP WITH RECORDING COMPUTER PLAYBACK OR STREAMING AUDIO

Warning icon On Windows Vista, Windows 7 and Windows 8, current Audacity can record computer playback even on sound devices lacking that ability. To use that feature, choose "Windows WASAPI" host in Device Toolbar, then the output device you want to record from, then the "loopback" input for that device. This "loopback" device does not need to be enabled in the Windows "Sound" control panel. For details, see Recording Computer Playback on Windows .

If the computer sound device itself has an input for recording sounds the computer is playing, it can go by various names such as: "Stereo Mix", "Wave Out", "Sum", "What U Hear" or "Loopback". The exact name (and whether you have such an input) depends on the drivers of your sound device. Worse, this input source is often hidden by default in the system mixer.

Sometimes "Stereo Mix" can only be made to work by using the control panel supplied by the sound card manufacturer - this is often reported with RealTek inbuilt sound devices. Try launching the sound device control panel from the Windows Control Panel or the system tray (by the clock). If you see a volume control for Stereo Mix, try clicking to select it. Confusingly, some RealTek devices "select" an input by muting all but one, so in this case, mute everything except stereo mix. If you don't see Stereo Mix, click the wrench icon and enable Stereo Mix in the dialogue that pops up. In some RealTek versions the option to check is "Enabled recording multi-streaming". You should now see a volume control for Stereo Mix. Remember to select or unmute it as above. See this Forum topic for more help with RealTek.

Be aware that on some machines, the "Stereo Mix" option will never work because it is disabled internally by the driver settings due to copyright concerns. This is a known issue with Lenovo Thinkpad laptops, but sometimes editing the driver files can enable stereo mix.

If all else fails, you can connect a cable from the line-out (green) port of the computer to the line-in (blue), and choose the line-in as recording source. If you need to hear what you're recording, you can buy a single stereo to double stereo adaptor that will give you a spare jack to plug the speakers into. Alternative suggestions follow below.

  • SoundLeech is a free evaluation program running from the system tray. It records only to WAV, direct from the program producing the sound, without the need for a sound device that can record computer playback.
  • TotalRecorder is a low cost recording package. Internet streams can optionally be captured at faster than real time rates (monitoring is not available in that mode).
  • Buy an external USB sound card, which normally offer a "stereo mix" type of option, such as the Trust Sound Expert External.

Windows Vista / Windows 7 / Windows 8

On Windows Vista / Windows 7/ Windows 8, the quickest way to access the mixer is to right-click over the speaker icon in the System Tray > Recording Devices. Or click Windows Start > Control Panel > Hardware and Sound > Sound (if you're using "Classic View" there's a direct link to "Sound" in the Control Panel), then click on the "Recording" tab.


Vistarec.png


It is common on Vista and later that not all recording inputs are automatically enabled in the main Recording tab. This means they are invisible in that tab, and also invisible to recording applications like Audacity. So you need to make them visible, then enable and make default the main one you want to use, following the steps below.

Warning icon All the settings below are specific to each recording or playback device. Therefore after enabling, making default and adjusting settings for your main recording and playback devices, it is best to enable and adjust settings for each other device you want to use.

Recording Settings

  1. Right-click anywhere inside the Recording tab and choose "Show disabled devices" then right-click again and check "Show Disconnected Devices".
  2. For a device having a physical input like line-in or microphone, connect the required cable and make sure it fits tightly - a physical device not connected may show as "currently unavailable".
  3. Right-click specifically over the input device you want to record with (for example, line-in or "Stereo Mix"), and if visible, choose "Enable".
  4. Right-click once again over the input device you want to record with, and choose "Set as Default Device".
  5. Right-click once again over the input device you want to record with, click Properties then the Levels tab and ensure the volume slider is turned up.
  6. Right-click once again over the required input device, click Properties then click the Advanced tab.
    1. Set Default Format to mono or stereo to match with the number of "recording channels" in Audacity's Device Toolbar or the Devices tab of Audacity Preferences (Audio I/O tab in legacy Audacity 1.3.7 or earlier).
    2. Set the sample rate in Default Format so that it's the same as the project rate bottom left of the Audacity screen. 44100 Hz is a safe choice if you are unsure. Now click "OK".


Adjust Communications Settings (even if you don't make internet calls)

Windows sound settings are often optimised for VoIP (internet calls or video conferencing) using programs such as Skype, but these settings can interfere with high quality microphone recordings of music.

  1. Look for and turn off all sound enhancements and any other sound effects unless you need them. To do this, right-click over "Microphone", choose Properties then look for an Effects or Enhancements tab where you can disable all effects.
  2. On Windows 7 or Windows 8, also click the main Communications tab, then under "When Windows detects communications activity:", choose "Do nothing". This should prevent unwanted playback volume changes when recording computer playback or when recording over playback of another track.
  3. If you do make internet calls and require to use specific devices for calls, proceed as follows.
    • To use a particular microphone only for calls, right-click over that device and choose "Set as Default Communication Device" (a green "telephone" icon will appear by the device).
    • Similarly, to use for example headphones as playback device for calls and speakers or other devices for music, choose the Playback tab at the top of "Sound", right-click over the device to use for calls and choose "Set as Default Communication Device".
    • If you want to use a headset for calls, choose "Set as Default Communication Device" for the headset on both the "Recording" and "Playback" tabs.


Playback Settings

Now choose the main Playback tab if you are not already there.

  1. Right-click over your desired "Speakers" or "Headphones" sound device and if visible, choose "Set as Default Device". If the right-click menu also shows "Set as Default Communication Device", choose that as well, then by default all programs will use that device.
  2. Right-click over your desired device again, choose Properties then the Advanced tab, and set Default Format to a stereo choice with the same sample rate you chose in step 6.2 of the "Recording Settings" above.
  3. To ensure the sound card does not add unwanted playback or recording sound effects like "Cathedral" or "Closet", look for Levels, Custom or Effects tabs and turn off all effects that are not required. Click "OK" as required to close Windows "Sound".
  4. Now open the Windows Control Panel and look for any control panel that the sound device itself may have. Make sure again that no unwanted effects are being applied.


Audacity restart and settings

  1. To make Audacity aware of all the changes in Sound, restart Audacity or use Transport > Rescan Audio Devices (not available in legacy Audacity 1.3.12 or earlier).
  2. In Device Toolbar or Devices Preferences, make sure MME host is chosen, then choose the output (playback) and input (recording) device you require. If you choose "Microsoft Sound Mapper - Output" and "Microsoft Sound Mapper - Input" then this should select the "Default" playback and recording devices you chose in Windows "Sound" above.

Alternative settings if crackly recording or playback occurs, or if recordings made while playing other tracks are not synchronized: (requires Audacity 1.3.7 or later)
  1. Open Windows "Sound", choose the main "Recording" tab then right-click over your chosen recording device and choose "Properties". Click the "Advanced" tab, then put a checkmark (tick) in both Exclusive Mode boxes.
  2. Choose the main "Playback" tab then right-click over your chosen playback device, choose "Properties," click the "Advanced" tab and similarly enable both Exclusive Mode boxes.
  3. Restart Audacity or use Transport > Rescan Audio Devices then choose Windows DirectSound host in Device Toolbar or Devices Preferences.
    • In Exclusive Mode, the sample rate selected in "Default Format" no longer applies, so be sure at bottom left of Audacity to choose a project rate that your device supports.

Windows XP or earlier

On XP or earlier, right-click over the speaker icon in the System Tray > Adjust Audio Properties. Or you can click Windows Start > (Settings) > Control Panel > Sounds, Speech and Audio Devices > Sounds and Audio devices.

Warning icon This Control Panel applet is called "Sounds and Multimedia" in Windows 2000 and ME, and "Multimedia" in Windows 98, so looks slightly different to the image below.

First, click on the Audio tab, and in the "Sound Recording" panel, select the correct "Default device" from the drop-down list and click "Volume":

Xpau.PNG


and select your input by putting a mark in the check box, and turn up the volume slider:

Xpcp.PNG


Note that input sources are sometimes available to use, but hidden. If you cannot see the input you're looking for, click "Volume" under the "Sound Recording" panel again, then Options > Properties. Select your sound device in the Mixer Device panel, and ensure all the boxes in the window below are checked:

Xppr.PNG


Click OK. To make Audacity aware of the changes, restart Audacity or use Transport > Rescan Audio Devices (not available in legacy Audacity 1.3.12 or earlier). If the input you wanted was in the Windows list, it will now be available to select in Audacity.

If the input you want cannot be made available or made to work , or if you want the convenience in legacy Audacity 1.3.12 or earlier of selecting the input in Audacity's Mixer Toolbar, see Updating Sound Device Drivers.

OS X-specific issues

See this page.

Linux-specific issues

No devices available

If Device Toolbar or Devices Preferences show no playback and/or recording devices, this means there are currently no audio devices available to, or recognized by Audacity. There are a few possible causes of this.

  • You don't have the correct permissions to access the sound device, perhaps because you need to add your user to the "audio" group.
  • If your system does not use PulseAudio or if you choose the (hw) device in Device Toolbar, another audio program, sound server or service is using the sound device. You will need to disable applications or services that are using the device before Audacity can access it, or share the device among applications using JACK.
  • If you choose the OSS host (where available) in Device Toolbar, you must check that /dev/dsp (the OSS device) is present. It may be possible under OSS to share the sound device with another application if you use the wrapper provided by aRts and launch Audacity using:
    $ artsdsp audacity

    Note: some users report recording issues when using the aRts wrapper.

Only default or sysdefault devices available

If only "default" or "sysdefault" devices are available in Device Toolbar, you can select the required devices in ALSAmixer.

Mixer Toolbar disabled

If Audacity's Mixer Toolbar output and input level sliders are missing their hover tooltips and grayed out on zero volume (or have no audible effect), then Audacity has been built without PortMixer support. You can choose Help > About Audacity... then the Build Information tab then the "Features" section to check if PortMixer is disabled.

To enable Audacity's Mixer Toolbar, you can compile Audacity from source code omitting --with-portmixer=no from your ./configure options (or give no ./ configure options at all). See Compiling Audacity for Beginners for help.

Mixer Toolbar input slider grayed out on maximum

If Audacity's Mixer Toolbar input slider is grayed out on maximum volume, this means Audacity cannot control the system input slider for the input device selected in Device Toolbar. Use the system mixer instead to adjust the input volume of the device.

On systems using PulseAudio you can install PulseAudio Volume Control (pavucontrol) from the distribution's repository, then use pavucontrol to choose the input device and control its input volume. On systems without PulseAudio installed, you can use ALSAmixer.

Personal tools

Donate securely by PayPal, using your credit card or PayPal account!