Release Notes 1.3.10

From Audacity Wiki
Jump to: navigation, search
The text on this page should only be modified by subscribers to Audacity-devel mailing list.

To understand what this page is for and how it is used, please join that list or read the list archives on Sourceforge.
The discussion page can be used by anyone to make suggestions and comments about this page.


Audacity 1.3.10 was available between 1 December 2009 and January 17th 2010 for Windows (2000, XP and Vista), Mac OS X and Linux. It was the recommended version for Windows 7, but full support was provisional - see the Known Issues section for details. Audacity 1.3.7 is the latest available Beta version for Windows 98 and ME.

These Release Notes describe:

  • Changes to 1.3.10 Beta as compared with 1.3.9
  • Issues with 1.3.10 Beta which were known at time of release
 
Related article(s):

Contents


Warning icon Notes for Windows:
  • MP3 export from Audacity 1.3.7 and later requires the latest version of the LAME encoder
  • The Windows installer will not replace 1.2.x installations, but will install alongside them

Items struck out have been fixed in the latest development code, meaning that if you compile Audacity yourself from that code, or use one of our nightly development builds, these issues should not occur.


Changes in 1.3.10

Bug fixes

  • Imports and Exports:
    • Freeze importing audio files when Default View Mode set to Pitch (EAC)
    • Simultaneous On-Demand imports sorted incorrectly
    • WAV or AIFF files imported as noise if Preferences set to copy in the data at 24-bit quality
    • WMA exports corrupted if they contained metadata
    • Metadata Editor appeared before the Export window when exporting to any format
  • Effects and analysis:
    • Crash or hang using Equalization on longer tracks
    • Reverse did not reverse clip boundaries
    • Nyquist:
      • Excessive memory consumption led to slow processing or crashes
      • Values appearing in text boxes not always the default or previously entered values
      • Errors running in European locales where comma used as decimal separator
    • VST effects remained in Effect menu even when re-scanned and no longer available
    • Truncate Silence produced incorrect results if silences spanned a block boundary
  • Other bug fixes:
    • Spurious "not writable/disk full" errors when saving projects
    • Playing, rendering or exporting multiple tracks led to desynchronized playback or loss of audio data
    • Crash opening Preferences when no recording and/or playback devices enabled or connected
    • Preferences window: OK button did not respond to ENTER when a tab selected in left-hand panel
    • Mixer Board solo button handling
    • (Windows) After a period launching correctly, Audacity sometimes did not come up on top at launch
    • (Mac OS X) Correctly installed Help folder could not be found
    • (Mac OS X and Linux) Output slider could affect VU playback meter which then did not reflect actual waveform volume level
    • (Linux) Undoing or redoing a label edit could cause a crash

Changes and improvements

  • Linked audio and label tracks disabled until a future Beta version so they can be bug fixed
  • Input volume slider will be disabled if it doesn't have proper control of system slider; use the system slider instead
  • Proper support for copying/pasting label-with-audio including label text
  • New "Edit > Paste Text to New Label" menu item to paste system clipboard
  • Contrast Tool now modeless
  • More intuitive handling of multiple project windows
  • Various other minor improvements


Known Issues at Release

Cross-Platform bugs

  • Imports:
    • On-Demand WAV/AIFF import not available if using the optional FFmpeg importer (that is, if "FFmpeg-compatible files" set in the import dialog)
    • (Windows) The Audacity executable cannot be added to the Explorer "Open With" menu if you have another version of Audacity also called "audacity.exe". You can set the file association to always use the Audacity Beta executable to open the required file type, but it will not appear in the list accessed by the "Open With" context menu item whilst there is another "audacity.exe" on the computer.
    • (Linux) Metadata in imported FLAC files not visible
  • Exports:
    • Album art and lyrics in imported metadata lost when exporting
    • WAVEX (Microsoft) headers: GSM 6.10 files cannot be exported, and U-Law/A-Law files may not be playable.
    • M4A: exports at 38000 Hz may not play properly (FFmpeg bug); M4A renamed to MOV will not play on Windows in iTunes or QuickTime
    • Muting specific time-shifted mono tracks produces audio at wrong point on timeline in exported file if muted tracks are to left of unmuted.
    • (Windows) Exported "Comments" ID3 tag not recognised by Windows Media Player or Explorer
  • Genre WAV info tag (IGNR) not supported due to limitation in libsndfile.
  • It is currently possible to attempt simultaneous imports or exports by using shortcuts (or File > New on Mac): Audacity is not yet capable of running these simultaneous operations safely, and attempting this may crash your project.
  • Effects and Analysis:
    • Truncate Silence may not give intuitive results on multiple tracks.
    • Nyquist effects join separate clips together
    • LADSPA Multiband EQ (optional download) may not be visible in the Effect menu, or may crash in use
  • Label tracks:
    • Typing "j" or "k" in a label may activate the "move cursor" shortcut instead
    • Multiple labels cannot be added to the same label track using Nyquist Analyze effects or Nyquist Prompt. Workaround: move the audio track below the label track.
  • Mixer Board:
    • The meter range does not reflect a change in the dB range meter preferences until restart
  • Accessibility:
    • The following may not read correctly in screen readers: Labels, cells in Label Editor, time values in Generate effects, accelerators in Preferences, Metadata Editor(JAWS 11)
  • Miscellaneous:
    • If playback scrolls, cursor jumps to start of scroll on stop, hiding previously visible audio preceding the playback position
    • Not all menu items correctly enabled when the preference: "Select all audio in project, if none selected" is checked
    • A few interface elements do not change correctly after a language change until restart
    • Calculation of "disk space remains for recording (time)" incorrect when recording in 24-bit quality. You may record for 50% longer than the indicated time.
    • Pressing Play (but not Space) in a second project when another is already playing stops playback of the first project
    • Automatic Crash Recovery disregards track zoom level and position
    • Projects created by Audacity 1.1.x or earlier are no longer supported. Workaround: Export each project track as WAV using the appropriate legacy version of Audacity, then import the WAV files into current Audacity.
    • Audacity can import, display and cut/copy/paste MIDI files, then export them, but they cannot be played; undoing an edit with a MIDI track open causes the MIDI data to be lost in Windows builds

Intermittent bugs

Please write to feedback_AT_audacityteam_DOT_org if you experience any of the following known but not fully understood issues, giving us steps to reproduce them so they can be fixed.

For items marked , some work has already been done which may have eliminated the issue - your help with testing these issues is especially welcome.

  • Projects do not reopen properly with "orphaned" or "missing"blockfiles or "duplicate attribute" errors.
  • Projects do not re-open properly from the Automatic Crash Recovery dialogue.
  • Projects crash when applying repeated effects towards the end of audio tracks.
  • WAV or AIFF files import as noise.
  • (Windows XP, reported on) Clicks during recording
  • (Windows) Timer Record unreliable with recordings starting before and ending after midnight
  • (Windows) On Vista and 7, and on XP with some USB microphones, the Audacity input/output level sliders act independently of/incorrectly with system level sliders:
    • The achieved recorded level only matches the level indicated on the ecording VU meter if the Audacity input slider is at 100%
    • On Vista, adjusting the system level sliders then starting to record may reset the system level sliders unless monitoring is on
  • (Windows) Effects processing/waveform rendering after completion may be much slower than Audacity Beta 1.3.8
  • (Mac OS X 10.5.8 PPC) Hang when scanning for VST effects on first install of Audacity Beta. Workaround: rename the system VST folders:
    /Library/Audio/Plug-ins/VST or
    ~/Library/Audio/Plug-ins/VST
  • (Linux) After opening a sufficiently long audio file, opening a second file of any size leads to locked GUI/console messages until first file completes play


Platform-specific bugs

  • (Windows XP) The input slider and selector for inbuilt devices are unavailable if a USB microphone is also connected
  • (Windows 7) On launching Audacity, "Runtime Error Program:(location) R6034" occurs. Workaround: Right-click over audacity.exe, click Properties and change compatibility mode to Vista SP2 or XP SP3.
  • (Windows) Visible scanning dialogue appears on every launch of Audacity when no VST plug-ins are present
  • (Windows) On Vista and 7, input sources such as microphone and line-in must be selected in the Audacity Audio I/O Preferences, not the Mixer Toolbar input selector.
  • (Windows) Timer Record cannot maintain scheduled duration if system clock changes.
  • (Windows) Audacity is incompatible with some professional sound cards and may crash if one of these cards is the default when you open Audacity. Workaround: Make a different sound card your default when using Audacity, but please let us know if this affects you so we can track down and solve the problem.
  • (Mac OS X) Very occasionally, users may find that recording causes "error opening sound device", or that after running Audacity, other media players don't produce any sound, or crash: to resolve this, set up your sound device in Apple Audio MIDI Setup to work in stereo, 16-bit, with a sample rate of 44100 Hz or 48000 Hz, and set the sample format and rate identically in Audacity. More help here
  • (Mac OS X) If using Audacity when the "Hear" audio plug-in is running (or has been since boot), there will be excessive memory usage which could cause a crash: appears to be due to buggy memory allocation in "Hear".
  • (Linux) If Audacity is left open but without focus, its CPU use will rise slowly until all available the system CPU is consumed. This is a bug in wxGTK 2.8.10 (not previous versions) which will be fixed in wxGTK 2.8.11. For Package Maintaners / Distributors: The upstream change in wxGTK is simple and can easily be patched into wxGTK 2.8.10 if desired: Grab the changeset, run it through dos2unix (as it seems to come with dos line-endings), and apply it to the wxGTK 2.8.10 sources (with -p3 to get the paths right if you patch from the top level of the tarball distribution).
  • (Linux) Effects and other dialogues do not have focus on opening. This is a bug in wxGTK for which there is no current workaround. Click in the dialogue to navigate it and change parameters.
  • (Linux) Audacity will require a FFmpeg package or build later than 0.5 in order for optional FFmpeg import/export features to work.
  • (Linux) Audacity now supports interfacing with JACK, but this has not been tested, and has a number of known reliability and usability issues: patches to improve both will be welcomed.
Personal tools