Release Notes 1.3.13

From Audacity Wiki
Jump to: navigation, search
The text on this page should only be modified by subscribers to Audacity-devel mailing list.

To understand what this page is for and how it is used, please join that list or read the list archives on Sourceforge.
The discussion page can be used by anyone to make suggestions and comments about this page.


Audacity 1.3.13 was available from 11th April 2011 until 10 December 2011 for Windows, Mac OS X and Linux. These Release Notes describe:
  • Changes to 1.3.13 Beta as compared with 1.3.12
  • Issues with 1.3.13 Beta which were known at time of release
 
Related article(s):

Contents


Warning icon Notes for Windows:
  • MP3 export from Audacity 1.3.7 and later requires the latest version of the LAME encoder
  • The Windows installer will not replace 1.2.x installations, but will install alongside them

Changes in 1.3.13

Bug fixes

Interface

  • Cutting or copying from a track at a given sample rate into a track at another rate resulted in speed-changed audio.
  • Generating inside a clip could modify the clip length or create spurious clips.
  • Recorded stereo tracks were only half the height of imported or generated stereo tracks. Imported stereo files had a "1" appended to the track name.
  • Edit > Region Save did not save the cursor position.
  • (Windows) Projects crashed when clicking rapidly inside the interface or when applying repeated effects towards the end of audio tracks.
  • (Windows) Some Unicode characters could not be typed into labels, or caused a freeze using some input methods.
  • (OS X) Crash when quitting an empty project window, or when closing the main project window while a progress dialog was on screen.
  • Numerous other interface fixes including Dependencies dialog, Keyboard Preferences and spurious lines drawn on waveform.

Imports and Exports

  • Support added for later versions of the optional FFmpeg library up to current FFmpeg HEAD. This should significantly improve FFmpeg support on Linux. FFmpeg downloads for Windows and Mac updated to v0.6. This fixes mono AAC files importing as stereo, though current 0.5 versions of FFmpeg will still work.
  • Both FFmpeg and LAME should now be properly detected even when other versions of those libraries exist on the system.
  • New warning (on by default) for importing uncompressed audio files. Better error messages when read-directly uncompressed files are missing.
  • Imported ID3v2 metadata tags were removed when exporting without the Metadata Editor appearing (for example, when using an export command in Chains). Note: As a result of this fix, ID3v1 tags must now be written by exporting using (external program) and an installed LAME.
  • U-Law/A-Law files with WAV headers now use the standard 18 byte fmt chunk, so should now be recognised by most telephony applications.
  • Variable bit rate MP3s exported using "MP3 Files" were larger than necessary because using the bit reservoir was disabled.
  • (OS X) Files imported from iTunes could create invalid characters in the .aup project file, causing an error when re-opening the project. Note: An error "reference to invalid character number" will still occur if re-opening a project created in previous Betas that contains such characters. To fix the issue, open a back-up copy of the .aup file in a text editor, turn off word wrap, then in the line indicated in the error message, remove the string of characters that starts with &# and ends with a semi-colon (;).

Other bug fixes

  • Nyquist effects: fixes for crashes, incorrect slider behaviour and better support for backslashes, double quotes and Unicode characters.
  • (Windows and OS X) Processing of VST effects was substantially slower than in previous versions of Audacity.
  • (OS X 10.5 PPC) A first-time installation of Audacity Beta would hang on launch if VST effects were detected.
  • (Linux) Recordings made with the pulse device crashed or stalled when using overdub and/or software playthrough.
  • (Linux) Play-at-Speed crashed at 0.08 speed or lower if Audacity was configured with libsamplerate.

Changes and Improvements

  • Control Toolbar renamed to Transport Toolbar.
  • Device Toolbar (on by default) now contains all input and output device choices, including host and recording channels. Input/output choices are no longer in Mixer Toolbar on Windows XP or some older operating systems. New Transport > Rescan Audio Devices menu item to refresh the device list.
  • New "Sync-Lock Tracks" feature (turned on in the Tracks menu) to allow groups of audio and/or label tracks to retain synchronisation when the track length changes.
  • Equalization: New "Manage Curves" dialog for importing and exporting curves.
  • Noise Removal: New "Sensitivity" slider to adjust the noise threshold, and new option to isolate noise.
  • New "Extended Import" Preferences for specifying different importers to open specific file extensions.
  • Improved Automatic Crash Recovery with all project changes autosaved.
  • MIDI tracks can be vertically zoomed, time shifted and display bar lines. Note: the channel selection buttons are not available in 1.3.13.
  • (Windows and Linux) The window Close button and other system close or shutdown commands now quit on closing the last window. File > Close now always clears to a new, empty project.
  • (OS X) Simpler installer with top-level "Audacity" folder.


Known Issues at Release

We still have an issue in 1.3.13 that we need your help with so we can release a 2.0 version in the near future:
  • Projects that were apparently correctly saved re-open with "Missing Audio Data Blockfile(s)" or "Orphan Blockfile(s)" errors. This bug does not affect everyone, but it may cause loss of audio data.
    • Please let us know whenever you see these errors. Are there any steps you took when the project(s) were previously open that you think could enable us to reproduce the problem? We believe having multiple project open at once, or having a long project with many tracks could cause the issue to occur.
    • If you see these errors, we recommend choosing the options to "Treat missing audio as silence" or "Continue without deleting" the orphans.


Here are some other bugs we would like your help to track down too.


Imports and Exports

  • If WAV/AIFF files are imported into a project using "Read Directly" import but then become unavailable, warnings are given when playing, recording, applying effects and exporting, but not all editing and project save actions are warned.
  • On-Demand WAV/AIFF import is not available if using the optional FFmpeg importer.
  • Album art and lyrics in imported metadata are lost when exporting.
  • Exported "Comments" ID3 tag not recognized by Windows Media Player or Explorer
  • Genre WAV info tag (IGNR) not supported due to limitation in libsndfile
  • Other metadata import/export may not always be consistent. This may depend on the program that created the imported tags and the program used to read the exported tags.
  • WAVEX (Microsoft) headers: GSM 6.10 files cannot be exported, and U-Law/A-Law files may not be playable
  • M4A: exports at 38000 Hz may not play properly (FFmpeg bug); M4A renamed to MOV will not play on Windows in iTunes or QuickTime
  • WMA: no metadata is exported if using the older FFmpeg 0.5 library due to a bug in FFmpeg. Metadata is supported in FFmpeg 0.6 but applications other than Audacity may not see all the tags.
  • Dither noise is incorrectly applied by default if exporting to WAV or AIFF PCM files having the same bit-depth as the project (for example, to 16-bit WAV from a 16-bit project). Workaround: Set "High Quality" dither to "None" in the Quality Preferences.
  • Custom FFmpeg Export: many combinations of formats and codecs are incompatible, as are some combinations of general options and codecs. Some files may be exported as zero kb files.
  • Audacity may freeze if using the Nero AAC encoder to export via (external program). It is reported this only occurs when using multiple CPU cores. Workaround: Export to AAC directly by adding FFmpeg to your computer, or set Audacity to use only one CPU core.
  • Muting specific time-shifted mono tracks when exporting produces audio at wrong point on timeline in exported file if muted tracks are to left of unmuted.
  • Audacity can import, display and cut/copy/paste MIDI files, then export them, but they cannot be played; undoing an edit with a MIDI track open causes the MIDI data to be lost in Windows builds
  • (Linux) Files exported using the FFmpeg native encoder included with many system versions of FFmpeg are of very poor quality. This is an issue with the library itself. Workaround: When compiling FFmpeg, configure with the libfaac encoder thus: --disable-encoder=aac --enable-libfaac
  • (Linux) Mono AAC files import as stereo if FFmpeg uses the libfaad decoder. This is again an issue with the library itself.
  • (Linux) Exports using "M4A (AAC) Files" are very slow irrespective of the AAC encoder FFmpeg is configured to use. Workaround: choose (external program) when exporting, entering an appropriate path and command (for example, /usr/bin/ffmpeg -i - "%f") to run FFmpeg using Audacity's command-line encoder.
  • (Linux) Custom FFmpeg Export dialogue does not respond to ENTER after clicking in the Formats or Codec selector.
  • (OS X and Linux) Entering a backslash "\" in a file name when saving a project gives a "Could not save project. Path not found." error.
  • (Linux) After opening a sufficiently long audio file, opening a second file of any size leads to locked GUI/console messages until first file completes play.
  • (Windows Vista, 7) Audacity will crash if attempting to import WAV files while they are still being rendered by the open source Psycle tracker program.

Installation

  • (OS X 10.6.x) Administrative (and occasionally, root) permissions may be needed on some machines to install the optional LAME or FFmpeg libraries into /usr/local/lib/audacity. In case of difficulty, please download the zip version of FFmpeg 0.6.2 for Audacity and extract the files to your own preferred location. This download site is not affiliated with Audacity.

Playback and Recording

  • (Windows, OS X) If you click in Device Toolbar then use a shortcut to Play or Record, you must click in the waveform or background before you can use any further shortcuts.
  • Adding or removing an external audio device while Audacity is open will not be automatically reflected in Device Toolbar or Devices Preferences. Workaround: Use Transport > Rescan Audio Devices.
  • Play-at-Speed slider: Change of playback speed is no longer automatic after you move the play-at-speed slider. To change speed, move the slider, then click the green button to left of the slider to play at the new speed.
  • (Windows XP) When a USB device is connected and the motherboard playback or recording device is selected, the Audacity input/output sliders may have no effect or the input selector may disappear. When the USB device is selected, the input/output sliders may move together or have no effect.
  • (Windows) Audacity is incompatible with some professional sound cards and may crash if one of these cards is the default when you open Audacity. Workaround: make a different sound card your default when using Audacity, but please let us know if this affects you so we can track down and solve the problem.
  • (Windows) SHIFT + A (Play/Stop and Set Cursor) and custom unmodified shortcuts for playback or recording write a label at the cursor position if the label track has the yellow focus border. Workaround: use up or down arrow to move focus out of the label track before using the shortcut.
  • (Windows) Timer Record cannot maintain scheduled duration if system clock changes.
  • (Windows) Recording at 24-bit quality or higher isn't possible even with devices that support it due to current limitations in PortAudio.
  • (OS X) Playback to Bluetooth headsets gives an error. Workaround: Revert to Audacity 1.3.3, or use Soundflower to send the Audacity output to an audio application that works with the headset.
  • (Linux) If pulseaudio is used as the audio device, repeatedly starting and stopping playback or recording in quick succession (or holding down the Play or Record button) may lead to a freeze. Workaround: bypass pulseaudio by setting the playback and recording device to an ALSA/hw choice in Device Toolbar.

Effects and Analysis

  • The following effects remove envelope control points: Change Speed/Pitch/Tempo; Equalization; Noise Removal; Sliding Time Scale/Pitch Shift; any Nyquist effect in the Effect menu. Workaround: Use Tracks > Mix and Render to apply the envelope to the waveform before applying the effect. Reverse retains the control points, but does not move them.
  • Truncate Silence does not adjust clip boundaries inside the selection being truncated.
  • Truncate Silence doesn't work well on multiple tracks.
  • Truncate Silence: The resultant silence after the effect is 1 ms less than that expected, unless the result was expected to be 1 ms.
  • Nyquist effects join separate clips together
  • Nyquist effects: in locales where comma acts as the decimal separator, entering a comma in a text box to left of a slider only produces the whole number before the comma. Workaround: use a dot (period) as the decimal separator
  • LADSPA Multiband EQ may not be visible in Effect menu (occurs on Windows XP), and crashes soon after opening
  • (Windows) On a few Windows XP or 2000 machines, the background of the Frequency Analysis graph is reported to be completely transparent, and new spectrum plots are drawn underneath previous plots.

Interface

  • (Windows) The Audacity executable cannot be added to the Explorer "Open with" context menu if you have another version of Audacity on the system which is also called "audacity.exe". Workaround: either use the "Open with" dialogue to browse to the executable each time, or rename the executable to "audacity_beta.exe" or some other unique name.
  • (Windows) It is currently possible to perform simultaneous imports or exports by using Taskbar buttons to switch project windows then use shortcuts. Audacity is not yet capable of running these simultaneous operations safely, so attempting this may crash your project.
  • (Windows) The "Files Missing" warning always restores maximised windows to smaller size.
  • (Linux) Using a file manager (for example, context menu) or the command line to open further files gives an error. Even if Audacity is closed, only one file can be opened from the file manager. Workaround: Use File > Open, or (for audio files) File > New then drag the files in.
  • Audacity has several weaknesses in preserving the context of the audio being worked with:
    • If playback scrolls, pressing Stop leaves the waveform where it stopped and the cursor invisible. Pressing Play to resume then scrolls the waveform to start at the left edge, hiding the previously visible context before the cursor position
    • Current scrolling behaviour makes it too hard to watch the waveform progress, with a single shift of cursor and waveform position when cursor reaches the right edge
    • Zoom to Selection shows none of the surrounding context
  • Calculation of "disk space remains for recording (time)" incorrect when recording in 24 bit quality.
  • Cut Preview only plays the upper track of multiple selected or Sync-Locked tracks.
  • (Linux) If Audacity is compiled with the option to use libsamplerate and the default "Best Sinc Interpolator" for high-quality conversion is used, Tracks > Resample may lead to truncation of the waveform. Workaround: change the project rate to the desired rate, export the track and re-import it.
  • (Linux) PortAudio's default latency values which are used when recording with software playthrough are much lower than Audacity's default "Audio to buffer" setting. This may cause playthrough or recording glitches when recording from pulse with software playthrough enabled. Workaround: record from an (hw) device instead if software playthrough is required.
  • (Linux) Audacity has some bugs and limitations interfacing with JACK. Patches to resolve the following will be welcomed:
    • Recording/Playback ports for JACK are only opened on demand, so they exist during record and playback but disappear after pressing "Stop"
    • Re-routing the default ports to/from JACK can only be done when Audacity is paused
    • Clicking in the input meter to start monitoring will crash Audacity if it hasn't previously recorded from JACK in that session. Workaround: Record for a few seconds then Stop before monitoring.
  • Deleting a region starting at time zero which has been fitted to zero crossings will leave the first sample of the remaining audio behind time zero (left pointing arrows at edge of waveform), hence not exportable. Workaround: Use Time Shift Tool or Tracks > Align Tracks > Align with Zero to align the track correctly.
  • Snap To state and Selection Format when Snap To is on are global. Therefore changing these in one project will make them show incorrectly in any other projects.
  • Snap-To does not move the cursor when first enabled or when the selection format is changed.
  • Mouse Bindings are not currently configurable by the user.
  • Not all menu items are correctly enabled when the preference: "Select all audio in project, if none selected" is checked.
  • A few interface elements do not change correctly after a language change until restart.
  • If you save a region with Edit > Save Region then click OK in Preferences, the saved region cannot be restored.
  • We're aware that some error messages in Audacity are not as helpful as we would like them to be. If you see a cryptic error message from Audacity, try a search (or ask) on http://forum.audacityteam.org/
  • (OS X) The "Cmd - Wheel - Rotate" mouse binding does not zoom in unless you uncheck "Zoom using scroll ball while holding Command" at "Mouse and Keyboard" in the Mac System Preferences.
  • (OS X and Linux) In some locales, Preferences text may be truncated or overlapped, or dropdown boxes truncated.
  • (Linux) The OK button has focus on opening effects and other dialogs, instead of fields for changing values. This is a bug in wxGTK. To navigate the dialog, tab into it or click in it.
  • (Linux) Tracks that were selected on project save are deselected when re-opening the project.
  • (Linux) If Audacity is left open but without focus, its CPU use will rise slowly until all available system CPU is consumed. This is a bug in wxGTK 2.8.10 (not previous versions) which will be fixed in wxGTK 2.8.11. See: http://trac.wxwidgets.org/ticket/11315
    • For Package Maintainers / Distributors: The upstream change in wxGTK is simple and can easily be patched into wxGTK 2.8.10 if desired: Grab http://trac.wxwidgets.org/changeset/62397?format=diff&new=62397, run it through dos2unix (as it seems to come with dos line-endings), and apply it to the wxGTK 2.8.10 sources (with -p3 to get the paths right if you patch from the top level of the tarball distribution).
  • (Linux) If Audacity is configured with the option to use libsamplerate, an action involving resampling outside libsamplerate's limits of 1/256 to 256x will cause the progress dialogue to hang, or possibly a crash.
  • (Windows) There may be substantial delays drawing the waveform in some circumstances. These include fitting longer zoomed-in projects to the window, or when zooming in on fitted projects, also after importing files or running effects.

Mixer Board

  • Meter range does not reflect a change in the dB range meter preferences until restart.
  • (Linux) Meters may not respond immediately to playback which could cause them to report incorrect peak level or not display clipping.

Projects

  • When exiting Audacity with multiple project windows open, the "Save changes?" prompt does not indicate which project is being closed.
  • It is no longer possible to use Save Project or Save Project As to overwrite another pre-existing project, even if that project is not in use. Functionality to overwrite a project not in use will be restored in a future version of Audacity when we are sure it will always be safe.
  • Projects created by Audacity 1.1.x or earlier are no longer supported. Workaround: Export each project track as WAV using the appropriate legacy version of Audacity, then import the WAV files into current Audacity.
  • (OS X) When saving a project, wait after the "Saving project data files" dialog completes for any "Cleaning up cache directories" and Inspecting Project Data" dialogs to appear and disappear before closing the project window, or there may be a crash.

Label Tracks

  • (Linux) In projects containing several hundred labels or more, Audacity will freeze on 100% CPU when opening the "Audacity Karaoke" window, and will freeze again while that window is open when editing a label or performing other actions on the project. Workaround: Open or place an empty label track above the one you want to use.
  • Unless Tracks > Sync-Lock Tracks is on, pasting or inserting audio does not affect labels even if the label track is included in the selection.

Accessibility

  • Many, but not all parts of the Audacity interface are accessible on Windows to those who can't use a mouse, and/or use a screen reader. For details, see http://manual.audacityteam.org/man/Accessibility .

    There are some accessibility bugs in the parts of Audacity that are accessible.

  • Toolbar buttons cannot be operated by pressing either ENTER or Space: ENTER incorrectly moves to the next control and Space starts/stops playback. However the buttons can be operated either by using their shortcut keys, or for users of screen readers by using the Jaws cursor or equivalent. Note: it will be necessary to go to the Keyboard Preferences to set a shortcut for the Play-at-speed button.
  • For users of screen readers, when the Silence Generator dialog opens, the duration control is incorrectly read as 0 seconds. However, if you tab round to the control again, the correct value is read.
  • Some interface text or markings remain in black when using High Contrast light-on-dark themes, so cannot be read properly
  • The yellow track focus border remains "on" even when toolbars or dialogs have focus.

Bugs requiring more investigation

Warning icon Please let us know if you experience any of the following known but not fully understood issues, giving us steps to reproduce them so they can be fixed. Feel free, to test even if you don't normally use the feature concerned.
  • (Windows Vista, 7) When a USB device is connected, the listing of inputs for the built-in sound device in Device Toolbar or Devices Preferences may become corrupt, indicating single inputs as multiple inputs. It may only be possible to record from the built-in input which is currently set as default at "Sound" in the Windows Control Panel, irrespective of the input selected in Audacity. Workaround: Try Transport > Rescan Audio Devices, or a computer reboot.
    • Please report make and model number of devices that exhibit the issue, along with description of symptoms and any steps you have noticed that create the issue.
  • (Windows Vista) If you change the input volume in Audacity and then record, the volume is reset to its original level. This appears to occur mostly with a few specific USB devices, and sometimes only on Vista SP1, so it is currently hard for us to fix. Workaround: Check if the manufacturer supplies their own drivers for the device and try those. See if upgrading to Vista SP2 or Windows 7 helps.
    • Please report make and model number of devices that exhibit the issue, also the drivers and exact version of Vista and Service Pack in use (for example, Vista 32-bit, SP1)
  • (OS X and Linux) After using Tracks > Mix and Render, some keyboard shortcuts such as Play/Stop and those for saving projects or opening a new project window have no effect.
  • Label tracks: typing "j" or"k" in a label track may activate the "move cursor" shortcut instead.
  • Importing WAV or AIFF files (possibly those created by Audacity) may cause a freeze or a crash. After this occurs, Audacity may become destabilized and crash again even without importing further files. It is believed to mostly affect Intel Mac machines and to be caused by memory corruption. Workaround: Reboot the computer.
  • (Windows and OS X) Some USB or Firewire recording devices only record silence, or only offer mono recording for a stereo device, or only mono or stereo for a device that previously supported multi-channel recording. Workaround: You can try 1.3.10 Beta or earlier (including 1.2.5/6), but these versions may have other bugs or limitations.
    • Please report make and model number of devices that exhibit the issue.
  • (Windows) Timer Record may carry on recording past the scheduled end time, resulting in Audacity having to be force quit.

Compiling

  • (Windows) LADSPA effects cannot be categorized even when Audacity is compiled with USE_LIBLRDF defined.
  • (Windows) Compilation with Visual Studio 2010 is not yet supported.
  • (Windows) The slv2 library needed for LV2 support does not build.

Miscellaneous platform-specific issues

  • (Mac OS X) Very occasionally, users may find that recording causes "error opening sound device", or that after running Audacity, other media players don't produce any sound, or crash: to resolve this, set up your sound device in Apple Audio MIDI Setup to work in stereo, 16-bit, with a sample rate of 44100 Hz or 48000 Hz, and set the sample format and rate identically in Audacity. More help at: http://audacityteam.org/forum/viewtopic.php?f=17&t=5064
  • (Mac OS X) If using Audacity when the "Hear" audio plug-in is running (or has been since boot), there will be excessive memory usage which could cause a crash: appears to be due to buggy memory allocation in "Hear".
Personal tools