Release Notes 1.3.8

From Audacity Wiki
Jump to: navigation, search
The text on this page should only be modified by subscribers to Audacity-devel mailing list.

To understand what this page is for and how it is used, please join that list or read the list archives on Sourceforge.
The discussion page can be used by anyone to make suggestions and comments about this page.


Audacity 1.3.8 for Windows (2000, XP and Vista), Mac OS X and Linux was current from 17 July 2009 to 31 August 2009. Audacity 1.3.7 was the latest available Beta version for Windows 98 and ME over this period.

These Release Notes describe:

  • Changes to 1.3.8 Beta as compared with 1.3.7
  • Issues with 1.3.8 Beta which were known at time of release
 
Related article(s):

Contents


Warning icon Notes for Windows:
  • MP3 export from 1.3.7 and later requires the latest version of the LAME encoder
  • The Windows installer will not replace 1.2.x installations, but will install alongside them

Items struck out have been fixed in the latest development code, meaning that if you compile Audacity yourself from that code, or use one of our nightly development builds, these issues should not occur.


Changes in 1.3.8

New Features

Effects and Analysis:

  • VST Effects now display GUI by default
  • Faster Equalization and Noise Removal; improved Truncate Silence and Click Track
  • Chains applied to files now clear temporary data after processing each file
  • Updated Nyquist implementation with support for SAL syntax and improved memory management
  • Plot Spectrum now analyzes up to 237.8 seconds of audio, with separate windows for each project and improved display; new preferences for Spectrograms
  • Contrast Analysis tool now modeless for easier use

Interface:

  • Draft Manual/Quick Help included in Windows and Mac installers
  • New "Mixer Board" view with per-track VU meters
  • Mute, solo, gain, pan and track height saved in projects
  • More compact Preferences window with easier-to-use Keyboard tab and new toolbars shortcuts
  • New Screenshot Tools and improved screen reader support

Other:

  • Record more than 16 channels (hardware/drivers permitting)
  • Improved support for non-mmap ALSA devices such as PulseAudio
  • 32-bit float data over 0 dB now handled without clipping
  • "Stop" option when importing preserves already imported data
  • AMR NB import/export now supported if the optional FFmpeg library is installed
  • Faster waveform drawing and better response in multi-track projects

Bug fixes

  • Export Multiple: failed with no export or warning if empty label encountered; project and exported files silenced if overwriting imported WAV files without copying the data in
  • Metadata Editor hidden if it was on a now unavailable second monitor
  • Misaligned audio after "Split New" or Noise Removal effect
  • Incorrect label movement and paste with linked audio and label tracks
  • Equalization, Cut Preview and Advanced Mixing Options dialogue
  • (Linux) Mixer Toolbar should now adjust levels and select input sources properly
  • "Audio cache" preference caused crashes - data is now only cached in memory if available RAM is above a level defined in preferences
  • Various other crashes


Known Issues at Release

  • Imports:
    • Non-MP3 files imported via drag or Recent Files will crash or freeze when filter in file open window is set to MP3.
    • (Windows) The Audacity 1.3.8 executable cannot be added to the Explorer "Open With" menu if you have another version of Audacity also called "audacity.exe". You can set the file association to always use Audacity 1.3.8 to open the required file type, but it will not appear in the list accessed by the "Open With" context menu item.
  • Exports:
    • Metadata Editor appears before the Export window when exporting to any format. Click OK in Metadata Editor to proceed to the Export window. If you do not use metadata, you can go to the Import / Export tab of Preferences and uncheck "Show Metadata Editor prior to export step".
    • WAVEX (Microsoft) headers: GSM 6.10 files cannot be exported, and U-Law/A-Law files may not be playable
    • M4A: exports at rates below 44100 Hz have incorrect sample rates, and 38000 Hz exports may not play properly (FFmpeg bugs); M4A renamed to MOV will not play on Windows in iTunes or QuickTime
    • Muting specific time-shifted mono tracks produces audio at wrong point on timeline in exported file if muted tracks are to left of unmuted.
  • It is currently possible to attempt simultaneous imports or exports by using shortcuts (or File > New on Mac): Audacity is not yet capable of running these simultaneous operations safely, and attempting this may crash your project.
  • Genre WAV info tag (IGNR) not supported due to limitation in libsndfile.
  • Effects and Analysis:
    • Some VST plug-ins may have two instances if vst-bridge present.
    • Nyquist effects, SoundTouch, SBSMS and Generators join separate clips together.
    • Equalization used in a chain applies the parameters last used via the Effect menu instead of those stored in chain.
    • LADSPA Multiband EQ (optional download) may not be visible in the Effect menu, or may crash in use.
    • Compressor produces shorter attack/decay times than those specified in the dialogue.
  • Audio generated or pasted when cursor is in white space overwrites instead of inserts.
  • If playback scrolls, cursor jumps to start of scroll on stop, hiding previously visible audio preceding the playback position.
  • If shortcut for "Add label at playback position" is an unmodified character, confirming the second label with ENTER places that character in a label at the start cursor.
  • Preferences window: OK button does not respond to ENTER when a tab is selected in the left-hand panel.
  • At 120 DPI, importing a second stereo track causes the pre-existing stereo track above to split.
  • On-Demand:
    • Does not work if using the optional FFmpeg importer (that is, if "FFmpeg-compatible files" set in the import dialogue)
    • When importing a mixture of uncompressed and compressed files, the compressed files intentionally load first to minimise UI blockage, unless File > Open is used so that the files import into separate projects. This distinction is not yet observed on Windows. On all platforms, multiple files in one project will not necessarily be sorted in file name order after import.
  • Mixer Board:
    • The slider maximum gain is +6 dB, and its tooltip will not show more than this maximum even if the gain applied on the Track Control Panel slider is higher.
    • Selecting a track by clicking the Track Control Panel does not select it on the Mixer Board.
    • The meter range does not reflect a change in the dB range meter preferences until restart.
  • Not all menu items are correctly enabled when the preference: "Select all audio in project, if none selected" is checked
  • A few interface elements do not change correctly after a language change until restart.
  • Calculation of "disk space remains for recording (time)" incorrect when recording in 24-bit quality. You may record for 50% longer than the indicated time.
  • Pressing Play (but not Space) in a second project when another is already playing stops playback of the first project
  • Projects created by Audacity 1.1.x or earlier are no longer supported. Export each project track as WAV using the appropriate legacy version of Audacity, then import the WAV files into current Audacity
  • Audacity can import, display and cut/copy/paste MIDI files, then export them, but they cannot be played; undoing an edit with a MIDI track open causes the MIDI data to be lost in Windows builds
  • Audacity requires restart to detect audio devices plugged in while it is running.


Intermittently occurring bugs: Please write to feedback_AT_audacityteam_DOT_org if you experience any of these known but not fully understood issues, giving us steps to reproduce them so they can be fixed:

  • Projects do not reopen properly with "orphaned" or "missing" blockfiles or "duplicate attribute" errors
  • Projects do not re-open properly from the Automatic Crash Recovery dialogue
  • Projects crash when applying repeated effects towards the end of audio tracks
  • AIFF files import as noise
  • (Windows XP, reported on) Clicks during recording
  • (Windows) Timer Record unreliable with recordings starting before and ending after midnight
  • (Linux) After opening a sufficiently long audio file, opening a second file of any size leads to locked GUI/console messages until first file completes play


  • (Windows) On Vista, and on XP with some USB microphones, the system mixer level sliders and the Audacity Mixer Toolbar level sliders act independently. The achieved recorded level only matches the level indicated on the Recording VU meter if the Audacity input slider is at 100%.
  • (Windows) On Vista, input sources such as microphone and line-in must be selected in the Audacity Audio I/O Preferences, not the Mixer Toolbar input selector.
  • (Windows) Timer Record cannot maintain scheduled duration if system clock changes.
  • (Windows) Audacity is incompatible with some professional sound cards and may crash if one of these cards is the default when you open Audacity: as a workaround, make a different sound card your default when using Audacity, but please let us know if this affects you so we can track down and solve the problem.
  • (Mac OS X) Very occasionally, users may find that recording causes "error opening sound device", or that after running Audacity, other media players don't produce any sound, or crash: to resolve this, set up your sound device in Apple Audio MIDI Setup to work in stereo, 16-bit, with a sample rate of 44100 Hz or 48000 Hz, and set the sample format and rate identically in Audacity. [More help]
  • (Mac OS X) If using Audacity when the "Hear" audio plug-in is running (or has been since boot), there will be excessive memory usage which could cause a crash: appears to be due to buggy memory allocation in "Hear".
  • (Linux) Undoing or redoing a label edit may cause a crash if some character strings are common to all labels.
  • (Linux) Effects and other dialogues do not have focus on opening. This is a bug in wxGTK for which there is no current workaround. Click in the dialogue to navigate it and change parameters.
  • (Linux) If Portmixer uses emulated playback volume rather than native, the Audacity output slider will affect the VU playback meters and these may not then reflect the actual volume level of the waveform.
  • (Linux) Audacity will require a FFmpeg package or build later than 0.5 in order for optional FFmpeg import/export features to work.
  • (Linux) Audacity now supports interfacing with JACK, but this has not been tested, and has a number of known reliability and usability issues: patches to improve both will be welcomed
Personal tools