Release Notes 1.3.9

From Audacity Wiki
Jump to: navigation, search
The text on this page should only be modified by subscribers to Audacity-devel mailing list.

To understand what this page is for and how it is used, please join that list or read the list archives on Sourceforge.
The discussion page can be used by anyone to make suggestions and comments about this page.


Audacity 1.3.9 was available between 1 September and 30 November 2009 for Windows (2000, XP and Vista), Mac OS X and Linux. Audacity 1.3.7 was the latest available Beta version for Windows 98 and ME.

These Release Notes describe:

  • Changes to 1.3.9 Beta as compared with 1.3.8
  • Issues with 1.3.9 Beta which were known at time of release
 
Related article(s):

Contents


Warning icon Notes for Windows:
  • MP3 export from 1.3.7 and later requires the latest version of the LAME encoder
  • The Windows installer will not replace 1.2.x installations, but will install alongside them

Items struck out have been fixed in the latest development code, meaning that if you compile Audacity yourself from that code, or use one of our nightly development builds, these issues should not occur.


Changes in 1.3.9

Bug fixes

  • Crash, slow launch or excessive CPU/memory use arising from automatic VST support:
    • VST instrument plug-ins should now be correctly ignored
    • VST effects now scanned only at start of first session that detects them, then cached; effects are now not loaded or opened until needed
    • New "Effects" tab in Preferences to enable/disable VST effects and enable VST rescan on next launch
  • Default View Mode now works
  • Chains now always apply their stored parameters rather than those last used in Effect menu
  • Non-MP3 files imported via drag or Recent Files caused crash if filter in file open window set to MP3
  • AAC exports (using the optional FFmpeg library) were silenced
  • Generating audio always fitted the project in the window; fit now done only if generating in new track
  • View menu items/shortcuts incorrectly disabled when playing or recording
  • DTMF generator defaulted to zero duration on open
  • Unwanted interactions between linked audio and label tracks
  • Noise Removal shifted clips if the selection region included white space
  • (Windows XP) Failure to launch on some machines due to "incorrect configuration" issue
  • (Windows) Crash importing a stereo file while a screen reader such as JAWS is running
  • (Mac OS X) :
    • Audio Units effects applied to all tracks in project even if not selected
    • QuickTime importer now handles files greater than 16-bit or 64000 Hz
  • Various other interface bugs

Improvements

  • Compressor: new option to compress based on peaks, improved attack and decay time support
  • Mixer Board: improved design, more responsive meters and now interacts fully with Track Control Panel in main window


Known Issues at Release

  • Imports
    • (Windows) The Audacity executable cannot be added to the Explorer "Open With" menu if you have another version of Audacity also called "audacity.exe". You can set the file association to always use the Audacity Beta executable to open the required file type, but it will not appear in the list accessed by the "Open With" context menu item whilst there is another "audacity.exe" on the computer.
    • (Linux) Metadata in imported FLAC files not visible
  • Exports:
    • Metadata Editor appears before the Export window when exporting to any format. Click OK in Metadata Editor to proceed to the Export window. If you do not use metadata, you can go to the Import / Export tab of Preferences and uncheck "Show Metadata Editor prior to export step".
    • WAVEX (Microsoft) headers: GSM 6.10 files cannot be exported, and U-Law/A-Law files may not be playable.
    • M4A: exports at 38000 Hz may not play properly (FFmpeg bug); M4A renamed to MOV will not play on Windows in iTunes or QuickTime
    • Muting specific time-shifted mono tracks produces audio at wrong point on timeline in exported file if muted tracks are to left of unmuted.
    • It is currently possible to attempt simultaneous imports or exports by using shortcuts (or File > New on Mac): Audacity is not yet capable of running these simultaneous operations safely, and attempting this may crash your project.
    • Genre WAV info tag (IGNR) not supported due to limitation in libsndfile.
  • Effects and Analysis:
    • VST effects always remain in Effect menu even when rescanned and no longer available.
    • Nyquist effects , SoundTouch, SBSMS and Generators join separate clips together.
    • Values appearing in Nyquist effects text boxes are not always he default or previously entered values.
    • LADSPA Multiband EQ (optional download) may not be visible in the Effect menu, or may crash in use.
    • If playback scrolls, cursor jumps to start of scroll on stop, hiding previously visible audio preceding the playback position.
    • Preferences window: OK button does not respond to ENTER when a tab is selected in the left-hand panel.
  • On-Demand:
    • Does not work if using the optional FFmpeg importer (that is, if "FFmpeg-compatible files" set in the import dialogue)
    • When importing a mixture of uncompressed and compressed files, the compressed files intentionally load first to minimise UI blockage. unless File > Open is used so that the files import into separate projects. This distinction is not yet observed on Windows. On all platforms, multiple files in one project will not necessarily be sorted in file name order after import.
  • Mixer Board:
    • The meter range does not reflect a change in the dB range meter preferences until restart.
  • Not all menu items are correctly enabled when the preference: "Select all audio in project, if none selected" is checked.
  • Edit Labels: start/end times not available to screen readers.
  • Label tracks: typing "j" or "k" in a label may activate the "move cursor" shortcut instead.
  • Time Track disables linking of audio and label tracks.
  • A few interface elements do not change correctly after a language change until restart.
  • Calculation of "disk space remains for recording (time)" incorrect when recording in 24-bit quality. You may record for 50% longer than the indicated time.
  • Pressing Play (but not Space) in a second project when another is already playing stops playback of the first project.
  • Automatic Crash Recovery disregards track zoom level and position.
  • Projects created by Audacity 1.1.x or earlier are no longer supported. Export each project track as WAV using the appropriate legacy version of Audacity, then import the WAV files into current Audacity.
  • Audacity can import, display and cut/copy/paste MIDI files, then export them, but they cannot be played; undoing an edit with a MIDI track open causes the MIDI data to be lost in Windows builds.
  • Audacity requires restart to detect audio devices plugged in while it is running.


Intermittently occurring bugs:

Please write to feedback_AT_audacityteam_DOT_org if you experience any of these known but not fully understood issues, giving us steps to reproduce them so they can be fixed:

  • Projects do not reopen properly with "orphaned" or "missing"blockfiles or "duplicate attribute" errors.
  • Projects do not re-open properly from the Automatic Crash Recovery dialogue.
  • Projects crash when applying repeated effects towards the end of audio tracks.
  • AIFF files import as noise.
  • (Windows) After a period launching correctly, Audacity may not come up on top at launch. Workaround: Right-click over Audacity's Taskbar icon > "Maximize" or "Restore", ALT - tab, or reset the audacity.cfg settings file by removing all content except "NewPrefsInitialized=1".
  • (Windows XP, reported on) Clicks during recording.
  • (Windows) Timer Record unreliable with recordings starting before and ending after midnight.
  • (Linux) After opening a sufficiently long audio file, opening a second file of any size leads to locked GUI/console messages until first file completes play.


  • (Windows 7) On launching Audacity, "Runtime Error Program:(location) R6034" occurs. Workaround: Right-click over audacity.exe, click Properties and change compatibility mode to Vista SP2 or XP SP3.
  • (Windows) On Vista and 7, and on XP with some USB microphones, the Audacity input/output level sliders act independently of/incorrectly with system level sliders.
    • The achieved recorded level only matches the level indicated on the Recording VU meter if the Audacity input slider is at 100%.
    • On Vista, adjusting the system level sliders then starting to record may reset the system level sliders unless monitoring is on.
  • (Windows) On Vista and 7, input sources such as microphone and line-in must be selected in the Audacity Audio I/O Preferences, not the Mixer Toolbar input selector.
  • (Windows) Timer Record cannot maintain scheduled duration if system clock changes.
  • (Windows) Audacity is incompatible with some professional sound cards and may crash if one of these cards is the default when you open Audacity. Workaround: Make a different sound card your default when using Audacity, but please let us know if this affects you so we can track down and solve the problem.
  • (Mac OS X) Very occasionally, users may find that recording causes "error opening sound device", or that after running Audacity, other media players don't produce any sound, or crash: to resolve this, set up your sound device in Apple Audio MIDI Setup to work in stereo, 16-bit, with a sample rate of 44100 Hz or 48000 Hz, and set the sample format and rate identically in Audacity. More help here
  • (Mac OS X) If using Audacity when the "Hear" audio plug-in is running (or has been since boot), there will be excessive memory usage which could cause a crash: appears to be due to buggy memory allocation in "Hear".
  • (Linux) Undoing or redoing a label edit may cause a crash if some character strings are common to all labels.
  • (Linux) Effects and other dialogues do not have focus on opening. This is a bug in wxGTK for which there is no current workaround. Click in the dialogue to navigate it and change parameters.
  • (Linux) If Portmixer uses emulated playback volume rather than native, the Audacity output slider will affect the VU playback meters and these may not then reflect the actual volume level of the waveform.
  • (Linux) Audacity will require a FFmpeg package or build later than 0.5 in order for optional FFmpeg import/export features to work.
  • (Linux) Audacity now supports interfacing with JACK, but this has not been tested, and has a number of known reliability and usability issues: patches to improve both will be welcomed.
Personal tools