Selecting Audio

From Audacity Wiki
Revision as of 10:53, 17 November 2010 by PeterSampson (Talk | contribs)

(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to: navigation, search
There is a general rule in Audacity that if you want to use items from the Effect or Analyze menu (or from most of the other menus), you first of all have to select all or part of a track, so that Audacity knows what part of the track to work on. Any selected area plays when you hit the green Play button, or Spacebar.
 
Related article(s):
  • Navigation Tips for changing the playback position and moving between different tracks


You can select the entire length of all tracks on screen with the hotkey CTRL + A (or CMND + A on a Mac). If you have a number of different tracks on screen you can select the entire length of one of those tracks by clicking on the Track Control Panel of that track (where the mute/solo buttons are). To select the entire length of other specific tracks at the same time, hold down SHIFT while clicking in the Track Control Panels of the other tracks you want to select.

You can select part of any track by:

  • clicking in the track and dragging to left or right with your mouse.
  • holding down SHIFT with the left or right arrow keys.
  • clicking in the track where you want to start your selection, then hold SHIFT while clicking in the track at the point where you want to end your selection.

The same selection area can be placed in other tracks on screen by holding down SHIFT whilst clicking on the Track Control Panels of the other tracks.

To create a series of one-at-a-time selections through a track without any gaps or overlaps between them, you can "leapfrog" the selection by clicking on the left end and dragging it past the right end. The right end stays fixed and thus becomes the new left end of the selection. Similarly, you can create selections backwards through a track by grabbing the right edge of the selection and dragging it past the left one.

There are also some shortcuts and menu commands to create a selection from the cursor point to the start or end points of the project or tracks.

  • SHIFT + HOME creates a selection area from time zero in the project (on the timeline above the waveform) to the cursor point.
  • SHIFT + END creates a selection area from the cursor point to the end of the project.
  • Edit > Select... > Start to Cursor creates a selection area in the selected tracks from the start of the leftmost audio track to the cursor point. The start of an audio track (the point where its blue waveform begins) does not have to be time zero. The track can be shifted left or right using the Time Shift tool <---> (hotkey F5) in the Control Toolbar .
  • Edit > Select... > Cursor to End creates a selection area in the selected tracks from the cursor point to the end of the rightmost audio track.

The SHIFT + HOME and SHIFT + END hotkeys can be changed on the Keyboard tab of Preferences at "Selection to Start" and "Selection to End" respectively. The Start to Cursor and Cursor to End menu items can be allocated to hotkeys on the same tab.

Finally, selection areas can be saved and recalled. One selection area at a time can be saved with the Edit > Selection Save command and recalled with Edit > Selection Restore. The selection area is restored in all the tracks that are currently selected.

Personal tools