1.2.x Release Notes

From Audacity Wiki
Jump to: navigation, search


This page accumulates changes to the legacy stable branch of Audacity (1.2.x)

Contents

Changes in Audacity 1.2.6

  • Fixed memory leaks on Windows.
  • Corrected font size problems.
  • FLAC import now works correctly. FLAC export does not work on Windows or Mac.
  • Fixed Mac OS X (PPC only) screen redraw issues.

Known Problems in 1.2.6

  • Audacity can import and display MIDI files, but cannot play or edit them.
  • Linux: Recording in full duplex (playing existing tracks while recording) on some systems causes mono recordings to sound distorted or low-pitched. To work around this problem, set Audacity to record in stereo.
  • MacOS X: Audacity cannot work with files or folders that are contained inside folders with non-English characters (accents, symbols, etc.) in their names. Files with accented characters work, and Audacity projects with accented characters work. Only folders with accented characters in their names will cause problems.
  • The following additional problems have become apparent in Audacity 1.2.6 after release:
    • Labels do not accept lower case "z". To use "z" in labels, go to the Keyboard Preferences and change the shortcut for "Find Zero Crossings" to something other than z.
    • Windows Vista or 7: Pressing Stop after recording may cause a crash.
    • Mac OS X: Shortcut keys may activate when typing in file open or save windows.
    • See Audacity for the recommended version on Windows 7, Windows Vista and Mac OS X 10.6/10.7.

Changes in Audacity 1.2.5

  • An official Intel Mac version is now available.
  • Fixed bug in Generate Silence which caused it to apply to all tracks instead of just the selected ones.
  • Mac OS X: audio device opening code has been rewritten. First, it is much more conservative about changing device settings; it will not change settings when you open the program or close the preferences dialog anymore, and it will not change the settings when you begin playback/recording if the current settings are adequate. When it does change the settings, it should work much better on devices such as the Griffin iMic, ART USB Phono Plus, and Ion iMX02 USB.
  • Mac OS X: added new Audio I/O preference that lets you tell Audacity to never change any audio device settings.
  • Newer libsndfile supports FLAC import and export
  • Updated soundtouch to current version which is faster and better quality
  • Modified configure script prefers system libraries to local copies to reduce compilation times and memory usage.
  • Minor updates to help files.

Libraries

  • Bundled copy of Libsoundtouch upgraded from 1.2.2 to 1.3.1. Configure script updated so the system version of libsoundtouch can be used instead of local to reduce compile time
  • Bundled copy of libsndfile upgraded from 1.0.11 to 1.0.15, which adds FLAC support and fixes crashes when importing files from Apple iTunes. System libsndfile can be used, but a version before 1.0.12 gets a warning that FLAC isn't supported.
  • Bundled Portaudio v19 CVS snapshot updated to current Portaudio project CVS. This works on a lot more linux ALSA systems.
  • Configure script now checks wxwidgets toolkit version more carefully.

Bug Fixes

  • Multiple patches for GCC 4.x and 64-bit architectures to fix compilation failures.
  • More detailed error messages for audio file formats audacity cannot import
  • Clearer indication of remaining free disk space
  • Generate silence now works properly again, adding silence only to the selected tracks.

Mac OS X

  • Added preference for Mac OS X that lets you choose not to ever modify audio devices
  • Audacity should now import iTunes AIFF files without crashing

Translations

  • New translations: Welsh (cy), Turkish (tr), Bangladeshi (bn), Slovakian (sk), Romanian (),
  • Updated translations: Lithuanian, Bulgarian, Galician, Traditional Chinese, Slovenian, Swedish, simplified Chinese


Changes in Audacity 1.2.4b

  • A serious problem with the French translation was corrected.

Changes in Audacity 1.2.4

  • The File menu now includes a list of recent files.
  • The "Generate Silence" effect now prompts for a length.
  • Audacity is now built with Vorbis 1.1, which features better encoding quality and file compression.
  • Dragging sound files into the Audacity window now works on Mac OS X and Linux, as well as Windows. (Before, it worked only on Windows.)
  • Better support for certain audio devices on Mac OS X 10.4 "Tiger"
  • The "View History" window can now discard old undo levels to save disk space on Windows. (This previously worked only on Linux and Mac.)
  • "Preferences" command is now in Edit menu.
  • "Plot Spectrum" command is now in Analyze menu.
  • Opening a project file saved by a later version of Audacity displays an intelligent error message. Also, trying to import a project file (instead of open it) displays an intelligent error message.
  • Audacity now compiles in Visual C++ .NET 2003.
  • Other minor bug fixes.
  • New or updated translations: Arabic (ar), Czech (cs), Finnish (fi), Hungarian (hu), Japanese (ja), Norwegian (nb), Slovenian (sl), Simplified Chinese (zh_CN), Traditional Chinese (zh_TW).
Personal tools

Donate securely by PayPal, using your credit card or PayPal account!