Exporting your Audacity Project into iTunes and iPod

From Audacity Wiki
Jump to: navigation, search
Peter 7Apr14: ToDo-1 Following a comment that Gale made in the Manual three years ago I upgraded the Manual page Exporting to iTunes with further material and structure from this page. Accordingly this page can be deprecated from the Non-legacy Wiki after the planned Wiki split.
To export to iTunes, use one of the File > Export commands in Audacity to export to the particular file format you want, such as WAV, AIFF or MP3. Then move that file into iTunes from the location you exported it to, using the iTunes File > Add File to Library or File > Add Folder to Library commands.

You may also want to read this workflow tutorial from the current Audacity Manual Sample workflow for exporting to iTunes.

Note: Submitting a podcast to iTunes is a different process than exporting an Audacity file to the iTunes software. Two broad steps are required: 1) upload your podcast file and an RSS feed to an online file server; 2) submit the feed to iTunes Store. See our Tutorial Creating a simple voice and music Podcast with Audacity for more help.

Contents


Exporting to iTunes

What format should I export to?

WAV or AIFF (universal support, lossless, best for CD burning)

If you want a perfect lossless copy of your audio, choose WAV or AIFF. For playing files in iTunes or iPod, the safest recommendation is to export a standard "CD quality" 44100 Hz, 16-bit WAV. Although the latest iTunes can play 24-bit or 32-bit WAV and AIFF, iPods may skip when playing 24-bit WAV files (or any Audacity-exported AIFF files) unless they are connected to the computer. iPods do not play 32-bit files at all.

However, one advantage of exporting to AIFF is that lyrics or album art can be added to the file in iTunes, which is not possible with WAV files. A workaround if iPods do not play Audacity-exported AIFF files is to export them as WAV, then convert them to AIFF in iTunes using the steps below but choosing "AIFF Encoder" instead of "MP3 Encoder".

For burning the file to audio CD in iTunes, 44100 Hz, 16-bit WAV or AIFF is best. Exporting as stereo, even if the file is mono, is safest. This means:

  1. Ensure the Project Rate bottom left of the Audacity window is set to 44100 Hz
  2. In current Audacity, choose File > Export then select "WAV (Microsoft) signed 16-bit PCM" or "AIFF (Apple) signed 16-bit PCM" in the export window
    • In legacy Audacity 1.2.x through 1.3.2, choose Edit > Preferences (Audacity > Preferences on a Mac computer) then File Formats tab: "Uncompressed Export Format" section, and choose WAV (Microsoft 16-bit PCM) or AIFF (Apple/SGI 16-bit PCM) before exporting
  3. If you want a stereo export but your Project does not already contain a stereo track, choose Tracks > Add New > Stereo Track (Project > New Stereo Track in legacy Audacity 1.2.x through 1.3.0).

Jump to here if you're only interested in burning a CD.

MP3 (universal support, small files, lossy)

If you want to distribute your files on the internet (for example as a podcast), choose MP3. This is a space-saving (although slightly lossy) format that anyone should be able to play. To export as MP3 from Audacity you need first to download the LAME encoder and point Audacity to it.

If you want to put the files on iPod, or simply store them in iTunes in a compact form, MP3 is also a good choice. However, recent iPods can skip or crash when playing MP3s created in applications other than iTunes, unless they are connected to the computer. As an alternative you could export as WAV or AIFF from Audacity and convert the files to MP3 in iTunes using the following instructions. These instructions are for iTunes 8 or later. If you have iTunes 7, the import setting is changed on the small "Importing" tab inside the "Advanced" tab of Preferences.

  1. Click Edit > Preferences (or iTunes > Preferences on Mac)
  2. Click on the leftmost "General" tab
  3. Click the Import Settings button half way down on the right
  4. In the "Import Using" dropdown, choose "MP3 Encoder"
  5. Click OK and OK
  6. Select the file to be converted, then right-click or control-click over it and choose "Create MP3 version"

M4A (Apple proprietary format, lossy and lossless variants)

Apple's own M4A format is also good for iPod or storage in iTunes. M4A files typically use lossy AAC encoding. AAC produces a slightly smaller file than an MP3 of comparable quality. M4A files can also use Apple Lossless ALAC encoding. ALAC is quite similar to FLAC, and produces larger files than MP3 but smaller than WAV.

Current versions of Audacity can export directly to M4A (AAC, but not ALAC) by installing the optional FFmpeg library. If you are exporting an AAC file for mobile devices, you can change the M4A extension after the file name and dot to M4R or 3GP as required by the device.

Legacy Audacity 1.2.x through 1.3.5 cannot export to any M4A variants, but you can export to WAV or AIFF and convert to M4A in iTunes. To do this, follow the MP3 conversion steps above but instead of "MP3 Encoder", choose "AAC Encoder" for lossy AAC encoding or "Apple Lossless Encoder" for lossless ALAC encoding.

OGG format (open source, small files, lossy)

Audacity supports the OGG format with Vorbis encoding. Vorbis is a lossy compressed format similar to MP3 and M4A (AAC), but takes less space than either for a file of comparable quality. An iPod cannot play OGG, but iTunes can with a hack. To play OGG files in iTunes or Quick Time, download and install the xiph.org QuickTime Components. Alternatively, users on OS X only can install Ogg Drop. As well as adding OGG Vorbis support to QuickTime, it provides an easy drag'n'drop interface to convert to OGG Vorbis from AIFF, compressed AIFC, Audio CD tracks, uncompressed QuickTime soundtracks and System Sound files.

FLAC format (open source, fairly large files, lossless)

Audacity supports FLAC natively. These are lossless files but about half the size of WAV or AIFF. To play FLAC files in iTunes or Quick Time on Mac, download and install the xiph.org QuickTime Components (which also support OGG), then download and install Fluke. You may also need to rename the extension of FLAC files to MOV. For more help on Mac, see this Apple Forum thread https://discussions.apple.com/thread/3002052?start=0&tstart=0.

On Windows it is recommended to convert FLAC to WAV for use in iTunes. You can use SUPER Player to convert from FLAC to WAV.

Export Location

You can choose any location for the export from Audacity such as a "Music" folder on your Desktop or even the iTunes "Music" folder if you have one. However you must still import this file from the exported location into the iTunes Library (which makes it visible when you view Library > Music on the left-hand panel of iTunes). There are two ways to import your exported audio files into iTunes:

  • Select Library:Music in the left-hand panel of Tunes and drag the file from the location you exported it to into the main iTunes window to right of the panel (to burn the files to CD, drag them directly into an iTunes Playlist in the left-hand panel as per below)
  • Use the File > Add File to Library command from within iTunes.


Warning icon By default iTunes is a "virtual" Library containing no actual files but only links to them. To avoid losing your files, do *not* delete the exported files from the location you exported them to, unless you have already gone to Preferences > Advanced in iTunes and enabled "Copy files to iTunes Media folder when adding to library" (in legacy iTunes 7 this is on a small "General" tab inside "Advanced").

Burning to CD in iTunes

  1. If you have not already done so, drag the file(s) from your iTunes Music window (under Library in the left-hand panel) into an iTunes playlist (all files from this playlist will be burned to the CD)
  2. Click the Burn Disc button bottom right of the window (in iTunes 10, click File > Burn Playlist to Disc)
  3. In the "Burn Settings" window that appears, select the "Preferred Speed" and make sure "Audio CD" is selected (in iTunes 7, this should be configured beforehand, on the small "Burning" tab inside the Advanced tab of Preferences)
  4. Click "Burn"
  5. If you receive a "computer not authorised" error, double-click the file in the iTunes playlist and enter the password you use to login to iTunes store; additionally, you cannot burn a playlist containing M4P files that have been burned more than seven times
  6. If you receive "Error 4880" this means burning cannot initialise because of a hardware defect or because the burn speed is too high


Reminder: Unless you select "Audio CD" before burning, the CD won't play on standalone CD players

For more general help on burning to CD, see How to burn CDs.

Syncing iTunes to Apple iPad, iPhone or iPod touch

To load songs from your iTunes Library onto iPad, iPhone or iPod touch:

  1. Connect your device to your computer using the included cable (by default, iTunes opens automatically)
  2. Select your device in iTunes under Devices on the left-hand side and click the Info tab
  3. Choose which items to sync by clicking the respective tabs in iTunes

For more information about syncing your Apple device with your computer, see the information online or download the User's Guide.

Current iPhone models allow up to 32 GB storage, but if you need more space you can stream music from your main computer's hard drive to the iPhone using Subsonic (tutorial here). Or use Mecanto to stream from online storage even if your computer is switched off.


Audacity cannot be run on iPad, iPhone or iPod (or other mobile computers or smartphones) due to disk space/speed requirements and lack of interface support. See here for alternative editors.

Getting files off an iPod

What happens if you need to get files off your iPod (for example, if your computer fails, or you want to transfer songs from your home computer to your work one)? iTunes will not allow you to download your purchases again. To cover all eventualities, consider retaining all the files listed in iTunes Library in their original location on the hard drive, or ideally back them up to CD or DVD.

To copy files from iPod to a drive, launch iTunes with your iPod connected (in Tunes 7, you must go to Preferences: Options and select "Enable Disk Use"). Now your iPod will show up as a storage device in Windows Explorer or the Finder in OS X. Next you have to reveal the files as they will be hidden. In Windows Explorer, click Tools > Folder Options: View tab. Select "Show hidden files and folders" then exit the dialogue. On OS X, you can make the Finder show its hidden files and folders by entering this as a command in the terminal:

defaults write com.apple.finder AppleShowAllFiles -bool true

or try this free program to do the same thing.

Within the iPod storage device in Explorer or Finder you should see a folder called iPod Control and within that, a series of folders with names such as D1, D12, and so on. Your files are scattered about in those folders. You can now copy those to your hard drive or a flash drive or reimport them to iTunes.

You can also automatically transfer songs that you buy from the iTunes store from the iPod to another computer. The first time you attach the iPod to another machine, you'll see a pop-up window offering at the bottom to move your purchased files. iTunes allows you to play them on up to five different computers.

Removing iPod on Windows Vista and iTunes 7.1

When Apple released iTunes 7.1 to fix a number of incompatibilities with Windows Vista, it introduced a major problem with removing the iPod.

Normally, when you go to remove your iPod, you click the "Safely Remove Hardware" icon in the System Tray that allows you to unplug a USB item safely. But if you use that interface (or eject the iPod using Windows Explorer) when using Windows Vista and iTunes 7.1.x, you could corrupt the contents of your iPod's hard drive. To safely eject an iPod, ensure you choose "Eject iPod" from the Controls menu within iTunes instead. If your iPod does become corrupted by Explorer or "Safely Remove Hardware", select your iPod in Apple iTunes, then click "Restore" on the Summary tab to restore your iPod to working condition.


A patch that should allow Safely Remove Hardware to do its job is now downloadable here
Personal tools

Donate securely by PayPal, using your credit card or PayPal account!