MP3

From Audacity Wiki
Jump to: navigation, search
MP3  is a size-compressed, lossy audio format. This means that it uses less disk space to store audio than uncompressed formats like WAV, but loses some of the original sound quality in doing so. To reduce the quality loss, the audio removed is mainly outside the adult range of hearing, and the artefacts  it introduces are chosen so they are largely masked by louder or more prominent sounds. The actual quality achieved depends on the bit rate you encode at, higher bit rates giving better quality but resulting in larger files.
Other compressed lossy formats exist that work in a broadly similar way, such as MP2 and the more modern and arguably superior OGG and M4A formats.
 
Related article(s):


Contents

MP3 support in Audacity

Audacity can both import audio in MP3 format, and export to MP3 format. Audacity can use the LAME  MP3 encoding library in order to export MP3s, but we do not distribute LAME because of patent restrictions. Instead, you need to download LAME separately. Instructions for doing this are here.

Settings

ToDo-2Add information about what the bit rate actually means in practice and what the other settings do. Explain stereo MP3 does not tend to use 2x as much space as mono, unlike wav and other uncompressed formats.

ID3 Tags

MP3 files contain "metadata" at the start of the file as ID3 tags . These tags typically contain information such as Track Title, Artist Name, Year and Genre. Some of this information may be visible in the playing window of software and hardware players. The tags can be edited with Audacity's tag editor.


  • Audacity 2.x (and 1.3.5 Beta and later): By default, the Metadata Editor will always appear at export time. In Audacity 1.3.7 to 1.3.9 the editor appears before the Export window. Enter any metadata you require in the editor, then click OK (not "Save") to proceed to the Export window. The Export window lets you choose the file name, path and any custom encoding settings (by clicking the Options button). In 1.3.10 onwards, Metadata Editor appears after the Export window.
    To prevent Metadata Editor appearing at export time, click Edit > Preferences, then the Import / Export tab, and in the "When exporting tracks..." section, uncheck "Show Metadata Editor prior to export step". The tags can still be viewed or edited at any time prior to export at File > Open Metadata Editor, and the tags in the editor at export time will still be exported.
    When using Export Multiple, Metadata Editor pops up as many times as there are files to export. This gives flexibility to adjust the tags separately for tracks which form compilations with different artists or genres. If all the tracks to be exported have common information except for Track Title and Track Number, you may prefer to set Preferences as above so that Metadata Editor does not appear prior to export. Then make any necessary edits to the common tags at File > Open Metadata Editor prior to export, and the multiple export will proceed silently with the Track Title and Track Number tags added automatically. The Track Title tag will be the same as the file name chosen in the label or track name, and the Track Number tag will be generated according to the order of the labels or tracks.
    Tag storing when importing MP3s is different to 1.2.5/6: each time an MP3 is imported, the tags for that file replace the previous content of the Metadata Editor, so if an imported MP3 has no tags, Metadata Editor will then have no content. If you want to export a previously imported MP3, open Metadata Editor to change the tags before export.
    ID3v2.3 tags are exported. Note that some players don't yet fully support these tags, and so may not see all the tags. To prevent any tags being exported, uncheck "Show Metadata Editor..." in Preferences, open the Editor and delete any text showing in the "Tag Value" fields. Note: when using Export Multiple, the automatically generated Track Title and Track Number tags will still be produced, and even if you show Metadata Editor at export and empty all the fields, empty tags will be produced rather than none at all.
  • Legacy Audacity 1.2.5/6 (and Audacity 1.3 Beta up to 1.3.4): The tag editor will pop up the first time you export as MP3, unless it already contains tags from an MP3 you imported, or from a saved project. After that first MP3 export, it will not appear again of its own accord in that session. However you can check or modify the tags it contains at any time, by clicking Project > Edit ID3 tags. If you have exported once and wish to export with different tags, use this menu to change the tags before exporting again.
    Note also that the first time an MP3 is imported, Audacity stores any ID3 tags it contains. but tags from any subsequent imported files are ignored. Therefore to export tags relevant to subsequently imported MP3s, the tag editor must be used to change the tags before export. Tags of any MP3 can be viewed in Windows Media Player or iTunes, or alternatively, edited there directly.
    The more flexible ID3v2 tags are used by default, and must be used if selecting a genre from "Goa" downwards in the dropdown list. ID3v1 should only be needed for very old software or hardware players. Note that Audacity will always export a "Genre" ID3 tag, even if all the other fields are blank.

Limitations

In addition to the degrading of sound quality, MP3 files also have a short silence at the beginning. This is not a bug in Audacity or in Lame but is a limitation of the MP3 format. If this is an important issue (for example when making audio loops) you will need to use a format that does not have this limitation, such as WAV, Flac or Ogg.

Re-encoding to MP3

Every time you export from Audacity as an MP3 (or other lossy audio format), this encoding necessarily degrades some of the original quality of the audio. If you import an MP3 into Audacity, edit it then export it as an MP3, you are thus losing quality twice - once in the original MP3 encoding of the imported audio, then again when you export it from Audacity as MP3. Therefore when you are exporting as MP3, work with the highest quality copy of the audio that you can - preferably a copy in a lossless format such as WAV, AIFF or FLAC. You can always obtain a lossless copy of an audio CD by extracting its audio to a WAV or AIFF file. Never extract the audio from a CD to MP3 if you want to export it from Audacity as an MP3.

If you can't avoid importing an MP3 into Audacity and then re-encoding to MP3, don't believe what you sometimes hear that using the same or higher bit rate as the original file will prevent quality loss. This is incorrect. All you can say is that the higher the bit rate you re-encode to, the less will be the quality loss that results.

If you only want to perform simple edits on your MP3 (cut, copy, paste, join, fade or normalize), you may prefer an application that can edit MP3s directly without having to decompress then re-encode them as Audacity does. Examples:

For more advanced edits such as effects, the audio needs to be decompressed in an editor like Audacity, so you must then accept any perceptible quality loss from re-encoding the MP3.

Personal tools