Release Notes 2.2.0

From Audacity Wiki
Jump to: navigation, search
Audacity 2.2.0 was released on 02 November 2017.
 
Related article(s):

Contents

Changes since previous version

See the New Features page in the Manual for more information about improvements and other changes.

Improvements

  • Four Selectable themes provided, with new 'Light' theme as default, plus option to customize
  • Many menu changes:
    • Menus Reorganized
    • Extended menu bar provided
    • New keyboard commands for working with clips
  • Help buttons ? in Preferences, Effects, Generators and Analyzers - and other places
  • Non-Greying out of effects when no selection (and explanatory dialog with help button)
  • Playback of MIDI (and Allegro) files imported into Note Tracks is now available.
  • 'Center' option in Selection Toolbar
  • Stem plots
  • Major overhaul to documentation/manual including many new images and streamlined text on landing pages for in-program help.

Other Changes

  • Append-record is now the default (use Shift + Record for old behavior, to record on a new track)
  • The Esc key now cancels all click-and-drag actions. It also chooses among overlapping mouse click targets, which is especially useful in the Multi-Tool.
  • Sync-Lock button removed (use menu item or keyboard shortcut instead)
  • New preferences and preference pages
  • Overhaul of much code:
    • Overhaul of envelope handling code to deal with some anomalies
    • Overhaul of exception handling for greater safety
  • New Logo

Bug Fixes

  • Major work on bug fixing. 198 bugs that were in 2.1.3 fixed for 2.2.0.
    • The most serious bug fixed this time round was bug 437 which was about what happens when Audacity is recording and runs out of storage.
    • The problems of incomplete support for macOs Sierra have been resolved (including bug 290, bug 1567, bug 1702, and bug 1703).
    • Most of the bugs fixed were more minor, such as bug 463 which was about a case in which the numbering on the timeline could display incorrect times.
For those who really have to know, the list of bugs fixed in 2.2.0 is here.

Supported Platforms

Audacity is for Windows, Mac and Linux desktop machines. There is no version of Audacity for Android or iPhone.

Windows

  • Audacity 2.2.0 requires the CPU to support the SSE2 instruction set which should be available on any Intel hardware produced after 2001 and any AMD hardware produced after 2003. To check what SSE levels your CPU supports, you can install CPU-Z. If your hardware only supports SSE, you may download Audacity 2.0.6 (ZIP, not installer) by clicking this link.
  • 2.2.0 does not officially support Windows XP.

macOS / Mac OS X

Linux

  • Linux support is tested on Ubuntu Linux.
    • Audacity may compile on Gentoo, Debian, Mint.
    • Audacity does not currently compile on SuSE Linux.

Issues

See our list of issues for much more detail of issues with Audacity 2.2.0.
  • Below are listed what we believe are the most common and important issues with 2.2.0 for most users.

File > Open

  • If you use the File > Open to "open" an audio file (WAV file or MP3 file say) the file will import properly but only the first few seconds of it will be shown (the default zoom level), but more importantly the horizontal scroll slider will be missing from the scroll bar, meaning you can't access the remaining audio.
    • All you need to do do is press the Play button or any of the Zoom buttons in the Edit toolbar and the horizontal scroll slider will be restored.
    • The best way to avoid this happening is to use the File > Import command to import the file into an Audacity project. All that the File > Open does with an audio file is to Import the audio into an open empty project, or if you already have an active project it will open a new project and import the file into that project.

Timer Record

  • Timer Record may not reliably stop the recording on some machines. The Elapsed and Remaining Time counters may stop counting. In this case it will be necessary to force quit Audacity.
    • On a few affected machines, the problem can be avoided if you leave focus on Audacity or ensure it has focus when recording is due to end.

(Linux) PULSE Audio

  • PulseAudio is not reliable when used with Audacity on Linux. Playback or recording may freeze, recording dropouts or fast playback may occur when using PulseAudio.
    • Freezes may be caused by repeatedly starting and stopping playback or recording in quick succession (or by holding down the Play or Record button).
    • Workarounds: Try launching Audacity from the terminal with the pulse latency set to 30 ms in an environment variable:
env PULSE_LATENCY_MSEC=30 audacity
  • If you get underruns noted in the terminal, try a higher number in the PULSE_LATENCY_MSEC command. If the problem is unchanged, try a lower number.
  • Alternatively, bypass pulseaudio by setting the playback and recording device to an ALSA (hw) choice in Device Toolbar. More help with this can be found here.

(Linux) MIDI

  • The timing of notes during MIDI playback may sound erratic on some machines. Optimizing the system for low latency MIDI playback can help to reduce the inaccuracies.

(Mac) Launch from Finder or AUP file

  • With Sierra 10.12 and High Sierra 10.13 opening a second project from Mac's Finder produces a second inaccessible instance of Audacity. If you already have an Audacity project open, and attempt to open a second .AUP from within the Finder window (whether by double clicking, right-clicking for Open on the pop-up menu, or typing Cmd-O) or by right-clicking on the .AUP file and using Open With, the second project attempts to open in a new instance of Audacity, visible in Apple’s Dock bar at the bottom of the screen. This second instance of Audacity will not be accessible and you will need to Force Quit it.
    • Workaround: Use Audacity's File > Open command to open the second and successive projects.

Accessibility

  • Far less of Audacity is properly accessible to visually impaired users than we would like. Currently the best supported platform for accessibility is Windows. We lost a lot of custom accessibility programming when we had to move to a more recent version of the wxWidgets library. A lot more detail about accessibility limitations can be found here

Bugzilla

We track these and many other bugs in our 'bugzilla' database.
  • Click on the bug numbers to see work done on these bugs.
IDSummary (6 tasks) ID
42Timer Record carries on recording past the scheduled end, requiring force quit42
1726Linux: MIDI playback timing / synchronisation problems1726
276Linux: PULSE-AUDIO issues. Freeze repeatedly starting/stopping streams.276
33Summary: Accessibility issues33
1767Opening a second project from Mac's Finder produces a second inaccessible instance of Audacity1767
1765Using File > Open to import audio gives wrong zoom level and no scroll bar slider1765





This table, which is just for editors, is direct from bugzilla for bugs 33,42,276,1726


Summary (6 tasks) cf_releasenotetextID
Timer Record carries on recording past the scheduled end, requiring force quitGROUP:Timer Record
  • (Windows and MacOS) On a few machines, Timer Record may not respond to a request to stop the recording or may carry on recording past the scheduled end time. The Elapsed and Remaining Time counters may stop counting. In this case it will be necessary to force quit Audacity. On a few affected machines, the problem can be avoided if you leave focus on Audacity or ensure it has focus when recording is due to end.
42
Linux: PULSE-AUDIO issues. Freeze repeatedly starting/stopping streams.GROUP:Miscellaneous platform-specific issues
  • (Linux) A playback or recording freeze, recording dropouts or fast playback may occur when using PulseAudio. Freezes may be caused by repeatedly starting and stopping playback or recording in quick succession (or by holding down the Play or Record button). Workarounds: Try launching Audacity from the terminal with the pulse latency set to 30 ms in an environment variable:
      {{code|1=env PULSE_LATENCY_MSEC=30 audacity}}
    If you get underruns noted in the terminal, try a higher number in the PULSE_LATENCY_MSEC command. If the problem is unchanged, try a lower number. Alternatively, bypass pulseaudio by setting the playback and recording device to an ALSA (hw) choice in Device Toolbar. More help with this can be found here.
276
Linux: MIDI playback timing / synchronisation problemsGROUP: MIDI
  • (Linux) The timing of notes during MIDI playback may sound erratic on some machines. Optimizing the system for low latency MIDI playback can help to reduce the inaccuracies.
1726
Summary: Accessibility issuesGROUP:Accessibility
  • Many, but not all parts of the Audacity interface are accessible on Windows and Mac (read the alert above about Mac) to those who can't use a mouse, and/or use a screen reader. It may be possible to make more of Audacity accessible in the longer term. For details, see https://manual.audacityteam.org/o/man/accessibility.html
  • There are some accessibility bugs in the parts of Audacity that are accessible (or behavior may vary according to the specific screen reader).
    • Toolbars that show disabled at View > Toolbars and are then re-enabled will launch undocked if Audacity has already been restarted. Workaround: perform View > Toolbars > Reset Toolbars before enabling any disabled toolbars.
    • After mouse down to drag a docked toolbar to a new docked or undocked position, the track focus is removed and the selected control loses its focus border even though that toolbar still has focus. When dragging or resizing an already undocked toolbar, the selected control similarly loses its focus border.
    • shortcuts for Up, Down, Left, Right, Return and NUMPAD ENTER
    • Selection Toolbar: The End/Length buttons do not have a dotted rectangle to indicate when they have focus, and keyboard arrow keys no longer move between the buttons. The names of the buttons are either not read by screen readers or the position of both options is incorrectly read as 1 of 1.
    • Keyboard Preferences: Window-Eyes doesn't read the key bindings when View by Tree is selected, and may not always read the bindings in other views. VoiceOver and Orca do not read the key bindings at all. You could export the bindings, modify them in a text editor then import the modified list.
    • Spectral Selection Toolbar:
      • You can't enter a new low frequency first if it is above the current high frequency - in that case, you must enter the new high frequency first.
      • If you change low and high frequencies to kHz, then typing or incrementing values in the High Frequencies box has unpredictable results.
    • It is not possible to use the keyboard to move the cursor or selection region to an arbitrary position when playing or recording. However you can use the [ or ] shortcuts respectively to set the left or right boundary of the selection at the playback or recording position ( https://manual.audacityteam.org/man/edit_menu_select.html#left ). Different Scrubbing modes may also be started using shortcuts or the Transport Menu, but there is no keyboard interface yet to control scrubbing. Scrubbing may be started by shortcut even if the pointer is in the waveform, although the Status Bar messages don't refer to moving the pointer to Scrub.
    • (Windows):
      • Edit toolbar buttons that depend on selection are (at least in NVDA) announced as Disabled when there is no selection, rather than being skipped over. Hitting ENTER on such a disabled button will auto-select the audio, applying the edit to all of that automatic selection.
      • In certain parts of the main window, NVDA does not speak typed characters (JAWS and Window-Eyes are not affected):
      • In the main window, not speaking a character if it is a command for example, j,k,[ or ]
      • In a label track, not speaking characters typed into a label.
    • (OS X/macOS):
      • Audacity is not yet fully Retina-ready. It is known that the Track Control Panel appears fuzzy. Please let us know of any other issues. Retinizer can no longer be applied to Audacity. If Retinizer is applied to previous Audacity this will prevent the export format being changed.
      • Selection is not in the first control of Generators, Effects or Analyzers. In most effects the selection is invisible and one TAB puts selection in the Manage Button. In Change Speed the selection is "Current Length" and in Change Pitch the selection is the first octave.
      • If you apply a real-time preview effect while focus has remained in Audacity, the effect loses focus. If you apply a real-time preview effect after task switching away from and back to Audacity, the effect will go behind the project window. The effect may be brought back to focus in both cases with ALT + F6.
      • It is not possible to move between the main Audacity window and some VST and Audio Unit effects using the ALT + F6 or ALT + SHIFT + F6 shortcuts when the effect is in Graphical Mode. You can use the "Manage" menu then Options... to change the effect to textual mode.
    • (OS X/macOS) Issues with VoiceOver:
    • {{advice|Unfortunately, current Audacity is not accessible for users of VoiceOver for the reasons given below. This was also the case for releases starting from Audacity 2.1.1. However, an accessible version of Audacity 2.1.1 is available on our Mac OS X downloads page. The name of this accessible version is "2.1.1-screen-reader" (DMG and ZIP downloads are available). It is hoped that future versions of Audacity will be accessible for users of VoiceOver.}}
        • (reported on OS X 10.9.x) After exporting, the black accessibility area is trapped in the Tooldock area, so there is no way to read the tracks. Workaround: Save as a project, close the project then reopen it. You can then navigate the tracks with VoiceOver.
        • If you use arrow keys to navigate the Timetext controls in Selection Toolbar, VoiceOver stops reading. Workaround: Use Control-Option-W
        • When you TAB forwards from "Audio Position" in Selection Toolbar, the "Selection End" or "Selection Length" radio button is read as "Selection Start". When you use COMMAND + F6 or COMMAND + SHIFT + F6 to move directly into "Selection End" from another toolbar, the button is read as "Selection Start".
        • Mixer Toolbar input/output sliders are not read, but just described as "multiple indicators". The "Graphic EQ" and vertical sliders in Equalization *are* read.
        • Metadata Editor table not read.
        • Edit Labels dialog not read.
        • In the "Edit Chains" window, only the first command in the "Chain" list is read, and it is only read when first accessed. In the "Select Command" window for inserting a new command in a Chain, commands in the table are not read.
        • "Manage Curves" table in Equalization not read.
      • GNU/Linux:
        • (Linux Ubuntu) Under Unity, keyboard shortcuts are not visible in the Audacity menus. Keyboard shortcuts are visible if you install the classic GNOME Flashback interface or under Unity if you open Audacity from the termimal with {{code|1=env UBUNTU_MENUPROXY=0 audacity}} Audacity will now ship with src/audacity.desktop.in set to UBUNTU_MENUPROXY=0 so Audacity compiled from source will show shortcuts in the menus and will have its own menu bar in the application. It will remain up to Ubuntu whether they use this desktop file in packaged versions of Audacity.
        • Access keys mostly do not work except for radio buttons and checkboxes.
        • (Linux with Xfce desktop) It is not possible to move forward through modeless windows, undocked Toolbars and the main project window using ALT + F6. You may move backward using ALT + SHIFT + F6, but focus may get trapped in windows or undocked toolbars.
        • (Linux) It is not possible to TAB through the search box in Keyboard Preferences. However, as long as the "Tree" or "Name" button is selected, you can use DOWN arrow to move out of the Search box into the list, then TAB into the lower controls.
        • (Linux) Playing or recording then stopping causes the currently focused track or tooldock area to lose focus. Some shortcuts for example those for Tools Toolbar will then not work until focus is restored. Workaround: To restore focus, deliver a mouse click in the interface or create a shortcut for Reset Toolbars and use that shortcut.
        • (Linux) TAB unexpectedly navigates out of the current tooldock area instead of staying inside it, and CTRL + F6 from Selection Toolbar and SHIFT + CTRL + F6 from the Tracks table do not navigate to the upper tooldock area but leave focus in the previous toolbar. However you can use the TAB navigation behavior described above to access the upper tooldock area.
        • (Linux) The shortcut to "Move backward from toolbars to tracks" does not cycle from the audio track to upper tooldock, only to Selection Toolbar. The shortcut to "Move forward from toolbars to tracks" does not cycle from Selection Toolbar to upper tooldock, only to the audio track.
      • (Linux) Issues with Orca:
        • Audacity tracks are not read.
        • Not all toolbar controls are read, examples being Timetext controls, Project Rate and controls in Device Toolbar.
        • Not all controls in Preferences are read.
        • Control labels for VAMP and VST plugins are not read.
        • Control labels for Nyquist plugins are read inconsistently in older version 3 or earlier plugins (Version 4 seems to read more consistently).
    33
    Opening a second project from Mac's Finder produces a second inaccessible instance of Audacity1767
    Using File > Open to import audio gives wrong zoom level and no scroll bar sliderGroup: Imports and Exports
    • When using File>Open to import an audio file , the file will be imported showing at normal zoom level (In earlier Audacity versions the audio was zoomed to fit the Audacity window). Also the zoom toolbar may not show the scroll-slider in the horizontal scroll-bar.
      • Workaround
        • Use Play or any zoom to restore the scroll-slider to the scroll-bar
        • Use the "Fit project in Window" button in the Edit toolbar (or its shortcut Ctrl+F, Cmd+F on Mac) to restore the zoom level obtaining in earlier Audacity versions.
    1765


    Personal tools

    Donate securely by PayPal, using your credit card or PayPal account!