Difference between revisions of "Aligning Audio"

From Audacity Wiki
Jump to: navigation, search
(Convert to Intro Template; tweak and fix broken link)
(changed Track Panel to Track Control Panel)
Line 34: Line 34:
 
into the other tracks, and optionally by marking cursor positions with labels.  
 
into the other tracks, and optionally by marking cursor positions with labels.  
  
To drag the cursor into the other tracks, make sure you are using the Selection Tool [[Image:selecttool.png|Selection Tool]] (shortcut {{shortcut|F1}}), and place your cursor at a point where you want to line up the tracks. Then hold down SHIFT on your keyboard and click in the Track Panels (where the mute/solo buttons are) of all your other tracks. Now you'll see the cursor displayed in all the tracks, and you can switch to the Time Shift Tool and line up all the tracks against the cursor line.  
+
To drag the cursor into the other tracks, make sure you are using the Selection Tool [[Image:selecttool.png|Selection Tool]] (shortcut {{shortcut|F1}}), and place your cursor at a point where you want to line up the tracks. Then hold down SHIFT on your keyboard and click in the Track Control Panels (where the mute/solo buttons are) of all your other tracks. Now you'll see the cursor displayed in all the tracks, and you can switch to the Time Shift Tool and line up all the tracks against the cursor line.  
  
To add a label at a cursor point, use {{Menu|Project > Add Label at Selection}} ''(this is in the {{Menu|Tracks menu}} in Audacity Beta)''. You can use the shortcut {{shortcut|CTRL + B}} (or {{shortcut|CMND + B}} on a Mac) instead. The label is created in a new Label Track underneath the audio tracks. When you click on the label, all tracks will be selected and the cursor will be displayed through all the tracks, just like when you selected all the tracks by clicking on their Track Panels. However the label provides a permanent reference point you can come back to, and because you can have multiple labels in a Label Track, there can be multiple points you can line up with.  
+
To add a label at a cursor point, use {{Menu|Project > Add Label at Selection}} ''(this is in the {{Menu|Tracks menu}} in Audacity Beta)''. You can use the shortcut {{shortcut|CTRL + B}} (or {{shortcut|CMND + B}} on a Mac) instead. The label is created in a new Label Track underneath the audio tracks. When you click on the label, all tracks will be selected and the cursor will be displayed through all the tracks, just like when you selected all the tracks by clicking on their Track Control Panels. However the label provides a permanent reference point you can come back to, and because you can have multiple labels in a Label Track, there can be multiple points you can line up with.  
  
 
You could also generate a Click Track before you put other tracks on screen, using the {{menu|Generate > Click Track}} command. This gives you visible and audible bars in that Click Track at the beat points of a chosen tempo. You could use a beat point to set a cursor position then drag the cursor into the other tracks as described above. You need to close this Click Track when you export your work (by clicking on the [X] top left of the track) so that you don't export the audible clicks.
 
You could also generate a Click Track before you put other tracks on screen, using the {{menu|Generate > Click Track}} command. This gives you visible and audible bars in that Click Track at the beat points of a chosen tempo. You could use a beat point to set a cursor position then drag the cursor into the other tracks as described above. You need to close this Click Track when you export your work (by clicking on the [X] top left of the track) so that you don't export the audible clicks.

Revision as of 14:55, 17 November 2010

This page explains how to align multiple tracks so that their audio starts at the same point on the timeline above the waveform. For example you would often want to do this when you have recorded one track against another and need to ensure the recorded track is properly synchronised with the other track(s).



Time Shift Tool

The easiest way for sighted users to align tracks with each other is to use the Time Shift Tool Time Shift Tool which is located top left of the Audacity screen in the Control Toolbar .

To use the Time Shift Tool, click on the Time Shift Tool button so it appears to be depressed, or press its shortcut F5. If you wish to change its shortcut to something other than F5, you can do so on the Keyboard tab of Preferences. Then zoom in with CTRL + 1 (or CMND + 1 on a Mac) so you can make a more precise alignment. Click in the track you want to move with the left button of the mouse, hold the button down while dragging the track to your required position, then release the mouse button.


Alternative ways of aligning tracks

Visually impaired users can use this Time Shifter plug-in to time-shift tracks without a mouse. This is one of a number of Nyquist plug-ins available for use in Audacity and works on both mono and stereo tracks. Instructions are given in Timeshif.TXT inside the zip folder. To install new plug-ins, place them in the Plug-Ins folder inside the Audacity installation folder. On Windows computers, your installation folder is usually under "Program Files". On Mac OS X, it is usually under "Applications". Time shifter will appear in the Effect Menu underneath the separator after you restart Audacity.

There are also a number of alignment options under the Project Menu (Tracks Menu in Audacity Beta) that are available when you select one or more audio tracks. See Selecting Audio for help selecting audio tracks. The available options are:

  • align selected tracks with time zero
  • align start or end of selected tracks with cursor
  • align start or end of selected tracks with the start or end of a selection
  • align tracks together


Note of course that the last option above only synchronises the audio of the tracks if the audio starts at the same place in all the tracks.


Marking align points

Some users find it easier to align tracks together when there is a vertical reference point extending down through all the tracks. You can make such a reference point by dragging the cursor down into the other tracks, and optionally by marking cursor positions with labels.

To drag the cursor into the other tracks, make sure you are using the Selection Tool Selection Tool (shortcut F1), and place your cursor at a point where you want to line up the tracks. Then hold down SHIFT on your keyboard and click in the Track Control Panels (where the mute/solo buttons are) of all your other tracks. Now you'll see the cursor displayed in all the tracks, and you can switch to the Time Shift Tool and line up all the tracks against the cursor line.

To add a label at a cursor point, use Project > Add Label at Selection (this is in the Tracks menu in Audacity Beta). You can use the shortcut CTRL + B (or CMND + B on a Mac) instead. The label is created in a new Label Track underneath the audio tracks. When you click on the label, all tracks will be selected and the cursor will be displayed through all the tracks, just like when you selected all the tracks by clicking on their Track Control Panels. However the label provides a permanent reference point you can come back to, and because you can have multiple labels in a Label Track, there can be multiple points you can line up with.

You could also generate a Click Track before you put other tracks on screen, using the Generate > Click Track command. This gives you visible and audible bars in that Click Track at the beat points of a chosen tempo. You could use a beat point to set a cursor position then drag the cursor into the other tracks as described above. You need to close this Click Track when you export your work (by clicking on the [X] top left of the track) so that you don't export the audible clicks.

If you use the Beta version of Audacity, there is no visual guesswork involved in aligning tracks: you can snap to labels when you time shift a track towards them, and if you drag a selection area, the start point of the area on the time line is displayed dynamically in the Selection Toolbar as you drag.