Audacity PortAudio v19

From Audacity Wiki
Revision as of 21:56, 27 November 2007 by Richardash1981 (talk | contribs) (clean out old failures. Summarise status)
Jump to: navigation, search

This page reflects the status of PortAudio v19 support in audacity 1.3.4. The status of PortAudio v19 in 1.2.x is very simple - completely unmaintained and unsupported.

In Audacity 1.3.4, the default PortAudio version for all platforms is v19. Audacity 1.3.4 uses a snapshot of the PortAudio development code from 1st July 2007.

Windows

PortAudio appears to be stable and relatively well behaved on Windows. Support is primarily for MME (Multi Media Extensions) drivers, although DirectSound devices are also supported. ASIO is not supported as discussed on the ASIO_Audio_Interface page.

Mac OS X

CoreAudio support only, no ASIO as discussed on ASIO_Audio_Interface. Recent changes to PortAudio v19 appear to be causing regressions here, and it works much less well that v18 does with many USB audio devices. On the other hand, it's reported to work better with Firewire audio devices (which are quite popular on Mac it seems). Nothing is well tested or developed due to a shortage of Mac developers on Audacity.

Linux

ALSA is supported and works fine on development systems, although some distros repeatedly report problems that don't show up anywhere else. OSS probably works but is rarely tested as it is largely obsolete for most desktop users. Jack is not tested and known to have multiple issues - help, especially patches to fix these would be much appreciated.