Difference between revisions of "Building On Mac"

From Audacity Wiki
Jump to: navigation, search
(Command Line Tools)
m (+deprecated)
 
(64 intermediate revisions by 8 users not shown)
Line 1: Line 1:
{{IntroNoItal|This guide will help you establish a working development environment for Audacity on OS X Snow Leopard, Lion or Mountain Lion. <p>The steps detailed below are focused on getting you building Audacity as quickly and easily as possible, but you may use the environment for general development as well.</p>}}  
+
{{deprecated|https://github.com/audacity/audacity/blob/master/BUILDING.md}}
 +
{{ednote|1=[[ToDo-2]] Add<br>
 +
* Instructions for building modules
 +
}}{{Intro|1='''These are instructions for building on Mac'''
  
{{advice|1=
+
The build family of pages:
If Audacity is your only goal for getting this development environment established you don't really need to download and install Xcode 4 (steps 2 and 7).  However, products like MacPorts and Fink require Xcode 4 to be installed if you are using Lion or Mountain Lion, so now would be a good time to install Xcode 4.  And it wouldn't hurt to go ahead with Xcode 4 installation in case you might need it in the future.}}
+
* [[Building On Windows]]
{{ednote|'''Gale 21Jan13:''' Hi Leland, can you be a bit more specific in the advice div above. On a new system that lacks MacPorts or Fink, you can do without either of those and you can use only Xcode 3? You can ignore steps 2 and 7 in the Contents entirely?
+
* [[Building On Mac]]
 +
* [[Building On Linux]]}}
  
'''Leland 21Jan13:''' Is that better Gale?  I'm starting to think that I should just leave that note out entirely since it may be clearer for users to just do the steps from top to bottom. What do ya think?}}
+
== Instructions in mac/build.txt ==
  
== Download Xcode 3.2.6 ==
+
{{note|1=These instructions for building on mac are in [https://github.com/audacity/audacity/blob/master/mac/cmake_build.txt mac/cmake_build.txt in the Git repo].}}
  
To download Xcode, you will need to register at the Apple Developer site:
+
<pre>
 +
Instructions for building on macOS using CMake.
  
:http://developer.apple.com
+
Building on macOS has been made much simpler with the Audacity 2.4.0
 +
release. Still, read this document throughly before starting.
  
Once registered, the available downloads are located here:
+
1) Get and install the latest Xcode version available your macOS version:
  
:http://developer.apple.com/downloads
+
      MacOS                  Xcode Version (as of Mar 2020)
 +
      Catalina - 10.15        11.3
 +
      Mojave - 10.14          10.3
 +
      High Sierra - 10.13    9.4.1
 +
      Sierra - 10.12          9.2
 +
      El Capitan - 10.11      8.2.1
 +
      Yosemite - 10.10        7.2.1
  
Xcode 3.2.6 is the last version that (officially) supports the PPC architecture and the macosx10.4u SDK.  Unless you're building release versions, the PPC support isn't absolutely necessary, but the SDK is required.
+
2) Clone the Audacity repository:
  
Enter “Xcode 3.2.6” in the search box on the left, press enter, and download the “Xcode 3.2.6 and iOS SDK 4.3” dmg:
+
      git clone https://github.com/audacity/audacity
  
:[[File:Bom xcode 326 download.png|780px]]
+
3) Clone wxWidgets 3.1.3:
  
== Download Xcode 4.5.2 ==
+
      git clone --recurse-submodules https://github.com/audacity/wxWidgets.git
  
Snow Leopard users may skip this step.
+
  Ensure that you clone with the "--recurse-submodules" option, and do not
 +
  just download the Zip package, otherwise there will be required components
 +
  missing.
  
NOTE:  You may choose to install other versions of Xcode, but at the time this guide was written, 4.5.2 was the latest and other versions may not work as outlined here.
+
  Don't be tempted to use wxWidgets already installed by a package manager
 +
  such as Homebrew because this will cause problems.
  
Enter “Xcode 4.5.2” in the search box on the left, press enter, and download the “Xcode 4.5.2” dmg:
+
  We have applied some Audacity specific patches to wxWidgets to better
 +
  support VoiceOver, so please use the audacity-fixes-3.1.3 branch. It's
 +
  the default branch on our GitHub copy:
  
:[[File:Bom xcode 452 download.png|780px]]
+
      https://github.com/audacity/wxWidgets/tree/audacity-fixes-3.1.3
  
Enter “Command Line Tools” in the search box on the left ("try "command" if you get no results), press enter and download the latest “Command Line Tools” dmg that corresponds to your version of OS X:
+
  You can be certain the correct branch is active with:
  
:[[File:Bom tools 452 download.png|780px]]
+
      git checkout audacity-fixes-3.1.3
  
== Download wxWidgets ==
+
4) Change directory to the folder where wxWidgets was cloned and build it using:
  
You must download the wxMac version 2.8.12 of wxWidgets from:
+
      sudo <path to Audacity source>/mac/scripts/build_wxwidgets
  
:http://www.wxwidgets.org/downloads/
+
5) The config command should return "3.1.3" if the install was successful:
  
[[File:Bom wxwidgets 2812 download.png|780px]]
+
      /usr/local/x86_64/bin/wx-config --version
  
Download the "[[Media:Build wxwidgets.gz|Build wxwidgets.gz]]" script that will be used to build wxWidgets for use with Audacity. Make sure you save the file as "build_wxwidgets.gz".  Safari will automatically uncompress the file, others may not.
+
6) Now that you have wxWidgets installed, edit your ~/.bash_profile or
 +
  ~/.zprofile and add:
  
== Download cmake ==
+
      export WX_CONFIG=/usr/local/x86_64/bin/wx-config
  
Download the latest Unix/Linux source version of cmake from:
+
  Log out and back in again (or reboot) for this to take effect.
  
:http://www.cmake.org/cmake/resources/software.html
+
7) Download the CMake 3.16.4 DMG from:
  
[[File:Bom cmake download.png|780px]]
+
      https://cmake.org/download
  
== Download pkg-config ==
+
8) Double click the DMG, follow the prompts and drag the CMake app to the
 +
  Applications folder.
  
Download the latest version of pkg-config from:
+
  If you will be building from the command line, open the CMake application
 +
  and click the "Tools -> How to Install For Command Line Use" menu. It will
 +
  give you additional instructions on making CMake available to the command
 +
  line.
  
:http://pkgconfig.freedesktop.org/releases/
+
  You are now ready to start building Audacity.
  
[[File:Bom pkg-config download.png|780px]]
+
BUILDING USING THE CMAKE GUI
  
== Install Xcode 3.2.6 ==
+
  NOTE: Building with the GUI interface will result in the downloading of
 +
        another copy of wxWidgets from Audacity.
  
Locate the Xcode 3.2.6 dmg, xcode_3.2.6_and_ios_sdk_4.3.dmg, on your system and double click it to have Finder verify and mount it:
+
1) Open the app.
  
[[File:Bom xcode 326 mount.png|center|480px]]
+
2) Click the "Browse Source..." button and locate the top of your Audacity
 +
  source tree, then click the "Open" button.
  
The “Xcode and iOS SDK” installer checks the version of OS X that is currently running and it will not work on any version above Snow Leopard.  However, this version check can be bypassed by starting the installation from the command line.
+
3) Click the "Browse Build..." button and find the location where you want to
 +
  put the build (use the "New Folder" button at the bottom left to create a
 +
  new folder).
  
NOTE:  It is advisable to have all OS X updates applied to your system before installing Xcode 3.2.6. This is especially important for Lion users as the installation will fail.
+
  This folder does not have to be in or even near the source tree, but it
 +
  must not be the same as the source tree. However, it is common to make it
 +
  a subdirectory of the Audacity source tree.
  
Open a Terminal window and start the installation by entering the following commands:
+
4) Click the "Configure" button and when the dialog pops up, select "Xcode" for
 +
  the generator, then click the "Done" button.
  
:export COMMAND_LINE_INSTALL=1
+
5) Click the "Generate" button to create the Xcode project.
:open "/Volumes/Xcode and iOS SDK/Xcode and iOS SDK.mpkg"
 
  
[[File:Bom xcode 326 install.png|780px]]
+
6) Now you can either click the "Open Project" button or go to your "Build" folder in
 +
  Finder and open the Xcode project as normal.
  
This will start the installation while bypassing the version check.
+
BUILDING FROM THE COMMAND LINE
  
On Mountain Lion, the installer needs to restart itself:
+
1) Change directory to your Audacity source tree.
  
[[File:Bom xcode 326 restart.png|780px]]
+
      cd audacity
  
And, since the Xcode 3.2.6 certificate has expired, you will be asked to accept it:
+
2) Create the "build" folder (name it anything you like):
  
[[File:Bom xcode 326 cert.png|780px]]
+
      mkdir bld
  
You will then get to the normal installation process:
+
3) Change to the "build" folder:
  
[[File:Bom xcode 326 installer.png|780px]]
+
      cd bld
  
Proceed through the various installation pages until you get to the “Custom Install” page:
+
4) Configure and generate the Xcode project:
  
[[File:Bom xcode 326 custom install.png|780px]]
+
      cmake -G Xcode ..
  
Open the Essentials item by clicking the arrow:
+
5) Build Audacity using the CMake command or xcodebuild:
  
[[File:Bom xcode 326 options.png|780px]]
+
      cmake --build . --config Release
  
The minimum required options are “Unix Development” and “Mac OS X 10.4 SDK”, but if you're running Snow Leopard, you may elect to install everything.  On Lion or above, you will not be able to use “System Tools” and may choose to use the “iOS SDK” and “Documentation” from Xcode 4.5.2:
+
      xcodebuild --configuration Release
  
[[File:Bom xcode 326 selected options.png|780px]]
+
  The "Audacity.app" bundle will be in the "bin/Release" subdirectory of your
 +
  "build" folder, so you can start it via Finder or:
  
Continue through the pages to start the installation.
+
      open bin/Release/Audacity.app
  
On Mountain Lion, you will be prompted to stop iTunes near the end of the installation:
+
Notes:
  
[[File:Bom xcode 326 itunes.png|center|480px]]
+
  - If you'd like to get a completely clean build, just delete "build" folder
 +
    and return to step 2 above.
  
To terminate the process and allow the installation to complete, open a Terminal window and enter:
+
  - Once the Xcode project is generated, you shouldn't have to "configure" or
 +
    "generate" again as it will be done for you automatically after pulling
 +
    updates and building.
  
:sudo killall iTunesHelper
+
    For example:
[[File:Bom xcode 326 ituneshelper.png|780px]]
 
  
Close the installer when complete:
+
        cd <audacity> directory
 +
        git pull
 +
        cd bld
 +
        cmake --build . --config Release
  
[[File:Bom xcode 326 complete.png|780px]]
+
  - Instructions on optional signing of DMGs, showing languages other than English,
 +
    and other useful information can be found on our wiki at:  
 +
    http://wiki.audacityteam.org/wiki/Building_On_Mac
  
The first time you use Xcode you will be prompted to install Java if you do not have it installed already.  So, use Finder to navigate to the "/Developer/Applications" folder, by selecting "Go to folder" from the "Go" menu in Finder:
+
</pre>
  
[[File:Bom audiacty_build_xcode_goto.png|center|480px]]
+
== CMake Build ==
  
Enter "/Developer/Applications" for the path and click "Go":
+
<pre>
 +
1) Change directory to your Audacity source tree.
  
[[File:Bom audiacty_build_xcode_folder.png|780px]]
+
      cd audacity
  
Now double click the "Xcode" application to start it:
+
2) Create the "build" folder (name it anything you like):
  
[[File:Bom audiacty_build_xcode_start.png|780px]]
+
      mkdir bld
  
At this point you may prompted to install Java:
+
3) Change to the "build" folder:
  
[[File:Bom audiacty_build_xcode_java.png|center|480px]]
+
      cd bld
  
Wait for the installation to complete and quit Xcode.
+
4) Configure and generate the Xcode project:
  
This completes the Xcode 3.2.6 installation.
+
      cmake -G Xcode ..
  
== Install Xcode 4.5.2 ==
+
5) Build Audacity using the CMake command or xcodebuild:
Snow Leopard users should skip this step.
 
  
Locate the Xcode 4.5.2 dmg, xcode4520418508a.dmg, on your system and double click it to have Finder verify and mount it:
+
      cmake --build . --config Release
  
[[File:Bom xcode 452 mount.png|center|480px]]
+
      xcodebuild --configuration Release
  
The Xcode folder will open when it's mounted:
+
  The "Audacity.app" bundle will be in the "bin/Release" subdirectory of your
 +
  "build" folder, so you can start it via Finder or:
  
[[File:Bom xcode 452 folder.png|780px]]
+
      open bin/Release/Audacity.app
 +
</pre>
  
You may choose to drag the Xcode app to wherever you like, but this guide expects it to be located in the Applications folder:
+
== For a Release CMake build ==
  
[[File:Bom xcode 452 copy.png|780px]]
+
Additionally:
  
Locate the Command Line Tools dmg, xcode452cltools10_76938212a.dmg, on your system and double click it to have Finder verify and mount it:
+
<pre>
 +
6) Add the help files
  
[[File:Bom tools 452 mount.png|center|480px]]
+
  Open contents of bin/Release/Audacity.app
 +
  Add in files with directory help/manual/ and then the 5 top level items
  
The Command Line Tools folder will open:
+
7) Notarize Audacity
  
[[File:Bom tools 452 folder.png|780px]]
+
  ../mac/scripts/build_dist.sh ../mac ../bld/bin/Release
 +
</pre>
  
Start the installation by double clicking the installer, “Command Line Tools (Lion).mpkg” in this case:
+
For Notarization to work, you'll need to have already jumped through the Apple hoops, and have set up your signing file.  There are two stages to notarization, one for the bundle, one for the dmg.
  
[[File:Bom tools 452 installer.png|780px]]
+
To test the Notarization, upload the dmg to dropbox and then download it again.  Then double-click to
 +
install and drag across to /Applications. When you launch Audacity, you now get a warning about having downloaded from the internet, rather than being prevented from running...
  
Once the installation completes, close the installer:
 
  
[[File:Bom tools 452 complete.png|780px]]
+
== Optional Extras ==
  
Open a Terminal window and enter:
+
{{tip|'''FFmpeg and LAME'''
 +
For these, see [[Building Extras on Mac]]}}
  
:sudo xcode-select -switch "/Applications/Xcode.app/Contents/Developer"
+
== Variations ==
  
[[File:Bom xcode 452 switch.png|780px]]
+
{{note|1=These instructions for variations on building aren't in mac/build.txt in the Git repo.  They're actually mostly obsolete instructions.  The CMake building now takes care of the GitIdent and mod-script-pipe.  Languages should not be an issue if you are already set up with gettext.  The signing has been replaced by Notarization.  We no longer declutter the dmg, and no one has complained or commented about it on the forums.}}
  
You will be asked to enter your password:
+
===Fetching The Manual===
  
[[File:Bom xcode 452 switched.png|780px]]
+
We have [[Building The Manual|instructions for fetching the manual]] on another page.
  
To make it a little easier to use Xcode 3.2.6 from the command line, create a link to the 3.2.6 version of xcodebuild.  You make change the "xcodebuild3" to whatever you like, just remember when building Audacity from the command line to use what you specify here:
 
  
:sudo ln -s /Developer/usr/bin/xcodebuild /usr/bin/xcodebuild3
+
===Defaulting to Portable Settings===
  
[[File:Bom xcode 452 xcodebuild3.png|780px]]
+
<pre>
 +
1. Within audacity.app/Contents add the directories:
 +
    Portable Settings
 +
    Portable Settings/AutoSave
  
This completes the Xcode 4.5.2 installation.
+
2. Set permissions on these two directories to 777
 +
    chmod 777 "Portable Settings"
 +
    chmod 777 "Portable Settings/AutoSave"
 +
</pre>
  
== Install cmake ==
+
These steps should of course be done before signing.
  
Open a terminal window, extract the cmake archive and change to the extracted directory using:
+
== Official Full Releases==
  
:tar xf ~/Downloads/cmake-2.8.10.2.tar
+
Official Audacity full releases:
:cd cmake-2.8.10.2
 
  
[[File:Bom cmake extract.png|780px]]
+
* Have a GitIdent, visible in the about box build information, that says what branch was used in building.
 +
* Include a copy of the manual.
 +
* Include other languages.
 +
* Have a de-cluttered .dmg (the folders in it are dragged outside the visible area)
 +
* Are signed with a signing key.
  
Configure cmake:
+
<s>
 +
===Updating GitIdent===
  
:./configure --prefix=/usr/local --docdir=/share/doc/CMake --mandir=/share/man
+
<pre>
 +
The Audacity "About" box can contain a link to the git commit at which
 +
Audacity was built. To create this, run this batch script in /mac/scripts/
 +
 +
  get_gitident.sh
 +
 +
If you do this, you are responsible for making sure the ident is correct
 +
in future builds.  The script overwrites RevisionIdent.h in the src directory.
 +
If you make further changes to your local copy after this step, or merge a
 +
more recent version from git, this file, and hence the ident in the build,
 +
stays the same, and so would be misleading.
 +
 +
To reset RevisionIdent.h you could do:
 +
 +
  git reset --hard origin/master
 +
</pre>
  
[[File:Bom cmake configure.png|780px]]
+
===Include mod-script-pipe===
  
Build cmake:
+
Build this within the Xcode project ON THE SAME DAY as you built audacity.  You can click on the .so in the IDE to find out where Xcode put it (it will have some weird long temporary path).
  
:make
+
Just before code signing, add it in to the Audacity bundle, into a subdirectory called 'modules'.
 +
</s>
  
[[File:Bom cmake build.png|780px]]
+
===Include Languages===
  
Install cmake:
 
  
:sudo make install
+
{{alert|1=Beware!  Audacity needs a clean and then a recompile if it is to include languages.<br>
 +
For some reason yet to be investigated, incremental compiles will not include the language files in audacity.app.<br>
 +
''(Check by looking inside the app and looking in 'Resources')''}}
  
[[File:Bom cmake install.png|780px]]
+
<pre>
 +
If you need Audacity to show languages other than English, install the gettext
 +
suite of tools (to get the msgfmt command). The source can be downloaded from:
  
This completes the cmake installation.
+
  ftp://ftp.gnu.org/gnu/gettext/gettext-latest.tar.gz
  
== Install pkg-config ==
+
Untar it:
  
Open a terminal window, extract the pkg-config archive and change to the extracted directory using:
+
  tar xf gettext-latest.tar.gz
  
:tar xf ~/Downloads/pkg-config-0.27.1.tar
+
And install:
:cd pkg-config-0.27.1
 
  
[[File:Bom pkgconfig extract.png|780px]]
+
  cd gexttext-latest
 +
  ./configure
 +
  sudo make install
  
Configure pkg-config:
+
Then clean and recompile.
 +
Incremental compiles will NOT include the language files.
  
:sh configure --with-internal-glib
+
</pre>
  
[[File:Bom pkgconfig configure.png|780px]]
+
<s>
 +
===Decluttering the dmg===
  
Build pkg-config:
+
<pre>
 +
1. Open the dmg
  
:make
+
2. Drag the right border wider.
  
[[File:Bom pkgconfig build.png|780px]]
+
3. Drag all folders that should not be visible into that area.
  
Install pkg-config:
+
4. Drag right border narrower again.
 +
</pre>
  
:sudo make install
 
  
[[File:Bom pkgconfig install.png|780px]]
+
===Signing the DMG===
  
This completes the pkg-config installation.
+
<pre>
 +
1) Comment out the last line of mac/scripts/build_dist.sh so that it reads
 +
 +
  #rm -rf ${DMG} TMP.dmg
 +
 +
  This will prevent deletion of TMP.dmg
  
== Install wxWidgets ==
+
2) Delete any previous /private/tmp/TMP.dmg and /private/tmp/Audacity.dst
 +
    (otherwise, the rebuilt plug-ins folder will contain an unnecessary duplicate
 +
    of itself).
  
Open a Terminal window and extract the wxWidgets source:
+
    Then clean and build Audacity normally.
 +
 +
3) Navigate to /private/tmp/ and type
 +
 +
    hdiutil resize -size 200m TMP.dmg
 +
 +
    This step is needed as codesigning takes some temporary space, more than is
 +
    available in the dmg.
 +
 +
4) mount the dmg
 +
    hdiutil mount TMP.dmg
  
:tar xf ~/Downloads/wxMac-2.8.12.tar
+
4a) Not part of the signing, but a good idea to de-clutter the dmg
 +
    per instructions in the section above.
 +
 +
5) Codesign the app (deep to make sure everything important is signed)
 +
   
 +
    codesign --deep -s <identity> -v "/Volumes/Audacity 2.2.0/Audacity.app"
  
[[File:Bom wxwidgets 2812 extract.png|780px]]
+
    If you see errors like this, no matter what size you used in step (3):
  
Change to the newly created directory:
+
        can't allocate code signature data for: /Volumes/Audacity 2.2.0/Audacity.app/Contents/MacOS/Audacity
 +
        (for architecture i386) because larger updated load commands do not fit (the program must be relinked
 +
        using a larger -headerpad value)
  
:cd wxMac-2.8.12
+
    Then in the XCode project, add -headerpad_max_install_names to Other Linker flags (OTHER_LDFLAGS)
 +
    for Release configuration of the Audacity target, and go back to step (2).
 +
 +
6) Check it is signed to gatekeeper's satisfaction:
 +
 +
    spctl -a -v "/Volumes/Audacity 2.2.0/Audacity.app"
 +
 +
7) unmount the dmg
  
[[File:Bom wxwidgets 2812 cd.png|780px]]
+
    hdiutil eject "/Volumes/Audacity 2.2.0"
 +
 +
8) Make a compressed dmg
 +
 +
    hdiutil convert TMP.dmg -format UDZO -imagekey zlib-level=9 -o "Newname.dmg"
 +
 +
9) codesign that
 +
 +
    codesign -s <identity> -v Newname.dmg
 +
</pre>
 +
</s>
  
Start the build.  This assumes you downloaded the build_wxwidgets script to your Downloads directory:
 
  
:sh ~/Downloads/build_wxwidgets
 
 
[[File:Bom wxwidgets 2812 build.png|780px]]
 
 
After all configurations are built, you will be prompted for your password:
 
 
[[File:Bom wxwidgets 2812 install.png|780px]]
 
 
All configurations have been built and installed:
 
 
[[File:Bom wxwidgets 2812 complete.png|780px]]
 
 
To verify, list the installed configurations:
 
 
[[File:Bom wxwidgets 2812 list.png|780px]]
 
 
Make sure you see 1 default configuration and 3 alternates:
 
 
[[File:Bom wxwidgets 2812 installed.png|780px]]
 
 
wxWidgets installation is now complete.
 
 
== Create links ==
 
To make it easier for Xcode to find the cmake, pkg-config, and wx-config, create links to them in the Xcode developer tree:
 
 
:sudo ln -s /usr/local/bin/pkg-config /Developer/usr/bin
 
:sudo ln -s /usr/local/bin/cmake /Developer/usr/bin
 
:sudo ln -s /usr/local/bin/wx-config /Developer/usr/bin
 
 
[[File:Bom create links.png|780px]]
 
 
== Download Audacity ==
 
 
Now that everything is in place, we finally get to the whole purpose of this exercise, building Audacity.  But first, you must decide if you want to use the source for the current stable version of Audacity or if you want to get the absolute latest development source.  Remember that the latter may not build (usually does) due to active development.
 
 
Make your choice when downloading from here:
 
 
:http://audacity.sourceforge.net/download/source
 
 
[[File:Bom audiacty_build_download.png|780px]]
 
 
Once you have the source downloaded and extracted, you may use either the xcodebuild command line utility or the Xcode 3.2.6 IDE.
 
 
The Audacity xcode project has 4 configurations defined:
 
 
:Debug Static - disables optimization, enables debugging code, and links to static libraries
 
:Debug Shared - disables optimization, enables debugging code, and links to shared libraries
 
:Release Static - enables optimization, disables debugging code, and links to static libraries
 
:Release Shared - disables optimization, disables debugging code, and links to shared libraries
 
 
So you'll need to select which one you want to use in the following steps, but "Debug Static" will be used for this guide.
 
 
== Build with xcodebuild ==
 
 
To use the command line utility, open a Terminal window, change to the Audacity mac directory, and start the build.  If you didn't install Xcode 4.5.2 above, then use "xcodebuild" here:
 
 
:cd audacity/mac
 
:xcodebuild3 -configuration "Debug Static"
 
 
[[File:Bom audiacty_build_xcodebuild.png|780px]]
 
 
When it completes, you should get a "Build Succeeded" message:
 
 
[[File:Bom audiacty_build_xcodebuild_complete.png|780px]]
 
 
The newly built Audacity can be started from Finder, using gdb, or simply:
 
 
:open "build/Debug Static/Audacity.app"
 
 
[[File:Bom audiacty_build_xcodebuild_open.png|780px]]
 
 
== Build with Xcode IDE ==
 
 
To build Audacity using the Xcode 3.2.6 IDE, use Finder to navigate to the "/Developer/Applications" folder, by selecting "Go to folder" from the "Go" menu in Finder:
 
 
[[File:Bom audiacty_build_xcode_goto.png|center|480px]]
 
 
Enter "/Developer/Applications" for the path and click "Go":
 
 
[[File:Bom audiacty_build_xcode_folder.png|780px]]
 
 
Now double click the "Xcode" application to start it:
 
 
[[File:Bom audiacty_build_xcode_start.png|780px]]
 
 
Open the Audacity Xcode project by selecting "Open" from the "File" menu in Xcode:
 
 
[[File:Bom audiacty_build_xcode_open.png|center|480px]]
 
 
Navigate to the "audacity/mac" folder and then double click the "Audacity.xcodeproj" project:
 
 
[[File:Bom audiacty_build_xcode_xcodeproj.png|780px]]
 
 
Now just click "Build and Run" on the toolbar and a freshly built Audacity will start when the build completes.
 
 
[[File:Bom audiacty_build_xcode_build.png|780px]]
 
  
 
[[Category:Mac Platform]] [[Category:For Developers]]
 
[[Category:Mac Platform]] [[Category:For Developers]]

Latest revision as of 11:54, 19 August 2021

Warning icon This page has been deprecated. Newer information can be found here: https://github.com/audacity/audacity/blob/master/BUILDING.md
The information on this page are likely out-of-date and will not be updated in the forseeable future. It may be removed at any time.
ToDo-2 Add
  • Instructions for building modules
These are instructions for building on Mac

The build family of pages:

Instructions in mac/build.txt

These instructions for building on mac are in mac/cmake_build.txt in the Git repo.
Instructions for building on macOS using CMake.

Building on macOS has been made much simpler with the Audacity 2.4.0
release. Still, read this document throughly before starting.

1) Get and install the latest Xcode version available your macOS version:

      MacOS                   Xcode Version (as of Mar 2020)
      Catalina - 10.15        11.3
      Mojave - 10.14          10.3
      High Sierra - 10.13     9.4.1
      Sierra - 10.12          9.2
      El Capitan - 10.11      8.2.1
      Yosemite - 10.10        7.2.1

2) Clone the Audacity repository:

      git clone https://github.com/audacity/audacity

3) Clone wxWidgets 3.1.3:

      git clone --recurse-submodules https://github.com/audacity/wxWidgets.git

   Ensure that you clone with the "--recurse-submodules" option, and do not
   just download the Zip package, otherwise there will be required components
   missing.

   Don't be tempted to use wxWidgets already installed by a package manager
   such as Homebrew because this will cause problems.

   We have applied some Audacity specific patches to wxWidgets to better 
   support VoiceOver, so please use the audacity-fixes-3.1.3 branch. It's
   the default branch on our GitHub copy:

      https://github.com/audacity/wxWidgets/tree/audacity-fixes-3.1.3

   You can be certain the correct branch is active with:

      git checkout audacity-fixes-3.1.3

4) Change directory to the folder where wxWidgets was cloned and build it using:

      sudo <path to Audacity source>/mac/scripts/build_wxwidgets

5) The config command should return "3.1.3" if the install was successful:

      /usr/local/x86_64/bin/wx-config --version

6) Now that you have wxWidgets installed, edit your ~/.bash_profile or
   ~/.zprofile and add:

      export WX_CONFIG=/usr/local/x86_64/bin/wx-config

   Log out and back in again (or reboot) for this to take effect.

7) Download the CMake 3.16.4 DMG from:

      https://cmake.org/download

8) Double click the DMG, follow the prompts and drag the CMake app to the
   Applications folder.

   If you will be building from the command line, open the CMake application
   and click the "Tools -> How to Install For Command Line Use" menu. It will
   give you additional instructions on making CMake available to the command
   line.

   You are now ready to start building Audacity.

BUILDING USING THE CMAKE GUI

   NOTE: Building with the GUI interface will result in the downloading of
         another copy of wxWidgets from Audacity.

1) Open the app.

2) Click the "Browse Source..." button and locate the top of your Audacity
   source tree, then click the "Open" button.

3) Click the "Browse Build..." button and find the location where you want to
   put the build (use the "New Folder" button at the bottom left to create a
   new folder).

   This folder does not have to be in or even near the source tree, but it
   must not be the same as the source tree. However, it is common to make it
   a subdirectory of the Audacity source tree.

4) Click the "Configure" button and when the dialog pops up, select "Xcode" for
   the generator, then click the "Done" button.

5) Click the "Generate" button to create the Xcode project.

6) Now you can either click the "Open Project" button or go to your "Build" folder in
   Finder and open the Xcode project as normal.

BUILDING FROM THE COMMAND LINE

1) Change directory to your Audacity source tree.

      cd audacity

2) Create the "build" folder (name it anything you like):

      mkdir bld

3) Change to the "build" folder:

      cd bld

4) Configure and generate the Xcode project:

      cmake -G Xcode ..

5) Build Audacity using the CMake command or xcodebuild:

      cmake --build . --config Release

      xcodebuild --configuration Release

   The "Audacity.app" bundle will be in the "bin/Release" subdirectory of your
   "build" folder, so you can start it via Finder or:

      open bin/Release/Audacity.app

Notes:

   - If you'd like to get a completely clean build, just delete "build" folder
     and return to step 2 above.

   - Once the Xcode project is generated, you shouldn't have to "configure" or
     "generate" again as it will be done for you automatically after pulling
     updates and building.

     For example:

        cd <audacity> directory
        git pull
        cd bld
        cmake --build . --config Release

   - Instructions on optional signing of DMGs, showing languages other than English,
     and other useful information can be found on our wiki at: 
     http://wiki.audacityteam.org/wiki/Building_On_Mac

CMake Build

1) Change directory to your Audacity source tree.

      cd audacity

2) Create the "build" folder (name it anything you like):

      mkdir bld

3) Change to the "build" folder:

      cd bld

4) Configure and generate the Xcode project:

      cmake -G Xcode ..

5) Build Audacity using the CMake command or xcodebuild:

      cmake --build . --config Release

      xcodebuild --configuration Release

   The "Audacity.app" bundle will be in the "bin/Release" subdirectory of your
   "build" folder, so you can start it via Finder or:

      open bin/Release/Audacity.app

For a Release CMake build

Additionally:

6) Add the help files

   Open contents of bin/Release/Audacity.app
   Add in files with directory help/manual/ and then the 5 top level items

7) Notarize Audacity

   ../mac/scripts/build_dist.sh ../mac ../bld/bin/Release

For Notarization to work, you'll need to have already jumped through the Apple hoops, and have set up your signing file. There are two stages to notarization, one for the bundle, one for the dmg.

To test the Notarization, upload the dmg to dropbox and then download it again. Then double-click to install and drag across to /Applications. When you launch Audacity, you now get a warning about having downloaded from the internet, rather than being prevented from running...


Optional Extras

Bulb icon FFmpeg and LAME

For these, see Building Extras on Mac

Variations

These instructions for variations on building aren't in mac/build.txt in the Git repo. They're actually mostly obsolete instructions. The CMake building now takes care of the GitIdent and mod-script-pipe. Languages should not be an issue if you are already set up with gettext. The signing has been replaced by Notarization. We no longer declutter the dmg, and no one has complained or commented about it on the forums.

Fetching The Manual

We have instructions for fetching the manual on another page.


Defaulting to Portable Settings

 1. Within audacity.app/Contents add the directories:
    Portable Settings
    Portable Settings/AutoSave

 2. Set permissions on these two directories to 777
    chmod 777 "Portable Settings"
    chmod 777 "Portable Settings/AutoSave"

These steps should of course be done before signing.

Official Full Releases

Official Audacity full releases:

  • Have a GitIdent, visible in the about box build information, that says what branch was used in building.
  • Include a copy of the manual.
  • Include other languages.
  • Have a de-cluttered .dmg (the folders in it are dragged outside the visible area)
  • Are signed with a signing key.

Updating GitIdent

 The Audacity "About" box can contain a link to the git commit at which 
 Audacity was built. To create this, run this batch script in /mac/scripts/
 
   get_gitident.sh
 
 If you do this, you are responsible for making sure the ident is correct
 in future builds.  The script overwrites RevisionIdent.h in the src directory.
 If you make further changes to your local copy after this step, or merge a
 more recent version from git, this file, and hence the ident in the build, 
 stays the same, and so would be misleading.
 
 To reset RevisionIdent.h you could do:
 
   git reset --hard origin/master

Include mod-script-pipe

Build this within the Xcode project ON THE SAME DAY as you built audacity. You can click on the .so in the IDE to find out where Xcode put it (it will have some weird long temporary path).

Just before code signing, add it in to the Audacity bundle, into a subdirectory called 'modules'.

Include Languages

Warning icon Beware! Audacity needs a clean and then a recompile if it is to include languages.

For some reason yet to be investigated, incremental compiles will not include the language files in audacity.app.
(Check by looking inside the app and looking in 'Resources')

If you need Audacity to show languages other than English, install the gettext
suite of tools (to get the msgfmt command).  The source can be downloaded from:

   ftp://ftp.gnu.org/gnu/gettext/gettext-latest.tar.gz

Untar it:

   tar xf gettext-latest.tar.gz

And install:

   cd gexttext-latest
   ./configure
   sudo make install

Then clean and recompile.
Incremental compiles will NOT include the language files.

Decluttering the dmg

 1. Open the dmg

 2. Drag the right border wider.

 3. Drag all folders that should not be visible into that area.

 4. Drag right border narrower again.


Signing the DMG

 1) Comment out the last line of mac/scripts/build_dist.sh so that it reads
 
   #rm -rf ${DMG} TMP.dmg
 
   This will prevent deletion of TMP.dmg

 2) Delete any previous /private/tmp/TMP.dmg and /private/tmp/Audacity.dst
    (otherwise, the rebuilt plug-ins folder will contain an unnecessary duplicate
    of itself).

    Then clean and build Audacity normally.
 
 3) Navigate to /private/tmp/ and type 
 
    hdiutil resize -size 200m TMP.dmg
 
    This step is needed as codesigning takes some temporary space, more than is 
    available in the dmg.
 
 4) mount the dmg
    hdiutil mount TMP.dmg

 4a) Not part of the signing, but a good idea to de-clutter the dmg
    per instructions in the section above.
 
 5) Codesign the app (deep to make sure everything important is signed)
     
    codesign --deep -s <identity> -v "/Volumes/Audacity 2.2.0/Audacity.app"

    If you see errors like this, no matter what size you used in step (3):

        can't allocate code signature data for: /Volumes/Audacity 2.2.0/Audacity.app/Contents/MacOS/Audacity
        (for architecture i386) because larger updated load commands do not fit (the program must be relinked
        using a larger -headerpad value)

    Then in the XCode project, add -headerpad_max_install_names to Other Linker flags (OTHER_LDFLAGS)
    for Release configuration of the Audacity target, and go back to step (2).
 
 6) Check it is signed to gatekeeper's satisfaction:
 
    spctl -a -v "/Volumes/Audacity 2.2.0/Audacity.app"
 
 7) unmount the dmg

    hdiutil eject "/Volumes/Audacity 2.2.0"
 
 8) Make a compressed dmg
 
    hdiutil convert TMP.dmg -format UDZO -imagekey zlib-level=9 -o "Newname.dmg"
 
 9) codesign that
 
    codesign -s <identity> -v Newname.dmg