Difference between revisions of "Building for Distros"

From Audacity Wiki
Jump to: navigation, search
(improvements.)
(More links)
 
Line 4: Line 4:
  
 
* Use patched wx3.1.3. from [https://github.com/audacity/wxWidgets https://github.com/audacity/wxWidgets].  If you use a wx3.0 version Audacity will be unstable and crash.
 
* Use patched wx3.1.3. from [https://github.com/audacity/wxWidgets https://github.com/audacity/wxWidgets].  If you use a wx3.0 version Audacity will be unstable and crash.
 +
** Accessibility should be enabled.
 
* Use the version of libs (portaudio, lame, VAMP etc) in our source.
 
* Use the version of libs (portaudio, lame, VAMP etc) in our source.
* Patches welcome, where they do not damage the builds we support (Windows 10, macOS 10.15, Ubuntu 18.04).
+
* Patches to CMake welcome, where they do not damage the builds we support (Windows 10, macOS 10.15, Ubuntu 18.04).
  
  
Line 11: Line 12:
  
 
Links to various stuff
 
Links to various stuff
 +
 +
* [[For Upstream wxWidgets]]
 +
* [[Ppa and Distro Issues]]
 +
* Ye Olde [[Notes for Packagers|archaic bitrotted-notes]] for packagers (pre the transition to CMake)

Latest revision as of 09:14, 3 June 2020

...To Be Written...

Bullet Points

  • Use patched wx3.1.3. from https://github.com/audacity/wxWidgets. If you use a wx3.0 version Audacity will be unstable and crash.
    • Accessibility should be enabled.
  • Use the version of libs (portaudio, lame, VAMP etc) in our source.
  • Patches to CMake welcome, where they do not damage the builds we support (Windows 10, macOS 10.15, Ubuntu 18.04).


Other Information

Links to various stuff