Difference between revisions of "Completed Features"

From Audacity Wiki
Jump to: navigation, search
(add completed feature moved from requests)
m
 
(78 intermediate revisions by 5 users not shown)
Line 1: Line 1:
 +
{{deprecated|[[:Category:Release Notes]]}}
 +
{{ednote|1=
 +
'''Gale 19Apr14:''' [[ToDo-2]] This page is WAY out of date for 2.0.x. Lots of completed features should be moved from [[Feature Requests]] to here.
 +
*'''Peter 20Sep14:''' I don't really see the point of this page.  For a start who uses it?  I have never seen a complaint on the Forum or on the [email protected] digest about this page not being up to date.  I'm pretty sure the developers don't use this page, I didn't know it was here until you stuck the P2 on it back in April.  Surely it is the [[Release Notes]] for the various versions that show which new functionality has been added - and the Manual for any version contains the set of functionality for that specific version. <p>So my vote would be to deprecate this page and not waste valuable time attempting to update it and keep it up to date - the ROI is extremely, minimally, low.</p><p>If we do want to mark things on the Feature Requests page then I suggest that it may be simpler just to format theme with <strike>strikethrough</strike> and an optional note - though just deleting them might be a lot simpler.</p>
 +
* '''Gale 21Sep14:''' Richard Ash used to maintain this page for a while after he created it. I think the point of this page "used to be" as a single page for users to check if a feature they wanted to request is already available. The [[Release Notes]] are on multiple pages (and on another Wiki for pre-2.x) and do not contain every single new feature added. If we agree to open up the Wiki again as has been suggested, there may be more point to this page again.<p> I don't think permanent strikethroughs on Feature Requests will make it more readable and I do see it as a P2 that Feature Requests includes items that are already implemented. </p><p>Perhaps we should move the completed features from Feature Requests to a sandbox page to determine how many of those features were mentioned in release notes and how easy it would be to find that feature in the Manual.</p>
 +
*'''Peter 27Jan15:''' I moved several items for 2.1.0 here (and one from 2.0.6 "Delete Label").  <p>I reformatted the H3s using "===" formatting to make sectional editing easier.</p><p>I do see now that this page gathers some useful development history in one place.</p>
 +
}}
 +
{{Hint|1=<p>'''HINT:''' Use the "Search" facility in your web browser (normally {{shortcut|CTRL + F}} on Windows) to search for completed features.</p>}}
 +
 
__TOC__
 
__TOC__
  
==Completed==
+
== Completed in released versions ==
 +
<div id="stable"></div>
 +
===Legacy 1.2.x Releases===
 +
 
 +
{{adviceopen|These previous [[Feature Requests|feature requests]] were available in legacy 1.2.6.}}
 +
 
 +
* Continuously variable pitch/speed... known as "Gliding Stretch" in Cool Edit Pro/Adobe Audition (implemented as [https://web.audacityteam.org/onlinehelp-1.2/track_time.htm Time Track])
 +
* '''VU Meter''' with both peak and RMS display, peak-hold lines, linear and dB scales, resizable windows, and clipping indicators
 +
* [https://web.audacityteam.org/onlinehelp-1.2/track_label.htm Add labels] at cursor or selection, labels can be also be added while playing or recording
 +
* Export Multiple - exports separate file for each label or track in one process
 +
* Waveform (dB) view option on the track pop-down menu
 +
* Allow generation of x seconds of silence at cursor as per 1.0.0 instead of fixed 30 second interval; allow generate tone to "beep out" a selection
 +
* Basic [https://manual.audacityteam.org/o/man/noise_reduction.html Noise Reduction] effect
 +
* Allow clear or partial clear of Undo History
 +
* Mouse scroll zooms in and out of the waveform (Use CTRL + Wheel-Rotate)
 +
* Loop file or marker in track: drum lines, bass loops, etc. (Use SHIFT + Play button or its shortcut "L", or the "Repeat" effect to paste a loop 'x' number of times)
 +
* Listen to a few seconds at the beginning and end of selection, to test whether long selection is desired selection (place mouse cursor near start or end of selection, use "B" shortcut, then audio plays from start of selection to mouse cursor, or from mouse cursor to end of selection)
 +
 
 +
 
 +
<div id="beta"></div>
 +
===Legacy 1.3.x Releases===
 +
 
 +
{{adviceopen|These previous [[Feature Requests|feature requests]] were available in the final 1.3.14 release in the legacy 1.3 series. 1.3.14 also included all the features implemented in 1.2.x as above.}}
 +
 
 +
* '''Effects:'''
 +
** '''Equalization''':
 +
*** curves saved in XML format in the Audacity settings folder
 +
*** optional grid for graph
 +
** '''Nyquist:'''
 +
*** SAL syntax supported from 1.3.8 onwards
 +
 
 +
* '''Interface:'''
 +
** '''Mix and Render to New Track''' (CTRL + SHIFT + M)
 +
** New Preferences option for "System" language which is used on first launch rather than asking for language choice
 +
** Selection Bar: numerical display of cursor position and beginning/end of selection allows cursor or selection position to be changed
 +
** Time Shift Tool moves multiple selected tracks at the same time; shift amount displayed in Selection Bar
 +
** Support for multiple clips per track; these can be time-shifted and pasted anywhere including after the end of current audio
 +
** Support for GTK+2 & Unicode wxWidgets builds
 +
** Menu item to create a new mono track from an unsplit stereo track
 +
** Red color for clipping in the waveform display window (Show Clipping in View menu); count number of clipped samples (Find Clipping in Analyze menu)
 +
** A beep after long processes have completed (NOTE: not audible on many systems, needs more work post 1.4 so that it calls a system audio file) 
 +
** Solo button mutually exclusive, so that soloing a different track automatically unsolos the previously soloed one  (use the "Simple" solo button option in the Interface tab of Preferences)
 +
** Muted tracks are not exported (even if the solo button option set to "Standard" so that muted tracks can be soloed) 
 +
** Horizontal line at 0 (DC=0) properly detects DC offset
 +
** More precise volume levelling (you can now SHIFT + click to drag the gain/pan sliders with more precision; dragging the sliders now does so in 1 unit increments).
 +
** "Default View Mode" preference to choose view for new tracks, such as Waveform (dB)
 +
** ''(Windows, Linux)'' '''ALT + F4, window [X] and system close methods to quit as well as File > Exit; File > Close should always clear to a new, empty workspace
 +
 
 +
* '''Labels:'''
 +
**Make selection between one pair of adjacent labels (click in a label, drag a selection from that point and have it snap to any other label)
 +
**Create labels automatically at pre-defined intervals on the timeline for example every five minutes. (Use Regular Interval Labels in the Analyze Menu)
 +
 
 +
* '''Projects''':
 +
** Save Project As.. dialog defaults to saving wherever it last saved
 +
** Track states saved in project: height, collapsed, mute/solo and gain/pan
 +
 
 +
* '''Shortcuts:'''
 +
** playback cursor to resume at stop point, not at start point (use SHIFT+ A for play or stop and select)
 +
** short/long seek while playing and stopped (use "," for short jump left and "."  for short jump right, modify with SHIFT to produce a long jump); arrow keys still work as before for seeking while playing
 +
**  Set regions while playing and stopped (the same shortcut keys "[" and "]" can be now be used for setting the left boundary while playing, and adjusting that boundary while stopped). To use for creation of multiple region-labels while playing: use "[" then "]" to mark left and right boundary, CTRL + B to label, then up arrow (&uArr;) and repeat process as required
 +
** play a given length before and after the selected area but skip the selection itself, to preview what a cut would sound like (use the "C" shortcut, and customise the length of preview in the Audio I/O tab of Preferences)
 +
 
 +
* '''Toolbars:'''
 +
** '''Meter Toolbar''' can be made narrower which is more suitable for vertical orientation
 +
** '''Device Toolbar''' turned on by default and added Host and Input Channels.
 +
 
 +
* Use ID3v2 for MP3 tags export.
 +
* Allow leaving Genre field blank in Metadata Editor
 +
* Noise generation supports pink and brown as well as white
 +
* Chirp and Tone generation and Spectrograms support any frequencies of up to half the current project rate.
 +
* Logarithmic Spectrogram view
 +
* Single menu command for removal of center-panned content such as vocals from stereo tracks (please see the limitations of this technique on our [[Vocal Removal Plug-ins]] page)
 +
* Import/export [[FLAC]]
 +
* Import/export AC3/AMR NB/AMR WB/M4A/WMA using [https://manual.audacityteam.org/o/man/faq_installation_and_plug_ins.html#ffdown FFmpeg]. 
 +
* ID tags: customisable and alphabetically ordered genre list, and support for export of [[OGG]] tags
 +
* More MP3 encoding options (choice of CBR or VBR, presets, Joint Stereo)
 +
* Export to the imported [[WAV]] or [[AIFF]] file, even if Audacity preferences set to read that file directly rather than making a copy of it
 +
* Export to multi-channel files - enabled on the Import/Export tab of Preferences by checking "Use custom mix..." in the "When exporting tracks..." panel. Supports up to 32 output channels (WAV, AIFF or OGG) or 8 output channels (FLAC). Currently there is no support for exporting multichannel files using File > Export Multiple, no panning support and no multi-channel playback. See [[More GSoC Ideas#Multi-Channel Audio support|here]] for outline ideas for improving support.
 +
* Export multiple: filter out disallowed characters in labels; progress dialogs explicitly state which file is currently being processed.
 +
* "All supported formats" mask for file selection in the Windows open dialog
 +
* Multi-band graphic equalizer with ability to add custom presets
 +
** Ability to export and import the presets. A library of presets could then be made available (see [[EQCurvesDownload]] for the beginnings of such a library).
 +
* Allow recording start and end times to be scheduled with a timer
 +
* Allow recording at end of an existing track (hold SHIFT while pressing Record or use SHIFT + R hotkey)
 +
* Mixer support for ALSA on Linux
 +
* Support for command line export via an external encoder such as LAME
 +
* More flexible/less aggressive noise removal like Goldwave
 +
* Automated recovery of audio data after crash/power loss with choice of autosave interval
 +
* Fix clipping effect for overdriven sound (Clip Fix underneath the divider in Effect menu)
 +
* 32-bit float data over 0 dB now handled without clipping, so can be losslessly de-amplified if required. Files produced by certain utilities that contain 32 bit data over 0 dB can now be imported.
 +
* Truncate silence works on stereo tracks as well as mono
 +
* 24 bit uncompressed export should be a primary choice in export options, not relegated to "Other".
 +
* Records in stereo by default.
 +
* [[VoiceActivated|Sound Activated Recording]] pauses recording when signal falls below defined threshold, and resumes recording in same track when signal rises above threshold again.
 +
* '''Support for non-MMAP devices like [http://pulseaudio.org/ PulseAudio]''', so that audio can be played through networked computers, and soundcards aggregated. 
 +
* '''Delete temp files after processing each file in a chain.'''
 +
* '''Normalize:'''
 +
** Normalize stereo channels independently as an option, not pre-ordained behaviour.
 +
** Move the negative sign into the text box.
 +
 
 +
 
 +
<div id="current"></div>
 +
===Current 2.x Releases===
 +
{{adviceopen|These previous [[Feature Requests|feature requests]] were introduced in the [https://web.audacityteam.org/download/ current 2.x series], where most of the features introduced in 1.2 and 1.3 still exist.}}
 +
 
 +
* '''Scrubbing and Seeking'''
 +
* '''Optional Fixed Play/Record head'''
 +
*'''New Adjustable Fade effect'''
 +
* '''New Distortion effect'''
 +
* '''You can superimpose a track name on the waveform''' for audio tracks
 +
* '''Effects manager/Plugin manager:'''  add and remove plug-ins from menus
 +
* '''Extreme Stretch''' effect - see [[Extreme Stretch Effect]] 
 +
* '''Reverb''' effect replaced the Gverb effect (which had many issues).
 +
* '''Support for Nyquist process effects in Chains''' (2.0.1).
 +
* '''Bass and Treble" effect with gain slider replaced Bass Boost''' (2.0.3).
 +
* '''TAB / SHIFT + TAB cycles through clips''' to nearest label edge (2.0.5).
 +
*'''Right-click Delete label''' 
 +
* '''Meter Toolbar:'''
 +
**'''Headroom indicators''' drawn at user-specified n dB below 0 dB FS with fill color change when headroom level exceeded (green below headroom, yellow above, red when clipping. 
 +
**'''Resizable to half-height'''
 +
**'''Greater initialised width:'''
 +
**'''Display meters independently'''
 +
**'''Toggle between standard size input and output meters for editing/playback, and full width input meter only when recording.'''
 +
**'''Save all Meter settings in the Meter Preferences so they will be available on restart of Audacity''', namely Horizontal/Vertical, Linear/dB and dB range as well as existing refresh rate.
 +
**'''Inactive Recording meter displays message''' "Click to Start Monitoring"
 +
*'''Effects groupable by plug-in format (VST/LADSPA/LV2/Nyquist/AU)'''
 +
* '''Help Menu: Move down "About" to bottom of menu''' to be consistent with most other software 
 +
* '''Tracks Menu:'''
 +
** Align Tracks > End-to-End'''
 +
** Mix and Render to New Track (CTRL + SHIFT + M)
 +
** Force export to mono (at specified bit rate) (2.1.3)
  
'''These are all previous [[Feature Requests|feature requests]] which are now implemented in Audacity. The first version to implement them is in brackets.
+
* '''Transport Menu:''' Add "Play/Stop and Set Cursor" (SHIFT + A)
  
* [[VuMeter]] - complete with both peak and RMS display, peak-hold lines, linear and dB scales, resizable windows, and clipping indicators (1.2.2).
+
<div id="svn"></div>
* Add label at current playback cursor (1.2.2).
 
* Import/export [[FLAC]] (Free Lossless Audio Codec) - Fully implemented via the current version of libsndfile in future releases. 1.3 has an enhanced exporter which supports FLAC tags as well (1.3.2).
 
* Export Multiple - exports separate file for each label appeared in (1.2.2).
 
* Automation: Export many files at once (1.2.3).
 
* Time Position - display as a number the postion of the cursor, of the begin and end of selection (1.3.0).
 
* Waveform scale: dB option - already done - change the option on the track pop down menu to "waveform (dB)"
 
* More than one clip per track (1.3.0).
 
* Move cursor to a specific time (useful for blind users, and anyone with long files) (1.3.0).
 
* Support for GTK+2 & Unicode wxWidgets builds (1.3.0).
 
* Allow generation of X seconds of silence at cursor a la v1.0.0 "Insert Silence" instead of fixed 30 second interval (1.2.4).
 
* Make Mono Track: Option to create a new mono track from a stereo track (1.3.0).
 
* Set selection based on times (i.e. select 1.0 sec to 5.0 sec) (1.3.0).
 
* 12-band graphic equalizer (smoother and faster than the current FFT filter or Equalizer) (1.3.2).
 
* Time limit for recording
 
** See [[TimedRecording]]  for a way to do this in Audacity 1.2. (didn't work for me either)
 
** See also [[AudaRemote]], a scheduled recording program for Audacity on Windows.
 
* Scheduled start time for recording (1.3.2).
 
* [[ClickPop]] removal (1.2.4).
 
* Make "label at selection" work while recording (1.2.4).
 
* Allow clear or partial clear of Undo buffers (1.2.4).
 
* Quickly find the locations in your recording where you need to do some editing.
 
''Press CTRL + M to add a label at the current playback or recording position. This then gives you markers on the project which you can click on to return to the position you were at when you created the label.
 
* Mixer support for ALSA on Linux (1.3.2).
 
* LAME commandline switches. If you choose an external encoder such as LAME when exporting you can use command line switches (1.3.3).
 
* Noise removal (more flexible - ala Goldwave, possibility to apply effect even less) (1.3.3).
 
* Time Shift Tool to move all selected tracks at the same time, and tell in tool bar the shift amount (1.3.3)
 
* Ability to time-shift a /selection/ within a track and not have to split selection to another track first (1.3.0).
 
* Paste a selection to any track, to the current position of the cursor, not just to the beginning of the track, or just to the end of existing material on the track (1.3.0)
 
* Automation via export-to-pipe: Instead of only being able to export to a file, could Audacity be made to have the ability to pipe data in a given format to a specific application?  This would be really useful, because it would allow the user to do things like convert WAV format data created by Audacity to formats that Audacity does not support (yet) or to otherwise do post-processing in a fully automated fashion.  For example, I'd like to convert WAV data created by Audacity using notlame's --vbr-new option, which Audacity does not support (as far as I know).  Right now that involves exporting to WAV and then manually running notlame --vbr-new on the exported file.  With a lot of files to process in this manner, this becomes kind of a pain.  Exporting to a pipe could solve this problem and many others besides (1.3.3).
 
* I would love it there were more stompbox-style effects, you know, like distortion, the leslie speaker effect, chorus, flanger, talkbox/vocoder, That would be great. LADSPA plugins are already supported, and there are many available for such effects (1.3.3).
 
* A nondefault setting to allow recovery/retaining of current data (recording in progress or otherwise) in case of accidental closure of audacity or power failure - even if data cannot be fully recovered it is preferable to have something (e.g. 70 minutes) rather than nothing, especially when recording live events. Now implemented, with full autosave and recovery (1.3.3)
 
* Export OGG tags (title, artist, album, etc) (1.3.3)
 
* An "all recognized formats" mask selection in the Windows open dialog (1.3.3)
 
* Display genre drop-down list in alphabetical order (1.3.3)
 
* More MP3 encoding options (bitrate, the possibility of choosing between CBR or VBR, etc...) (1.3.3)
 
* Define Selection of audio through simple dialog: It would be much faster for a screen reader user to define the selection through a little "Select Specified Time" dialog, similar to WavePad. Then just press the "Preview" button to hear the selected audio rather than mess with toolbars (1.3.0).
 
* The scroll wheel on a mouse zooms in and out of the waveform (like in Sound Forge).<span style="color:green"> (1.2.x): Use CTRL-Wheel-Rotate</span>  
 
  
 +
== Experimental ==
 +
{{adviceopen|1=These previous [[Feature Requests|feature requests]] are now implemented experimentally if you build Audacity from the latest [https://web.audacityteam.org/community/developers#svn SVN HEAD development code] and turn the feature on.}}
  
 +
* '''Seek left during playback seeks behind cursor'''
  
  
 
==Not necessary==
 
==Not necessary==
  
'''These are all previous [[Feature Requests|feature requests]] which are not deemed necessary as there are already other ways of doing the same thing'''
+
{{adviceopen|These are previous [[Feature Requests|feature requests]] which are felt un-necessary - there are already other ways of doing the same thing.}}
  
 +
* An option to normalize tracks individually: normalizing works either on all tracks as a single group, or only on the selected track (use the standard technique to select multiple tracks: select the first track you want to normalize by clicking in its Track Control Panel, then hold down SHIFT while clicking in the other track(s) you want to normalize)
  
* An option to normalize tracks individually. (Currently, normalizing works either on all tracks as a single group, or only on the selected track.) (1 vote)<BR> <span style="color:green;font-style:italic"> Use the standard technique to select multiple tracks. Select the first track you want to normalize by clicking in its Track Panel where the mute/solo buttons are, then hold down SHIFT while clicking in the other track(s) you want to normalize. </span>
+
[[Category:Feature Planning]]

Latest revision as of 09:40, 19 August 2021

Warning icon This page has been deprecated. Newer information can be found here: Category:Release Notes
The information on this page are likely out-of-date and will not be updated in the forseeable future. It may be removed at any time.
Gale 19Apr14: ToDo-2 This page is WAY out of date for 2.0.x. Lots of completed features should be moved from Feature Requests to here.
  • Peter 20Sep14: I don't really see the point of this page. For a start who uses it? I have never seen a complaint on the Forum or on the [email protected] digest about this page not being up to date. I'm pretty sure the developers don't use this page, I didn't know it was here until you stuck the P2 on it back in April. Surely it is the Release Notes for the various versions that show which new functionality has been added - and the Manual for any version contains the set of functionality for that specific version.

    So my vote would be to deprecate this page and not waste valuable time attempting to update it and keep it up to date - the ROI is extremely, minimally, low.

    If we do want to mark things on the Feature Requests page then I suggest that it may be simpler just to format theme with strikethrough and an optional note - though just deleting them might be a lot simpler.

  • Gale 21Sep14: Richard Ash used to maintain this page for a while after he created it. I think the point of this page "used to be" as a single page for users to check if a feature they wanted to request is already available. The Release Notes are on multiple pages (and on another Wiki for pre-2.x) and do not contain every single new feature added. If we agree to open up the Wiki again as has been suggested, there may be more point to this page again.

    I don't think permanent strikethroughs on Feature Requests will make it more readable and I do see it as a P2 that Feature Requests includes items that are already implemented.

    Perhaps we should move the completed features from Feature Requests to a sandbox page to determine how many of those features were mentioned in release notes and how easy it would be to find that feature in the Manual.

  • Peter 27Jan15: I moved several items for 2.1.0 here (and one from 2.0.6 "Delete Label").

    I reformatted the H3s using "===" formatting to make sectional editing easier.

    I do see now that this page gathers some useful development history in one place.

HINT: Use the "Search" facility in your web browser (normally CTRL + F on Windows) to search for completed features.

Completed in released versions

Legacy 1.2.x Releases

These previous feature requests were available in legacy 1.2.6.
  • Continuously variable pitch/speed... known as "Gliding Stretch" in Cool Edit Pro/Adobe Audition (implemented as Time Track)
  • VU Meter with both peak and RMS display, peak-hold lines, linear and dB scales, resizable windows, and clipping indicators
  • Add labels at cursor or selection, labels can be also be added while playing or recording
  • Export Multiple - exports separate file for each label or track in one process
  • Waveform (dB) view option on the track pop-down menu
  • Allow generation of x seconds of silence at cursor as per 1.0.0 instead of fixed 30 second interval; allow generate tone to "beep out" a selection
  • Basic Noise Reduction effect
  • Allow clear or partial clear of Undo History
  • Mouse scroll zooms in and out of the waveform (Use CTRL + Wheel-Rotate)
  • Loop file or marker in track: drum lines, bass loops, etc. (Use SHIFT + Play button or its shortcut "L", or the "Repeat" effect to paste a loop 'x' number of times)
  • Listen to a few seconds at the beginning and end of selection, to test whether long selection is desired selection (place mouse cursor near start or end of selection, use "B" shortcut, then audio plays from start of selection to mouse cursor, or from mouse cursor to end of selection)


Legacy 1.3.x Releases

These previous feature requests were available in the final 1.3.14 release in the legacy 1.3 series. 1.3.14 also included all the features implemented in 1.2.x as above.
  • Effects:
    • Equalization:
      • curves saved in XML format in the Audacity settings folder
      • optional grid for graph
    • Nyquist:
      • SAL syntax supported from 1.3.8 onwards
  • Interface:
    • Mix and Render to New Track (CTRL + SHIFT + M)
    • New Preferences option for "System" language which is used on first launch rather than asking for language choice
    • Selection Bar: numerical display of cursor position and beginning/end of selection allows cursor or selection position to be changed
    • Time Shift Tool moves multiple selected tracks at the same time; shift amount displayed in Selection Bar
    • Support for multiple clips per track; these can be time-shifted and pasted anywhere including after the end of current audio
    • Support for GTK+2 & Unicode wxWidgets builds
    • Menu item to create a new mono track from an unsplit stereo track
    • Red color for clipping in the waveform display window (Show Clipping in View menu); count number of clipped samples (Find Clipping in Analyze menu)
    • A beep after long processes have completed (NOTE: not audible on many systems, needs more work post 1.4 so that it calls a system audio file)
    • Solo button mutually exclusive, so that soloing a different track automatically unsolos the previously soloed one (use the "Simple" solo button option in the Interface tab of Preferences)
    • Muted tracks are not exported (even if the solo button option set to "Standard" so that muted tracks can be soloed)
    • Horizontal line at 0 (DC=0) properly detects DC offset
    • More precise volume levelling (you can now SHIFT + click to drag the gain/pan sliders with more precision; dragging the sliders now does so in 1 unit increments).
    • "Default View Mode" preference to choose view for new tracks, such as Waveform (dB)
    • (Windows, Linux) ALT + F4, window [X] and system close methods to quit as well as File > Exit; File > Close should always clear to a new, empty workspace
  • Labels:
    • Make selection between one pair of adjacent labels (click in a label, drag a selection from that point and have it snap to any other label)
    • Create labels automatically at pre-defined intervals on the timeline for example every five minutes. (Use Regular Interval Labels in the Analyze Menu)
  • Projects:
    • Save Project As.. dialog defaults to saving wherever it last saved
    • Track states saved in project: height, collapsed, mute/solo and gain/pan
  • Shortcuts:
    • playback cursor to resume at stop point, not at start point (use SHIFT+ A for play or stop and select)
    • short/long seek while playing and stopped (use "," for short jump left and "." for short jump right, modify with SHIFT to produce a long jump); arrow keys still work as before for seeking while playing
    • Set regions while playing and stopped (the same shortcut keys "[" and "]" can be now be used for setting the left boundary while playing, and adjusting that boundary while stopped). To use for creation of multiple region-labels while playing: use "[" then "]" to mark left and right boundary, CTRL + B to label, then up arrow (⇑) and repeat process as required
    • play a given length before and after the selected area but skip the selection itself, to preview what a cut would sound like (use the "C" shortcut, and customise the length of preview in the Audio I/O tab of Preferences)
  • Toolbars:
    • Meter Toolbar can be made narrower which is more suitable for vertical orientation
    • Device Toolbar turned on by default and added Host and Input Channels.
  • Use ID3v2 for MP3 tags export.
  • Allow leaving Genre field blank in Metadata Editor
  • Noise generation supports pink and brown as well as white
  • Chirp and Tone generation and Spectrograms support any frequencies of up to half the current project rate.
  • Logarithmic Spectrogram view
  • Single menu command for removal of center-panned content such as vocals from stereo tracks (please see the limitations of this technique on our Vocal Removal Plug-ins page)
  • Import/export FLAC
  • Import/export AC3/AMR NB/AMR WB/M4A/WMA using FFmpeg.
  • ID tags: customisable and alphabetically ordered genre list, and support for export of OGG tags
  • More MP3 encoding options (choice of CBR or VBR, presets, Joint Stereo)
  • Export to the imported WAV or AIFF file, even if Audacity preferences set to read that file directly rather than making a copy of it
  • Export to multi-channel files - enabled on the Import/Export tab of Preferences by checking "Use custom mix..." in the "When exporting tracks..." panel. Supports up to 32 output channels (WAV, AIFF or OGG) or 8 output channels (FLAC). Currently there is no support for exporting multichannel files using File > Export Multiple, no panning support and no multi-channel playback. See here for outline ideas for improving support.
  • Export multiple: filter out disallowed characters in labels; progress dialogs explicitly state which file is currently being processed.
  • "All supported formats" mask for file selection in the Windows open dialog
  • Multi-band graphic equalizer with ability to add custom presets
    • Ability to export and import the presets. A library of presets could then be made available (see EQCurvesDownload for the beginnings of such a library).
  • Allow recording start and end times to be scheduled with a timer
  • Allow recording at end of an existing track (hold SHIFT while pressing Record or use SHIFT + R hotkey)
  • Mixer support for ALSA on Linux
  • Support for command line export via an external encoder such as LAME
  • More flexible/less aggressive noise removal like Goldwave
  • Automated recovery of audio data after crash/power loss with choice of autosave interval
  • Fix clipping effect for overdriven sound (Clip Fix underneath the divider in Effect menu)
  • 32-bit float data over 0 dB now handled without clipping, so can be losslessly de-amplified if required. Files produced by certain utilities that contain 32 bit data over 0 dB can now be imported.
  • Truncate silence works on stereo tracks as well as mono
  • 24 bit uncompressed export should be a primary choice in export options, not relegated to "Other".
  • Records in stereo by default.
  • Sound Activated Recording pauses recording when signal falls below defined threshold, and resumes recording in same track when signal rises above threshold again.
  • Support for non-MMAP devices like PulseAudio, so that audio can be played through networked computers, and soundcards aggregated.
  • Delete temp files after processing each file in a chain.
  • Normalize:
    • Normalize stereo channels independently as an option, not pre-ordained behaviour.
    • Move the negative sign into the text box.


Current 2.x Releases

These previous feature requests were introduced in the current 2.x series, where most of the features introduced in 1.2 and 1.3 still exist.
  • Scrubbing and Seeking
  • Optional Fixed Play/Record head
  • New Adjustable Fade effect
  • New Distortion effect
  • You can superimpose a track name on the waveform for audio tracks
  • Effects manager/Plugin manager: add and remove plug-ins from menus
  • Extreme Stretch effect - see Extreme Stretch Effect
  • Reverb effect replaced the Gverb effect (which had many issues).
  • Support for Nyquist process effects in Chains (2.0.1).
  • Bass and Treble" effect with gain slider replaced Bass Boost (2.0.3).
  • TAB / SHIFT + TAB cycles through clips to nearest label edge (2.0.5).
  • Right-click Delete label
  • Meter Toolbar:
    • Headroom indicators drawn at user-specified n dB below 0 dB FS with fill color change when headroom level exceeded (green below headroom, yellow above, red when clipping.
    • Resizable to half-height
    • Greater initialised width:
    • Display meters independently
    • Toggle between standard size input and output meters for editing/playback, and full width input meter only when recording.
    • Save all Meter settings in the Meter Preferences so they will be available on restart of Audacity, namely Horizontal/Vertical, Linear/dB and dB range as well as existing refresh rate.
    • Inactive Recording meter displays message "Click to Start Monitoring"
  • Effects groupable by plug-in format (VST/LADSPA/LV2/Nyquist/AU)
  • Help Menu: Move down "About" to bottom of menu to be consistent with most other software
  • Tracks Menu:
    • Align Tracks > End-to-End
    • Mix and Render to New Track (CTRL + SHIFT + M)
    • Force export to mono (at specified bit rate) (2.1.3)
  • Transport Menu: Add "Play/Stop and Set Cursor" (SHIFT + A)

Experimental

These previous feature requests are now implemented experimentally if you build Audacity from the latest SVN HEAD development code and turn the feature on.
  • Seek left during playback seeks behind cursor


Not necessary

These are previous feature requests which are felt un-necessary - there are already other ways of doing the same thing.
  • An option to normalize tracks individually: normalizing works either on all tracks as a single group, or only on the selected track (use the standard technique to select multiple tracks: select the first track you want to normalize by clicking in its Track Control Panel, then hold down SHIFT while clicking in the other track(s) you want to normalize)