Difference between revisions of "Completed Proposal Menu Reorganisation"

From Audacity Wiki
Jump to: navigation, search
(Save Simplification: I tend to favour retaining Export)
m (James moved page Proposal Menu Reorganisation to Completed Proposal Menu Reorganisation without leaving a redirect: Essential idea implemented for 2.2.0)
 
(76 intermediate revisions by 7 users not shown)
Line 1: Line 1:
 
{{Proposal_Header| This proposal page is about reorganising the menus. }}
 
{{Proposal_Header| This proposal page is about reorganising the menus. }}
 +
 +
__TOC__
  
 
== Proposed Feature ==
 
== Proposed Feature ==
Line 7: Line 9:
 
The Audacity menus have also become rather complex with numerous options, especially when label linking is enabled.  
 
The Audacity menus have also become rather complex with numerous options, especially when label linking is enabled.  
  
 +
== Developer/QA Backing ==
 +
* "Something needs to be done!" That sentiment is backed by (at least)
 +
** '''JC'''
 +
** '''GA''' - But regressions in functionality and need for ease of access must be kept in mind
 +
** '''PS''' - I strongly support restricting the Open (Open Project) command to only opening Projects.  I also support the implementation of Effect Menu categorization now that the assigment of hot-keys to effects has been implemented.
 +
** '''BW'''
 +
 +
== Issues ==
 +
* New users:
 +
** Confused about what 'export' and 'save' mean.
 +
** Too many choices.
 +
** Expecting to work with (e.g.) wav rather than projects.
 +
* Experienced users:
 +
** Find menus too long.
 +
** Find menus too verbose.
 +
 +
== Details ==
 +
The general tenor of the solution is to make it easier and more natural to get to the most commonly used and most familiar options.  This will mainly be achieved by better grouping of menu items into submenus, rather than putting them all at the same level.
  
 +
{{Hint|'''Note:''' April 2011: The changes to Open/Export/Import proved contentious and also there is concern that some non-rearrangement changes proposed to get that to work would risk jeopardizing the 2.0 schedule.  The Edit-Menu changes don't have these problems and have been implemented. Actually making other changes will be parked until December 2011, or until 2.0 comes out, whichever is sooner.  }}
  
== Developer Backing ==
+
===Effect Menu===
* [[User:James|James Crook]] - In favour of certain changes suggested here.
+
This sub-proposal has been moved to a free-standing [[Proposal Effect Menu Categorization]].
  
 +
This was done to provide focus on this particular menu and in the interests of simplifying this page and its associated talk page.
  
== Use Cases ==
 
* New users of Audacity who are confused about export and save, or what the menu items actually mean
 
* Experienced users of Audacity who feel the menus are too long or verbose
 
  
 +
===[[Proposal File Menu Reorganization|File Menu]]===
 +
This sub-proposal has been moved to a free-standing [[Proposal File Menu Reorganization]].
  
== Details ==
+
This was done to provide focus on this particular menu and in the interests of simplifying this page and its associated talk page.
 +
 
 +
 
 +
===[[Proposal Edit Menu Reorganization|Edit Menu]]===
 +
'''Done:'''
 +
<s>
 +
* 'Remove Audio >' leading to
 +
** 'Cut|Split Cut|Delete|Split Delete|Silence Audio|Trim'
 +
* 'Clip Boundaries >' leading to
 +
** 'Split|Split New|Join|Detach at Silences'
 +
*Cut & Delete have been restored to the top level in the Edit menu for 2.0.6
 +
</s>
  
Subject to discussion. Some options to choose from below:
+
Despite the moving of items into submenus as above leading to a strong overall reduction in complaints about Edit Menu, complaints that remain have focused on the undesirability of "core" edit items like Cut and Delete being "hidden" in a submenu. A free-standing [[Proposal Edit Menu Reorganization]] discusses this.
  
 +
===Tracks Menu===
 +
* 'Mix and Render >'
 +
** 'Replace|Mix to New Track'
 +
* 'All Track Mute/Solo >'
 +
** 'Mute All|UnMute All|UnSolo All|UnMute & UnSolo All'
  
=== Discussion ===
 
* '''Gale:''' I'd prefer ... menu changes clarifying save and export (e.g. moving "save" down), adding a line to the project save warning about keeping .aup and _data together, and warning every time you import an aliased file (either until you turn the warning off, or a one-time warning).
 
  
===Save Simplification===
+
===View Menu===
 +
* Now has the Metadata Editor, and it is called 'Metadata Editor' not 'Open Metadata Editor'.
  
* Replace Save-Project|Save-Project-As|Save-Compressed-Project-As|Export|Export-Selection|Export-Multiple by Save|Save-As|Save-Special.
 
  
Save is only for saving in .aup format.  Save-As and Save-Special would actually both allow the full range of saving options through an extended custom save dialog.  The Save-Special however is more-in-your-face about showing you the options.  With Save-Special before you get to the save-as dialog you get an options dialog to select whether you are saving just the selection or the whole project.  You'll also be told what sample rate you are saving at, and be given the option of changing that.  If you use Save-Special you will see the options for the choice you have made and you get a radio button choice for the audio type, with wav and mp3 given prominence - the file extension is then defaulted from the type.  If instead you use Save-As you don't automatically get shown that choice, and the audio type is defaulted from the name.
+
===Tools Menu===
 +
* This is a new menu before Help, with things that mostly come from Help.
  
*Peter 21Jan10:  I tend to favour retaining the Export command.  Many software packages use '''Save''' when storing data in their internal format - and '''Export''' when creating the non-native formats that are intended for use elsewhere - the current structure has a syntactic purity.  I do know that some users (particularly newbies) find it to understand - but as BillW points out elsewhere this is a RTFM issue and that Audacity could be more informative when users ar Saving/Exporting.  See:  http://wiki.audacityteam.org/wiki/Top_Usability_Issues
 
  
===Edit Simplification===
+
===Help Menu===
* Replace Split/Split-Cut/Split-New/Split-Delete/Paste/Paste-Text-Labels/Copy/Trim/Silence-Audio/Detach-At-Silences/Duplicate/Join/Delete, by Copy/Cut/Paste/Trim/Delete/Duplicate/Join
+
The items which are really 'tools' (diagnostics) taken out of Help and are now in the Tools menu.
 +
* Help Menu has 'About' as the last entry.
  
Haven't really worked out exactly how to reduce the menu, but there seem to be way too many options here.  For now this is just a placeholder for noting that some simplification is being thought about.
 
  
===Signposting ===  
+
=== Images ===
 +
[[User:James/Proposal Menu Reorganisation|Mock up]] of proposed menu changes.
  
'''Gale:''' Give the users visual clues that are in their face. Look at GIMP. Every menu item has a hover tooltip which is duplicated in the Status Bar. It would have to have a Preference to turn it off (as it does in GIMP).
 
 
 
Not sure if this should be here or as an alternative solution to Save vs Export on [[Top Usability Issues]]. I think it belongs here. It is a possible way of avoiding the need to use a longer menu wording than needed, and the text is driven by the menus. 
 
  
{{Proposal}}
+
== Side Issues ==
 +
These aren't strictly part of the menu reorganization, but came up in discussion of it.  They are not being acted on for this proposal.
 +
* Some users would like Export to default to the directory where the audacity project is.
 +
** Ed has a patch to allow this
 +
* Some users would like project save and export directories to be set by preferences.
 +
** Ed has a patch to allow .aup to be drag and dropped too.
 +
* It would probably be a good idea to modify trim so that it only removes audio from selected clips, not whole clips outside its selection.
 +
* The "align" commands are inadequate, confusing and lack shortcut bindings. A command to align tracks end-to-end is sorely needed.
 +
* Stop and move cursor to stop point, which is SHIFT+A, is not in the menu.  Preferred option is to make this a preference as to how stop behaves.
 +
* Signposting: Give the users visual clues that are in their face. Look at GIMP. Every menu item has a hover tooltip which is duplicated in the Status Bar. It would have to have a Preference to turn it off (as it does in GIMP).
 +
* Lots of discussion of shortcut keys.  (Moved to talk page for now).
 +
* At this stage we are NOT proposing a mode where Audacity can switch over to using a wav file as if it were its project - much as Microsoft word can open a txt file, but then warns when you try to save it that 'some features/formatting can't be saved in text format'.  It's not that hard to add, but it would go outside the scope of this proposal.  This would be a good feature though and solve a lot of user confusion.  If we were to do it, we'd list in the warning dialog what would be lost.  IF we did this we could at the same time change the labeling of 'Save Project' and 'Save Project As' to 'Save' and 'Save As'.  We would also change 'Recent Projects' back to 'Recent Files'.
 +
* In the Edit menu, there is an unresolved issue as to how to handle the different behaviour of [ and ] when the track is static or playing (currently this is at Edit > Select > Left / Right at Playback Position).
 +
* There is a consistent view among some users that the Tracks Menu and not the Track Control Panel should have commands for channel setting (or even rate and format). This is on grounds of discoverability above all else. Gale thinks this is worth some consideration although it might be hard to make it work intuitively. It "would" be a considerable time saving if e.g. you wanted to split 20 stereo pairs in a project.
 +
* If Open still imports audio (or more likely, if Import has a means of importing into a new window), we should consider the current restriction that "Open" doesn't import Label Tracks, MIDI or raw data. There is no logical reason for that, indeed a high probability that you might well want to import MIDI or raw into a new window.

Latest revision as of 18:26, 2 August 2017

Proposal pages help us get from feature requests into actual plans. This proposal page is about reorganising the menus.
Proposal pages are used on an ongoing basis by the Audacity development team and are open to edits from visitors to the wiki. They are a good way to get community feedback on a proposal.


  • Note: Proposals for Google Summer of Code projects are significantly different in structure, are submitted via Google's web app and may or may not have a corresponding proposal page.

Proposed Feature

One driver for reorganising the menus is to avoid the problems that arise from having 'export' and 'save' as different functions. The options there can with care be merged so that there are fewer menu items.

The Audacity menus have also become rather complex with numerous options, especially when label linking is enabled.

Developer/QA Backing

  • "Something needs to be done!" That sentiment is backed by (at least)
    • JC
    • GA - But regressions in functionality and need for ease of access must be kept in mind
    • PS - I strongly support restricting the Open (Open Project) command to only opening Projects. I also support the implementation of Effect Menu categorization now that the assigment of hot-keys to effects has been implemented.
    • BW

Issues

  • New users:
    • Confused about what 'export' and 'save' mean.
    • Too many choices.
    • Expecting to work with (e.g.) wav rather than projects.
  • Experienced users:
    • Find menus too long.
    • Find menus too verbose.

Details

The general tenor of the solution is to make it easier and more natural to get to the most commonly used and most familiar options. This will mainly be achieved by better grouping of menu items into submenus, rather than putting them all at the same level.


Note: April 2011: The changes to Open/Export/Import proved contentious and also there is concern that some non-rearrangement changes proposed to get that to work would risk jeopardizing the 2.0 schedule. The Edit-Menu changes don't have these problems and have been implemented. Actually making other changes will be parked until December 2011, or until 2.0 comes out, whichever is sooner.

Effect Menu

This sub-proposal has been moved to a free-standing Proposal Effect Menu Categorization.

This was done to provide focus on this particular menu and in the interests of simplifying this page and its associated talk page.


File Menu

This sub-proposal has been moved to a free-standing Proposal File Menu Reorganization.

This was done to provide focus on this particular menu and in the interests of simplifying this page and its associated talk page.


Edit Menu

Done:

  • 'Remove Audio >' leading to
    • 'Cut|Split Cut|Delete|Split Delete|Silence Audio|Trim'
  • 'Clip Boundaries >' leading to
    • 'Split|Split New|Join|Detach at Silences'
  • Cut & Delete have been restored to the top level in the Edit menu for 2.0.6

Despite the moving of items into submenus as above leading to a strong overall reduction in complaints about Edit Menu, complaints that remain have focused on the undesirability of "core" edit items like Cut and Delete being "hidden" in a submenu. A free-standing Proposal Edit Menu Reorganization discusses this.

Tracks Menu

  • 'Mix and Render >'
    • 'Replace|Mix to New Track'
  • 'All Track Mute/Solo >'
    • 'Mute All|UnMute All|UnSolo All|UnMute & UnSolo All'


View Menu

  • Now has the Metadata Editor, and it is called 'Metadata Editor' not 'Open Metadata Editor'.


Tools Menu

  • This is a new menu before Help, with things that mostly come from Help.


Help Menu

The items which are really 'tools' (diagnostics) taken out of Help and are now in the Tools menu.

  • Help Menu has 'About' as the last entry.


Images

Mock up of proposed menu changes.


Side Issues

These aren't strictly part of the menu reorganization, but came up in discussion of it. They are not being acted on for this proposal.

  • Some users would like Export to default to the directory where the audacity project is.
    • Ed has a patch to allow this
  • Some users would like project save and export directories to be set by preferences.
    • Ed has a patch to allow .aup to be drag and dropped too.
  • It would probably be a good idea to modify trim so that it only removes audio from selected clips, not whole clips outside its selection.
  • The "align" commands are inadequate, confusing and lack shortcut bindings. A command to align tracks end-to-end is sorely needed.
  • Stop and move cursor to stop point, which is SHIFT+A, is not in the menu. Preferred option is to make this a preference as to how stop behaves.
  • Signposting: Give the users visual clues that are in their face. Look at GIMP. Every menu item has a hover tooltip which is duplicated in the Status Bar. It would have to have a Preference to turn it off (as it does in GIMP).
  • Lots of discussion of shortcut keys. (Moved to talk page for now).
  • At this stage we are NOT proposing a mode where Audacity can switch over to using a wav file as if it were its project - much as Microsoft word can open a txt file, but then warns when you try to save it that 'some features/formatting can't be saved in text format'. It's not that hard to add, but it would go outside the scope of this proposal. This would be a good feature though and solve a lot of user confusion. If we were to do it, we'd list in the warning dialog what would be lost. IF we did this we could at the same time change the labeling of 'Save Project' and 'Save Project As' to 'Save' and 'Save As'. We would also change 'Recent Projects' back to 'Recent Files'.
  • In the Edit menu, there is an unresolved issue as to how to handle the different behaviour of [ and ] when the track is static or playing (currently this is at Edit > Select > Left / Right at Playback Position).
  • There is a consistent view among some users that the Tracks Menu and not the Track Control Panel should have commands for channel setting (or even rate and format). This is on grounds of discoverability above all else. Gale thinks this is worth some consideration although it might be hard to make it work intuitively. It "would" be a considerable time saving if e.g. you wanted to split 20 stereo pairs in a project.
  • If Open still imports audio (or more likely, if Import has a means of importing into a new window), we should consider the current restriction that "Open" doesn't import Label Tracks, MIDI or raw data. There is no logical reason for that, indeed a high probability that you might well want to import MIDI or raw into a new window.