Completed Proposal Menu Reorganisation

From Audacity Wiki
Revision as of 21:07, 25 April 2011 by PeterSampson (talk | contribs) (Added my support - particularly for restriction of Open to Projects only)
Jump to: navigation, search
Proposal pages help us get from feature requests into actual plans. This proposal page is about reorganising the menus.
Proposal pages are used on an ongoing basis by the Audacity development team and are open to edits from visitors to the wiki. They are a good way to get community feedback on a proposal.


  • Note: Proposals for Google Summer of Code projects are significantly different in structure, are submitted via Google's web app and may or may not have a corresponding proposal page.

Proposed Feature

One driver for reorganising the menus is to avoid the problems that arise from having 'export' and 'save' as different functions. The options there can with care be merged so that there are fewer menu items.

The Audacity menus have also become rather complex with numerous options, especially when label linking is enabled.


Developer/QA Backing

  • "Something needs to be done!" That sentiment is backed by (at least)
    • JC
    • GA
    • PS - I particularly like restricting the Open (Open Project) command to only opening Projects


Issues

  • New users:
    • Confused about what 'export' and 'save' mean.
    • Too many choices.
    • Expecting to work with (e.g.) wav rather than projects.
  • Experienced users:
    • Find menus too long.
    • Find menus too verbose.


Details

The general tenor of the solution is to make it easier and more natural to get to the most commonly used and most familiar options. This will mainly be achieved by better grouping of menu items into submenus, rather than putting them all at the same level.


File Menu

Mostly better use of fly-out submenus.

  • 'Open' will be renamed 'Open Project' and ONLY open an Audacity project. If you try to open a wav file it will tell you about projects and tell you to import instead. This will help reduce the risk of users thinking they are genuinely opening and working on a wav file directly.
  • The code that allows wav and other files from the 'Open' will be kept around for a future day when we allow the any-file mode.
  • 'Save Project|Save Project As >|Export >' as the three saving options on the main menu, in that order.
  • 'Save Project As >' leads to
    • 'Standard Project...|Compressed Project...'.
  • 'Export >' leads to
    • 'Export All Audio|Export Selection|Export Multiple|Export Labels|Export MIDI|Export Settings...'.
  • The Open Meta-Data-Editor is no longer a menu item.
    • It is available via 'Export Settings...'.
  • The chains menu item is now called 'Batch Chains >' and leads to
    • 'Edit|Run'.

Other Changes:

  • 'Check Dependencies...' moves to the Tools menu. It is a diagnostic tool.


Edit Menu

  • 'Remove Audio >' leading to
    • 'Cut|Split Cut|Delete|Split Delete|Silence Audio|Trim'
  • 'Clip Boundaries >' leading to
    • 'Split|Split New|Join|Detach at Silences'


Tracks

  • 'Mix and Render >'
    • 'Replace|Mix to New Track'
  • 'All Track Mute/Solo >'
    • 'Mute All|UnMute All|UnSolo All|UnMute & UnSolo All'


Tools Menu

  • This is a new menu before Help, with things that mostly come from Help.


Help Menu

Split into Tools (first) then Help.

  • Help Menu has 'About' as the last entry.


Side Issues

These aren't strictly part of the menu reorganization, but came up in discussion of it. They are not being acted on for this proposal.

  • Some users would like Export to default to the directory where the audacity project is.
  • Some users would like project save and export directories to be set by preferences.
  • Drag-and-drop opening should have the same restrictions as 'Open'
  • It would probably be a good idea to modify trim so that it only removes audio from selected clips, not whole clips outside its selection.
  • The "align" commands are inadequate, confusing and lack shortcut bindings. A command to align tracks end-to-end is sorely needed.
  • Stop and move cursor to stop point, which is SHIFT+A, is not in the menu. Preferred option is to make this a preference as to how stop behaves.
  • Signposting: Give the users visual clues that are in their face. Look at GIMP. Every menu item has a hover tooltip which is duplicated in the Status Bar. It would have to have a Preference to turn it off (as it does in GIMP).
  • Lots of discussion of shortcut keys. (Moved to talk page for now).
  • At this stage we are NOT proposing a mode where Audacity can switch over to using a wav file as if it were its project - much as Microsoft word can open a txt file, but then warns when you try to save it that 'some features/formatting can't be saved in text format'. It's not that hard to add, but it would go outside the scope of this proposal. This would be a good feature though and solve a lot of user confusion. If we were to do it, we'd list in the warning dialog what would be lost. IF we did this we could at the same time change the labeling of 'Save Project' and 'Save Project As' to 'Save' and 'Save As'.