Difference between revisions of "Completed Proposal Menu Reorganisation/Layout Ideas"

From Audacity Wiki
Jump to: navigation, search
(my take on the File menu)
(get rid of my truncated example of File menu now that Bill has a complete one, add menu label to Bill's (hope he doesn't mind))
Line 1: Line 1:
'''-- Ed 22 January 2010'''<BR>
+
'''Edgar 22 Jan 2010''' split the Help menu into Tools and Help :<BR>
I was thinking of something like:<BR>
 
 
 
'''File'''<BR>
 
{{MenuItem|New}}
 
{{MenuItem|Open...}}
 
{{MenuItem|Recent Files &nbsp; &nbsp;>}}
 
{{MenuItem|Close}}
 
{{MenuItem|Save Project}}
 
{{MenuItem|&nbsp;'''''Other Items'''''&nbsp;}}
 
{{MenuItem|Import &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; >}}
 
<blockquote>
 
{{MenuItem|Audio...}}
 
{{MenuItem|Labels...}}
 
{{MenuItem|MIDI...}}
 
{{MenuItem|Raw Data...}}
 
</blockquote>
 
{{MenuItem|Export...}}
 
 
 
 
 
 
 
'''Edgar:''' split the Help menu into Tools and Help :<BR>
 
 
'''Tools'''<BR>
 
'''Tools'''<BR>
 
{{MenuItem|Show Log...}}
 
{{MenuItem|Show Log...}}
Line 51: Line 30:
  
 
==Bill 23 Jan 2010==
 
==Bill 23 Jan 2010==
I was focused mainly on re-organizing the Export section
+
I was focused mainly on re-organizing the Export section<BR>
 +
'''File'''
 
{{MenuItem|New}}
 
{{MenuItem|New}}
 
{{MenuItem|Open...}}
 
{{MenuItem|Open...}}

Revision as of 06:20, 24 January 2010

Edgar 22 Jan 2010 split the Help menu into Tools and Help :
Tools

 Show Log...
 Run Benchmark...
 Audio Device Info...
 - - - - - - - -
 Screenshot Tools...


Help

 Manual (in web browser)
 - - - - - - - -
 About Audacity


Note that in the above "About" item there should be no ellipsis -- the use of an ellipsis signifies that the user will be asked to supply additional information before the action can be completed.
This also makes the Help menu very short. I think we could expand upon a little:

Help

 Manual (in web browser)
 Manual Topics >
 Quick Help
 Frequently Asked Questions
 Tutorials
 References
 - - - - - - - -
 About Audacity


Bill 23 Jan 2010

I was focused mainly on re-organizing the Export section
File

 New
 Open...
 Recent Files    >
 -
 Close
 Save Project
 Save Project As...
 Save Compressed Copy of Project...
 Check Dependencies...
 -
 Open Metadata Editor...
 Import             >
 Audio...
 Labels...
 MIDI...
 Raw Data...
 Export             >
 Mix
 Selection
 Mutliple...
 Labels...
 MIDI...
 -
 Apply Chain...
 Edit Chains...