Completed Proposal Menu Reorganisation/Layout Ideas

From Audacity Wiki
Revision as of 22:04, 23 January 2010 by BillWharrie (talk | contribs) (my take on the File menu)
Jump to: navigation, search

-- Ed 22 January 2010
I was thinking of something like:

File

 New
 Open...
 Recent Files    >
 Close
 Save Project
  Other Items 
 Import             >
 Audio...
 Labels...
 MIDI...
 Raw Data...
 Export...



Edgar: split the Help menu into Tools and Help :
Tools

 Show Log...
 Run Benchmark...
 Audio Device Info...
 - - - - - - - -
 Screenshot Tools...


Help

 Manual (in web browser)
 - - - - - - - -
 About Audacity


Note that in the above "About" item there should be no ellipsis -- the use of an ellipsis signifies that the user will be asked to supply additional information before the action can be completed.
This also makes the Help menu very short. I think we could expand upon a little:

Help

 Manual (in web browser)
 Manual Topics >
 Quick Help
 Frequently Asked Questions
 Tutorials
 References
 - - - - - - - -
 About Audacity


Bill 23 Jan 2010

I was focused mainly on re-organizing the Export section

 New
 Open...
 Recent Files    >
 -
 Close
 Save Project
 Save Project As...
 Save Compressed Copy of Project...
 Check Dependencies...
 -
 Open Metadata Editor...
 Import             >
 Audio...
 Labels...
 MIDI...
 Raw Data...
 Export             >
 Mix
 Selection
 Mutliple...
 Labels...
 MIDI...
 -
 Apply Chain...
 Edit Chains...