Difference between revisions of "Developing On Linux"

From Audacity Wiki
Jump to: navigation, search
(KDevelop Tutorial link)
(fix broken kdevelop link)
Line 5: Line 5:
 
* [[Developing On Mac]]}}
 
* [[Developing On Mac]]}}
  
 
+
'''Also see:''' {{external|1=[http://www.crotchett.com/kdevelop/index.html Tutorial: building Audacity on the Kdevelop IDE for KDE]}}.
There is also a {{external|1=[http://http://www.crotchett.com/kdevelop/index.html Tutorial on using KDevelop with Audacity]}}.
 
  
 
= Getting Audacity =
 
= Getting Audacity =

Revision as of 19:26, 8 December 2007

Users on Linux and Unix systems often compile Audacity from source code to experiment with the latest Beta version, or even the latest code in CVS . Linux users may also need to compile either Audacity stable or Beta if there is no suitable Audacity package for their distribution. This page is a checklist of what you need to compile Audacity on Linux/Unix and the configure commands required.
If you need help with the basic steps in compiling Audacity, please see Compiling Audacity Step by Step Guide.
 
Related article(s):
  • Also for building with Windows, see [install-directory]\win\compile.txt

Also see: Tutorial: building Audacity on the Kdevelop IDE for KDE .

Getting Audacity

  • CVS: The other main way to get Audacity is to use CVS - this is the best way if you want to actively develop Audacity, or keep up with the latest and greatest features. For more information, see our CVS page . For a CVS interface on Mac to access our CVS repository, try MacCVS  (this needs an external SSH client if you want to commit code to our repository) or MacCVSClient . On Linux, BSD and other open source operating systems, command-line CVS clients are typically included in the default installation, or are available directly from the operating system repository.

Prerequisites

Audacity 1.2.x (stable)

At a minimum, Audacity 1.2.x requires wxWidgets . Currently we recommend using version 2.4.2. You're welcome to use any 2.4.x release, but there were some new bugs in 2.4.1 that cause problems, so the current version is recommended. Audacity will not work with wxX11 (as it's incomplete, and things like dialogues are missing that we need), or with unicode builds of wxWidgets (so configure with --disable-unicode)

Older versions are completely unsupported. It may be possible to compile Audacity 1.2.x with wxWidgets 2.5.x, but please don't expect it to compile out-of-the-box. Unfortunately this hasn't stopped some distributions trying, and so annoying a lot of users. Note that wxWidgets 2.4.2 for Mac OSX does not compile correctly; getting it from CVS resolves the issue.

Audacity supports wxGTK for Linux (and other Unix), wxMac for Mac OS X, and wxMSW for Windows using either MSVC++ or Cygwin. There is no support for wxMotif, wxX11, or other wx variants yet.

Audacity does not currently support the Unicode builds of wxWidgets. When configuring wxWidgets on Unix, make sure you don't enable these features. To be safe:

 ./configure --disable-unicode

Having GTK2 enabled does not usually cause any problems, however, providing the build and runtime versions match exactly (not always the case with binary distributions).

If you have Mac OS X, you may want to patch wxMac before building it - see below.

Audacity 1.3 (unstable)

The development branch of audacity (version 1.3.x or the CVS HEAD) requires wxWidgets 2.6.3 or higher. Unicode and GTK2 builds are supported by default. Older development versions (2.5.x) may not work, so get the current wxWidgets 2.6.x release.

Optional Packages

The configure script of Audacity gives the option to link in or not to link in a number of 'optional' packages. 'Optional' as some are more optional than others.

There are possibilities surrounding the following packages:


id3tag use libid3tag  for MP3 ID3 tag support
LADSPA  compile with LADSPA plug-in support [default=yes]
libmad  use libmad for mp3 decoding support
libflac  [local], [system], [none] - enable FLAC support [default=none]
libresample use libresample: [yes], [no]
libsamplerate  alternatively, use libsamplerate (instead of libresample): [local], [system], [none]
libsndfile  choose which libsndfile to use: [local], [system]
PortAudio  which version of PortAudio to use (=[v18,v19]) [stable default=v18], [Beta default=v19]    
PortMixer compile with PortMixer [default=yes]
Nyquist  compile with Nyquist support [default=yes]
SoundTouch  compile with SoundTouch [default=yes]
vorbis  enable ogg vorbis support
 
help make the help file "audacity-1.2-help.htb" [default=yes]


The following syntax is used as a parameter to the configure script to enable or disable a package or to pass further information about the package.

 --with-PACKAGE[=ARG]    use PACKAGE [ARG=yes]
 --without-PACKAGE       do not use PACKAGE (same as --with-PACKAGE=no)

The possibilities range from whether to include them or not to whether to use local or system versions. In almost all cases these are standard libraries, and only provided in CVS for convenience, so if you have up to date versions installed as shared libraries you should select the external copies. The exceptions are libresample (which is developed as part of Audacity), Nyquist (which we have modified to integrate it with Audacity), and PortAudio (which has had to be patched to make it work).

Examples:

To enable support for ogg files:

 --with-vorbis=[local|system]

To use an external sndfile library (which you have previously built and installed):

 --with-libsndfile=system

To disable nyquist:

 --without-nyquist

Compiling on Unix

To compile Audacity on Linux, Mac OS X, and most other Unix systems, use the standard "configure; make" sequence:

 ./configure
 make

However, you may want to start by running ./configure --help first to see the options, and possibly add special options.

If you are compiling from a CVS checkout, then you can re-generate the configure script by running

 autoreconf

in the top level directory first.

If this causes trouble, with errors like

 configure: warning: CC=gcc: invalid host type
 configure: warning: CXX=g++: invalid host type
 configure: error: can only configure for one host and one target at a time
 configure: error: /bin/sh './configure' failed for lib-src/portaudio-v19

Then try prefixing the configure command with "env -i"

 env -i ./configure --without-portmixer --with-portaudio=v19

This appears to be fixed for Audacity 1.2.4 and onwards.

In order to use ALSA devices with PortAudio v19 (the default for audacity 1.3.2 beta) it is necessary to have the ALSA development library installed before compiling Audacity. In Ubuntu Studio, for example, this can be installed by running

 sudo apt-get install libasound2-dev