Developing On Linux

From Audacity Wiki
Revision as of 11:03, 30 August 2007 by James (talk | contribs) (Removed Mac and windows specific pieces.)
Jump to: navigation, search

Note: if you use Linux and need to compile Audacity from source (say, if you use Linux but we don't have a binary package like an RPM available for your distribution) but you don't know how, see CompilingAudacityForBeginners

Related Pages:

Getting Audacity

  • CVS: The other main way to get Audacity is to use CVS - this is the best way if you want to actively develop Audacity, or keep up with the latest and greatest features. For more information, see our CVS page.

Prerequisites

Audacity 1.2.x (stable)

At a minimum, Audacity 1.2.x requires wxWidgets. Currently we recommend using version 2.4.2. You're welcome to use any 2.4.x release, but there were some new bugs in 2.4.1 that cause problems, so the current version is recommended. Audacity will not work with wxX11 (as it's incomplete, and things like dialogues are missing that we need), or with unicode builds of wxWidgets (so configure with --disable-unicode)

Older versions are completely unsupported. It may be possible to compile Audacity 1.2.x with wxWidgets 2.5.x, but please don't expect it to compile out-of-the-box. Unfortunately this hasn't stopped some distros trying, and so annoying a lot of users. Note that wxWidgets 2.4.2 for Mac OSX does not compile correctly; getting it from CVS resolves the issue.

Audacity supports wxGTK for Linux (and other Unix), wxMac for Mac OS X, and wxMSW for Windows using either MSVC++ or Cygwin. There is no support for wxMotif, wxX11, or other wx variants yet.

Audacity does not currently support the Unicode builds of wxWidgets. When configuring wxWidgets on Unix, make sure you don't enable these features. To be safe:

 ./configure --disable-unicode

Having GTK2 enabled does not usually cause any problems, however, providing the build and runtime versions match exactly (not always the case with binary distributions).

If you have Mac OS X, you may want to patch wxMac before building it - see below.

Audacity 1.3 (unstable)

The development branch of audacity (version 1.3.x or the CVS hEAD) requires wxWidgets 2.6.3 or higher. Unicode and GTK2 builds are supported by default. Older development versions (2.5.x) may not work, so get the current wxWidgets 2.6.x release.

Optional Packages

The configure script of Audacity gives the option to link in or not to link in a number of 'optional' packages. 'Optional' as some are more optional than others.

There are possibilities surrounding the following packages:

 libmad[1]          use libmad for mp3 decoding support
 vorbis[2]          enable ogg vorbis support
 id3tag               use libid3tag for MP3 ID3 tag support
 libsndfile[3]      which libsndfile to use: [local], [system]
 libresample          use libresample: [yes], [no]
 libsamplerate[4]   use libsamplerate (instead of libresample): [local], [system], [none]
 libflac[5]         local system none - enable FLAC support [default=none]
 ladspa[6]          compile with ladspa plug-in support [default=yes]
 nyquist[7]         compile with Nyquist support [default=yes]
 PortMixer            compile with PortMixer  [default=yes]
 PortAudio[8]       which version of PortAudio  to use (=[v18,v19])[default=v18]
 soundtouch[9]      compile with SoundTouch  [default=yes]
 help                 Make the help file "audacity-1.2-help.htb"[default=yes]

The following syntax is used as a parameter to the configure script to enable or disable a package or to pass further information about the package.

 --with-PACKAGE[=ARG]    use PACKAGE [ARG=yes]
 --without-PACKAGE       do not use PACKAGE (same as --with-PACKAGE=no)

The possibilities range from whether to include them or not to whether to use local or system versions. In almost all cases these are standard libraries, and only provided in CVS for convenience, so if you have up to date versions installed as shared libraries you should select the external copies. The exceptions are libresample (which is developed as part of audacity), nyquist (which we have modified to integrate it with audacity), and portaudio (which has had to be patched to make it work).

Examples:

To enable support for ogg files:

 --with-vorbis=[local|system]

To use an external sndfile library (which you have previously built and installed):

 --with-libsndfile=system

To disable nyquist:

 --without-nyquist

Compiling on Unix

To compile Audacity on Linux, Mac OS X, and most other Unix systems, use the standard "configure; make" sequence:

 ./configure
 make

However, you may want to start by running ./configure --help first to see the options, and possibly add special options.

If you are compliling from a CVS checkout, then you can re-generate the configure script by running

 autoreconf

in the top level directory first.

Note: see the page CompilingAudacityForBeginners if you are confused by anything above. We walk you through the process step-by-step.

If this causes trouble, with errors like

 configure: warning: CC=gcc: invalid host type
 configure: warning: CXX=g++: invalid host type
 configure: error: can only configure for one host and one target at a time
 configure: error: /bin/sh './configure' failed for lib-src/portaudio-v19

Then try prefixing the configure command with "env -i"

 env -i ./configure --without-portmixer --with-portaudio=v19

This appears to be fixed for Audacity 1.2.4 and onwards.

In order to use ALSA devices with PortAudio v19 (the default for audacity 1.3.2 beta) it is necessary to have the ALSA development library installed before compiling Audacity. In Ubuntu Studio, for example, this can be installed by running

 sudo apt-get install libasound2-dev