Difference between revisions of "Developing On Mac"

From Audacity Wiki
Jump to: navigation, search
(Remove other help link to -devel in line with current policy)
(update wxMac2.8.11)
Line 12: Line 12:
  
 
===Building===
 
===Building===
Generally it seems easier to build a native PPC or Intel version than a Universal Binary. This scenario is reported to build from [http://code.google.com/p/audacity/source/browse/ SVN HEAD] as a Universal Binary on both Power PC and Intel Mac on OS X 10.5.1, using Xcode 3 and either wxWidgets 2.6.4 or 2.8.10, or the OS X 10.5.1 wxWidgets shared library.  The general principles are:  
+
Generally it seems easier to build a native PPC or Intel version than a Universal Binary. This scenario is reported to build from [http://code.google.com/p/audacity/source/browse/ SVN HEAD] as a Universal Binary on both Power PC and Intel Mac on OS X 10.5.1, using Xcode 3 and either wxWidgets 2.6.4 or 2.8.11, or the OS X 10.5.1 wxWidgets shared library.  The general principles are:  
 
:1 Setup wxWidgets
 
:1 Setup wxWidgets
 
:1.1 -Create a wx directory in your audacity directory.  For example:  $HOME/audacity/wx
 
:1.1 -Create a wx directory in your audacity directory.  For example:  $HOME/audacity/wx
:1.2 -Patch the wxMac2.8.10 bz doing the following
+
:1.2 -If for some reason you are using wxMac 2.8.10, Patch the wxMac2.8.10 by doing the following
 
{{Codelist|cd /path/to/wxMac-2.8.10<br>
 
{{Codelist|cd /path/to/wxMac-2.8.10<br>
 
patch -p1 < /path/to/audacityrepos/mac/wxMac-2.8.10.patch<br>
 
patch -p1 < /path/to/audacityrepos/mac/wxMac-2.8.10.patch<br>
Line 31: Line 31:
 
:3.5. If you get an error saying that pkg-config is required, you need to add the path of pkg-config on your system to the XCode settings by adding the line 'PATH = /sw/bin:$PATH' (if you use fink) to the .xcconfig file (in the project's XCode settings folder.  It may also be in /opt/bin if you use macports vs fink.
 
:3.5. If you get an error saying that pkg-config is required, you need to add the path of pkg-config on your system to the XCode settings by adding the line 'PATH = /sw/bin:$PATH' (if you use fink) to the .xcconfig file (in the project's XCode settings folder.  It may also be in /opt/bin if you use macports vs fink.
  
:4. Compile Audacity 1.3.13 using Xcode. Open the latest Xcode project file and update it if required. In the list of targets do a "Get Info" on Audacity and Configure. You may need to change a few "User-Defined" settings. Most of the Wx ones need changing to which version of wxWidgets you've chosen and the path that you set above in --prefix when building it. You may have to change the CONFIG_STATIC and CONFIG_UNICODE in Configure. Most of the settings required for these variables can be gained from running wx-config --libs, --ld or --cflags.  Also note that if using OS X 10.6 you may have to set xcode to use gcc 4.0 instead of 4.2 in your project settings.
+
:4. Compile Audacity using Xcode. Open the latest Xcode project file and update it if required. In the list of targets do a "Get Info" on Audacity and Configure. You may need to change a few "User-Defined" settings. Most of the Wx ones need changing to which version of wxWidgets you've chosen and the path that you set above in --prefix when building it. You may have to change the CONFIG_STATIC and CONFIG_UNICODE in Configure. Most of the settings required for these variables can be gained from running wx-config --libs, --ld or --cflags.  Also note that if using OS X 10.6 you may have to set xcode to use gcc 4.0 instead of 4.2 in your project settings.
 
:4.1 If you get an error related to libflac, you have libflac installed to /usr/local/lib, and Audacity is linking to this instead of the libflac that the project builds.  To workaround this, rename /usr/local/lib/libFLAC.dylib and libFLAC++.dylib to something else.  A more proper workaround would be changing the include and linker paths to remove /usr/local/lib.
 
:4.1 If you get an error related to libflac, you have libflac installed to /usr/local/lib, and Audacity is linking to this instead of the libflac that the project builds.  To workaround this, rename /usr/local/lib/libFLAC.dylib and libFLAC++.dylib to something else.  A more proper workaround would be changing the include and linker paths to remove /usr/local/lib.
  

Revision as of 19:59, 8 October 2010

Related articles:


Latest position building from SVN HEAD

Prerequisites

You will need pkgconfig installed. By default this is not on your mac, but if you use fink or macports you may already have it in /sw/bin or /opt/bin. If you don't have it, you'll need to install fink. Then you can get it using fink with the command

sudo apt-get pkgconfig

Alternatively you can use macports to install it.

Building

Generally it seems easier to build a native PPC or Intel version than a Universal Binary. This scenario is reported to build from SVN HEAD as a Universal Binary on both Power PC and Intel Mac on OS X 10.5.1, using Xcode 3 and either wxWidgets 2.6.4 or 2.8.11, or the OS X 10.5.1 wxWidgets shared library. The general principles are:

1 Setup wxWidgets
1.1 -Create a wx directory in your audacity directory. For example: $HOME/audacity/wx
1.2 -If for some reason you are using wxMac 2.8.10, Patch the wxMac2.8.10 by doing the following
cd /path/to/wxMac-2.8.10

patch -p1 < /path/to/audacityrepos/mac/wxMac-2.8.10.patch

1.3 -Build wxWidgets from the command line. Make a build directory inside the wxWidgets directory and from there run (without the line breaks):
../configure --disable-shared --enable-universal_binary
--prefix=/path/to/audacity-beta/wx/ --enable-static --enable-unicode 
--disable-dependency-tracking --disable-monolithic --enable-debug

For wxWidgets 2.6.x:
  1. add --with-expat=builtin  to the above
  2. in utils/wxrc/Makefile add -mmacosx-version-min=10.4  to the CXX = g++ line (25)
  3. change the #define of ICONV_CHAR_CAST in src/common/strconv.cpp to:
    #define ICONV_CHAR_CAST(x) ((const char **)(x))

2. Do make followed by make install (by typing 'make', then 'make install'. If you have the wx-prefix outside of your home directory you may need 'sudo make install' instead, which will prompt you for a password.)
3. Open the audacity.xcodeproj file. You should create a text file called Debug_Static.xcconfig in the same directory as the project file, and add the line to this text file to include the path you specified as --prefix when building wxMac. For example 'WXPREFIX = /path/to/audacity/wx'.
3.5. If you get an error saying that pkg-config is required, you need to add the path of pkg-config on your system to the XCode settings by adding the line 'PATH = /sw/bin:$PATH' (if you use fink) to the .xcconfig file (in the project's XCode settings folder. It may also be in /opt/bin if you use macports vs fink.
4. Compile Audacity using Xcode. Open the latest Xcode project file and update it if required. In the list of targets do a "Get Info" on Audacity and Configure. You may need to change a few "User-Defined" settings. Most of the Wx ones need changing to which version of wxWidgets you've chosen and the path that you set above in --prefix when building it. You may have to change the CONFIG_STATIC and CONFIG_UNICODE in Configure. Most of the settings required for these variables can be gained from running wx-config --libs, --ld or --cflags. Also note that if using OS X 10.6 you may have to set xcode to use gcc 4.0 instead of 4.2 in your project settings.
4.1 If you get an error related to libflac, you have libflac installed to /usr/local/lib, and Audacity is linking to this instead of the libflac that the project builds. To workaround this, rename /usr/local/lib/libFLAC.dylib and libFLAC++.dylib to something else. A more proper workaround would be changing the include and linker paths to remove /usr/local/lib.

Help

Please ask on the Compiling Audacity section of our Forum if you are stuck with any of the above.

Old information

For wxWidgets 2.6.x

  1. add --with-expat=builtin  to the above in utils/wxrc/Makefile
  2. add -mmacosx-version-min=10.4  to the CXX = g++ line (25)
  3. change the #define of ICONV_CHAR_CAST in src/common/strconv.cpp to:
    #define ICONV_CHAR_CAST(x) ((const char **)(x))
  4. Do make followed by make install.
  5. Open the audacity.xcodeproj file. You should create a text file called Debug_Static.xcconfig in the same directory as the project file, and add the line to this text file to include the path you specified as --prefix when building wxMac. For example 'WXPREFIX = /path/to/audacity/wx'.
  6. If you get an error saying that pkg-config is required, you need to add the path of pkg-config on your system to the XCode settings by adding the line 'PATH = /sw/bin:$PATH' (if you use fink) to the .xcconfig file (in the project's XCode settings folder. It may also be in /opt/bin if you use macports vs fink.
  7. Compile Audacity 1.3.4 using Xcode. Open the latest Xcode project file and update it if required. In the list of targets do a "Get Info" on Audacity and Configure. You may need to change a few "User-Defined" settings. Most of the Wx ones need changing to which version of wxWidgets you've chosen and the path that you set above in --prefix when building it. You may have to change the CONFIG_STATIC and CONFIG_UNICODE in Configure. Most of the settings required for these variables can be gained from running wx-config --libs, --ld or --cflags.

If further problems are encountered: please view this thread  on the Audacity Forum .

Broken script to build Universal Binary

A script  was available that built a Universal Binary version of Audacity on OS X 10.4. The script started with a wxMac-2.6.4 tarball, downloaded a fresh copy of Audacity from CVS, compiled both targets separately, merged them into the universal binary, and finally made the disk image.

As of 1 Nov 08 the script was broken, Audacity head being built using wx 2.8.10.