Difference between revisions of "Developing On Mac"

From Audacity Wiki
Jump to: navigation, search
(a bit about different versions)
Line 8: Line 8:
 
= Compiling on Mac OS X =
 
= Compiling on Mac OS X =
  
Currently only command-line building is supported; there is no up-to-date Project Builder or Xcode project file.  Compile just as you would a Unix program (see [[Developing On Linux|here]]).  After building "audacity", an additional step is performed, that creates "Audacity.app".  Make sure that you run "Audacity.app" and not "audacity", otherwise it won't work. Note that in the "mac" directory there is a patch file for wxMac-2.4.0 - it's recommended that you apply this patch first.  This enables support for custom cursors, allows disabling anti-aliased text (for speed), and fixes a couple of bugs.
+
Currently only command-line building is supported; there is no up-to-date Project Builder or Xcode project file.  Compile just as you would a Unix program (see [[Developing On Linux|here]]).  After building "audacity", an additional step is performed, that creates "Audacity.app".  Make sure that you run "Audacity.app" and not "audacity", otherwise it won't work.
 +
 
 +
== Audacity 1.2.x / wxWidgets 2.4.* ==
 +
Note that in the "mac" directory there is a patch file for wxMac-2.4.0 - it's recommended that you apply this patch first.  This enables support for custom cursors, allows disabling anti-aliased text (for speed), and fixes a couple of bugs.
 +
 
 +
== Audacity 1.3.x / wxWidgets ==
 +
Audacity 1.3.x can be built with wxMac 2.6 or 2.8. There have however been reports of stability issues with wxMac 2.8, so in general stick to the latest wxMac 2.6.x (currently wxMac 2.6.4).
  
 
[[Category:Mac Platform]] [[Category:For Developers]]
 
[[Category:Mac Platform]] [[Category:For Developers]]

Revision as of 19:12, 3 January 2008

Related Pages:



Compiling on Mac OS X

Currently only command-line building is supported; there is no up-to-date Project Builder or Xcode project file. Compile just as you would a Unix program (see here). After building "audacity", an additional step is performed, that creates "Audacity.app". Make sure that you run "Audacity.app" and not "audacity", otherwise it won't work.

Audacity 1.2.x / wxWidgets 2.4.*

Note that in the "mac" directory there is a patch file for wxMac-2.4.0 - it's recommended that you apply this patch first. This enables support for custom cursors, allows disabling anti-aliased text (for speed), and fixes a couple of bugs.

Audacity 1.3.x / wxWidgets

Audacity 1.3.x can be built with wxMac 2.6 or 2.8. There have however been reports of stability issues with wxMac 2.8, so in general stick to the latest wxMac 2.6.x (currently wxMac 2.6.4).