Difference between revisions of "Exporting your Audacity Project into iTunes and iPod"

From Audacity Wiki
Jump to: navigation, search
(update for iTunes 10)
(added a div at top for people who are looking to publish podcasts to iTunes)
Line 1: Line 1:
 
{{intro|1=To export to iTunes, use one of the {{menu|File > Export}} commands in Audacity to export to the particular file format you want, such as WAV, AIFF or MP3. Then move that file into iTunes from the location you exported it to, using the iTunes '''File > Add File to Library''' or '''File > Add Folder to Library''' commands.|2=}}  
 
{{intro|1=To export to iTunes, use one of the {{menu|File > Export}} commands in Audacity to export to the particular file format you want, such as WAV, AIFF or MP3. Then move that file into iTunes from the location you exported it to, using the iTunes '''File > Add File to Library''' or '''File > Add Folder to Library''' commands.|2=}}  
 +
 +
{{hint|'''Note:''' Submitting a [http://en.wikipedia.org/wiki/Podcast podcast] to iTunes is a different process than exporting an Audacity file to the iTunes software. Two broad steps are required: 1) upload your podcast file and an [http://en.wikipedia.org/wiki/RSS RSS feed] to an online file server; 2) [http://www.apple.com/itunes/podcasts/specs.html submit the feed to iTunes Store]. See our Tutorial [[Creating a simple voice and music Podcast with Audacity]] for more help.}}
  
  

Revision as of 20:45, 1 November 2010

To export to iTunes, use one of the File > Export commands in Audacity to export to the particular file format you want, such as WAV, AIFF or MP3. Then move that file into iTunes from the location you exported it to, using the iTunes File > Add File to Library or File > Add Folder to Library commands.


Note: Submitting a podcast to iTunes is a different process than exporting an Audacity file to the iTunes software. Two broad steps are required: 1) upload your podcast file and an RSS feed to an online file server; 2) submit the feed to iTunes Store. See our Tutorial Creating a simple voice and music Podcast with Audacity for more help.



Exporting to iTunes

What format should I export to?

If you want a perfect lossless copy of your audio, or to burn it in iTunes to an "audio CD" for playing on any CD player, choose WAV or AIFF. It is strongly recommended to export a standard "CD quality" 44100 Hz, 16 bit WAV or AIFF, to make sure iTunes understands the file. If burning that file to a CD, make sure the exported file is stereo. This means:

  1. Ensure the Project Rate bottom left of the Audacity screen is set to 44100 Hz
  2. Click Edit > Preferences (Audacity > Preferences on a Mac computer) then File Formats tab: "Uncompressed Export Format" section, and choose WAV (Microsoft 16 bit PCM) or AIFF (Apple/SGI 16 bit PCM).
    In the current Audacity 1.3 Beta, do not open Preferences, but after the File > Export step, choose the WAV 16 bit PCM or AIFF 16 bit PCM option in the export window.
  3. If you want a stereo export but your Project does not already contain a stereo track, click Project > New Stereo Track (Tracks > Add New > Stereo Track in Audacity 1.3.x)

Jump to here if you're only interested in burning a CD.

If you want to distribute your files on the internet (for example as a podcast), choose MP3, as this is a space-saving (although slightly lossy) format that anyone should be able to play. To export as MP3 from Audacity you need first to download the LAME encoder and point Audacity to it.

If you want to put the files on iPod, or simply store them in iTunes in a compact form, MP3 is also a good choice. However, there are some reports that when run on battery, recent iPods can struggle or crash when playing MP3s created in applications other than iTunes. As an alternative you could export as WAV or AIFF from Audacity and convert the files to MP3 in iTunes using the following instructions. These instructions are for iTunes 9 or later. If you have iTunes 7, the import setting is changed on the small "Importing" tab inside the "Advanced" tab of Preferences. If you have iTunes 7 or 8, the MP3 is created by right-click or control-click over the file to be converted.

  1. Click Edit > Preferences (or iTunes > Preferences on Mac)
  2. Click on the leftmost "General" tab
  3. Click the Import Settings button half way down on the right
  4. In the "Import Using" dropdown, choose "MP3 Encoder"
  5. Click OK and OK
  6. Select the file to be converted then click Advanced > Create MP3 version

Apple's own size-compressed M4A (AAC) format is also a good format for iPod or storage in iTunes. Generally, M4A files provide the same quality as MP3 for a slightly smaller file size. Audacity 1.2 cannot export to Apple formats, but you can export to WAV or AIFF and convert to M4A in iTunes by choosing "AAC Encoder" in iTunes preferences as above. You can also choose "Apple Lossless Encoder". This provides a lossless file of the same quality as a WAV or AIFF file exported from Audacity, but only half as large (though still much larger than MP3 or compressed M4A). If you choose "Apple Lossless Encoder", the file will still appear in iTunes with an M4A extension. Current versions of Audacity 1.3 can export directly to compressed M4A by installing the optional FFmpeg library.

You'll probably know that Audacity supports the OGG format (a lossy compressed format similar to MP3/compressed M4A, but of higher quality for the same file size than either). An iPod cannot play OGG, but iTunes can with a hack. To play OGG Files in iTunes or Quick Time, install the OGG codecs for QuickTime. Alternatively, users on OS X only can install Ogg Drop. This also adds OGG support to QuickTime, as well as providing an easy drag'n'drop interface to convert AIFF and AIFC files, Audio CD tracks, uncompressed QuickTime soundtracks and System Sound files to an Ogg Vorbis file.

Export Location

You can choose any location for the export from Audacity such as a "Music" folder on your Desktop or even the iTunes "Music" folder if you have one. However you must still import this file from the exported location into the iTunes Library (which makes it visible when you view Library > Music on the left-hand panel of iTunes). There are two ways to import your exported audio files into iTunes:

  • Select Library:Music in the left-hand panel of Tunes and drag the file from the location you exported it to into the main iTunes window to right of the panel (to burn the files to CD, drag them directly into an iTunes Playlist in the left-hand panel as per below)
  • Use the File > Add File to Library command from within iTunes.


Warning icon iTunes is a "virtual" Library containing no actual files but only links to them. To avoid losing your files, do *not* delete the exported files from the location you exported them to, unless you have already gone to Preferences > Advanced in iTunes and enabled "Copy files to iTunes Media folder when adding to library" (in iTunes 7 this is on a small "General" tab inside "Advanced").


Burning to CD in iTunes

  1. If you have not already done so, drag the file(s) from your iTunes Music window (under Library in the left-hand panel) into an iTunes playlist (all files from this playlist will be burned to the CD)
  2. Click the Burn Disc button bottom right of the window (in iTunes 10, click File > Burn Playlist to Disc)
  3. In the "Burn Settings" window that appears, select the "Preferred Speed" and make sure "Audio CD" is selected (in iTunes 7, this should be configured beforehand, on the small "Burning" tab inside the Advanced tab of Preferences)
  4. Click "Burn"
  5. If you receive a "computer not authorised" error, double-click the file in the iTunes playlist and enter the password you use to login to iTunes store; additionally, you cannot burn a playlist containing M4P files that have been burned more than seven times
  6. If you receive "Error 4880" this means burning cannot initialise because of a hardware defect or because the burn speed is too high


Reminder: Unless you select "Audio CD" before burning, the CD won't play on standalone CD players


For more general help on burning to CD, see How to burn CDs.

Syncing to your iPod

To load songs from your iTunes Library onto iPod, iPod nano or iP mini:

  1. Connect your iPod to your computer.
  2. When the iPod icon appears in the iTunes left-hand panel (below Devices), select it. If the "Summary" pane isn't showing, click the "Summary" tab. Make sure that "Manually manage music" is not selected (if you have an iPod that displays video, the checkbox says "Manually manage music and video")
  3. Click the Music tab then:
    • To automatically update your iPod with all the songs and playlists in your library, select "Sync music" and then select "All songs and playlists". iTunes loads the songs and playlists in your iTunes library onto your iPod, and deletes songs from your iPod that aren't in your library.
    • To automatically update your iPod with only certain playlists, select "Sync music" and "Selected playlists," and then select the playlists you want synchronized.
    • If you connect and update your iPod, and then add songs to your iTunes Library that you want to add to your iPod, choose File > Sync iPod.
    • If you want to sync only items in your library that have a checkmark next to them, click the Summary tab and select "Only sync checked items".


Further assistance can be found in the iTunes Help menu.

Getting files off an iPod

What happens if you need to get files off your iPod (for example, if your computer fails, or you want to transfer songs from your home computer to your work one)? iTunes will not allow you to download your purchases again. To cover all eventualities, consider retaining all the files listed in Tunes Library in their original location on the hard drive, or ideally back them up to CD or DVD.

To copy files from iPod to a drive, launch iTunes with your iPod connected (in Tunes 7, you must go to Preferences: Options and select "Enable Disk Use"). Now your iPod will show up as a storage device in Windows Explorer or the Finder in OS X. Next you have to reveal the files as they will be hidden. In Windows Explorer, click Tools > Folder Options: View tab. Select "Show hidden files and folders" then exit the dialogue. On OS X, you can make the Finder show its hidden files and folders by entering this as a command in the terminal:

defaults write com.apple.finder AppleShowAllFiles -bool true

or try this free program to do the same thing.

Within the iPod storage device in Explorer or Finder you should see a folder called iPod Control and within that, a series of folders with names such as D1, D12, and so on. Your files are scattered about in those folders. You can now copy those to your hard drive or a flash drive or reimport them to iTunes.

You can also automatically transfer songs that you buy from the iTunes store from the iPod to another computer. The first time you attach the iPod to another machine, you'll see a pop-up window offering at the bottom to move your purchased files. iTunes allows you to play them on up to five different computers.

Removing iPod on Windows Vista and iTunes 7.1

When Apple released iTunes 7.1 to fix a number of incompatibilities with Windows Vista, it introduced a major problem with removing the iPod.

Normally, when you go to remove your iPod, you click the "Safely Remove Hardware" icon in the System Tray that allows you to unplug a USB item safely. But if you use that interface (or eject the iPod using Windows Explorer) when using Windows Vista and iTunes 7.1.x, you could corrupt the contents of your iPod's hard drive. To safely eject an iPod, ensure you choose "Eject iPod" from the Controls menu within iTunes instead. If your iPod does become corrupted by Explorer or "Safely Remove Hardware", select your iPod in Apple iTunes, then click "Restore" on the Summary tab to restore your iPod to working condition.


A patch that should allow Safely Remove Hardware to do its job is now downloadable here