Exporting your Audacity Project into iTunes and iPod

From Audacity Wiki
Revision as of 02:37, 23 May 2007 by Windinthew (talk | contribs) ('''What format should I export to?''')
Jump to: navigation, search

Exporting to iTunes

You simply need to use one of the File > Export As .. commands in Audacity to export the particular format you want your file to be in (e.g. AIFF, MP3). Then you move that file into iTunes from the location you exported it to.


What format should I export to?

If you want a perfect lossless copy of your audio, or to burn it in iTunes to an "audio CD" for playing on any CD player, you should choose .WAV or .AIFF. It is strongly recommended you export a standard "CD quality" 44 100 Hz, 16 bit stereo WAV or AIFF to make sure iTunes understands the file. This means:

  1. ensure your Project Rate bottom left of the Audacity screen is set to 44 100 Hz
  2. ensure on the Quality tab of Preferences: Uncompressed Export Format that you choose WAV (Microsoft 16 bit PCM) or AIFF (Apple/SGI 16 bit PCM)
  3. If your Project does not already contain a stereo track, click Project > New Stereo Track (or Tracks > Add New > Stereo Track in Audacity 1.3.x).


Jump to here if you're only interested in burning a CD.

If you want to distribute your files on the internet (for example as a podcast), you should choose .MP3, as this is a space-saving (although slightly lossy) format that anyone should be able to play. To export as .MP3 from Audacity you need first to download the LAME encoder and point Audacity to it. See Lame Installation.

If you want to put the files on iPod, or simply store them in iTunes in a compact form, .MP3 is also a good choice. However, there are some reports that when run on battery, recent iPods can struggle or crash when playing MP3s created in applications other than iTunes. So you may want to export as .WAV or .AIFF from Audacity and convert the files to .MP3 in iTunes instead. To do this, you set the conversion format in iTunes Preferences at Advanced > Importing: "Import using MP3 encoder". Then you can right-click or control-click over the files in iTunes library and convert them to .MP3.

Apple's own size-compressed .M4A format is also a good format for iPod or storage in iTunes. Generally, .M4A files will give you the same quality as .MP3 for a slightly smaller filesize. Audacity cannot export to Apple formats but you can export to .WAV or AIFF and convert to .M4A in iTunes. To do this, go to Advanced > Importing in iTunes Preferences and choose "AAC Encoder". This gives you a compressed .M4A file similar to an .MP3. You can also choose "Apple Lossless Encoder" - this gives you a lossless file of the same quality as the .WAV/.AIFF you exported from Audacity, but only half or less as large (though it's still much larger than .MP3 or compressed .M4A). If you choose "Apple Lossless Encoder" the file will still appear in iTunes with an .M4A extension. Finally, right-click or control-click over the files in iTunes Library to convert them to .M4A.

You'll probably know that Audacity supports the .OGG format (a lossy compressed format similar to MP3/compressed .M4A, but of higher quality for the same file size than either). An iPod cannot play .OGG, but iTunes can with a hack. To play OGG Files in iTunes or Quick Time , install the OGG codecs for QuickTime. Alternatively you can download and install Oggdrop which as well as allowing you to play .OGG files in iTunes or Quick Time functions as a standalone application allowing you to encode CD tracks or audio files in other formats to OGG.

Export Location

You can choose any location for the export you like such as a "Music" folder on your Desktop or even the iTunes "Music" folder if you have one. However you must still import this file from the exported location into the iTunes Library (which makes it visible when you view Library > Music on the left hand panel of iTunes). There are three ways to import your exported audio files into iTunes.

  • Select Library > Music in iTunes and drag the file from the location you exported it to, into the iTunes window. If you want to burn the files to CD, it's best to drag them directly into an iTunes Playlist in the left-hand panel. See the section below on burning to CD.
  • Use the File > Add Files to Library command from within iTunes.
  • Use the File > Import command from within iTunes.


HINT: iTunes is a "virtual" Library containing no actual files but only links to them. Therefore you should *not* delete the exported files from the location you exported them to, unless you have already enabled "copy files to iTunes Music folder when adding to Library" in iTunes Preferences (at Advanced : General tab). If you subsequently delete your exported file without having enabled this Preference before the export, you will lose the file!


Burning to CD in iTunes

The files also have to be in an iTunes Playlist before they can be burnt to CD. If you did not drag the files into a Playlist when you imported them into iTunes, simply drag them from the iTunes Library window into the playlist you want in the left hand panel. Then go to the "Advanced" tab of Preferences, and click the "Burning" tab. Select the burner speed, the gap between songs if you are burning multiple files onto the CD, and (most important), make sure "Audio CD" is selected. Unless you choose Audio CD, the CD won't play on standalone CD players.

For more general help on burning to CD, see How to burn CDs


Syncing to your iPod

To load songs from your iTunes Library onto iPod, iPod nano or iPod mini:

1 - connect your iPod to your computer.

2 - when the iPod icon appears in the iTunes window (below Devices), select it. If the "Summary" pane isn't showing, click the "Summary" tab. Make sure that "Manually manage music" is not selected. (If you have an iPod that displays video, the checkbox says "Manually manage music and video.")

3 - click the Music tab and do one of the following:

To automatically update your iPod with all the songs and playlists in your library, select "Sync music" and then select "All songs and playlists." iTunes loads the songs and playlists in your iTunes library onto your iPod, and deletes songs from your iPod that aren't in your library.

To automatically update your iPod with only certain playlists, select "Sync music" and "Selected playlists," and then select the playlists you want synchronized.

If you connect and update your iPod, and then add songs to your iTunes Library that you want to add to your iPod, choose File > Sync iPod.

If you want to sync only items in your library that have a checkmark next to them, click the Summary tab and select "Only sync checked items."

Further information or assistance can be found in the iTunes Help.


Getting files off iPod when you need to

What happens if you need to get files off your iPod (e.g. if your computer fails, or you want to transfer songs from your home computer to your work one)? iTunes will not allow you to download your purchases again. To cover all eventualities, consider retaining all the files listed in Tunes Library in their original location on the hard drive, or ideally back them up to CD or DVD.

If you do want to copy files from iPod to a drive, open up iTunes with your iPod plugged in and go to Preferences. Under Options, select Enable Disk Use. Now your iPod will show up as a storage device in Windows Explorer or the Finder in OS X. Next you need to reveal the files as they will be hidden. In Windows Explorer, click Tools > Folder Options, then View. Select "Show hidden files and folders" then exit the dialogue. On OS X, you can make the Finder show its hidden files and folders by entering this as a command in the terminal:

defaults write com.apple.finder AppleShowAllFiles -bool true

or try this free program to do the same thing.

Within the iPod storage device in Explorer or Finder you should see within a folder called "iPod Control" a series of folders with names such as D1, D12, and so on. Your files are scattered about in those folders. You can now copy those to your hard drive or a flash drive or reimport them to iTunes.

You can also automatically transfer songs that you buy from the iTunes store from the iPod to another computer. The first time you attach the iPod to another machine, you'll see a pop-up window offering at the bottom to move your purchased files. iTunes allows you to play them on up to five different computers.


Removing your iPod on Windows Vista

When Apple released iTunes 7.1 to fix a number of incompatibilities with Windows Vista, it introduced a major problem with removing the iPod.

Normally, when you go to remove your iPod, you click the "Safely Remove Hardware" icon in the System Tray that allows you to unplug a USB item safely. But if you use that interface (or eject the iPod using Windows Explorer) when using Windows Vista and iTunes 7.1.x, you could corrupt the contents of your iPod's hard drive. To always safely eject an iPod, ensure you choose "Eject iPod" from the Controls menu within iTunes instead. If your iPod does become corrupted by Explorer or "Safely Remove Hardware", select your iPod in Apple iTunes, then click "Restore" on the Summary tab to restore your iPod to working condition.

A patch that should allow Safely Remove Hardware to do its job is now downloadable here.