Difference between revisions of "File manager context menus"

From Audacity Wiki
Jump to: navigation, search
(Avoiding loss of project audio due to missing dependent file: reworking beta excision)
(Opening multiple files from the context menu: use kbrd template)
Line 181: Line 181:
 
Using legacy 1.2.x versions of Audacity under Windows, you cannot right-click and open multiple files, or right-click and open ''any'' files if Audacity is already running; this will give an "Audacity already running" error. This is fixed in the [http://audacity.sourceforge.net/download/ the current version of Audacity]. Each file will open in a new project window.
 
Using legacy 1.2.x versions of Audacity under Windows, you cannot right-click and open multiple files, or right-click and open ''any'' files if Audacity is already running; this will give an "Audacity already running" error. This is fixed in the [http://audacity.sourceforge.net/download/ the current version of Audacity]. Each file will open in a new project window.
 
{{Hint|
 
{{Hint|
Other ways to open a file or files without having to launch Audacity first are to select them and then hit {{Button|ENTER}} ; or select them then drag them onto the Audacity icon (for example, on your desktop or in your Program Files folder).}}
+
Other ways to open a file or files without having to launch Audacity first are to select them and then press {{kbrd|Enter}}; or select them then drag them onto the Audacity icon (for example, on your desktop or in your Program Files folder).}}
 
   
 
   
  
  
 
{{CategoryTips}}
 
{{CategoryTips}}

Revision as of 18:20, 28 April 2012

Project files and folders

What is an Audacity project?

Saving an Audacity project lets you save unfinished work and re-open it later in Audacity exactly as it was, with all edits and recorded/imported tracks preserved. This is a different process from using one of the Export commands in the File Menu. Export creates an audio file like WAV or MP3. Use Export whenever you want to hear your work in media players or to burn CDs, because no other programs can open Audacity project files.

There is no need to save a project. If you don't, the necessary audio data is stored in the temporary folder specified in the Directories tab of Preferences until exiting the program. At that point, Audacity offers the choice of saving a project or not.

Some benefits of saving a project:

  • No need to re-import or re-record files
  • Fast loading, even of multiple long tracks
  • Audio data always preserved in lossless quality. This is useful if you have already exported to a lossy audio format like MP3 but decide to edit the file further. Editing and re-exporting the project saves the additional quality loss of re-editing the exported MP3.

When you save an Audacity project, it creates two items inside the folder you specified for the project:

  • a _data folder bearing the name of the project, containing its audio data (in the form of many 1 MB-sized uncompressed .au files).
  • an .aup project file bearing the same project name, which is merely a text file that references the _data folder.


Warning icon Before closing a project, it is good practice to File > Export... a WAV file which will provide a backup in case of any problems. If you have multiple tracks above each other in the project, select each track in turn (by clicking above the Mute / Solo buttons in the track), then File > Export Selection... as WAV.

To reopen a saved Audacity project, click File > Open and open the saved .aup file (not the .au files in the _data folder). In the event of there being no saved .aup file (for example, because of a crash or power outage), see our crash recovery page.

When you have saved a project and exited Audacity more than once, 1.2 versions of Audacity will save an *.aup.bak backup project file. This backup references the state of the project the previous time you saved and exited. Although the .aup.bak file provides some insurance if the .aup file is accidentally deleted or corrupted, it's important you always open the .aup file if you have it, not the .aup.bak file. Otherwise, Audacity internal file errors can occur.
  • The current version of Audacity (and legacy Beta 1.3 versions onwards) do not write .aup.bak files and will not open any created by previous versions of Audacity.

Although you can share Audacity projects with people on other computers, it's necessary to send the other user both the .aup file and the _data folder, and the _data folder must contain a full copy of any imported files that the project contains. As the _data folder can become very large, it's often better to export a compressed file like MP3 and send that instead.

Audacity projects should not be used for long-term storage of audio. When you are completely satisfied with your exported file(s) and are certain you won't need to export further files from the project, delete the .aup file. the .aup.bak backup file (if there is one), and the _data folder, to save disk space.

Moving and renaming project files and folders

As the .aup file references the _data folder, both must be kept together inside the same folder in which you created the project. If you want to move either the .aup file or the _data folder, you must move both to the same new location.

For the same reasons, you should not rename the _data folder, even if you leave it in the same folder it was created in.

If you want to rename an existing project, the safest way is to do it in Audacity. This creates a new .aup file and matching _data folder with your chosen name:

  1. Click File > Save Project As...
  2. In the "Save Project As:" dialogue, enter the new name for the project in the "File name" box. Audacity will offer you the current name of the .aup file, so overwrite it with your new chosen name.
  3. Click the "Save" button.

To avoid confusion between the differently named versions of the same project, delete the previous .aup file and .aup.bak file (if any), together with the previous _data folder. The only legitimate reason for keeping the original project file and folder would be if you wanted to retain a snapshot of your project at a particular point in time before making further edits in the renamed project. If you do this, we recommend giving the renamed project the same name, but differentiating it by including a version number in the name.

Note that if you absolutely know what you are doing, you *can* rename the project manually. It is possible to just rename the .aup file and not rename the _data folder, but this is strongly discouraged and means you cannot make further changes to the project later on.

To rename the project manually so you can save further changes to it, you must follow these steps:

  1. Rename the .aup file for example, "renamed.aup"
  2. Rename the _data folder to the same name as the .aup file, for example, "renamed_data"
  3. Make a copy of the .aup file to be on the safe side
  4. Open the copy of the .aup file in a text editor such as Notepad
  5. Turn "wordwrap" off, look for the second line near the top of the file that starts
    <audacityproject projname=""

    and change the projname inside the quotes to point to the correct _data folder; for example, if you renamed your .aup file to "renamed.aup", the start of the second line of the .aup file should be changed to:

    <audacityproject projname="renamed_data"
    .

Making a backup copy of a project

As with a rename, the safest way to make a backup copy of a project is to use File > Save Project As....

  1. Click File > Save Project As....
  2. In the "Save Project As:" dialogue, enter the name for the backup copy of the project in the "File name" box. Audacity will offer you the current name of the .aup file, so overwrite it with the new name. It is recommended to include the date and time of the backup in the file name, without slashes; for example, type:
    backup_of_song_project_12Jan2012_10_33_AM

    which will save "backup_of_song_project_12Jan2012_10_33_AM.aup" and "backup_of_song_project_12Jan2012_10_33_AM_data".

  3. Click the "Save" button.

If you must make manual copies of projects, please do it this way:

  1. Make a new folder to contain the backup
  2. Select and copy the original .aup and _data folder
  3. Navigate into the new folder and paste the copied .aup and _data folder.

Because the copied .aup and _data folder are now in a different folder, Windows (or you) do not have to rename them. This way, the .aup file will always reference the correct _data folder.

Avoiding loss of project audio due to missing dependent file

Legacy 1.2.x versions of Audacity.

By default, Audacity imports uncompressed files such as WAV or AIFF by reading them directly from the file. This is normal practice with media editors and both speeds up the import considerably and avoids the rapid consumption of disk space that copying the file would involve. However, this means you need to keep the imported WAV or AIFF file available for Audacity to use, in the exact file path it existed in when you imported it.

Therefore the project will have either no sound, or sound only in places, if you do any of these:

  • move the WAV or AIFF file to another location
  • delete it
  • rename it
  • disconnect the removable source it resides on
  • open the project on another computer without copying the dependent WAV or AIFF to the same path on that computer

This is true even though the waveform is visible on the screen, because the waveform is only a representation of the audio made when it was first imported. Any regions that do have sound will be those edited while the original audio file was still in place.

To correct this situation, open the .aup Project file in a text editor such as Notepad. The file(s) originally used to read data into the project are marked in the .aup file as "aliasfile". Use the text editor's "Find" function to search for "aliasfile" (without quotes), and note the full path to these files that is stated in the .aup file e.g. aliasfile='C:\My Music\Music22.wav'

Restoring the files noted as aliasfiles to the exact path noted in the .aup file, will restore full sound to the project.

To avoid this problem in future when importing uncompressed files, either retain the original audio file (in its correct location) or set Audacity to make a copy of the file, which will then be stored in the Project's _data folder when the Project is saved. To set Audacity to make a copy of the imported file, go to the File Formats tab of Preferences, find "when importing uncompressed audio...." and check the radio button "make a copy of the file before editing (safer)". Click OK to save the change.

Note: this issue does not arise if importing compressed data such as an MP3 or OGG file, as Audacity automatically makes a copy upon import.


Current Audacity versions

In 2.0 versions onwards, you still need to keep the imported WAV or AIFF file available for Audacity to use, in the exact file path it existed in when you imported it. However, when you exit a project that depends on such files, Audacity will by default show a dialogue providing the option to copy the files into the project to make it self-contained. The dialogue also gives options to always copy data into the Project, never do so, or always ask what to do. These three options can also be accessed on the File Formats tab of Preferences. This tab is called "Import / Export" in Audacity 1.3.5 and later.

File and folder errors

Directory write-protected or disk full error when writing WAV/AIFF

This tip applies to legacy 1.2.x and legacy 1.3.0/1.3.1 versions of Audacity.

You will receive the above error if you both:

  • when importing uncompressed audio data such as a WAV or AIFF file, use Audacity's default behaviour of reading the data directly from the original file, and
  • export your Project's audio data to the same file name and directory as the file you imported

The problem occurs because Audacity cannot delete the original file in order to overwrite it when it is already reading it. (This issue does not arise if importing a compressed audio file such as an MP3 file, because in the case of compressed audio Audacity automatically makes a copy upon import.)

To avoid this problem in legacy 1.2.6, either

  • save the exported WAV or AIFF to another file name or another directory, or
  • set Audacity to make a copy of the imported file: go to the File Formats tab of Preferences, find "when importing uncompressed audio...." and check the radio button "make a copy of the file before editing (safer)". Click OK to save the change.


In current Audacity, this problem is handled differently, and the steps needed in legacy 1.2.6 are not needed. If Audacity is set to make a copy of the original file, you can overwrite the original file just as in legacy 1.2.6. If Audacity is set to read directly from the original file, it will rename the original file by appending "-old1" to its file name, allowing you to export the edited audio as the original filename. Once you are happy with the newly exported file, delete the original file with the "-old1" suffix.


Context menus

A context menu is the menu of options accessible when you right-click over a file in the operating system's file manager (for example, Explorer in Windows). The following information applies to Windows, but similar principles apply to other operating systems.

Open with

This context menu item allows you to open the file with programs other than the default program associated with that file type. You can add a program to the "Open with" menu and choose if that program will now be the default program to open that file type when you double-click it.

Once a program has been added to the "Open with" menu, it will be listed when you hover over "Open with". If you add Audacity to "Open with", this provides a way to open files with Audacity when it isn't already running, but retain the default double-click action to play the file with Windows Media Player. If a track is already open in Audacity when you execute "Open with", your file will be opened in a new project window.

On Windows, the Audacity executable cannot be added to the Explorer "Open with" hover menu if you have another version of Audacity on the system which is also called "audacity.exe" (for example, if you have both the current Audacity and the legacy "1.2.x" Audacity installed). This is a limitation in Windows. Workarounds:
  • Use the Open with > Choose default program... dialogue to browse to the required executable each time.
  • Alternatively, rename one executable to a unique name such as "audacity_2.exe", then use Open with > Choose default program..., browse to the renamed executable and make sure "Always use the selected program to open this kind of file" is checked.

Custom context menus

To give more direct context menu access to Audacity, Windows lets you add a custom context menu item of your own for a file type, such as "Edit WAV in Audacity".

To create a custom context menu item in Windows 98, ME, 2000 or XP:

  1. Click Windows Start button > (Settings) > Control Panel > Folder Options, or Tools > Folder Options from inside Explorer
  2. Click on the File Types tab
  3. Navigate to the file extension for your context menu item, such as WAV, and click "Advanced"
  4. In the window that appears, click "New" to add a new context menu item (or to change an existing item, click "Edit")
  5. In the "Action" box, type or change the entry as you wish it to appear in the menu (for example, Edit WAV in Audacity)
  6. In the "Application used to perform action" box, type the full path to the Audacity executable inside quotes, followed by %1 inside quotes, for example:
    "C:\Program Files\Audacity 2.0.0 (Unicode)\audacity.exe" "%1"
  7. Click OK, OK and Close.


Windows Vista and 7 lack any direct way to either create or edit custom context menu items. You can use a free third-party application called Default Programs Editor for this purpose.


Warning icon File names including spaces:

Don't forget the "%1" after the path to Audacity. If this is missing, Audacity will think file names including spaces are separate files, and give an error for each one, or not open the file at all. As a quick alternative to editing an incorrect context menu entry, replace the spaces in the filename with an underscore, for example:
C:\Multimedia\audio_files\very_beautiful_melodies.wav


Opening multiple files from the context menu

"Open with" on Windows only supports opening one file at a time.

Using legacy 1.2.x versions of Audacity under Windows, you cannot right-click and open multiple files, or right-click and open any files if Audacity is already running; this will give an "Audacity already running" error. This is fixed in the the current version of Audacity. Each file will open in a new project window.

Other ways to open a file or files without having to launch Audacity first are to select them and then press Enter; or select them then drag them onto the Audacity icon (for example, on your desktop or in your Program Files folder).