Difference between revisions of "Improving and Remastering Audio: Advanced Steps and Tips"

From Audacity Wiki
Jump to: navigation, search
(added one image plus description ti "finished" draft)
(Zooming: remove dead link)
 
(27 intermediate revisions by 4 users not shown)
Line 1: Line 1:
<h3>&nbsp;</h3>__NOTOC__ {{UserWip}}
+
{{alert|This article was written for a now obsolete 1.3 Beta version of Audacity so until it is updated, some material may not be accurate for [https://web.audacityteam.org/download/ current Audacity].}}   
 +
{{ednote|'''Peter 3May14:''' Gale has commented on its sister page [[Improving and Remastering Audio]].
 +
*'''Peter 9Jun14:''' Following a suggestion from Steve on the Forum, this page and it's sister article are slated to remain on the Wiki but be updated to become version-neutral with links to the manual for how-tos. }}
 +
<h3>&nbsp;</h3>__NOTOC__
 
{{Introrel|This is part 2 of an article intended to provide a first but detailed guideline to those who want to clean up poor quality audio files, for example those who are starting to digitize their record or tape collection and want to do a little more than just transfer them to their hard disk with their existing quality.|The bulk of the article deals with editing one single audio file. In part D is a section about preparing a set of files for a CD or a playlist.
 
{{Introrel|This is part 2 of an article intended to provide a first but detailed guideline to those who want to clean up poor quality audio files, for example those who are starting to digitize their record or tape collection and want to do a little more than just transfer them to their hard disk with their existing quality.|The bulk of the article deals with editing one single audio file. In part D is a section about preparing a set of files for a CD or a playlist.
|3=[[Transferring tapes and records to computer or CD]]
+
|3=[[Improving and Remastering Audio]]
*[[Noise Removal]]
+
*[https://manual.audacityteam.org/o/man/tutorial_copying_tapes_lps_or_minidiscs_to_cd.html Transferring tapes and records to computer or CD]
*[[Click Removal]]
+
*[https://manual.audacityteam.org/o/man/noise_reduction.html Noise Reduction]
*{{external|[http://audacity.sourceforge.net/de/docs/effekte/reverb/index.htm Tutorial in German about using Audacity effects with real-time control.]}}
+
*[https://manual.audacityteam.org/o/man/click_removal.html Click Removal]
*{{external|[http://home.arcor.de/mfiedler/einfuehrung-effekte.html "Einführung in alle gängigen Effekte der Musikproduktion"]}} More detailed tutorial in German about all effects.}}
+
}}
  
  
Line 60: Line 63:
 
'''These notes concern the mode "acting on a set of files".'''
 
'''These notes concern the mode "acting on a set of files".'''
  
*How to add own chains
+
*'''How to add own chains'''
**Select {{menu|File > Edit Chains...}}.<br>The new window shows the existing chains on the left, the commands and parameters of the selected chain on the right.
+
#Select {{menu|File > Edit Chains...}}.<br>The new window shows the existing chains on the left, the commands and parameters of the selected chain on the right.
**To define a new chain, click "Add" below the left list, enter a name, click "OK" (New chains are saved automatically under the entered name and are listed the next time). A new "torso" chain appears on the right with a first entry "-END-".
+
#To define a new chain, click "Add" below the left list, enter a name, click "OK" (New chains are saved automatically under the entered name and are listed the next time). A new "torso" chain appears on the right with a first entry "-END-".
**Insert commands by clicking "Insert" below the commands list. The "Select Command" window appears.
+
#Insert commands by clicking "Insert" below the commands list. The "Select Command" window appears.
**Select a command by '''doubleclicking''' it, its name has to show at the top!
+
#Select a command by '''doubleclicking''' it, its name has to show at the top!
**If there are parameters and you want to change them, click "Edit Parameters", edit them. Some commands use current parameters, e.g. "ExportMp3" uses the currently set bitrate.
+
#If there are parameters and you want to change them, click "Edit Parameters", edit them. Some commands use current parameters, e.g. "ExportMp3" uses the currently set bitrate.
**Click "OK".
+
#Click "OK".
**Repeat the last 4 steps (from "insert" on) until done.
+
#Repeat from step 3 ("Insert"), until done.
***[[image:Attention.png|30px]] The last command before "-END-" has to be an "'''Export'''". Else the chain processing is carried out without any results. The initial '''import''' is done without the need of a command.
+
#Arrange the commands using the buttons below the commands list.
***[[image:Attention.png|30px]] "Amplify" may cause clipping.
+
#Click "OK" bottom right.
***[[image:Attention.png|30px]] "TruncateSilence" also effects silence '''within''' your files.
 
**Arrange the commands using the buttons below the commands list.
 
**Click "OK" bottom right.
 
  
*How to a apply a chain
+
[[image:Attention.png|30px]] The last command before "-END-" has to be an "'''Export'''".<br>Else the chain processing is carried out without any results.<br>The initial '''import''' is done without the need of a command.
**With no file loaded into Audacity select {{menu|File > Apply Chain...}}
+
 
**In the new window select one of the chains and click on "Apply to Files...".
+
[[image:Attention.png|30px]] "Amplify" may cause clipping.
**In the file selection window select the files.
+
 
**Batch processing starts, displaying various progress informations.
+
[[image:Attention.png|30px]] "TruncateSilence" also effects silence '''within''' your files.
**After all files are processed, there is a new subdirectory to the one you selected the files from, named "cleaned", containing the processed files.<br>
+
 
 +
 
 +
*'''How to a apply a chain'''
 +
#With no file loaded into Audacity select {{menu|File > Apply Chain...}}
 +
#In the new window select one of the chains and click on "Apply to Files...".
 +
#In the file selection window select the files.
 +
#Batch processing starts, displaying various progress informations.
 +
#After all files are processed, there is a new subdirectory to the one you selected the files from, named "cleaned", containing the processed files.<br>
 
[[image:Attention.png|30px]] This new directory may not be visible at once in the directory treeview.
 
[[image:Attention.png|30px]] This new directory may not be visible at once in the directory treeview.
  
  
[[image:GoTop.jpg]] [[Improving and Remastering Audio: Advanced Steps and Tips#&nbsp;|Back to Top]]
+
[[image:GoTop.jpg]] <span class="plainlinks">[http://audacityteam.org/wiki/index.php?title=Improving_and_Remastering_Audio:_Advanced_Steps_and_Tips Back to Top]</span>
  
  
Line 116: Line 123:
  
  
[[image:Benchmark.jpg|benchmark results window]|left]] However the number of files Audacity (and your computer) can handle at once is limited. To find out, select {{menu|Help > Run Benchmark...}}. After some time the results are displayed, and at the bottom you find the number of files playable simultaneously.<br clear="all" />
+
[[image:Benchmark.jpg|benchmark results window]|left]] However the number of files Audacity (and your computer) can handle at once is limited. To find out, select {{menu|Help > Run Benchmark...}}. After some time the results are displayed, and at the bottom you find the number of files playable simultaneously. Using compressed audio does not help, because Audacity converts it to its uncompressed AU-format. To ease processing close other applications.<br clear="all" />
  
 
Instead of the above you may arrange all your songs in two tracks, thus '''avoiding the''' mentioned '''playback limitation'''. Use a third track for routing/switching purposes.
 
Instead of the above you may arrange all your songs in two tracks, thus '''avoiding the''' mentioned '''playback limitation'''. Use a third track for routing/switching purposes.
 +
 +
If Files with different sample rates are involved, see [[#Combining Different Sample Rates|Combining Different Sample Rates]]. Immediately after the import adapt the sample rate, move the song to the desired place, close the now empty track.
  
 
With the time shift tool you can move the songs along the time axis, but '''also from track to track''', so no need for switching tools is given.
 
With the time shift tool you can move the songs along the time axis, but '''also from track to track''', so no need for switching tools is given.
  
If you place the tool on an unselected song, only this song is moved, if you select one track  
+
If you place the tool on an unselected song, only this song is moved, if you select one track
by clicking left of the waveform display, all songs in this track are moved.
+
by clicking left of the waveform display, all songs in this track are moved. Avoid shifting songs to the left of t = 0 s.
  
 
[[image:playlist2.jpg|playlist with many songs in 2 tracks plus 3rd track for routing]]
 
[[image:playlist2.jpg|playlist with many songs in 2 tracks plus 3rd track for routing]]
  
  
I can´t abstain from stating: It´s a pleasure to see my childhood railway dreams come true this way.
+
The first method displays all song names, plays tracks with different sample rates, but the screen gets crowded and the number of songs is very limited.
 +
The second method plays a large number of songs, but they have to be of the same sample rate (or must be rendered), and no song names are displayed.
  
  
Line 135: Line 145:
  
 
===Re-Vinylize===
 
===Re-Vinylize===
The following instruction is a modification of the {{external|[http://audacity.sourceforge.net/de/docs/effekte/reverb/index.htm Tutorial in German about using Audacity effects with real-time control.]}}
+
#Obtain an audio file with a lot of hiss, crackle etc.
*Obtain an audio file with a lot of hiss, crackle etc.
+
#From this extract the noise:
*From this extract the noise:
+
##Load this file,
**Load this file,
+
##select {{menu|Tracks > Add New... > Stereo Track}} (or Audio Track for mono)
**select {{menu|Tracks > Sdd New... > Stereo Track (or Audio Track for mono)
+
##copy the loaded file into this new track,
**copy the loaded file into this new track,
+
##denoise and declick this file as much as possible,
**denoise this file as much as possible,
+
##invert it: Select {{menu|Effect > Invert}},
**invert it: {{menu|Effect > Invert}},
+
##select all (both tracks have to been selected),
**select all (both tracks have to been selected),
+
##{{menu|Tracks > Mix and Render}}.<br>The last step is the vital step. By "adding" the original and the inverted file all originally identical waves are summed up to zero (thus deleted), and only the noise remains, that by now is only present in one of the tracks.
**{{menu|Tracks > Mix and Render}}.<br>The last step is the vital step. By "adding" the original and the inverted file all originally identical waves are summed up to zero (thus deleted), and only the noise remains, that by now is only present in one of the tracks.
+
#Mix the noise file into any other file:
*Mix the noise file into any other file:
+
##Import your re-vinylize-file,
**Import your re-vinylize-file,
+
##press "Play",
**press "Play",
+
##adjust the volume of the noise using the gain slider left of the wave display, press "Stop",
**adjust the volume of the noise using the gain slider left of the wave display, press "Stop",
+
##{{menu|Tracks > Mix and Render}}.
**{{menu|Tracks > Mix and Render}}.
 
  
  
 
If you want to additionally equalize the file (attenuate bass and treble), do it before adding the noise, else the noise might lose its impact.
 
If you want to additionally equalize the file (attenuate bass and treble), do it before adding the noise, else the noise might lose its impact.
  
There are also free plugins available, look for "vinyl".
+
There are also free plug-ins available, look for "vinyl".
  
  
 
[[image:GoTop.jpg]] [[Improving and Remastering Audio: Advanced Steps and Tips#bt|Back to Top]]
 
[[image:GoTop.jpg]] [[Improving and Remastering Audio: Advanced Steps and Tips#bt|Back to Top]]
 +
 
----
 
----
  
Line 167: Line 177:
 
*Place the cut at a zero crossing (where the waveform crosses the timeline).
 
*Place the cut at a zero crossing (where the waveform crosses the timeline).
 
*Place the cut in such a way, that the two ends of the waveform <br> join smoothly and show the same gradient (slope).
 
*Place the cut in such a way, that the two ends of the waveform <br> join smoothly and show the same gradient (slope).
*Use the Effect {{menu|Repair}} to smooth out remaining differences in the gradient.<br clear="all" />
+
*Use the {{menu|Effect > Repair}} to smooth out remaining differences in the gradient.<br clear="all" />
  
 
[[image:GoTop.jpg]] [[Improving and Remastering Audio: Advanced Steps and Tips#bt|Back to Top]]
 
[[image:GoTop.jpg]] [[Improving and Remastering Audio: Advanced Steps and Tips#bt|Back to Top]]
  
  
=== Comparative Listening ===
+
===Combining Different Sample Rates===
*Open two or more files.
+
Files with different sample rates play in different speeds or not at all, when combined in one track. Proceed as follows:
*For files with the same music assure synchronicity.
+
#Enter the desired sample rate in the "Project Rate" field bottom left.
*Press "Play".
+
#Select one entire file
*Repeatedly alternate between the tracks by clicking "Solo" on the left of the corresponding track panel.
+
#Do {{menu|Tracks > Mix and Render}}, watch the display beneath the track name change.
 +
#Repeat the last two steps for all other files with a "wrong" sample rate.
 +
 
 +
Now all files should behave the same.
 +
 
 +
 
 +
[[image:GoTop.jpg]] [[Improving and Remastering Audio: Advanced Steps and Tips#bt|Back to Top]]
 +
 
 +
 
 +
===Comparative Listening===
 +
#Open two or more files.
 +
#For files with the same music assure synchronicity.
 +
#Press "Play".
 +
#Repeatedly alternate between the tracks by clicking "Solo" on the left of the corresponding Track Control Panel.
  
  
Line 200: Line 223:
  
 
===Preview, Use Of===
 
===Preview, Use Of===
*Select the part of the file you want to preview,
+
#Select the part of the file you want to preview,
*chose the effect you want to apply,
+
#chose the effect you want to apply,
*make your settings and press {{menu|Preview}},
+
#make your settings and press "Preview",
*repeat the last step, if necessary,
+
#repeat the last step, if necessary,
*if possible, save your settings,
+
#if possible, save your settings,
*close the effect window,
+
#close the effect window,
*select the part of the file you want the effect apply to (or cancel the previous selection, which will cause Audacity to select all),
+
#select the part of the file you want the effect apply to (or cancel the previous selection, which will cause Audacity to select all),
*reopen the effect window,
+
#reopen the effect window,
*confirm the settings,
+
#confirm the settings,
*apply the effect by pressing {{menu|OK}}.
+
#apply the effect by pressing "OK".
  
  
Line 218: Line 241:
 
If sample precision replacements are required, use the following instructions:
 
If sample precision replacements are required, use the following instructions:
  
The selection bar at the bottom and a label track are used. Users of Audacity 1.3 may see [[http://www.audacityteam.org/manual/index.php?title=Audacity_Selection]] for a more detailed description of these elements.
+
The selection bar at the bottom and a label track are used. See [[http://www.audacityteam.org/manual/index.php?title=Audacity_Selection]] for a more detailed description of these elements.
  
For our purposes activate the radio button "Length" and set the time unit to "samples" (this can be done at any of the fields by using the drop-down menu of the field).
+
For our purposes activate the radio button "Length" and set the selection format to "samples" (this can be done at any of the fields by using the dropdown menu of the field).
  
 
*Replace a region with audio from elsewhere.<br>Use one of the following methods:
 
*Replace a region with audio from elsewhere.<br>Use one of the following methods:
 
**Method 1
 
**Method 1
***Mark the region to be replaced.
+
#Mark the region to be replaced.
***Select {{menu|Edit > Play Region... > Lock}}. This causes your marking to become stationary.
+
#Select {{menu|Edit > Play Region... > Lock}}. This causes your marking to become stationary.
***Use the time shift tool, place it '''outside''' the marked region, and shift the waveform, until the replacement audio is positioned under the marking (is selected).
+
#Use the time shift tool, place it '''outside''' the marked region, and shift the waveform, until the replacement audio is positioned under the marking (is selected).
***Press Ctrl-C to copy.
+
#Press Ctrl-C to copy.
***Shift the waveform back to the initial position.
+
#Shift the waveform back to the initial position.
***Press Ctrl-V to carry out the replacement.
+
#Press Ctrl-V to carry out the replacement.
***Select {{menu|Edit > Play Region... > Unock}}.
+
#Select {{menu|Edit > Play Region... > Unock}}.
 
**Method 2
 
**Method 2
***Mark the region to be replaced.
+
#Mark the region to be replaced.
***Press Ctrl-B to generate a label (name it (say "b"), press Enter).
+
#Press Ctrl-B to generate a label (name it (say "b"), press Enter).
***Keep in mind the number of samples shown in the Length field.
+
#Keep in mind the number of samples shown in the Length field.
***Go to where your replacement audio is.
+
#Go to where your replacement audio is.
***Select the replacement audio while watching the Length field.
+
#Select the replacement audio while watching the Length field.
***Modify your selection until you have marked the exact number of samples.
+
#Modify your selection until you have marked the exact number of samples.
***Press Ctrl-C to copy.
+
#Press Ctrl-C to copy.
***If your first section has got out of sigth, scroll the display or zoom out to Bring the selection into view.
+
#If your first section has got out of sigth, scroll the display or zoom out to Bring the selection into view.
***Click into the label "b" (first section gets marked).
+
#Click into the label "b" (first section gets marked).
***Close the label track (audio track gets focus with intact selection).
+
#Close the label track (audio track gets focus with intact selection).
***Press Ctrl-V to actually carry out the replacement.
+
#Press Ctrl-V to actually carry out the replacement.
  
  
 
*Replace a region in channel 2 with corresponding audio from channel 1.
 
*Replace a region in channel 2 with corresponding audio from channel 1.
**Place the cursor at the beginning of the region to be replaced in channel 2
+
#Place the cursor at the beginning of the region to be replaced in channel 2
**Press Ctrl-B to generate a label (name it (say "b"), press Enter).
+
#Press Ctrl-B to generate a label (name it (say "b"), press Enter).
**Mark the region to be replaced in channel 2 (Shift-Click to the right of the current **position, the drag curso to the wanted position).
+
#Mark the region to be replaced in channel 2 (Shift-Click to the right of the current #position, the drag curso to the wanted position).
**Keep in mind the number of samples shown in the Length field.
+
#Keep in mind the number of samples shown in the Length field.
**In the Track-Menu select "Split Stereo Track"
+
#In the Track-Menu select "Split Stereo Track"
**Cclose Channel 2.
+
#Close Channel 2.
**Press Ctrl-C to copy the remaining channel 1.
+
#Press Ctrl-C to copy the remaining channel 1.
**Undo (channel 2 reappears).
+
#Undo (channel 2 reappears).
**Mark the region to be replaced in channel 1 or 2 (Shift-Click to the right of the current position, the drag curso to the wanted position)
+
#Mark the region to be replaced in channel 1 or 2 (Shift-Click to the right of the current position, the drag curso to the wanted position)
**Close the label track (audio track gets focus with intact selection).
+
#Close the label track (audio track gets focus with intact selection).
**Press Ctrl-V to actually carry out the replacement.
+
#Press Ctrl-V to actually carry out the replacement.
  
  
 
[[image:GoTop.jpg]] [[Improving and Remastering Audio: Advanced Steps and Tips#bt|Back to Top]]
 
[[image:GoTop.jpg]] [[Improving and Remastering Audio: Advanced Steps and Tips#bt|Back to Top]]
 
 
===Selecting Audio===
 
When selecting a region of audio by clicking and dragging, the "border precision" is greater at the end of the selection. So '''end''' your selection at '''that''' point, where the  greater precision is required.
 
 
 
[[image:GoTop.jpg]] [[Improving and Remastering Audio: Advanced Steps and Tips#bt|Back to Top]]
 
 
 
===Undo===
 
If you are not sure about the current "undo" status, refer to the Menu {{menu|Edit > Undo / Redo}} (the relative actions are displayed here) or the Menu {{menu|View > History}}.
 
 
{|
 
|
 
[[image:Attention.png|30px]]
 
|
 
There are actions that are not always undone by '''one''' "Undo", but require '''two Undos'''.
 
 
One is the '''Effect Repair'''. Check the wave display.
 
|}
 
 
 
[[image:GoTop.jpg]] [[Improving and Remastering Audio: Advanced Steps and Tips#bt|Back to Top]]
 
 
  
 
===Zooming===
 
===Zooming===
Although there is ample [[Zooming|help]] on zooming in the Audacity manual, I include this survey. Because zooming is so vital to remastering, a reminder close at hand cannot be wrong.
+
Although there is ample help on zooming in the Audacity manual, I include this survey. Because zooming is so vital to remastering, a reminder close at hand cannot be wrong.
 
*Vertical:
 
*Vertical:
 
**Scaling:
 
**Scaling:
Line 303: Line 302:
 
***"Fit Selection"
 
***"Fit Selection"
 
***"Fit Project"
 
***"Fit Project"
**Use the corresponding options in the {{menu|View}} Menu (here is an additional option {{menu|Zoom Normal}}).
+
**Use the corresponding options in the "View" menu (here is an additional option {{menu|Zoom Normal}}).
 
**Use the "Zoom Tool" from the "Tools Panel".
 
**Use the "Zoom Tool" from the "Tools Panel".
  
  
[[image:GoTop.jpg]] [[Improving and Remastering Audio: Advanced Steps and Tips#bt|Back to Top]]
+
[[image:GoTop.jpg]] [[#top|back to top]]
 
 
----
 
[[User:Master of pausbacken|Master of pausbacken]] and Gale
 

Latest revision as of 15:23, 11 August 2019

Warning icon This article was written for a now obsolete 1.3 Beta version of Audacity so until it is updated, some material may not be accurate for current Audacity.
Peter 3May14: Gale has commented on its sister page Improving and Remastering Audio.
  • Peter 9Jun14: Following a suggestion from Steve on the Forum, this page and it's sister article are slated to remain on the Wiki but be updated to become version-neutral with links to the manual for how-tos.

 

This is part 2 of an article intended to provide a first but detailed guideline to those who want to clean up poor quality audio files, for example those who are starting to digitize their record or tape collection and want to do a little more than just transfer them to their hard disk with their existing quality.
The bulk of the article deals with editing one single audio file. In part D is a section about preparing a set of files for a CD or a playlist.
 
Related article(s):


Main Article

Advanced Steps and Tips

  1. Preliminary Notes
  2. Editing - General
  3. Editing - The Individual Steps
    1. Two-Channel Mono Files
    2. Unwanted Parts Removal (Trim)
    3. DC Offset Removal
    4. Noise Reduction
    5. Clicks, Pops, Dropouts Removal
    6. Pan Correction
    7. Frequency Spectrum Editing (Equalization)
    8. Volume Editing (Amplify / Envelope)
    9. Dynamics Editing
    10. Reconstructing Missing Parts
  1. Advanced Steps
  2. Tips


Advanced Steps

Batch Processing For Files (Apply Chain)

In a situatiion, where identical tasks have to been carried out on several files, batch processing comes handy. In a script you define what tasks to do and how, then you decide on wich files the process shall work.

The sripts containing the tasks to be done und their parameters are called "chains", running a batch process is called "applying a chain".

Some chains are pre-installed, others may be defined (and saved) by you.

Audacity distinguishes between two modes:

  • acting on all files of a project or
  • acting on a set of files.

These notes concern the mode "acting on a set of files".

  • How to add own chains
  1. Select File > Edit Chains....
    The new window shows the existing chains on the left, the commands and parameters of the selected chain on the right.
  2. To define a new chain, click "Add" below the left list, enter a name, click "OK" (New chains are saved automatically under the entered name and are listed the next time). A new "torso" chain appears on the right with a first entry "-END-".
  3. Insert commands by clicking "Insert" below the commands list. The "Select Command" window appears.
  4. Select a command by doubleclicking it, its name has to show at the top!
  5. If there are parameters and you want to change them, click "Edit Parameters", edit them. Some commands use current parameters, e.g. "ExportMp3" uses the currently set bitrate.
  6. Click "OK".
  7. Repeat from step 3 ("Insert"), until done.
  8. Arrange the commands using the buttons below the commands list.
  9. Click "OK" bottom right.

Attention.png The last command before "-END-" has to be an "Export".
Else the chain processing is carried out without any results.
The initial import is done without the need of a command.

Attention.png "Amplify" may cause clipping.

Attention.png "TruncateSilence" also effects silence within your files.


  • How to a apply a chain
  1. With no file loaded into Audacity select File > Apply Chain...
  2. In the new window select one of the chains and click on "Apply to Files...".
  3. In the file selection window select the files.
  4. Batch processing starts, displaying various progress informations.
  5. After all files are processed, there is a new subdirectory to the one you selected the files from, named "cleaned", containing the processed files.

Attention.png This new directory may not be visible at once in the directory treeview.


GoTop.jpg Back to Top


CD Or Playlist, Preparations

Get the size of the playlist

You will probably use some software dedicated to handling sets of audiofiles, that will provide you with all relevant information.

If not, you may control the total playtime by using any available music player capable of displaying the total time.

The file size may be used for a rough estimate. About 0,93 MB for 1 min at a bitrate of 128 kB/s is needed, this size being approximately proportional to the bitrate. Look at the "properties" of the folder containing your files to see the total size.


Adjust the single files to fit to the playlist

Adjust your files concerning, volume, sound etc.. If this goes with repeatedly changing and exporting the file, and if your target file format is a compressed one, it implies repeatedly decoding and coding, thereby degrading the audio quality. Either keep the files loaded in Audacity until the final change has done, or export as WAV or another uncompressed format, and do the compression as last step, after all files are done with, using File > Apply Chain....

  • You might check the transitions from one file to the next using a media player at hand or
  • import some files, preferably from the start, the middle and the end of the list and do comparative listening.
  • If the files are intended for sequential playback in a fixed order, you might align them in one big Audacity file and listen to the transitions there.
  • You might import them into different tracks in Audacity, then use the time shift tool Timeshifttool.png to move them along the time axis, thus creating a sequence to be listened to (see the following).


Build a playlist in Audacity

In this way (see last item above) it is easy creating crossfades, altering the order of the files, and control the total playtime.

If the screen becomes too crowded, collapse selected tracks by clicking on the upward triangle at the bottom of the track panel.


how to buil a playlist n Audacity


benchmark results window]
However the number of files Audacity (and your computer) can handle at once is limited. To find out, select Help > Run Benchmark.... After some time the results are displayed, and at the bottom you find the number of files playable simultaneously. Using compressed audio does not help, because Audacity converts it to its uncompressed AU-format. To ease processing close other applications.

Instead of the above you may arrange all your songs in two tracks, thus avoiding the mentioned playback limitation. Use a third track for routing/switching purposes.

If Files with different sample rates are involved, see Combining Different Sample Rates. Immediately after the import adapt the sample rate, move the song to the desired place, close the now empty track.

With the time shift tool you can move the songs along the time axis, but also from track to track, so no need for switching tools is given.

If you place the tool on an unselected song, only this song is moved, if you select one track by clicking left of the waveform display, all songs in this track are moved. Avoid shifting songs to the left of t = 0 s.

playlist with many songs in 2 tracks plus 3rd track for routing


The first method displays all song names, plays tracks with different sample rates, but the screen gets crowded and the number of songs is very limited. The second method plays a large number of songs, but they have to be of the same sample rate (or must be rendered), and no song names are displayed.


GoTop.jpg Back to Top


Re-Vinylize

  1. Obtain an audio file with a lot of hiss, crackle etc.
  2. From this extract the noise:
    1. Load this file,
    2. select Tracks > Add New... > Stereo Track (or Audio Track for mono)
    3. copy the loaded file into this new track,
    4. denoise and declick this file as much as possible,
    5. invert it: Select Effect > Invert,
    6. select all (both tracks have to been selected),
    7. Tracks > Mix and Render.
      The last step is the vital step. By "adding" the original and the inverted file all originally identical waves are summed up to zero (thus deleted), and only the noise remains, that by now is only present in one of the tracks.
  3. Mix the noise file into any other file:
    1. Import your re-vinylize-file,
    2. press "Play",
    3. adjust the volume of the noise using the gain slider left of the wave display, press "Stop",
    4. Tracks > Mix and Render.


If you want to additionally equalize the file (attenuate bass and treble), do it before adding the noise, else the noise might lose its impact.

There are also free plug-ins available, look for "vinyl".


GoTop.jpg Back to Top


Tips

Clean Cuts

avoid different slopes
In order to get inaudible cuts, apply the following techniques:
  • Place the cut into "silence".
  • Place the cut at a zero crossing (where the waveform crosses the timeline).
  • Place the cut in such a way, that the two ends of the waveform
    join smoothly and show the same gradient (slope).
  • Use the Effect > Repair to smooth out remaining differences in the gradient.

GoTop.jpg Back to Top


Combining Different Sample Rates

Files with different sample rates play in different speeds or not at all, when combined in one track. Proceed as follows:

  1. Enter the desired sample rate in the "Project Rate" field bottom left.
  2. Select one entire file
  3. Do Tracks > Mix and Render, watch the display beneath the track name change.
  4. Repeat the last two steps for all other files with a "wrong" sample rate.

Now all files should behave the same.


GoTop.jpg Back to Top


Comparative Listening

  1. Open two or more files.
  2. For files with the same music assure synchronicity.
  3. Press "Play".
  4. Repeatedly alternate between the tracks by clicking "Solo" on the left of the corresponding Track Control Panel.


For the export of files after using "Solo" see Exporting with "Solo"-Button or "Mute"-Button activated


GoTop.jpg Back to Top


Exporting with "Solo"-Button or "Mute"-Button activated

Attention.png

If you export a stereo file while "Solo" is still activated, channel 2 will be muted in the saved file.

If you cannot simply deactivate "Solo", use the Track-Menu to split the file, rebuild it, then deactivate "Solo".

Now both channels are exported as usual.

If instead "Mute" is activated, nothing is exported.


GoTop.jpg Back to Top


Preview, Use Of

  1. Select the part of the file you want to preview,
  2. chose the effect you want to apply,
  3. make your settings and press "Preview",
  4. repeat the last step, if necessary,
  5. if possible, save your settings,
  6. close the effect window,
  7. select the part of the file you want the effect apply to (or cancel the previous selection, which will cause Audacity to select all),
  8. reopen the effect window,
  9. confirm the settings,
  10. apply the effect by pressing "OK".


GoTop.jpg Back to Top


Replace

If sample precision replacements are required, use the following instructions:

The selection bar at the bottom and a label track are used. See [[1]] for a more detailed description of these elements.

For our purposes activate the radio button "Length" and set the selection format to "samples" (this can be done at any of the fields by using the dropdown menu of the field).

  • Replace a region with audio from elsewhere.
    Use one of the following methods:
    • Method 1
  1. Mark the region to be replaced.
  2. Select Edit > Play Region... > Lock. This causes your marking to become stationary.
  3. Use the time shift tool, place it outside the marked region, and shift the waveform, until the replacement audio is positioned under the marking (is selected).
  4. Press Ctrl-C to copy.
  5. Shift the waveform back to the initial position.
  6. Press Ctrl-V to carry out the replacement.
  7. Select Edit > Play Region... > Unock.
    • Method 2
  1. Mark the region to be replaced.
  2. Press Ctrl-B to generate a label (name it (say "b"), press Enter).
  3. Keep in mind the number of samples shown in the Length field.
  4. Go to where your replacement audio is.
  5. Select the replacement audio while watching the Length field.
  6. Modify your selection until you have marked the exact number of samples.
  7. Press Ctrl-C to copy.
  8. If your first section has got out of sigth, scroll the display or zoom out to Bring the selection into view.
  9. Click into the label "b" (first section gets marked).
  10. Close the label track (audio track gets focus with intact selection).
  11. Press Ctrl-V to actually carry out the replacement.


  • Replace a region in channel 2 with corresponding audio from channel 1.
  1. Place the cursor at the beginning of the region to be replaced in channel 2
  2. Press Ctrl-B to generate a label (name it (say "b"), press Enter).
  3. Mark the region to be replaced in channel 2 (Shift-Click to the right of the current #position, the drag curso to the wanted position).
  4. Keep in mind the number of samples shown in the Length field.
  5. In the Track-Menu select "Split Stereo Track"
  6. Close Channel 2.
  7. Press Ctrl-C to copy the remaining channel 1.
  8. Undo (channel 2 reappears).
  9. Mark the region to be replaced in channel 1 or 2 (Shift-Click to the right of the current position, the drag curso to the wanted position)
  10. Close the label track (audio track gets focus with intact selection).
  11. Press Ctrl-V to actually carry out the replacement.


GoTop.jpg Back to Top

Zooming

Although there is ample help on zooming in the Audacity manual, I include this survey. Because zooming is so vital to remastering, a reminder close at hand cannot be wrong.

  • Vertical:
    • Scaling:
      • Move cursor over the vertical axis, a magnifier symbol is shown
      • Click on the axis, to zoom in
      • Shift-click or right-click to zoom out
      • The position of clicking determines the symmetry or non-symmetry of the axis-scaling
    • Size of the display area (not the scaling):
      • Use View > Fit Vertically
      • Draw the bottom line of the track panel, for stereo racks: bottom line of channel 2 resizes both channels, bottom line of channel 1 changes the relative size.
      • Also see Edit > Preferences > Settings > Interface.
  • Horizontal:
    • Use the buttons from the magnifier panel
      • "Zoom in"
      • "Zoom out"
      • "Fit Selection"
      • "Fit Project"
    • Use the corresponding options in the "View" menu (here is an additional option Zoom Normal).
    • Use the "Zoom Tool" from the "Tools Panel".


GoTop.jpg back to top