Difference between revisions of "Improving and Remastering Audio: Advanced Steps and Tips"

From Audacity Wiki
Jump to: navigation, search
(Make "Main Article" in Contents Table a link)
(added sections Batch-Processing, CD or Playlist, Mono to Stereo, Re.Vinalize, removed section Voice to the Fore, thus basically finishing "Advanced Steps")
Line 39: Line 39:
 
*[[#Mono To Stereo|Mono To Stereo]]
 
*[[#Mono To Stereo|Mono To Stereo]]
 
*[[#Re-Vinylize|Re-Vinylize]]
 
*[[#Re-Vinylize|Re-Vinylize]]
*[[#Voice To The Fore|Voice To The Fore]]
 
 
[[#Tips|Tips]]
 
[[#Tips|Tips]]
 
     </td>
 
     </td>
Line 48: Line 47:
  
 
===Batch Processing For Files (Apply Chain)===
 
===Batch Processing For Files (Apply Chain)===
<br>
+
In a situatiion, where '''identical tasks''' have to been carried out on '''several files''', batch processing comes handy. In a '''script''' you define what tasks to do and how, then you decide on wich files the process shall work.
 +
 
 +
The sripts containing the tasks to be done und their parameters are called '''"chains"''', running a '''batch process''' is called '''"applying a chain"'''.
 +
 
 +
Some chains are pre-installed, others may be defined (and saved) by you.
 +
 
 +
Audacity distinguishes between two modes:
 +
*acting on all files of a project or
 +
*acting on a set of files.
 +
'''These notes concern the mode acting on a set of files.'''
 +
 
 +
*How to add own chains
 +
**Select {{menu|File > Edit Chains...}}.<br>The new window shows the existing chains on the left, the commands and parameters of the selected chain on the right.
 +
**To define a new chain, click "Add" below the left list, enter a name, click "OK" (New chains are saved automatically under the entered name and are listed the next time). A new "torso" chain appears on the right with a first entry "-END-".
 +
**Insert commands by clicking "Insert" below the commands list. The "Select Command" window appears.
 +
**Select a command by '''doubleclicking''' it, its name has to show at the top!
 +
**If there are parameters and you want to change them, click "Edit Parameters", edit them. Some commands use current parameters, e.g. "ExportMp3" uses the currently set bitrate.
 +
**Click "OK".
 +
**Repeat the last 4 steps (from "insert" on) until done.
 +
***[[image:Attention.png|30px]] The last command before "-END-" has to be an "Export". Else the chain processing is carried out without any results. The import is done without the need of a command.
 +
***[[image:Attention.png|30px]] "Amplify" may cause clipping.
 +
***[[image:Attention.png|30px]] "TruncateSilence" also effects silence '''within''' your files.
 +
**Arrange the commands using the buttons below.
 +
**Click "OK" bottom right.
 +
 
 +
*How to a apply a chain
 +
**With no file loaded into Audacity select {{menu|File > Apply Chain...}}
 +
**In the new window select one of the chains and click on "Apply to Files...".
 +
**In the file selection window select the files.
 +
**Batch processing starts, displaying various progress informations.
 +
**After all files are processed, there is a now subdirectory to the one you selected the files from, named "cleaned", containing the processed files.<br>
 +
[[image:Attention.png|30px]] This new directory may not be visible at once in the directory treeview.
 +
<br><br>
 
[[image:GoTop.jpg]] [[Improving and Remastering Audio: Advanced Steps and Tips#&nbsp;|Back to Top]]
 
[[image:GoTop.jpg]] [[Improving and Remastering Audio: Advanced Steps and Tips#&nbsp;|Back to Top]]
  
 
===CD Or Playlist, Preparations===
 
===CD Or Playlist, Preparations===
<br>
+
'''Get the size of the playlist'''<br>
[[image:GoTop.jpg]] <span class="plainlinks">[http://audacityteam.org/wiki/index.php?title=Improving_and_Remastering_Audio:_Advanced_Steps_and_Tips Back to Top]</span>  
+
You will probably use some software dedicated to handling sets of audiofiles, that will provide you with all relevant information.<br>If not you may control total playtime by using any available music player capable of displaying the total time.<br>
 +
The file size may be used for a rough estimate. About 0,93 MB for 1 min at a bitrate of 128 kB/s is needed, this size being approximately proportional to the bitrate. Rightclick on the folder containing your files and select properties to see the total size.<br><br>
 +
 
 +
'''Adjust the single files to fit to the playlist'''<br>
 +
Adjust volume, sound etc., then check the transitions from one file to the next by doing one of the following:
 +
*Use a player at hand.
 +
*Import some files, preferably from the start, the middle and the end of the list and do [[#Comparative Listening|comparative listening]].
 +
*If the files are intended for sequential playback in a fixed order, align them in one big Audacity file and listen to the transitions there.
 +
*Import the files into different tracks in Audacity, then use the time shift tool [[Image:Timeshifttool.png]] to move them along the time axis, thus creating a sequence to be listened to (see the following).<br><br>
 +
 
 +
'''Build a playlist in Audacity'''<br>
 +
In this way (see last item above) it is easy creating crossfades, altering the order of the files, and control the total playtime.<br><br>
 +
[[image:Playlist.jpg|how to buil a playlist n Audacity]]<br><br>
 +
[[image:Benchmark.jpg|benchmark results window]|left]] However the number of files Audacity (and your computer) can handle at once is limited. To find out, select {{menu|Help > Run Benchmark...}}. After some time the results are displayed, and at the bottom you find the number of files playable simultaneously.<br>
 +
The result is for uncompressed audio files. The number might be greater for compressed audio. Furthermore the above configuration '''plays''' only '''one''' time at a time (two in crossfade regions). But there may be other limitations. I have not tested it.<br clear="all" />
 +
If the screen becomes too crowded, collapse selected tracks by clicking on the upward triangle at the bottom of the track panel.
 +
<br><br>
 +
[[image:GoTop.jpg]] <span class="plainlinks">[http://audacityteam.org/wiki/index.php?title=Improving_and_Remastering_Audio:_Advanced_Steps_and_Tips Back to Top]</span>
  
 
===Mono To Stereo===
 
===Mono To Stereo===
<br>
+
A very simple way to create a stereolike impression is to duplicate a mono file and timeshift one against the other.<br>Of course this is not "stereo", but the impression might be one of augmented spatiality.<br><br>
 +
If your file is a 2-channel-mono file,
 +
*check, if the channels really <b>are</b> identical (see the section about [[Improving and Remastering Audio#Two-Channel Mono Files|Two-Channel Mono Files]]).
 +
*in the Track-Menu select {{menu|Split Stereo Track}},
 +
*close one channel by clicking on the "X" left of the wave display.<br><br>
 +
With only one channel present
 +
*Menu {{menu|Tracks > Add New... > Audio Track}},
 +
*copy the entire remaining channel into the new track,
 +
*time shift one channel for a fraction of a second, listen, repeat the sfift until satisfied,
 +
*in the Track-Menu select {{menu|Make Stereo Track}}<br>
 +
Alternatively look for a plugin that uses more sophisticated techniques.
 +
<br><br>
 
[[image:GoTop.jpg]] [[Improving and Remastering Audio: Advanced Steps and Tips#bt|Back to Top]]
 
[[image:GoTop.jpg]] [[Improving and Remastering Audio: Advanced Steps and Tips#bt|Back to Top]]
  
 
===Re-Vinylize===
 
===Re-Vinylize===
<br>
+
The following instruction is a modification of the {{external|[http://audacity.sourceforge.net/de/docs/effekte/reverb/index.htm Tutorial in German about using Audacity effects with real-time control.]}}
[[image:GoTop.jpg]] [[Improving and Remastering Audio: Advanced Steps and Tips#bt|Back to Top]]
+
*Obtain an audio file with a lot of hiss, crackle etc.
 
+
*From this extract the noise:
===Voice To The Fore===
+
**Load this file,
<br>
+
**select {{menu|Tracks > Sdd New... > Stereo Track (or Audio Track for mono)
 +
**copy the loaded file into this new track,
 +
**denoise this file as much as possible,
 +
**invert it: {{menu|Effect > Invert}},
 +
**select all (both tracks have to been selected),
 +
**{{menu|Tracks > Mix and Render}}.<br>The last step is the vital step. By "adding" the original and the inverted file all originally identical waves are summed up to zero (thus deleted), and only the noise remains, that by now is only present in one of the tracks.
 +
*Mix the noise file into any other file:
 +
**Import your re-vinylize-file,
 +
**press "Play",
 +
**adjust the volume of the noise using the gain slider left of the wave display, press "Stop",
 +
**{{menu|Tracks > Mix and Render}}.<br><br>
 +
If you want to additionally equalize the file (attenuate bass and treble), do it before adding the noise, else the noise might lose its impact.<br><br>
 +
There are also free plugins available, look for "vinyl".
 +
<br><br>
 
[[image:GoTop.jpg]] [[Improving and Remastering Audio: Advanced Steps and Tips#bt|Back to Top]]
 
[[image:GoTop.jpg]] [[Improving and Remastering Audio: Advanced Steps and Tips#bt|Back to Top]]
  

Revision as of 15:13, 28 January 2008

 

Example.png

This page is a User "Work in Progress"

Please let the claimant work with it at least two weeks after this sticker was put up (or until this sticker has been removed, if earlier).

Suggestions may be made to the claimant by clicking on the page's "discussion" tab.

This article is intended to provide a first but detailed guideline to those who want to clean up poor quality audio files, for example those who are starting to digitize their record or tape collection and want to do a little more than just transfer them to their hard disk one by one with their existing quality.
The bulk of this article deals with editing one single audio file. In the supplement is a section about preparing a set of files for a CD or a playlist.
 
Related article(s):


Main Article

Advanced Steps and Tips

  1. Preliminary Notes
  2. Editing - General
  3. Editing - The Individual Steps
    1. Two-Channel Mono Files
    2. Unwanted Parts Removal (Trim)
    3. DC Offset Removal
    4. Noise Reduction
    5. Pan Correction
    6. Frequency Spectrum Editing (Equalization)
    7. Volume Editing (Amplify / Envelope)
    8. Dynamics Editing
    9. Clicks, Pops, Dropouts Removal
    10. Reconstructing Missing Parts

Advanced Steps

Tips


Advanced Steps

Batch Processing For Files (Apply Chain)

In a situatiion, where identical tasks have to been carried out on several files, batch processing comes handy. In a script you define what tasks to do and how, then you decide on wich files the process shall work.

The sripts containing the tasks to be done und their parameters are called "chains", running a batch process is called "applying a chain".

Some chains are pre-installed, others may be defined (and saved) by you.

Audacity distinguishes between two modes:

  • acting on all files of a project or
  • acting on a set of files.

These notes concern the mode acting on a set of files.

  • How to add own chains
    • Select File > Edit Chains....
      The new window shows the existing chains on the left, the commands and parameters of the selected chain on the right.
    • To define a new chain, click "Add" below the left list, enter a name, click "OK" (New chains are saved automatically under the entered name and are listed the next time). A new "torso" chain appears on the right with a first entry "-END-".
    • Insert commands by clicking "Insert" below the commands list. The "Select Command" window appears.
    • Select a command by doubleclicking it, its name has to show at the top!
    • If there are parameters and you want to change them, click "Edit Parameters", edit them. Some commands use current parameters, e.g. "ExportMp3" uses the currently set bitrate.
    • Click "OK".
    • Repeat the last 4 steps (from "insert" on) until done.
      • Attention.png The last command before "-END-" has to be an "Export". Else the chain processing is carried out without any results. The import is done without the need of a command.
      • Attention.png "Amplify" may cause clipping.
      • Attention.png "TruncateSilence" also effects silence within your files.
    • Arrange the commands using the buttons below.
    • Click "OK" bottom right.
  • How to a apply a chain
    • With no file loaded into Audacity select File > Apply Chain...
    • In the new window select one of the chains and click on "Apply to Files...".
    • In the file selection window select the files.
    • Batch processing starts, displaying various progress informations.
    • After all files are processed, there is a now subdirectory to the one you selected the files from, named "cleaned", containing the processed files.

Attention.png This new directory may not be visible at once in the directory treeview.

GoTop.jpg Back to Top

CD Or Playlist, Preparations

Get the size of the playlist
You will probably use some software dedicated to handling sets of audiofiles, that will provide you with all relevant information.
If not you may control total playtime by using any available music player capable of displaying the total time.
The file size may be used for a rough estimate. About 0,93 MB for 1 min at a bitrate of 128 kB/s is needed, this size being approximately proportional to the bitrate. Rightclick on the folder containing your files and select properties to see the total size.

Adjust the single files to fit to the playlist
Adjust volume, sound etc., then check the transitions from one file to the next by doing one of the following:

  • Use a player at hand.
  • Import some files, preferably from the start, the middle and the end of the list and do comparative listening.
  • If the files are intended for sequential playback in a fixed order, align them in one big Audacity file and listen to the transitions there.
  • Import the files into different tracks in Audacity, then use the time shift tool Timeshifttool.png to move them along the time axis, thus creating a sequence to be listened to (see the following).

Build a playlist in Audacity
In this way (see last item above) it is easy creating crossfades, altering the order of the files, and control the total playtime.

how to buil a playlist n Audacity

benchmark results window]
However the number of files Audacity (and your computer) can handle at once is limited. To find out, select Help > Run Benchmark.... After some time the results are displayed, and at the bottom you find the number of files playable simultaneously.

The result is for uncompressed audio files. The number might be greater for compressed audio. Furthermore the above configuration plays only one time at a time (two in crossfade regions). But there may be other limitations. I have not tested it.
If the screen becomes too crowded, collapse selected tracks by clicking on the upward triangle at the bottom of the track panel.

GoTop.jpg Back to Top

Mono To Stereo

A very simple way to create a stereolike impression is to duplicate a mono file and timeshift one against the other.
Of course this is not "stereo", but the impression might be one of augmented spatiality.

If your file is a 2-channel-mono file,

  • check, if the channels really are identical (see the section about Two-Channel Mono Files).
  • in the Track-Menu select Split Stereo Track,
  • close one channel by clicking on the "X" left of the wave display.

With only one channel present

  • Menu Tracks > Add New... > Audio Track,
  • copy the entire remaining channel into the new track,
  • time shift one channel for a fraction of a second, listen, repeat the sfift until satisfied,
  • in the Track-Menu select Make Stereo Track

Alternatively look for a plugin that uses more sophisticated techniques.

GoTop.jpg Back to Top

Re-Vinylize

The following instruction is a modification of the Tutorial in German about using Audacity effects with real-time control. 

  • Obtain an audio file with a lot of hiss, crackle etc.
  • From this extract the noise:
    • Load this file,
    • select {{menu|Tracks > Sdd New... > Stereo Track (or Audio Track for mono)
    • copy the loaded file into this new track,
    • denoise this file as much as possible,
    • invert it: Effect > Invert,
    • select all (both tracks have to been selected),
    • Tracks > Mix and Render.
      The last step is the vital step. By "adding" the original and the inverted file all originally identical waves are summed up to zero (thus deleted), and only the noise remains, that by now is only present in one of the tracks.
  • Mix the noise file into any other file:
    • Import your re-vinylize-file,
    • press "Play",
    • adjust the volume of the noise using the gain slider left of the wave display, press "Stop",
    • Tracks > Mix and Render.

If you want to additionally equalize the file (attenuate bass and treble), do it before adding the noise, else the noise might lose its impact.

There are also free plugins available, look for "vinyl".

GoTop.jpg Back to Top

Tips

Clean Cuts

avoid different slopes
In order to get inaudible cuts, apply the following techniques:
  • Place the cut into "silence".
  • Place the cut at a zero crossing (where the waveform crosses the timeline).
  • Place the cut in such a way, that the two ends of the waveform
    join smoothly and show the same gradient (slope).
  • Use the Effect Repair to smooth out remaining differences in the gradient.


GoTop.jpg Back to Top

Comparative Listening

  • Open two or more files.
  • For files with the same music assure synchronicity.
  • Press "Play".
  • Repeatedly alternate between both tracks by clicking Solo left of the corresponding track panel.


GoTop.jpg Back to Top

Exporting with "Solo"-Button or "Mute"-Button activated

Attention.png

If you export a stereo file while "Solo" is still activated, channel 2 will be muted in the saved file.
If you cannot simply deactivate "Solo", use the Track-Menu to split the file, rebuild it, then deactivate "Solo".
Now both channels are exported as usual.
If instead "Mute" is activated, nothing is exported.

GoTop.jpg Back to Top

Preview, Use Of

  • Select the part of the file you want to preview,
  • chose the effect you want to apply,
  • make your settings and press Preview,
  • repeat the last step, if necessary,
  • if possible, save your settings,
  • close the effect window,
  • select the part of the file you want the effect apply to (or cancel the previous selection, which will cause Audacity to select all),
  • reopen the effect window,
  • confirm the settings,
  • apply the effect by pressing OK.


GoTop.jpg Back to Top

Replace

If sample precision replacements are required, use the following instructions:

The selection bar at the bottom and a label track are used. Users of Audacity 1.3 may see http://www.audacityteam.org/manual/index.php?title=Audacity_Selection for a more detailed description of these elements.

For our purposes activate the radio button "Length" and set the time unit to "samples" (this can be done at any of the fields by using the drop-down menu of the field).

  • Replace a region with audio from elsewhere.
    • Mark the region to be replaced.
    • Press Ctrl-B to generate a label (name it (say "b"), press Enter).
    • Keep in mind the number of samples shown in the Length field.
    • Go to where your replacement audio is.
    • Select the replacement audio while watching the Length field.
    • Modify your selection until you have marked the exact number of samples.
    • Press Ctrl-C to copy.
    • If your first section has got out of sigth, scroll the display or zoom out to Bring the selection into view.
    • Click into the label "b" (first section gets marked).
    • Close the label track (audio track gets focus with intact selection).
    • Press Ctrl-V to actually carry out the replacement.
  • Replace a region in channel 2 with corresponding audio from channel 1.
    • Place the cursor at the beginning of the region to be replaced in channel 2
    • Press Ctrl-B to generate a label (name it (say "b"), press Enter).
    • Mark the region to be replaced in channel 2 (Shift-Click to the right of the current **position, the drag curso to the wanted position).
    • Keep in mind the number of samples shown in the Length field.
    • In the Track-Menu select "Split Stereo Track"
    • Cclose Channel 2.
    • Press Ctrl-C to copy the remaining channel 1.
    • Undo (channel 2 reappears).
    • Mark the region to be replaced in channel 1 or 2 (Shift-Click to the right of the current position, the drag curso to the wanted position)
    • Close the label track (audio track gets focus with intact selection).
    • Press Ctrl-V to actually carry out the replacement.


GoTop.jpg Back to Top

Selecting Audio

When selecting a region of audio by clicking and dragging, the "border precision" is greater at the end of the selection. So end your selection at that point, where the greater precision is required.

GoTop.jpg Back to Top

Undo

If you are not sure about the current "undo" status, refer to the Menu Edit > Undo / Redo (the relative actions are displayed here) or the Menu View > History.

Attention.png

There are actions that are not always undone by one "Undo", but require two Undos.
One is the Effect Repair. Check the wave display.

GoTop.jpg Back to Top

Zooming

Although there is ample help on zooming in the Audacity manual, I include this survey. Because zooming is so vital to remastering, a reminder close at hand cannot be wrong.

  • Vertical:
    • Scaling:
      • Move cursor over the vertical axis, a magnifier symbol is shown
      • Click on the axis, to zoom in
      • Shift-click or right-click to zoom out
      • The position of clicking determines the symmetry or non-symmetry of the axis-scaling
    • Size of the display area (not the scaling):
      • Use View > Fit Vertically
      • Draw the bottom line of the track panel, for stereo racks: bottom line of channel 2 resizes both channels, bottom line of channel 1 changes the relative size.
      • Also see Edit > Preferences > Settings > Interface.
  • Horizontal:
    • Use the buttons from the magnifier panel
      • "Zoom in"
      • "Zoom out"
      • "Fit Selection"
      • "Fit Project"
    • Use the corresponding options in the View Menu (here is an additional option Zoom Normal).
    • Use the "Zoom Tool" from the "Tools Panel".


GoTop.jpg Back to Top