Mac OS X

From Audacity Wiki
Revision as of 18:26, 13 December 2010 by BillWharrie (talk | contribs) (Input sources not selectable in Audacity: PPC vs Intel differences, more advice, add images)
Jump to: navigation, search
Audacity is fully supported under Mac OS X. However, there are a number of quirks, and because of subtle differences between Mac OS X and other platforms, you may discover bugs or issues that are specific to Mac OS X. This page is solely for recording such OS X-specific problems, in other words those that are specific to the Apple Mac OS X operating system and thus do not occur with Audacity on Microsoft Windows or Unix/Linux systems.
If you are looking to request a new feature for Audacity, please go to our Feature Requests page.


On OS X 10.6 it is strongly recommended to use Audacity Beta, not Audacity 1.2.5.


This page is intended as a reference point only. It is not constantly monitored by the Audacity team and is thus not meant as a direct method for obtaining technical support.

Before adding a report here, please:

  • Check the existing reports below thoroughly, plus our extensive online help resources as listed on our Reporting Bugs page, to see if your issue is already known.
  • Only add an issue on this page if you're sure it is something specific to Macs only, you're sure of your facts, and that there is not some other explanation for the problem. In all other cases, please follow the instructions on Reporting Bugs to get help and/or give us a useful bug report that we can follow up.


Active issues

Many differences between the OS X and other platforms relate to the audio platform API - in the case of Mac OS X, this API is called Core Audio .

Audacity should not be run inside the .dmg image

Applies to: All Audacity versions

You should not run Audacity from within the .dmg image it's distributed in. This may cause permissions problems and won't allow you to add files to Audacity's Plug-Ins folder.

Always install Audacity thus:

  1. Inside your Applications folder, create a folder called "Audacity".
  2. Double-click the downloaded .dmg to mount it
  3. Option-drag the whole of the .dmg contents (not the .dmg itself) into the "Audacity" folder you created
  4. Double-click Audacity.app inside the Applications folder to launch it

No Unicode or long file name support

Applies to: Audacity 1.2.x versions only
There are bugs in the Mac version of wxWidgets, called wxMac, that can affect Audacity. One bug involves Unicode support: because of this bug, Audacity stable 1.2.x versions cannot work with files or folders located inside a directory named with non-ASCII characters (usually international or accented characters). There is an additional artificial restriction of file name length, limiting your file names to 32 characters despite support in OS X for much longer names. Upgrade to the latest 1.3.x version for Unicode and long file name support.

Loss of sound after running Audacity

Applies mainly to Audacity 1.2.4 and earlier
An Apple issue whereby certain other applications lose sound after running Audacity has now been largely resolved in the current Audacity 1.2.5 (Intel), 1.2.6 (Power PC) and 1.3.x Beta releases.

If you have lost sound on your system after running Audacity, make sure you have the latest Audacity stable or Beta version , and drag the entire contents of any older version to to the trash.

Audacity 1.2.5/6:

Launch Audacity and follow these steps:

1. Click Audacity > Preferences and on the Quality tab, set:
  • Default Sample Rate to 44 100 Hz
  • Default Sample Format to 16 bit
2. On the Audio I/O tab of Preferences:
  • Set "Recording Channels" to mono or stereo
  • Check the box "Do not modify audio device settings (such as sample rate)".
3. Set the Project Rate button bottom left of the Audacity screen to the 44 100 Hz.
4. Close Audacity then click on the Mac Hard Disk and then on Applications > Utilities > Audio MIDI Setup.
5. Click on the Audio Devices tab and on the left-hand (input) side, select your built-in audio device in the "Default Input" and "Properties For" dropdowns. On the right-hand (output) side, select your built-in audio device in the "Default Output" and "System Output" boxes.
6. On both the input and output sides, change the "Format" dropdown boxes to have the same settings as Audacity (that is, 44 100 Hz/2ch-16 bit, or 44 100 Hz/1ch-16 bit). The "1ch" or "2ch" refers to mono or stereo respectively.
Note: If you are on OS X 10.1 or earlier, go to Apple Menu > System Preferences > Sound and perform the same changes as above.

Audacity 1.3.3 and later:

Generally speaking, the later PortAudio v19 I/O library used in Audacity 1.3.3 and later should not change system sound settings. Therefore Beta Audacity does not have a "Do not modify audio device settings..." box, and it is not necessary to launch it to restore system sound. Simply follow the instructions above for 1.2.5/6 to reset system sound in Audio MIDI Setup.

However, if you have previously run a 1.2.x version of Audacity on the machine, it is recommended to completely reset the 1.3.x Preferences before launching Audacity again. Do this by opening audacity.cfg in a text editor and removing all the content except the line "NewPrefsInitialized=1". See here for full instructions.

Note: There is one other known reason why sound cuts out on G5 machines after running Audacity. It is due to a faulty headphone (external output) jack, whereby a component internal to the jack becomes bent from use so that the computer still thinks the headphones are plugged in. Because the user may be plugging headphones into the back of the computer when using Audacity, the timing of the occurrence would make one think it was the software, but it is not. When this is the problem, the user will notice a red glow coming out of the headphone jack. Try plugging your headphones back in and then gently manipulate the headphones plug up/down and left/right so as to bend back the internal component to its correct position. When done, the red light will go off and sound will be restored.

Playthrough

Although Apple Audio MIDI Setup has a "Thru" checkbox for playing audio that is being recorded, this is usually greyed out. Recording playthrough has in fact been disabled since the early days of OS X, and it is left to applications to provide this. In Audacity, try either "hardware playthrough" or "software playthrough" on the Audio I/O tab of Preferences (this is on the "Recording" tab in current Audacity Beta). Hardware playthrough doesn't always work, but has no delay and does not load the CPU. You can also obtain software playthrough using a free application called LineIn. Software playthrough will have delay and some CPU load.

No built-in streaming audio recording

Applies to: All Audacity versions
Macs have no ability to record streaming as it plays on the built-in sound device as can be done on Windows and Linux (if the sound device has that capability). It is possible to record streaming audio from the built-in microphone, but this a very lossy method that also picks up all ambient noise. Alternatives:

  • Join the line-out to line-in, then recording from the built-in input set to line-in
  • Capture the stream digitally with applications other than Audacity, before it reaches the sound card (using Soundflower to do this gives Audacity a direct way to record the captured stream)
  • Download the stream, if its web address is known

For more details, see the Mac section of Recording audio playing on the computer.

Support and setup for external audio devices

Applies to: All Audacity versions
Many (mostly higher-end) external Firewire Input/Output devices and some USB Input/Output devices won't work in 1.2.5/6. Try Audacity 1.3.x Beta instead which uses our later PortAudio v19 interface.

Whatever version of Audacity you have, it's advisable to set up external sound devices (such as USB and Firewire interfaces and USB microphones or headsets) in Apple Audio MIDI Setup, as well as doing so in Audacity.

  1. If you connected your external device while Audacity was open, click Audacity > Quit Audacity and restart it, so that Audacity can see the device
  2. In Audacity, select the device at Audacity > Preferences: Devices in the "Recording Device" box (and in the "Playback Device" box if appropriate) (these preferences are under "Audio I/O" in earlier Betas)
  3. On the same tab, choose the number of "Recording Channels" required
  4. Open the Finder > Applications > Utilities > Audio MIDI Setup:Apple Audio-MIDI Setup on OS X 10.5
  5. Click the Audio Devices tab and make sure on the left-hand (input) side that your device is selected in the "Default Input" and "Properties For" boxes - in the image above our device is called "USB Audio Codec"
  6. Match the input sample rate and channel mode in Audio MIDI Setup in all places - with your Audacity settings, and with any settings on the device or in its control software: for example, if the Audacity Project Rate at bottom left is 44100 Hz and you're recording in stereo, set the Audio MIDI input "Format" boxes to "44100.0 Hz" and "2 ch-16 bit"
  7. If you are playing back to the device, go to the right-hand (output) side of Audio MIDI Setup, set the device as Default Output and System Output, and similarly match the settings in the "Format" boxes to your settings in Audacity and in the device

In more advanced interface devices with 24-bit capability, it may also be necessary to explicitly match the Audacity "Default Sample Format" at Audacity > Preferences: Quality tab with both the Audio MIDI format settings and with the bit depth setting in the device.

Unresponsive Play and Record buttons

Applies to: All Audacity 1.2.x versions
The Record and occasionally Play buttons can fail to respond. Click them repeatedly or upgrade to Audacity 1.3.x.

Untranslated strings in non-English language

Applies to: Audacity 1.2.5 (Intel); 1.2.6 (PPC)
If selecting language other than English, any string that does not have a translation will appear blank instead of in English.

Shortcuts activate in file dialogues

Applies to: Audacity 1.2.5 (Intel); 1.2.6 (PPC)
When typing in save or export dialogues, the corresponding shortcuts can be activated in the main window (for example, typing "r" starts recording). Problem is probably caused (or exposed) by updating to OS X 10.5.3 Leopard or later. As a workaround, click Audacity > Preferences: Keyboard and change single key shortcuts to ones preceded by a modifier key, such as Command. Another possibility is to paste in the required text. Alternatively, update to the latest Beta version where this and many other 1.2 bugs are now fixed.

Audio Units GraphicEQ

Applies to: Audacity 1.3.1 and later
AUGraphicEQ has an inherent limitation that it cannot be resized in use, so that if more bands are selected than fit on the screen, not all the selected bands will be accessible. As a workaround, close the plug-in with the required number of bands selected, then re-open it. All the selected bands will now be accessible.

Audio Units Matrix Reverb

Applies to: Audacity 1.3.1 and later
AUMatrixReverb will only output in stereo and needs a stereo track to work on, so cannot be used on a mono track. It seems to be the only one of the built-in Audio Units plugins that has this limitation. To work round it, select the track by clicking in its Track Control Panel above the Mute/Solo buttons, then Edit > Duplicate. Click on the dropdown arrow in the Track Control Panel of the upper track > Make Stereo Track. After processing with AUMatrixReverb, click the arrow again > Split Stereo Track, click the arrow once more in the upper track and make it Mono, then delete the lower track by clicking on the [X] in the Track Control Panel.

Portable Settings

Applies to: Audacity 1.3.1 to 1.3.7
On OS X systems, portable settings aren't respected in version of Audacity prior to 1.3.8, instead the default user settings in the default "Application Support" hard drive location are always used. If you want to use Audacity with portable settings under OS X 10.3 (which requires Audacity 1.3.3 or earlier), please see our Portable Audacity page for a couple of workrounds.

Greyed out Audacity menu

Applies to: Audacity 1.3.2 and later
On some systems, items in the Audacity menu may be greyed out if a project is recovered and then a process is started and cancelled before completion. Workround: Click File > New and work from the new project window.

"Invisible "Window"

Applies to: Audacity 1.2.x and 1.3.0/1.3.1
On the Mac, closing a window does not usually quit the program. Closing the Audacity window will probably still leave the program running in the Dock. To quit Audacity, click Audacity > Quit Audacity, or use the keyboard shortcut Command-Q. In the Audacity versions mentioned above, if the program is still running in the Dock, it will appear there as an "invisible window".

DTMF Generator creates silence

Applies to: Audacity 1.3.3
Generate > DTMF Tones creates silence irrespective of Tone/silence ratio slider, due to a bug. Will be fixed in next 1.3.x release for Mac.


Cleared issues

These issues no longer exist in current versions of Audacity. You can upgrade to the latest Stable or Beta version here .

Input sources not selectable in Audacity

Applied to: Versions prior to 1.3.2
In versions prior to 1.3.2, Audacity's Mixer Toolbar input selector would normally show only "Default Input Source".
Starting with version 1.3.2, the Mixer Toolbar input selector will show:

  • on PPC machines, the built-in inputs available (such as Microphone, Line In and Digital In) when you select "Core Audio: Built-in Audio" (either in Device Toolbar, or via "Host" and "Recording Device" in Audacity Devices Preferences)
BuiltInAudioInput.png
  • on Intel machines, the built-in input selected when you select "Core Audio: Built-in Microphone" or "Core Audio: Built-in Input" (or similar, either in Device Toolbar, or via "Host" and "Recording Device" in Audacity Devices Preferences). Note the difference. On Intel machines the Mixer Toolbar input selector will have only one choice according to the selection made in the Device Toolbar or Devices Preferences. Users of Intel machines may want to enable the Devices Toolbar through View > Toolbars > Devices Toolbar.
IMacLineInput.jpg

For versions prior to 1.3.2, please select your input source in Apple Audio-MIDI Setup according to these instructions. Users of OS X 10.3.x can use Audacity 1.3.3 (but not 1.3.4 or later), so this issue should not apply to them as long as they use 1.3.3. Those using OS X 10.2.x should use Audacity 1.3.2.

SHIFT + P does not open Pan dialogue

Applied to: Audacity 1.3.0
Shift + P doesn't open the Pan dialogue because of a conflict with the Pause hotkey.

Failure to launch on managed accounts or Network Home

Applied to: Audacity 1.3.3 only
Audacity cannot be launched on managed accounts or on non-admin accounts in the Network Home directory. The error "You cannot open the application "Audacity.app" because it is not supported on this system" will occur. This was due to the permissions of the Audacity executable being wrongly set in this version.

Audacity 1.3.3 is likely to remain the latest available version for OS X 10.3. You can try:
  • Change the permissions of the Audacity executable within the Audacity.app bundle. Open Terminal.app from an Administrator account and type:
    "chmod 755 <path to Audacity.app folder>/Contents/MacOS/Audacity" for example:
    "/Applications/Audacity1.3.3Beta/Audacity.app/Contents/MacOS/Audacity".
  • Download the appropriate 1.3.2 version for Intel or PPC.


Crash when recording in 24 bit quality

Applied to: Audacity 1.2.4

Griffin iMic mono 8 bit recording problem

Applied to: Audacity 1.2.3 and earlier
Griffin iMic re-sets recording to mono 8bit only.

1.2.6 PPC only launches in English

Applied to: Audacity 1.2.6 (PPC) only
The first release of 1.2.6 only launched in English. If you have this version, download 1.2.6a instead.

Audacity won't launch on case-sensitive file systems

Applied to: Audacity 1.2.4 and earlier

Previous Intel Mac naming issue with libmp3lame.dylib

Applied to: all Audacity versions
An earlier version of http://spaghetticode.org/lame/libmp3lame-osx-universal-3.97.zip  mistakenly named the included MP3 encoding binary as libmp3lame.so instead of the libmp3lame.dylib which Audacity asks for. If you have this earlier version, please download the latest version from the link above.


User Reports

Echo/looping hardware fault

There is an audio looping/echo is a known fault on the newest (2005) PowerBooks (17 &15 inch) There are threads on Apple's support/discussions pages. Also occurs on PPC iBooks. It seems to be a core audio problem. Possibly a data stream corruption through to the sound processors. PowerBook users are awaiting a fix. Some people think it may be a logic board fault.Killing core audio in Activity viewer seems to be a temporary cure.


Vanishing Envelopes

Problem with 1.3.3:

Files created in Audacity 1.3.2 or 1.3.3 vanish (or are squashed to occupy a single point at the beginning of the track) when file is opened with Audacity 1.3.3.

In earlier versions, you could make them reappear by performing any kind of action and then undoing it - the envelopes would magically reappear. With the release of 1.33, this no longer works - after saving, closing, and reopening the file, the envelopes are gone for good. Others have reported the same problem .

I have read that this was a known bug which was repaired in 1.3.3, but that is clearly not the case.

Mac OSX 10.4.10 on a PowerBook G4, July 15, 2007

  • [BP] This bug was recreated with 10.5.1 and 1.3.3 with PPC iBook.
  • [BP] 10.5.2 or 10.4.11 with 1.3.3 or Head on Intel do not appear to contain this bug.