Difference between revisions of "Mixer Toolbar Issues"

From Audacity Wiki
Jump to: navigation, search
("listen to this device" is not a method to enable "stereo mix" - it's "software playthrough" so should not be enabled for stereo mix)
Line 169: Line 169:
 
Thirdly, on many distributions you must add your user to the "audio" group to give them permissions to access sound devices.  
 
Thirdly, on many distributions you must add your user to the "audio" group to give them permissions to access sound devices.  
 
{{Hint|Providing Audacity can successfully recognise the recording device in Preferences, you can always select input sources in [http://en.wikipedia.org/wiki/Alsamixer ALSAmixer], even if the correct source selection cannot be made in Mixer Toolbar, or if the input selector is not available.}}   
 
{{Hint|Providing Audacity can successfully recognise the recording device in Preferences, you can always select input sources in [http://en.wikipedia.org/wiki/Alsamixer ALSAmixer], even if the correct source selection cannot be made in Mixer Toolbar, or if the input selector is not available.}}   
 
+
* [http://www.designerevaluation.com/logo-design/ logo design]
 +
* [http://www.designerevaluation.com/ website design]
  
  
 
{{CategoryTroubleshooting}}
 
{{CategoryTroubleshooting}}

Revision as of 14:43, 17 March 2011

Introduction

One of the common problems encountered with the Mixer Toolbar is that its input selector can appear greyed out or lacking the expected choices, thus apparently preventing the user choosing the required recording source. The purpose of the selector is to link to the current mixing device (assuming this device offers a choice of input sources) and thus save the user going through a series of system menus to choose the source.

Recording Device

It is often assumed that Audacity controls the sources displayed in the input selector, but in fact the sources offered are governed by the drivers of the sound device that is currently selected in the Audacity Preferences. Drivers are a big issue on Windows machines, and it often happens that machines purchased new will only be supplied with generic Microsoft drivers. These may prevent the input selector from displaying all the possible inputs the device has (or any at all), or from linking properly to the system mixer (so that for example you end up always recording from line-in, or cannot apparently record at all, whatever source you choose on the input selector).

So the first step towards rectifying input selector problems is to go to the Audio I/O tab of Audacity Preferences (Devices tab in Audacity Beta 1.3.9 or later) and check that the playback and recording devices are explicitly set to the correct sound device you want to use. For example you may have multiple sound devices such as built-in sound and an external USB device, so you need to choose between them. If you are on Windows and experiencing problems, choose your sound device explicitly, not Microsoft Sound Mapper (which is intended to map to the currently selected default Windows sound device, but may not always do so correctly).

Note that some sound devices have individual analogue to digital converters (ADCs) for the different inputs such as microphone and line-in. Where this is the case, these inputs are treated as separate recording devices (e.g. Line-In: Realtek, Microphone: Realtek) and should be selected in the Audio I/O tab, not in the Mixer Toolbar selector, which will be greyed out. In a similar way, Windows Vista and Windows 7 always treats recording sources as "devices", so on this operating system the selector will always be greyed out and input sources must be chosen in the Audio I/O tab. See below for more explanation.

USB and Firewire recording devices

Note that if your selected recording device is a USB or Firewire device, these normally do not have multiple input sources to choose from, so Audacity's input selector will grey out. This is normal, and just means the selector is not needed. Any necessary configuration should be done on the device itself, or in any control software that comes with it. Examples of devices which will normally not require use of Audacity's input selector are the Griffin iMic, USB turntables and a wide variety of USB and Firewire mixers and interfaces.

Device already in use

Also check your sound device is not already in use. If you are on OS X or Linux and the sound device is already being used by another application, Audacity may not be able to access it for recording and the Mixer Toolbar input selector will appear greyed or minimised. Generally, this is not a problem on Windows, though issues with some applications are known. For example speech recognition in Word and the Fraps screen capture software are known to prevent other applications from using the sound device to record from a microphone.

Further help

If you've got this far and the problem is not solved, go to the appropriate section below your operating system:

OS X
Windows
Linux


and then if you still have problems, go to our page on Updating Sound Device Drivers.


OS X-specific issues

OS X has a very different audio hardware interface to most other operating systems. As a result, there may be no (or greyed out) Mixer Toolbar, or only one audio recording source available to Audacity, which will be identified as "Default Source". You will need to click on the Mac hard disk, then on Applications > Utilities > Audio-MIDI Setup and select your required recording source (e.g. Line In) in the Audio Input section so that it becomes the source that Audacity will use. This is how Audio-MIDI Setup looks in OS X 10.4:

AudioMidi.png


In OS X 10.0 and 10.1 there was no Audio-Midi Setup, so choose your recording source at System Preferences > Sound in the Apple Menu.

If you are on OS X 10.4 or higher and want to try our latest Beta version, this has a later version of our PortAudio interface and may enable you to select sources in Audacity's input selector (or possibly in the "Recording Device" dropdown in the Devices tab of Preferences).

We strongly suggest you read our further information about Mac OS X.


Windows Problems

Card Not Supported

Some high-end multi-channel cards on Windows systems don't use the standard Windows mixer interface and volume control, but instead supply a custom mixer application which Audacity can't hook in to. In these cases you need to select the recording settings and levels using the custom mixer application shipped with the sound card. Recording should work as normal with the card however.

Windows Vista / Windows 7

The most recent Windows operating systems called Vista and Windows 7 treat individual recording sources such as line-in, microphone and "stereo mix" as recording devices in their own right. As a result, the Mixer Toolbar input selector will be always be greyed out by default. Some users report that input sources can be made to appear in the input selector by running Audacity in compatibility mode for Windows XP. To do this, right-click over audacity.exe in Windows Explorer, then click Properties, then the "Compatibility" tab. This isn't a generally recommended solution.

Instead, select recording inputs at Edit > Preferences: Audio I/O tab, in the "Recording Device" dropdown (this dropdown is in the "Devices" tab in Audacity Beta). Also in the Beta version, recording devices can be viewed instead in Device Toolbar. To enable this toolbar, click View > Toolbars > Device Toolbar. Here is an example of recording inputs in Preferences for two different physical devices (an inbuilt sound device and an external USB sound card):

Microphone: Realtek HD Device

Line-In: Realtek HD Device

Microphone: USB Audio

Line-In: USB Audio

Stereo Mix: USB Audio


If selecting a particular input does not work, or you don't see the input you want, try selecting it in the Windows Control Panel (see the next section below).

We strongly suggest you read our further information about Windows Vista and Windows 7.

Using the Control Panel

Accessing the system mixer in the Windows Control Panel and trying to select your required source there may often allow you to record into Audacity, even if the source you want isn't in the Mixer Toolbar or Audio I/O "Recording Device" dropdowns, or isn't apparently recording properly.


HELP WITH RECORDING COMPUTER PLAYBACK OR STREAMING AUDIO

There is often confusion over what source to use for recording sounds the computer is playing, and worse, this source is often hidden by default in the system mixer. The required source can go by various names such as: "Stereo Mix", "Wave Out", "Sum", "What U Hear" or "Loopback". The exact name (and even if you have such a source option) depends on the drivers of your sound device. Try to enable and select a suitable option in the system mixer as described below. Try updating the sound device drivers if there is still no suitable source.

Sometimes "Stereo Mix" can only be made to work by using the control panel supplied by the sound card manufacturer - this is often reported with RealTek inbuilt sound devices. Try launching the sound device control panel from the Windows Control Panel or the system tray (by the clock). If you see a volume control for Stereo Mix, try clicking to select it. Confusingly, some RealTek devices "select" an input by muting all but one, so in this case, mute everything except stereo mix. If you don't see Stereo Mix, click the wrench icon and enable Stereo Mix in the dialogue that pops up. In some RealTek versions the option to check is "Enabled recording multi-streaming". You should now see a volume control for Stereo Mix. Remember to select or unmute it as above. See this Forum topic for more help with RealTek.

Be aware that on some machines, the "Stereo Mix" option will never work because it is disabled internally by the driver settings due to copyright concerns. This is a known issue with Lenovo Thinkpad laptops, but sometimes editing the driver files can enable stereo mix.

If all else fails, you can connect a cable from the line-out (green) port of the computer to the line-in (blue), and choose the line-in as recording source. If you need to hear what you're recording, you can buy a single stereo to double stereo adaptor that will give you a spare jack to plug the speakers into. Alternatively, try Freecorder 3.0 which is a virtual sound driver distinct from your sound device. It installs as a browser plug-in. Note that later versions of Freecorder from the manufacturer's site do not record to WAV, forcing you to record to the lossy MP3 format. Or buy an external USB sound card, which normally offer a "stereo mix" type of option, such as the Trust Sound Expert External.


On Windows Vista / Windows 7, the quickest way to access the mixer is to right-click over the speaker icon in the System Tray > Recording Devices. Or click Start > Control Panel > Hardware and Sound > Sound (if you're using "Classic View" there's a direct link to "Sound" in the Control Panel), then click on the "Recording" tab.

Vistarec.png


It is common on Vista and 7 that not all recording inputs are automatically enabled in the Recording tab. This means they are invisible in that tab, and also invisible to recording applications like Audacity. So you need to make them visible, then enable and make default the one you want to use, thus:

  1. Right-click anywhere inside the Recording tab and choose "Show disabled devices" then right-click again and check "Show Disconnected Devices"
  2. For a device having a physical input like line-in or microphone, connect the required cable and make sure it fits tightly - a physical device not connected may show as "currently unavailable"
  3. Right-click specifically over the input device you want to record with (for example, line-in or "Stereo Mix"), and if visible, choose "Enable"
  4. Right-click once again over the input device you want to record with, and choose "Set as Default Device"
  5. Right-click once again over the input device you want to record with, click Properties then the Levels tab and ensure the volume slider is turned up
  6. Optionally, right-click again over the desired device and choose "Set as Default Communication Device" - this is desirable if you are using a microphone for Skype or other VoIP program; also it is sometimes another required step to make the "stereo mix" device work
  7. To prevent possible sample rate or recording channel discrepancies, right-click again and click Properties then the Advanced tab, and make sure the "Default format" matches both with the project rate bottom left of the Audacity screen, and with the number of "recording channels" in the Audio I/O tab of Audacity Preferences (Devices tab in current Audacity Beta); now click "OK"
  8. Click the Playback tab of Sound, right-click over the "Speakers" or "Headphones" device for your computer sound device and set it as "Default Device" or "Default Communication Device" as required; then right-click and click Properties then the Advanced tab, and set "Default Format" to match with the settings in Step 7 above


On XP or earlier, right-click over the speaker icon in the System Tray > Adjust Audio Properties. Or you can click Start > (Settings) > Control Panel > Sounds, Speech and Audio Devices > Sounds and Audio devices. Please note that this Control Panel applet is called "Sounds and Multimedia" in Windows 2000 and ME, and "Multimedia" in Windows 98, so looks slightly different to the image below.

First, click on the Audio tab, and in the "Sound Recording" panel, select the correct "Default device" from the dropdown list and click "Volume":

Xpau.PNG


and select your input by putting a mark in the check box, and turn up the volume slider:

Xpcp.PNG


Note that input sources are sometimes available to use, but hidden. If you cannot see the input you're looking for, click "Volume" under the "Sound Recording" panel again, then Options > Properties. Select your sound device in the Mixer Device panel, and ensure all the boxes in the window below are checked:

Xppr.PNG


Click OK. If the input you wanted was in the window list, it will now be available to select in the recording Volume Control, and you may find Audacity's Mixer Toolbar has now been re-enabled.


If the input you want cannot be made available or made to work , or if you want the convenience on XP or earlier of selecting your input in Audacity's Mixer Toolbar , see the Updating Sound Device Drivers page.


Linux-specific issues

If the input selector is visible, but your issue is that the wrong input (or silence) is recorded, try changing the recording device in Audacity Preferences and choosing the input in ALSAmixer.

Entire Mixer Toolbar missing

If Audacity's entire Mixer Toolbar (i.e. the input and input level sliders and the input selector) is missing, this usually means that the version of Audacity you have installed has been built without PortMixer support. This could be because your Audacity version was built wrong, or because it's using an (experimental) v19 version of PortAudio which hasn't got PortMixer support. If you click on Help > About in Audacity, you should find the version of PortAudio that has been used and a list of which libraries were enabled at build time.

To enable Audacity's Mixer Toolbar, you can either install from a package which has PortAudio v18 or compile Audacity from the stable source code using PortAudio v18. For instructions on using the source code to compile Audacity, see CompilingAudacityForBeginners.

If you want to compile Audacity with PortAudio v19 (which gives native ALSA support) and also want to have a Mixer Toolbar, you must use the unstable 1.3.x series of Audacity. There may not be a 1.3.x package yet for your particular distribution, but you can compile Audacity from the unstable source code. If you want native ALSA support in Audacity 1.2.6, you could compile it with PortAudio v19, but this is no longer supported, and means you will have to choose your input source and the input/output levels in ALSAmixer.

Input Selector minimised, sliders present

If the selector just appears as a small lump but you have the input and output volume sliders, this usually means that there is currently no audio device available to, or recognised by Audacity for recording on your system. There are various possible causes for this. They include:

  1. Another audio program like XMMS is using the sound device
  2. A sound daemon/server like esound (ESD), aRts or PulseAudio is using the sound device
  3. You have system sounds turned on in a desktop environment like Gnome or KDE
  4. You don't have the correct permissions to access the sound device
  5. You are using Audacity 1.2.6 and are selecting the ALSA device but don't have the necessary OSS emulation modules installed.
  6. The recording device you currently have selected in the Audacity Preferences only has one input source, and so there is no choice that can be made. Many USB and Firewire Input/Output devices fall into this category.

So, there are three main points. Firstly, any other applications using the sound device must be disabled, unless you use:

  • the aRts daemon with the OSS device, in which case you can use the wrapper provided by aRts and run:
      $ artsdsp audacity

      Note: some users report recording issues when doing this.
    • A recent Ubuntu-supplied Audacity package including an alsa: pulse device. Otherwise, Audacity must be run with padsp to run PulseAudio with OSS, or pasuspender to suspend PulseAudio. Here is more information about Audacity and PulseAudio.

    Secondly, if you use OSS, you must check that /dev/dsp (the OSS device) is present. If you use ALSA, you must install the OSS emulation for ALSA, unless you are using Audacity 1.3.x which supports ALSA natively.

    • To load the installed OSS emulation modules for ALSA, you can launch Audacity from the command line as:
        $ aoss audacity

      Thirdly, on many distributions you must add your user to the "audio" group to give them permissions to access sound devices.

      Providing Audacity can successfully recognise the recording device in Preferences, you can always select input sources in ALSAmixer, even if the correct source selection cannot be made in Mixer Toolbar, or if the input selector is not available.