Difference between revisions of "NavigationTips"

From Audacity Wiki
Jump to: navigation, search
(giving current 2.x primacy over legacy 1.2.x)
(Use kbrd template where appropriate)
Line 52: Line 52:
 
Split lines disappear when you click on them to merge clips together, but you can use current Audacity's '''Cut Lines''' feature to place a vertical line at which audio was cut out. Click on the line at any time to restore the cut audio. Cut Lines are enabled on the {{Menu|Tracks tab of Preferences}}.         
 
Split lines disappear when you click on them to merge clips together, but you can use current Audacity's '''Cut Lines''' feature to place a vertical line at which audio was cut out. Click on the line at any time to restore the cut audio. Cut Lines are enabled on the {{Menu|Tracks tab of Preferences}}.         
  
If you prefer not to use split lines, you can also mark regions during playback with the {{shortcut| [ }}  ''(Select Left at Playback Position)'' and {{shortcut| ] }}  ''(Select Right at Playback Position)'' shortcuts. To use these, start playing then use {{shortcut| [ }}  to move the cursor to the current playback position. When you hear the end of the audio you want to mark as a region, use {{shortcut| ] }}  to draw a region from the cursor to the current playback position. You could then stop and place a label at the region with {{shortcut|CTRL + B}}. If you want to label while still playing, use {{button|ENTER}} then {{button|Up}} after typing the label to close the label and return focus to the track. You can now use {{shortcut| [ }}  and {{shortcut| ] }}  as above to mark another region between desired points.  
+
If you prefer not to use split lines, you can also mark regions during playback with the {{shortcut| [ }}  ''(Select Left at Playback Position)'' and {{shortcut| ] }}  ''(Select Right at Playback Position)'' shortcuts. To use these, start playing then use {{shortcut| [ }}  to move the cursor to the current playback position. When you hear the end of the audio you want to mark as a region, use {{shortcut| ] }}  to draw a region from the cursor to the current playback position. You could then stop and place a label at the region with {{shortcut|CTRL + B}}. If you want to label while still playing, use {{kbrd|Enter}} then {{kbrd|Up Arrow}} after typing the label to close the label and return focus to the track. You can now use {{shortcut| [ }}  and {{shortcut| ] }}  as above to mark another region between desired points.  
  
If you miss something you wanted to mark, you can't currently use seek to jump the playback position behind the cursor, but as always you can click in the track with the CTRL key depressed to restart playback anywhere, or simply click in the Timeline. If you click in the Timeline to left of the cursor, the {{shortcut| [ }} shortcut will draw a region from the playback cursor forwards to the cursor, which may not always be what you want. When the playback cursor is to left of the cursor, you can move the cursor to a desired point during playback and draw a region from there to the current playback position using {{shortcut| ] }}  for both actions.   
+
If you miss something you wanted to mark, you can't currently use seek to jump the playback position behind the cursor, but as always you can click in the track with the {{shortcut|CTRL}} key depressed to restart playback anywhere, or simply click in the Timeline. If you click in the Timeline to left of the cursor, the {{shortcut| [ }} shortcut will draw a region from the playback cursor forwards to the cursor, which may not always be what you want. When the playback cursor is to left of the cursor, you can move the cursor to a desired point during playback and draw a region from there to the current playback position using {{shortcut| ] }}  for both actions.   
  
 
<div id="multitrack"></div>
 
<div id="multitrack"></div>
 
===Navigating multiple tracks===
 
===Navigating multiple tracks===
 
+
Current Audacity can manipulate tracks and selected areas entirely with the keyboard. Use the {{kbrd|Up Arrow}} or {{kbrd|Down Arrow}} key on the keyboard to give focus to a track, as shown by the coloured border around the track. Then press {{kbrd|Enter}} to select or deselect the track.nter
Current Audacity can manipulate tracks and selected areas entirely with the keyboard. Use the {{Button|Up}} or {{Button|Down}} key on the keyboard to give focus to a track, as shown by the coloured border around the track. Then hit {{Button|ENTER}} to select or deselect the track.
 
  
 
There is an additional "roll-up" button (the upward pointing arrow) at the base of each Track Control Panel:<BR>
 
There is an additional "roll-up" button (the upward pointing arrow) at the base of each Track Control Panel:<BR>
Line 72: Line 71:
  
  
 
 
 
 
 
=='''Legacy Audacity 1.2.x'''==
 
=='''Legacy Audacity 1.2.x'''==
  
Line 113: Line 109:
 
You can also add a label at the current playback position while the track is playing, or at the current recording position while recording. To do this, click {{Menu|Project > Add Label at Playback Position}} ({{shortcut|CTRL + M}}). It can also be useful to drag out and a label a region while the track is playing or recording. To label that region, use {{menu|Project > Add Label at Selection}} as you would if the track was stopped.
 
You can also add a label at the current playback position while the track is playing, or at the current recording position while recording. To do this, click {{Menu|Project > Add Label at Playback Position}} ({{shortcut|CTRL + M}}). It can also be useful to drag out and a label a region while the track is playing or recording. To label that region, use {{menu|Project > Add Label at Selection}} as you would if the track was stopped.
  
Once you have clicked in a label to open it, you can use {{button|TAB}} to navigate to the next label and {{button|SHIFT + TAB}} to navigate back to the previous label.  
+
Once you have clicked in a label to open it, you can use {{kbrd|Tab}} to navigate to the next label and hold {{shortcut|SHIFT}} while pressing {{kbrd|Tab}} to navigate back to the previous label.  
  
 
Read more about labels in Audacity 1.2 [http://audacity.sourceforge.net/onlinehelp-1.2/track_label.htm here]. Labels in current Audacity operate in much the same way but are easier to move and resize, and easier to manipulate with the keyboard while playing or recording. See [http://manual.audacityteam.org/help/manual/man/label_tracks.html labels] documentation for current Audacity.     
 
Read more about labels in Audacity 1.2 [http://audacity.sourceforge.net/onlinehelp-1.2/track_label.htm here]. Labels in current Audacity operate in much the same way but are easier to move and resize, and easier to manipulate with the keyboard while playing or recording. See [http://manual.audacityteam.org/help/manual/man/label_tracks.html labels] documentation for current Audacity.     

Revision as of 18:12, 28 April 2012

This page explains how to how to navigate the waveform or tracks (including moving the playback position), and how to find and mark edit points.
For tips on how to view and adjust playback volume, and to achieve smooth playback quality, see Playback Tips.


Current Audacity improved navigation features

Easier ways to find the audio you want to edit

  • Seek function during playback: Seek by pre-determined amounts of time during playback by using the arrow keys of your keyboard. The default commands are:
    • Seek left (short period) during playback - LEFT arrow
    • Seek right (short period) during playback - RIGHT arrow
    • Seek left (long period) during playback - SHIFT + LEFT arrow
    • Seek right (long period) during playback - SHIFT + RIGHT arrow .
    The length of the seek period can be set on the Playback tab of Preferences. The shortcuts used for the seek commands can be changed on the Keyboard tab of Preferences.
  • "Play/Stop and Set Cursor" shortcut (SHIFT + A): This acts like Space except that when stopping playback, the cursor is set to the place where it stopped, so resumes from there. If you wanted that to be normal behaviour, you could go to the Keyboard tab of Preferences and change the shortcuts for "Play", "Stop" and "Play/Stop" to something other than Space, then change "Play/Stop and Set Cursor" from SHIFT + A to Space.
  • Poor man's scrubbing: You can change the playback position quickly by clicking in the track with the CTRL key depressed (or the CMD key on a Mac), instead of click and double Space.
  • Quick-Play: Another way to change the playback position is to click on the Timeline above the waveform. Playback will start from that point at once. Or click on the Timeline and drag a region (shown by arrowheads with a line connecting them). Release the mouse to play the region once. Neither an already selected region or the cursor is affected by Quick-Play.
  • Selection Toolbar:
Selbar.png

You can move the cursor, or define a selection area, by entering time position values in a "Selection Toolbar" at the bottom of the screen. Values may be typed in, or incremented with the up and down arrow keys of the keyboard.

  • "Cut Preview" shortcut (C):

Press C to hear the audio just before and after a selection region so as to preview how it would sound if you cut that region out. You can change the length of the audio preview before and after the cut on the Playback tab of Audacity Preferences.

  • Transcription Toolbar:

This is a special playback button with attached speed slider

Transtool.jpg

which allows you to play back at faster or slower speeds (affecting both tempo and pitch). If this is not visible, enable it at Toolbars > Show Transcription Toolbar.

Marking cut regions or points

The split command (shortcut CTRL + I) splits the audio into different clips at the cursor or selection region, marking the split points with a black vertical line in the waveform. You can use these lines to quickly find or cut regions. A quick workflow to find and cut regions using split lines works like this:

  1. Zoom in as far as you like and play
  2. When you hear the starting point of the audio you want to delete, SHIFT + A to stop playback at that point, then CTRL + I
  3. Press Play to resume from where you stopped, and when you reach the end of the intended cut, SHIFT + A then CTRL + I again
  4. Double-click to left of the split line you just placed to select the region between the two split lines
  5. Adjust the edges of the region as needed using the mouse (or use SHIFT + left or right arrow to expand the region and CTRL + SHIFT + left or right arrow to contract it)
  6. Edit > Cut

Split lines disappear when you click on them to merge clips together, but you can use current Audacity's Cut Lines feature to place a vertical line at which audio was cut out. Click on the line at any time to restore the cut audio. Cut Lines are enabled on the Tracks tab of Preferences.

If you prefer not to use split lines, you can also mark regions during playback with the  [  (Select Left at Playback Position) and  ]  (Select Right at Playback Position) shortcuts. To use these, start playing then use  [  to move the cursor to the current playback position. When you hear the end of the audio you want to mark as a region, use  ]  to draw a region from the cursor to the current playback position. You could then stop and place a label at the region with CTRL + B. If you want to label while still playing, use Enter then Up Arrow after typing the label to close the label and return focus to the track. You can now use  [  and  ]  as above to mark another region between desired points.

If you miss something you wanted to mark, you can't currently use seek to jump the playback position behind the cursor, but as always you can click in the track with the CTRL key depressed to restart playback anywhere, or simply click in the Timeline. If you click in the Timeline to left of the cursor, the  [ shortcut will draw a region from the playback cursor forwards to the cursor, which may not always be what you want. When the playback cursor is to left of the cursor, you can move the cursor to a desired point during playback and draw a region from there to the current playback position using  ]  for both actions.

Navigating multiple tracks

Current Audacity can manipulate tracks and selected areas entirely with the keyboard. Use the Up Arrow or Down Arrow key on the keyboard to give focus to a track, as shown by the coloured border around the track. Then press Enter to select or deselect the track.nter

There is an additional "roll-up" button (the upward pointing arrow) at the base of each Track Control Panel:

Audio track rolled down

If you click this, the track will be rolled up so that only the name of the track is visible in the Track Control Panel, so allowing many tracks to be fitted on screen without scrolling:

Audio track rolled up

To roll-down the track again, click the downward pointing arrow.

Also there is a new option on the Interface tab of Preferences "Tracks fit vertically zoomed. Checking this will automatically fit all tracks to the vertical screen height as they are added or removed.


Legacy Audacity 1.2.x

Changing playback position

Audacity does not currently have a drag bar like most media players with which you can drag the audio position as it is playing. There is a however a |<< button to left of the green play button which skips to the start of the track, and a >>| button to right of the stop button which skips to the end of it. You can also skip to to the start of the track with the HOME key on your keyboard and to the end of it with the END key.

Audacity always plays from where the cursor position is, or where a selected area is, when you hit Space or use the green Play button. Hit the yellow Stop button or Space again to stop playback. Hitting Play or Space a further time resumes playback from the original cursor position or the start of the original selection.

You can move the cursor position backwards or forwards anywhere on the visible screen by:

  • moving the cursor with the left or right arrow keys on your keyboard
  • (quicker) by clicking in the track at the desired point with your mouse

To start playback from the new point, press Space once. If you are already playing the track at another position, press Space twice and playback will resume from your newly chosen cursor position.

To create a selected area in the track, click in the track and drag to left or right with your mouse, or with the left or right arrow keys. When you press Space once, the whole of the selected area will start to play. You can similarly create a selected area in the track whilst already playing the track, in which case you press Space twice to move from the current playback position to playing the selected area. Another way to create a selected area in the track is to click in the track where you want to start your selection and hold SHIFT while clicking in the track at the point where you want to end your selection. Again, this also works while playing a track, so the selection area is drawn from the point where playback started to the point where you shift-clicked.

You can adjust the edges of the selection area with your mouse (hover over an edge then drag when the mouse cursor changes to a hand). Alternatively, adjust the selection edges with the left and right arrow keys. Holding down SHIFT while using left or right arrow will expand the left or right selection edge respectively. Holding down CTRL and SHIFT while using left or right arrow will contract the right or left selection edge respectively.

Note also the shortcut B (play to selection). This is a quick way of identifying a required part of a current selection area by playing it, without having to adjust the selection area first. If you place your mouse at a place in the selection area that is to left of the midpoint in the selection, pressing B will play from the start of the selection to the mouse cursor then stop. If you place your mouse at a place in the selection area that is to right of the midpoint, pressing B will play from the mouse cursor to the end of the selection then stop. If you like the selection area you heard, you can then use CTRL and SHIFT (designated by convention as CTRL + SHIFT) with the appropriate arrow key to contract the selection to the area you played with the B shortcut.

Zooming

To move to different positions in the track, it is easier if you are fully zoomed out with the View > Fit in Window command (CTRL + F), or the "Fit Project in Window" button on the extreme right of the Edit Toolbar.

If the track is zoomed in, you can drag the horizontal scroll bar near the bottom of the screen to find a new position to play from, but you cannot do this while the track is playing, unless you go to the Interface tab of Preferences and uncheck "Autoscroll while playing". If that feature is unchecked, once the green playback cursor moves past the right edge of the window, you'll always need to drag the horizontal scrollbar in order to see the current playback position, or fit the whole Project in the window so you can see the whole track again without scrolling.

Marking edit regions or points

Selected areas can be saved and recalled. One selected area at a time can be saved with the Edit > Selection Save command and recalled at any time with Edit > Selection Restore.

Multiple selected regions and cursor points can also be marked with "labels", using the Project > Add Label at Selection command (CTRL + B). Labels can be helpful as reference points for editing. The region or point can be recalled at any time by clicking in the label. The labels appear in a new Label Track underneath the audio track.

You can also add a label at the current playback position while the track is playing, or at the current recording position while recording. To do this, click Project > Add Label at Playback Position (CTRL + M). It can also be useful to drag out and a label a region while the track is playing or recording. To label that region, use Project > Add Label at Selection as you would if the track was stopped.

Once you have clicked in a label to open it, you can use Tab to navigate to the next label and hold SHIFT while pressing Tab to navigate back to the previous label.

Read more about labels in Audacity 1.2 here. Labels in current Audacity operate in much the same way but are easier to move and resize, and easier to manipulate with the keyboard while playing or recording. See labels documentation for current Audacity.

Navigating multiple tracks

If you have multiple tracks on screen you can fit them on screen without the need to scroll up and down by dragging the bottom edge of each track upwards at any point along the waveform. Or you can use the View > Fit Vertically command to fit all the tracks in the screen.

You can move tracks up and down by clicking on the Track Control Panel with the mouse and dragging up or down. Alternatively, click the downward pointing arrow at the top of the Track Popdown Menu and choose "Move Track Up" or "Move Track Down".