Difference between revisions of "NavigationTips"

From Audacity Wiki
Jump to: navigation, search
(oucnaelterno)
m (Reverted edits by DroncNasit (Talk); changed back to last version by James)
Line 1: Line 1:
riclet
 
 
    
 
    
 
='''Audacity 1.2.x'''=
 
='''Audacity 1.2.x'''=

Revision as of 13:13, 3 January 2008

Audacity 1.2.x

Changing playback position

Audacity does not currently have a drag bar like most media players with which you can drag the audio position as it is playing. There is a however a |<< button to left of the green play button which skips to the start of the track, and a >>| button to right of the stop button which skips to the end of it. You can also skip to to the start of the track with the HOME key on your keyboard and to the end of it with the END key.

Audacity always plays from where the cursor position is, or where a selected area is, when you hit spacebar or use the green Play button. Hit the yellow Stop button or spacebar again to stop playback. Hitting Play or spacebar a further time resumes playback from the original cursor position or the start of the original selection.

You can move the cursor position backwards or forwards anywhere on the visible screen by:

  • moving the cursor with the left or right arrow keys on your keyboard
  • (quicker) by clicking in the track at the desired point with your mouse

To start playback from the new point, click spacebar once. If you are already playing the track at another position, click spacebar twice and playback will resume from your newly chosen cursor position.

To create a selected area in the track, click in the track and drag to left or right with your mouse, or with the left or right arrow keys. When you press spacebar once, the whole of the selected area will start to play. You can similarly create a selected area in the track whilst already playing the track, in which case you press spacebar twice to move from the current playback position to playing the selected area. Another way to create a selected area in the track is to click in the track where you want to start your selection and hold SHIFT while clicking in the track at the point where you want to end your selection. Again, this also works while playing a track, so the selection area is drawn from the point where playback started to the point where you shift-clicked.

You can adjust the edges of the selection area with your mouse (hover over an edge then drag when the mouse cursor changes to a hand). Or you can adjust the selection edges with the left and right arrow keys. Holding down SHIFT while using left or right arrow will expand the left or right selection edge respectively. Holding down CTRL and SHIFT while using left or right arrow will contract the right or left selection edge respectively.

Note also the hotkey B (play to selection). This is a quick way of identifying a required part of a current selection area by playing it, without having to adjust the selection area first. If you place your mouse at a place in the selection area that is to left of the midpoint in the selection, pressing B will play from the start of the selection to the mouse cursor then stop. If you place your mouse at a place in the selection area that is to right of the midpoint, pressing B will play from the mouse cursor to the end of the selection then stop. If you like the selection area you heard, you can then use CTRL and SHIFT (designated by convention as CTRL + SHIFT) with the appropriate arrow key to contract the selection to the area you played with the B hotkey.

Selected areas can be saved and recalled. One selected area at a time can be saved with the Edit > Selection Save command and recalled at any time with Edit > Selection Restore.

Muliple selected areas and cursor points can also be marked with "labels", using the Project > Add Label at Selection command (CTRL + B), and recalled at any time by clicking in the label. The labels appear in a new Label Track underneath the audio track and can be helpful as reference points for editing. You can also add a label at the current playback position while the track is playing, by clicking Project > Add Label at Playback Position (CTRL + M). If you want to add a label at a selection area while the track is playing, use Project > Add Label at Selection. You can read more about labels here.


Zooming

If you want to move to different positions in the track, it is easier if you are fully zoomed out with the View > Fit in Window command (CTRL + F), or the "Fit Project in Window" button on the extreme right of the Edit toolbar.

If the track is zoomed in, you can drag the horizontal scroll bar near the bottom of the screen to find a new position to play from, but you cannot do this while the track is playing, unless you go to the Interface tab of Preferences and uncheck "Autoscroll while playing". If that feature is unchecked, once the green playback cursor moves past the right edge of the window, you'll always need to drag the horizontal scrollbar in order to see the current playback position, or fit the whole Project in the window so you can see the whole track again without scrolling.


Navigating multiple tracks

If you have multiple tracks on screen you can fit them on screen without the need to scroll up and down by dragging the bottom edge of each track upwards at any point along the waveform. Or you can use the View > Fit Vertically command to fit all the tracks in the screen.

You can move tracks up and down by clicking on the Track Panel with the mouse and dragging up or down. Or you can click the downward pointing arrow at the top of the Track Popdown Menu and choose "Move Track Up" or "Move Track Down".


Beta improved navigation features

You can fully manipulate tracks and selected areas with the keyboard in Audacity 1.3.2 and later. Full details on this are here.

Additionally, the Beta version of Audacity has a number of new features for easier changing of the playback position:

- Seek function during playback - you can seek by pre-determined amounts of time during playback by using the arrow keys of your keyboard. The default commands are:

Seek left (short period) during playback - Left arrow

Seek right (short period) during playback - Right arrow

Seek left (long period) during playback - Shift Left arrow

Seek right (long period) during playback - Shift Right arrow

The length of the seek period can be set on the Audio I/O tab of Preferences and the hotkeys used for the seek commands can be changed on the Keyboard tab of Preferences.


- Poor man's scrubbing - If you want to change the playback position by clicking in the track, you can now click in the track with the CTRL key depressed (or the CMD key on a Mac) to restart playback immediately from that point, instead of click and double spacebar.


- Selection Bar

Selbar.png

You can move the cursor, or define a selection area, by entering time position values in a "Selection Bar" at the bottom of the screen. Values may be typed in, or incremented with the up and down arrow keys of the keyboard.


- Transcription Toolbar

This is a special playback button with attached speed slider

Transtool.jpg

which allows you to play back at faster or slower speeds (affecting both tempo and pitch). If this is not visible, enable it at View > Toolbars > Show Transcription Toolbar.


For navigating multiple tracks, there is an additional "roll-up" button (the upward pointing arrow) at the base of each Track Panel:
Audio track rolled down

If you click this, the track will be rolled up so that only the name of the track is visible in the Track Panel, so allowing many tracks to be fitted on screen without scrolling:
Audio track rolled up

To roll-down the track again, click the downward pointing arrow.

Also there is a new option on the Interface tab of Preferences: "Tracks fit vertically zoomed". Checking this will automatically fit all tracks to the vertical screen height as they are added or removed.