New features in this release

From Audacity Wiki
Revision as of 13:52, 8 April 2020 by PeterSampson (talk | contribs)
Jump to: navigation, search
Editors BEWARE - this page has a DISPLAYTITLE
size=50%
This page is an overview of prominent new functionality that has been introduced in Audacity 2.4.0

Contents

  1. Hitting the big Time
  2. Export and Import of settings in effects
  3. Multi-view
  4. Opus export
  5. Spectrograms now show Clip Boundaries
  6. Selecting Waveform dB
  7. Scrubbing using the keyboard
  8. Muting and Unmuting selected tracks
  9. Changes to Play head pinning
  10. New effects and a new analyzer
  11. Searching the Manual
  12. Bug Fixes


Time Toolbar|Hitting the big Time

For this release the audio time position has been removed from the Selection Toolbar and created a new toolbar, the Time Toolbar. It is a read-only toolbar which displays the current audio position. The larger size of numbers makes it easy to read when, for example, you are recording an instrument you are playing and are further from the computer screen and keyboard than when directly editing the audio.

When Playing or Recording Time Toolbar dynamically shows the current playhead or recordhead position.

When Audacity is not Playing or Recording it will display either the current cursor position or the beginning of the current selection if present.

Time Toolbar in playback.png
Time Toolbar showing the current playback position of 44 seconds

Features of Time Toolbar:

  • Time Toolbar provides a larger display, easily readable at a glance, for the current audio position. It is a double-height toolbar with a default display of roughly 1.5x previous size.
  • You can resize to full double height , shrink it smaller or just remove the toolbar if you don't need it. It can be redocked in various positions in either tooldock and can be floated if you wish
  • The time display format can be changed independently of the Selection Toolbar's time format.
  • As this Toolbar is read-only you cannot use it to reset the audio position, to do that you need to use the Selection Toolbar.


Export and Import of settings in effects

Previously in Audacity you could only use the Export and Import buttons for VST and AU effects. This has now been extended to all effects that have a Manage button.

Import...

Imports presets which you have exported using the Export option (below) on this or other machines or which you have exported from other software that supports a compatible preset.

Export...

Exports an effect's current settings as presets (in a text file) for use in Audacity on other users or machines via Import or for use in other software that supports import of a compatible preset.

Bulb icon Note carefully that this Export creates a single exported text file with just the current settings in the effect. It does NOT export your entire set of User Presets.
The equalization effects: Filter Curve EQ and Graphic EQ:

In common with all other effects these now facilitate the import of pre-existing equalization curves for use in the effect.

  • Many published curves, such as those on the Audacity Wiki, and curves you may have exported in earlier versions of Audacity with the old Equalization effect, are in .XML format.
  • Graphic EQ, like all other Audacity effects, expects the imports to be text files in .TXT format. To facilitate this we have provided a tool EQ XML to TXT Converter, this is not enabled by default but you can enable it with the Plug-in Manager after which it will be present in the Tools Menu.


Multi-view

This is an advanced feature for expert users enabling Spectrogram and Waveform displays of the same audio shown simultaneously in the same track.

Spectrograms and Waveforms have different strengths and weaknesses:

  • Waveforms show you overall loudness best. You might see the danger of imminent clipping. Precision in cutting and splicing is also best performed in Waveform view.
  • Spectrograms show you frequencies. In vocals, for example, you can see how vowel sounds change over time. The onset of new sounds, when another sound is playing, often shows up more clearly in Spectrograms.

Choose whichever one gives you the best information for the task in hand.

Multi-view stereo default 50-50.png
Example of a stereo audio track with a Multi-view split 50:50 Waveform/Spectrogram

To get a split Multi-view for a track select Multi-view from the track's Track Control Panel dropdown menu.


Opus Export

Opus has been added as an export option to the File > Export > Export Audio  and  File > Export > Export Multiple commands.

It is accessed from those commands then choosing Opus (OggOpus) Files (FFmpeg) from the Save as type dropdown menu in the Export dialog:

OPUS for What's new.png


This Opus Export replaces the previous "opus" export from the (external program) option in the Export dialogs, which never worked for "opus", always giving a failure error message.
Warning icon Opus Export is only available on Windows and Linux for now - we aim to provide it on Mac in a future release - see Bug #2381.


Spectrograms now show Clip Boundaries

Spectrogram views have changed, they now show Clip Boundaries, the dark vertical lines in the image below.

Spectrogram with Split lines for 2.4.0 no TCP.png

Formerly these clip boundaries were only shown on Waveform views.

This change also affects the new Multi-view display.


Selecting Waveform dB

This used to be accomplished with the TCP dropdown menu, it is now in the Waveform Vertical Scale' context menu.

A right-click in the Vertical Scale will bring up a dropdown context menu enabling swapping between Linear Waveform (default) and Waveform dB views.

Vertical Scale Waveform context menu.png


Scrubbing using the keyboard

Two new shortcut commands have been added to facilitate scrubbing from the keyboard.

These are:

  • I: Scrub Forwards
  • U: Scrub Backwards

they are part of the Standard default set of keyboard shortcuts.

After pressing one of these scrubbing keys playback continues until the key is released. Playback starts from the cursor position or the start of a time selection if there is one. Scrubbing is not limited by any selection that may be present.

If one of the keyboard scrubbing keys is being held down, and the other keyboard scrubbing key is pressed scrubbing immediately changes direction, and does not stop when the original key is released.

The speed of playback is determined by the zoom level. If the zoom level is normal playback speed is one half of the normal playback speed. Zooming in (Ctrl + 1) halves the playback speed, zooming out (Ctrl + 3) doubles the playback speed. There are minimum and maximum playback speeds of one sixteenth and 3x, respectively.

Bulb icon If you want to use keyboard scrubbing at normal speed, just press Ctrl + 2 to return to normal zoom level followed by Ctrl + 3 to zoom out one level.



Tracks Menu: Mute/Unmute|Muting and Umuting selected tracks

Two new commands have been added to the Tracks menu to enable you to simultaneously Mute or Unmute all the currently selected tracks.

  • Tracks > Mute/Unmute > Mute Tracks
  • Tracks > Mute/Unmute > Unmute Tracks

These operate on all selected audio tracks in the project, as if you had used the Mute buttons from the Track Control Panel on each selected track.


Changes to Play/Record head pinning

The mechanism for toggling the Play and Record head from its default unpinned position to a pinned position on the Timeline has been changed. This was done to try to prevent users accidentally turning on pinned head and then not knowing how to revert to the default unpinned. When the head is pinned the head remains static and the waveforms will move as the audio is played or recorded.

Formerly a single click on the head icon at the left of the icon would toggle between the two modes. Now when you click on that icon a context menu is displayed:

Head button context menu.png

From this menu you can choose to select or un-select Pinned Play Head.

The same context menu is available when you right-click in the Timeline - alternatively unpinned or pinned head can also be selected in Transport > Transport Options.

Bulb icon If you miss the availability of single click functionality to achieve toggling the head mode it is easy to set up a single-key custom shortcut.


New effects and a new analyzer

Loudness Normalization

A new effect, "Loudness Normalization", has been added. As its name suggests, it normalizes for loudness.

Use Loudness Normalization to change the level of the audio (normally reduce it to recommended limits).

It is based on EBU R 128 recommendations on limiting the loudness of audio signals.

Loudness Normalization.png
Bulb icon Why use Loudness Normalization rather than Normalize or Amplify?
  • Using Loudness Normalization rather than Normalize or Amplify helps you more easily set the required LUFS loudness target when normalizing.

    When preparing audio for television or radio programs, podcasts and some websites you may be subject to loudness restrictions on the audio. Loudness is usually measure in LUFS (Loudness Units Full Scale). The LUFS level restrictions can vary by application. For example, the level for television in the US is normally -24 LUFS, the EBU (European Broadcasting Union) recommends -23 LUFS. Out of all the standards this one is the most serious in that a television network can get its broadcast license revoked for a violation.

  • Another use case is creating an equally loud playlist from different sources.


Measure RMS

A simple analyzer to measure the RMS (Root Mean Square) levels in a track.

Measure RMS.png

The example above is the measurement of a typical stereo track.

If you use this analyzer on a mono track you will just get a single figure shown.


Noise Gate

Another new effect has been added, "Noise Gate", which can be used to reduce the level of sound below a specified threshold level.

A noise gate is a kind of "dynamics processor" that allows audio above a specified threshold level to pass through unaffected (gate "open"), and stops or reduces sounds below the threshold level (gate "closed").

Noise Gates may be used to cut the level of residual noise between sections of a recording. This Noise Gate has a number of settings that allow it to be effective, unobtrusive and well suited to most types of audio.

Noise Gate.png


Spectral Delete

A new effect has been added to the spectral editing effects.

The Spectral Delete effect acts on a spectral selection to delete a spectral selection from the audio.

Spectral Delete - selection with toolbar.png
A spectral selection, shown in Multi-view, after applying Spectral Delete, deleting the frequencies from 5 kHz to 7kHz
For this we have used a higher than default "Window Size" of 4096 in the spectrogram settings, because that shows the accuracy of the frequency cut much better.

The Spectral Selection Toolbar has been enabled and floated to aid and show the accurate selection range.


Searching the Manual

For this release we have added a page to the Manual on Searching the Manual.

For various technical reasons we cannot provide a Search box/button for the Manual. So this page provides some useful workarounds.

The page can readily be accessed from any Manual page you are on from the Reference section of the left-hand navigation bars.

Reference - Search.png

There is also an entry for it in the Quick Help section on the Manual's front page.



Bug Fixes

There will be some ...



==Additional new features== This page New features in 2.4.0 - appendix gives an overview of further new functionality that has been introduced in this release of Audacity.

Links

> Audacity Release Notes 2.4.0 - detailed release notes for this release of Audacity