New features in Audacity 3.0.3

From Audacity Wiki
Revision as of 09:45, 25 May 2021 by PeterSampson (talk | contribs) (P2 Bugs fixed: *P2 [https://bugzilla.audacityteam.org/show_bug.cgi?id=2764 2764] - Open Project... under ScriptablesII can corrupt a project)
Jump to: navigation, search
size=50%
This page is an overview of prominent new functionality that has been introduced in Audacity 3.0.3

Version 3.0.3 is primarily a maintenance release to fix bugs and increase the stability of the Unitary Project database structure.

Contents

  1. Updating from Audacity 2.x
  2. Display of Track Name
  3. Bug Fixes


Updating from Audacity 2.x to Audacity 3.x

With the release of Audacity 3.0.0 the project file structure of Audacity was changed significantly with the entire project contained in a single unified database file.

If you have already updated to 3.0.0 or 3.0.2 you should already be aware of this.

But if you are updating from any earlier 2.x Audacity version please read Updating from Audacity 2.x to Audacity 3.x.

Older Projects:

Audacity 3.x can usually open AUP files created in older 2.x.x versions of Audacity , but saving the project in 3.x will prevent it opening again in Audacity versions prior to 3.0.0.

  • Note that this will leave behind the old AUP file and its associated _data folder which you will probably want to delete to recover disk space.
  • Audacity version 3.x should be able to open projects from Audacity 1.1 onwards - but not from 1.0


Display of Track Name

A new command has been added to the View menu, View > Track Name (on / off).

When this is enabled the audio track name is displayed superimposed translucently at top left of all audio tracks.

Note that the track name is always shown in the Track Control Panel but will be truncated if the name is too long to fit.

View Menu Show Track Name.png

This has the same effect as the setting for Show track name as overlay in Tracks Preferences.


Bug Fixes

In addition to the fixed bugs shown here, several changes have been maid to increase the stability of the Unitary Project database structure.

P1 Bugs fixed

  • P1 2754 - Change Tempo & Pitch and Sliding Stretch with selected audio in negative time crash Audacity on windows (error on Mac)
  • P1 2772 - Audacity crashes after failing to open corrupt project
  • P1 2793 - AUP3 projects fail to compact if project's path contains a single-quote

P2 Bugs fixed

  • P2 2339 - On second run of Audacity "Filter Curve EQ" gets changed to "Filter Curve..." in the Effect menu
  • P2 2700 - "Failed to open the project database"
  • P2 2758 - Linux: No support for Jack Audio System
  • P2 2741 - Msgctxt feature of translation not working
  • P2 2743 - The first use of the "window" command in LOF files is ignored by Audacity
  • P2 2747 - The Macros output directory is in the top section in audacity.cfg
  • P2 2764 - Open Project... under ScriptablesII can corrupt a project

P3 Bugs fixed

  • P3 2671 - ENH: "Show track name as overlay" cannot be turned on from main menus
  • P3 2778 - In German in the Erzeugen menu (Generator menu) "Silence..." is untranslated

P4 Bugs fixed

  • P4 1309 - Paste with sync-lock can give error message but still do something
  • P4 1406 - Undoing envelope points by shortcut with mouse down creates spurious undo entries
  • P4 2466 - Linux: Filter Curve EQ GUI far too wide
  • P4 2759 - Failed Macro command leaves empty undo item in history

P5 Bugs fixed

  • P5 1091 - Spectral Edit effects may have unpredictable results

Links

> Audacity Release Notes 3.0.3 - detailed release notes for this release of Audacity