Difference between revisions of "Nyquist Basics: The Audacity Nyquist Prompt"

From Audacity Wiki
Jump to: navigation, search
(started new page Nyquist Basics: The Audacity Nyquist Prompt)
 
(added 'Preparations' section)
Line 1: Line 1:
{{Introrel|[[Nyquist Plug-ins|Nyquist plug-ins]] are plain text files which can be read with any simple text editor. For example you can load the .lsp files from the Audacity "Nyquist" folder or the .ny files from the Audacity "Plug-Ins" folder into your favourite text editor and try to find out how they work. That's how many people learned Nyquist programming. Many additional Nyquist plug-ins can be found [[Download Nyquist Plug-ins|here]].|This is at the moment only a list of suggestions, and related pages still need to be written. Feel free to mention topics you are interested in by clicking on the [[Talk:Nyquist Audio Programming|discussion tab]] at the top of this page.|3=
+
{{Introrel|With the Audacity Nyquist Prompt you can test small snippets of Nyquist code or doing quick audio hacks. On this page the basic usage of the Nyquist prompt is explained.|3=
 
[[Plug-ins]]
 
[[Plug-ins]]
*[[:Category:Digital Audio Technology|Digital Audio Technology]]  
+
*[[:Category:Digital Audio Technology|Digital Audio Technology]]
 +
[[Nyquist Audio Programming]]
 
*{{external|[http://www.cs.cmu.edu/~music/music.software.html Nyquist homepage]}} at  Carnegie Mellon University}}
 
*{{external|[http://www.cs.cmu.edu/~music/music.software.html Nyquist homepage]}} at  Carnegie Mellon University}}
  
Line 7: Line 8:
 
__TOC__
 
__TOC__
  
==Basic Experiments==
+
==Preparations==
 +
 
 +
The Audacity Nyquist prompt is placed in the Audacity "Effect" menu which only can be activated if an Audacity audio track exists and at least a part of it marked or selected [Audacity 1.3.4].
 +
 
 +
===Load a Sound File===
 +
 
 +
If you have a mono or stereo sound file available you can load it into Audacity via:
 +
 
 +
* Audacity '''File''' menu > '''Import''' > '''Audio'''  or  '''Shift''' + '''Control''' + '''I'''
 +
 
 +
If you have no sound files available you can build your own mono or stereo tracks via the Audacity 'Generate' menu.
 +
 
 +
===Create a Mono Track===
 +
 
 +
Go to the Audacity 'Generate' menu and choose 'Tone'. Leave everything as-is, just click 'OK', a mono track will appear in the Audacity window.
 +
 
 +
===Create a Stereo Track===
 +
 
 +
'''1.''' Mark the whole mono track from above either by pressing 'Ctrl+A' on the keyboard, or by clicking with the mouse into the track header, with taking care not to move the buttons or sliders, the whole track then will appear in a different color.
 +
 
 +
'''2.''' Go to the 'Edit' menu and choose 'Duplicate'. A second, identical mono track will appear below the first one.
 +
 
 +
'''3.''' In the upper mono track, open the track menu by clicking on the small black triangle at the top of the track header and coose 'Make stereo track'. Both mono tracks then will get combined to a single stereo track.

Revision as of 05:46, 11 February 2008

With the Audacity Nyquist Prompt you can test small snippets of Nyquist code or doing quick audio hacks. On this page the basic usage of the Nyquist prompt is explained.
{{{2}}}
 
Related article(s):

Nyquist Audio Programming


Preparations

The Audacity Nyquist prompt is placed in the Audacity "Effect" menu which only can be activated if an Audacity audio track exists and at least a part of it marked or selected [Audacity 1.3.4].

Load a Sound File

If you have a mono or stereo sound file available you can load it into Audacity via:

  • Audacity File menu > Import > Audio or Shift + Control + I

If you have no sound files available you can build your own mono or stereo tracks via the Audacity 'Generate' menu.

Create a Mono Track

Go to the Audacity 'Generate' menu and choose 'Tone'. Leave everything as-is, just click 'OK', a mono track will appear in the Audacity window.

Create a Stereo Track

1. Mark the whole mono track from above either by pressing 'Ctrl+A' on the keyboard, or by clicking with the mouse into the track header, with taking care not to move the buttons or sliders, the whole track then will appear in a different color.

2. Go to the 'Edit' menu and choose 'Duplicate'. A second, identical mono track will appear below the first one.

3. In the upper mono track, open the track menu by clicking on the small black triangle at the top of the track header and coose 'Make stereo track'. Both mono tracks then will get combined to a single stereo track.