Difference between revisions of "Nyquist Basics: The Audacity Nyquist Prompt"

From Audacity Wiki
Jump to: navigation, search
(added explanation about the incompatible Nyquist manuals)
(changed 'create a stereo track' section)
Line 28: Line 28:
 
===Create a Stereo Track===
 
===Create a Stereo Track===
  
'''1.''' Select the whole mono track either by pressing {{Shortcut|CTRL + A}} on the keyboard, or by clicking with the mouse on the Track Panel (take care not to move the buttons or sliders). The audio waveform will then have a shaded colour. 
+
'''1.''' Create an empty stereo track.
  
'''2.''' Click {{Menu|Edit > Duplicate}}. A second, identical mono track will appear below the first one:
+
* In '''Audacity 1.2.x''' click {{Menu|Project > New Stereo Track}}.
 +
* In '''Audacity 1.3.x-beta''' click {{Menu|Track > Add New... > Stereo Track}}.
  
[[Image:Nyquist-prompt-two-mono-tracks.png|Two mono tracks]]
+
In both cases an empty stereo track will apperar in the Audacity window.
  
'''3.''' In the upper mono track, open the track menu by clicking on the small black triangle at the top of the Track Panel choose '''Make stereo track'''. Both mono tracks then will be combined into the left and right channel of a single stereo track:
+
'''2.''' Now click {{Menu|Generate > Tone}}. Leave everything as-is, just click "OK", the empty stereo track will get filled with the generated sound.
  
 
[[Image:Nyquist-prompt-stereo-track.png|Audacity stereo track]]
 
[[Image:Nyquist-prompt-stereo-track.png|Audacity stereo track]]

Revision as of 00:15, 19 February 2008

With the Audacity Nyquist Prompt you can test small snippets of Nyquist code you are working on, or run a Nyquist effect in any way you wish (as opposed to how that effect works as built into Audacity). On this page the basic usage of the Nyquist Prompt is explained.
 
Related article(s):
Please note: The notation in the current Nyquist 3.0 Reference Manual from the Nyquist Homepage at Carnegie Mellon Universtiy is incompatible to Nyquist in Audacity. Please use the Nyquist 2.36 Manual from the link above if you're working with Nyquist in Audacity.


Setting up

The Audacity Nyquist prompt appears in Audacity's "Effect" menu. This menu can be only be activated if an Audacity audio track exists and at least part of it is selected.

Load a Sound File

If you have a mono or stereo sound file available you can import it into Audacity via:

File > Import > Audio or the shortcut CTRL + SHIFT + I

If you have no sound files available you can build your own mono or stereo tracks via the Audacity "Generate" menu.

Create a Mono Track

Click Generate > Tone. Leave everything as-is, just click "OK", a mono track will appear in the Audacity window:

Audacity mono track

Create a Stereo Track

1. Create an empty stereo track.

  • In Audacity 1.2.x click Project > New Stereo Track.
  • In Audacity 1.3.x-beta click Track > Add New... > Stereo Track.

In both cases an empty stereo track will apperar in the Audacity window.

2. Now click Generate > Tone. Leave everything as-is, just click "OK", the empty stereo track will get filled with the generated sound.

Audacity stereo track

The Nyquist Prompt

Click Effect > Nyquist Prompt. If the Effect Menu is greyed out because no part of the audio is selected, press CTRL + A on the keyboard. A window like the following will appear:

Audacity Nyquist prompt window

The Nyquist Interpreter

In the "Nyquist Prompt" window, type into the text field a string "hello" with quotes:

Audacity Nyquist prompt window with quoted hello

If you click "OK", you should get a window displaying the word hello:

Window displaying the word hello

Click "OK" in the "hello" window to make it disappear again.

Congratulations, you just have learned how to send text messages to the user.

The Nyquist Debugger

After clicking "OK" in the "hello" window, go back to the Audacity Effect menu and choose Nyquist prompt again, but this time type the word hello without the quotes:

Audacity Nyquist prompt window with unquoted hello

Important: Now click "Debug" instead of "OK".

You should first get a window displaying a "Nyquist did not return audio" or similar message:

Window displaying Nyquist did not return audio

After clicking "OK" in the window above, a second window appears, displaying the detailed Nyquist error messages:

Window displaying Nyquist error: unbound variable


NOTE: The "Nyquist output" window only appears if you click "Debug" in the "Nyquist Prompt" window. If you click "OK", then, even with a Nyquist error, only the first window will appear.