PlaybackTips

From Audacity Wiki
Revision as of 01:16, 29 June 2007 by Galeandrews (talk | contribs) ('''Volume''': added Meter Toolbar image)
Jump to: navigation, search

Smooth Playback

If you have a very long Project with multiple tracks open, this eats a lot of computer resources and you will likely need far in excess of Audacity's stated minimum requirements (64 MB RAM, 300 MB Processor) for playing back of these tracks together. Think of 500 MB RAM and 1 GHz processor speed upwards, depending on the number of other programs and processes that are running and the number and length of tracks you want to have.

Generally the more RAM you have the better, though Windows 98 and ME have a bug that may cause problems if you have more than 512 MB installed RAM. There are suggested fixes for this problem here.

Consider enabling DMA on your drive if it is not already, and ensure your sound device drivers are up to date. Both these courses of action will also help ensure glitch-free recording. Consider reinstalling the operating system if changing drivers does not help - operating system problems can lead to erratic sound behaviour especially when the CPU is busy.

Also try these tips if you are having problems with uneven playback:

  • close as many other programs as possible
  • zoom out (View > Zoom Out or CTRL + 3)
  • mute the tracks you don't need to hear
  • select areas of tracks rather than the whole, in order to hear what a mix sounds like
  • select all of each track in turn (by clicking in the Track Panel where the mute/solo buttons are) and Project > Quick Mix (Tracks > Mix and Render in 1.3.2). This may help playback by ordering the audio data files more logically.
  • consider mixing some tracks together as soon as you no longer need them to be separate.
  • If you use the Beta 1.3.3 version of Audacity, consider increasing the default "Audio to buffer" setting of 100 milliseconds. This can be changed in the "Latency" panel in the Audio I/O tab of Preferences. This might lead to smoother playback on slower machines. The disadavantage would be that playback would take longer to start, and there would be more delay in laying down and monitoring recordings.


Volume

The output volume slider on the Mixer Toolbar controls only the output volume at which you hear your tracks. It has no control over the level of gain (if any) that is applied to the tracks when exported. This gain is controlled with the -....+ gain slider on the Track Panel. Avoid accidentally moving this slider away from centre. If it goes too far too right, this may lead to excessive volume and therefore distortion in your exported file. If it goes too far to left, you may negate the volume of your exported file.

Also note that if you play multiple tracks at once, their volume is combined. Therefore with multiple tracks you may need to move the gain sliders on each Track Panel leftwards to bring down the combined volume of the tracks. To keep the current balance between all your tracks, move each slider to left by the same amount. To judge if you have distortion, look at the green VU playback meter in the Meter Toolbar:
Meter Toolbar


If the green bars are hitting the right-hand edge of the scale and so bringing on the red hold lights to right of the meter, you have distortion in the output and must reduce the gain.

If the VU meters are not visible, go to the Interface tab of Preferences and check "Enable Meter Toolbar". If you are using the Beta 1.3.3 version of Audacity, click View > Toolbars > Show "Meter Toolbar".