Difference between revisions of "Plug-ins"

From Audacity Wiki
Jump to: navigation, search
(Types of plug-in: typo "legacy" to "legacy" and marked as obsolete)
(Added to Category:Tips)
Line 60: Line 60:
 
* To help us improve support for audio plug-ins, subscribe to [http://lists.sourceforge.net/lists/listinfo/audacity-devel audacity-devel] and introduce yourself.  
 
* To help us improve support for audio plug-ins, subscribe to [http://lists.sourceforge.net/lists/listinfo/audacity-devel audacity-devel] and introduce yourself.  
  
[[Category:Plug-ins]]
+
[[Category:Plug-ins]][[Category:Tips]]

Revision as of 19:18, 3 May 2014

This page is an overview of the four audio plug-in formats supported by Audacity.
Audacity has built-in support for LADSPA and Nyquist plug-ins, and platform-specific support for VST and Audio Unit plug-ins.
 
Related article(s):



Types of plug-in

Audacity can use four types of plug-in effects:

In obsolete legacy Audacity 1.2 to 1.3.7 you must add the VST Enabler to your computer to use VST plug-ins (the Enabler is essentially a LADSPA interface for VST plug-ins). Current Audacity has built-in support for VST effects.

How do you add plug-ins to Audacity?

On Windows and Mac, put them in the Audacity Plug-ins folder.

  • On Windows, the Audacity plug-ins folder is usually at C:\Program Files\Audacity\Plug-ins
  • On Mac, the Audacity plug-ins folder is usually at Mac Hard Disk > Applications > Audacity > Plug-ins
For extra paths from which Audacity can load LADSPA, VST or Audio Unit plug-ins, see the respective links in "Types of plug-in" above.
  • On Linux, plug-ins can be added to:
~/.audacity-files/plug-ins
/usr/share/audacity/plug-ins
/usr/lib/ladspa/plug-ins
/usr/local/share/audacity/plug-ins or
/usr/local/lib/ladspa/plug-ins


Free plug-in downloads


Limitations

  • No real-time effects: Audacity cannot yet preview an effect while changing the parameters of the effect. Audacity cannot yet apply effects to audio while it is playing or recording.
  • VST instrument (VSTi) plug-ins that generate sound are not supported


For Developers