Difference between revisions of "Plug-ins that crash Audacity or fail to work properly in Audacity"

From Audacity Wiki
Jump to: navigation, search
(WIP ignore)
 
m
 
(92 intermediate revisions by 3 users not shown)
Line 1: Line 1:
{{intro|This page collects together all bugs/issues relating to plug-ins that fail to work properly in Audacity or crash Audacity}}
+
{{deprecated|https://plugins.audacityteam.org
 +
 
 +
As of Audacity 3.2, Audacity validates plugins before loading them so crashing should no longer occur in the vast majority of cases}}
 +
{{ednote|'''Peter 10May19:''' Steve wrote by email:
 +
*I'm not overly concerned if one specific plug-in doesn't work - there are many reasons why that might be the case. I am concerned when a plug-in causes Audacity to crash, potentially losing the user's work.
 +
*If a Nyquist plug-in doesn't work, it is invariably because either because the Audacity version is too old, or it is a bug in the plug-in. If we host that plug-in, then it needs to be either fixed or we stop hosting it.
 +
*If it's a third party Nyquist plug-in, then I think that's an issue for the Forum rather than Bugzilla. }}
 +
{{intro|1=This page collects together all bugs/issues relating to plug-ins that fail to work properly in Audacity or crash Audacity.|There are a huge number of audio plug-ins available for Linux, and Audacity's plug-in support continues to improve. Users are advised to favor more modern plug-ins that are actively supported by their developers rather than ancient plug-ins that have been abandoned.}}
 +
__TOC__
 +
 
 +
 
 +
 
 +
=='''Generic plug-in issues'''==
 +
<div id="vst"></div>
 +
 
 +
=== Many VST plug-ins fail or crash===
 +
Many VST plug-ins fail or crash
 +
 
 +
See [https://bugzilla.audacityteam.org/show_bug.cgi?id=665 Bug 665 Plug-ins: Issues with 3rd party AUs and VSTs - Crash and hang bugs]
 +
{{ednote|'''Peter 10May19:''' Steve wrote by email:
 +
*Many years ago there was an attempt to list working / non-working VST plug-ins on the wiki. Unfortunately it was too much work to maintain.
 +
*There are so many VST plug-ins in the wild that it is almost impossible to provide a useful list. }}
 +
 
 +
 
 +
<div id="ladspa"></div>
 +
=== Some LADSPA plug-ins fail ===
 +
There are problem with LADSPA plug-ins. Most of these problem plug-ins are ancient and no longer supported by their developers, so are unlikely to be fixed.
 +
{{ednote|'''Peter 10May19:''' Steve wrote by email:
 +
*I think we should be looking at deprecating LADSPA support in favour of LV2, but that requires LV2 support to work, which mostly it doesn't. }}
 +
 
 +
 
 +
<div id="LV2"></div>
 +
<div id="calf"></div>
 +
=== Calf plug-ins ===
 +
Some LV2 plug-ins either fail, or cause Audacity to crash. Unfortunately the excellent "Calf" plug-in suite has been known to be problematic, but more recent versions have been reported to work well - your mileage may vary.
 +
 
 +
(Not logged in Bugzilla - but known about for a long while.)
 +
 
 +
 
 +
<div id="faust"></div>
 +
=== Faust plug-ins fail ===
 +
It would be really nice if Faust plug-ins worked, but there have been reports that they don't.
 +
{{ednote|'''Peter 10May19:''' Steve wrote by email: That is an issue that I think should be logged separately from other plug-in bugs. We don't need to log specific Faust plug-ins. }}
 +
 
 +
 
 +
<div id="auvstsuperbug"></div>
 +
 
 +
=== Plug-ins: Issues with 3rd party AUs and VSTs - Crash and hang bugs  ===
 +
*P5 [https://bugzilla.audacityteam.org/show_bug.cgi?id=665 665] - Issues with 3rd party plug-ins - Crash, hang and failure bugs
 +
 
 +
This is a super-bug that collects data on many plug-in bugs that relate to AU and VST plug-ins.
 +
 
 +
Initially created: 10Oct13
 +
 
 +
=='''Specific identified bugs that crash or fail'''==
 +
{{tip|Click on the bug number to see full details if the bug thread in our Bugzilla bug-tracker. }}
 +
<div id="ladspameq"></div>
 +
=== Windows: LADSPA Multiband EQ plug-in may not be visible in Effect menu and crashes  ===
 +
*P5 [https://bugzilla.audacityteam.org/show_bug.cgi?id=47 47] - Windows: LADSPA Multiband EQ may not be visible in Effect menu and crashes soon after opening
 +
Initially reported: 28Jan2010
 +
 
 +
 
 +
<div id="shortcuts"></div>
 +
=== Mac: VST and some AU plug-ins do not allow "moving through active windows" with shortcuts when in graphic mode  ===
 +
*P4 [https://bugzilla.audacityteam.org/show_bug.cgi?id=867 867] - Mac: VST and some AU plug-ins do not allow "moving through active windows" with shortcuts when in graphic mode
 +
Initially reported: 23Feb2015
 +
 
 +
 
 +
 
 +
<div id="lv2instruments"></div>
 +
=== Linux/Mac: LV2 instruments are listed in Plug-in Manager on Ubuntu 14.04 32-bit. ===
 +
*P4 [https://bugzilla.audacityteam.org/show_bug.cgi?id=1054 1054] - Linux/Mac: LV2 instruments are listed in Plug-in Manager on Ubuntu 14.04 32-bit.
 +
Initially reported: 02Jul2015
 +
 
 +
 
 +
<div id="fomp"></div>
 +
=== Linux: Fomp *VCO LV2 oscillator plug-ins incompatible when they shouldn't be. ===
 +
*P4 [https://bugzilla.audacityteam.org/show_bug.cgi?id=1056 1056] - Linux: Fomp *VCO LV2 oscillator plug-ins incompatible when they shouldn't be.
 +
Initially reported: 02Jul2015
 +
 
 +
 
 +
<div id="genericerror"></div>
 +
=== Mac/Linux: Too generic error if an incompatible LV2 plug-in is enabled. ===
 +
*P4 [https://bugzilla.audacityteam.org/show_bug.cgi?id=1055 1055] - Mac/Linux: Too generic error if an incompatible LV2 plug-in is enabled.
 +
Initially reported: 02Jul2015
 +
 
 +
 
 +
<div id="mda"></div>
 +
=== Windows: VST - MDA Tracker plug-in crashes ===
 +
*P4 [https://bugzilla.audacityteam.org/show_bug.cgi?id=1082 1082] - Windows: VST - MDA Tracker plug-in crashes
 +
Initially reported: 15Jul2015
 +
 
 +
 
 +
<div id="simulanaog"></div>
 +
 
 +
=== Windows: VST plug-in SimulAnalog Guitar Suite plug-ins crash Audacity ===
 +
*P4 [https://bugzilla.audacityteam.org/show_bug.cgi?id=1270 1270] - Windows: VST plug-in SimulAnalog Guitar Suite plug-ins crash Audacity.
 +
Initially reported: 01Dec2015
 +
 
 +
 
 +
<div id="reaeq"></div>
 +
 
 +
=== Windows: VST plug-in ReaEQ tabs cannot be enabled/disabled without restarting playback ===
 +
*P4 [https://bugzilla.audacityteam.org/show_bug.cgi?id=1399 1399] - Windows: VST plug-in ReaEQ tabs cannot be enabled/disabled without restarting playback
 +
Initially reported: 01Jun2016
 +
 
 +
 
 +
<div id="phasebug"></div>
 +
=== Windows: VST - PhaseBug Mono and Stereo hang Plug-in Manager and can't be enabled  ===
 +
*P4 [https://bugzilla.audacityteam.org/show_bug.cgi?id=1568 1568] - Windows: VST - PhaseBug Mono and Stereo hang Plug-in Manager and can't be enabled
 +
Initially reported: 25Dec2016
 +
{{advice|The original author and supplier of these PhaseBug plug-ins appears to be no longer in existence.  There are several privateer sites you can find on the Internet that still host these plug-ins - approach such sites with care. }}
 +
 
 +
 
 +
<div id="lv2presets"></div>
 +
 
 +
=== LV2 plug-ins: Recalling User Presets and setting defaults does not work correctly  ===
 +
*P4 [https://bugzilla.audacityteam.org/show_bug.cgi?id=1604 1604] - LV2 plug-ins: Recalling User Presets and setting defaults does not work correctly
 +
Initially reported: 07Mar2017
 +
 
 +
 
 +
<div id="vstinstruments"></div>
 +
=== VST Instruments and VST3 Effects listed in Plug-in Manager  ===
 +
*P4 [https://bugzilla.audacityteam.org/show_bug.cgi?id=1929 1929] - VST Instruments and VST3 Effects listed in Plug-in Manager
 +
Initially reported: 11Aug2018
 +
 
 +
 
 +
<div id="au"></div>
 +
=== Mac: some Audio Unit plug-ins fail to enable===
 +
Not all of the Audio Unit effects that Apple supplies can be enabled in Audacity.  They will show listed as available in the '''New''' section of the '''Plug-in Manager''' but if you try to enable them you will get an error message telling you that they failed to register.  This is an Apple issue and '''''not''''' an Audacity bug.
 +
 
 +
This only affects a few of the Audio Unit plug-ins:
 +
*AUScheduledSoundPlayer
 +
*AUMultiSplitter
 +
*AUMultiChannelMixer
 +
*AUMixer3D
 +
*AUMIxer
 +
*AUMatrixMixer
 +
*AUAudioFilePlayer
 +
*AUSpeechSynthesis
 +
 
 +
Also documented in the [https://manual.audacityteam.org/man/effect_menu_audiounit.html '''Manual'''] in 2018
 +
 
 +
 
 +
{{note|1=
 +
See also [https://bugzilla.audacityteam.org/show_bug.cgi?id=665 Bug 665 '''Plug-ins: Issues with 3rd party plug-ins - Crash, hang and failure bugs''']}}

Latest revision as of 13:32, 6 December 2022

Warning icon This page has been deprecated. Newer information can be found here: https://plugins.audacityteam.org

As of Audacity 3.2, Audacity validates plugins before loading them so crashing should no longer occur in the vast majority of cases

The information on this page are likely out-of-date and will not be updated in the forseeable future. It may be removed at any time.
Peter 10May19: Steve wrote by email:
  • I'm not overly concerned if one specific plug-in doesn't work - there are many reasons why that might be the case. I am concerned when a plug-in causes Audacity to crash, potentially losing the user's work.
  • If a Nyquist plug-in doesn't work, it is invariably because either because the Audacity version is too old, or it is a bug in the plug-in. If we host that plug-in, then it needs to be either fixed or we stop hosting it.
  • If it's a third party Nyquist plug-in, then I think that's an issue for the Forum rather than Bugzilla.
There are a huge number of audio plug-ins available for Linux, and Audacity's plug-in support continues to improve. Users are advised to favor more modern plug-ins that are actively supported by their developers rather than ancient plug-ins that have been abandoned.


Generic plug-in issues

Many VST plug-ins fail or crash

Many VST plug-ins fail or crash

See Bug 665 Plug-ins: Issues with 3rd party AUs and VSTs - Crash and hang bugs

Peter 10May19: Steve wrote by email:
  • Many years ago there was an attempt to list working / non-working VST plug-ins on the wiki. Unfortunately it was too much work to maintain.
  • There are so many VST plug-ins in the wild that it is almost impossible to provide a useful list.


Some LADSPA plug-ins fail

There are problem with LADSPA plug-ins. Most of these problem plug-ins are ancient and no longer supported by their developers, so are unlikely to be fixed.

Peter 10May19: Steve wrote by email:
  • I think we should be looking at deprecating LADSPA support in favour of LV2, but that requires LV2 support to work, which mostly it doesn't.


Calf plug-ins

Some LV2 plug-ins either fail, or cause Audacity to crash. Unfortunately the excellent "Calf" plug-in suite has been known to be problematic, but more recent versions have been reported to work well - your mileage may vary.

(Not logged in Bugzilla - but known about for a long while.)


Faust plug-ins fail

It would be really nice if Faust plug-ins worked, but there have been reports that they don't.

Peter 10May19: Steve wrote by email: That is an issue that I think should be logged separately from other plug-in bugs. We don't need to log specific Faust plug-ins.


Plug-ins: Issues with 3rd party AUs and VSTs - Crash and hang bugs

  • P5 665 - Issues with 3rd party plug-ins - Crash, hang and failure bugs

This is a super-bug that collects data on many plug-in bugs that relate to AU and VST plug-ins.

Initially created: 10Oct13

Specific identified bugs that crash or fail

Bulb icon Click on the bug number to see full details if the bug thread in our Bugzilla bug-tracker.

Windows: LADSPA Multiband EQ plug-in may not be visible in Effect menu and crashes

  • P5 47 - Windows: LADSPA Multiband EQ may not be visible in Effect menu and crashes soon after opening

Initially reported: 28Jan2010


Mac: VST and some AU plug-ins do not allow "moving through active windows" with shortcuts when in graphic mode

  • P4 867 - Mac: VST and some AU plug-ins do not allow "moving through active windows" with shortcuts when in graphic mode

Initially reported: 23Feb2015


Linux/Mac: LV2 instruments are listed in Plug-in Manager on Ubuntu 14.04 32-bit.

  • P4 1054 - Linux/Mac: LV2 instruments are listed in Plug-in Manager on Ubuntu 14.04 32-bit.

Initially reported: 02Jul2015


Linux: Fomp *VCO LV2 oscillator plug-ins incompatible when they shouldn't be.

  • P4 1056 - Linux: Fomp *VCO LV2 oscillator plug-ins incompatible when they shouldn't be.

Initially reported: 02Jul2015


Mac/Linux: Too generic error if an incompatible LV2 plug-in is enabled.

  • P4 1055 - Mac/Linux: Too generic error if an incompatible LV2 plug-in is enabled.

Initially reported: 02Jul2015


Windows: VST - MDA Tracker plug-in crashes

  • P4 1082 - Windows: VST - MDA Tracker plug-in crashes

Initially reported: 15Jul2015


Windows: VST plug-in SimulAnalog Guitar Suite plug-ins crash Audacity

  • P4 1270 - Windows: VST plug-in SimulAnalog Guitar Suite plug-ins crash Audacity.

Initially reported: 01Dec2015


Windows: VST plug-in ReaEQ tabs cannot be enabled/disabled without restarting playback

  • P4 1399 - Windows: VST plug-in ReaEQ tabs cannot be enabled/disabled without restarting playback

Initially reported: 01Jun2016


Windows: VST - PhaseBug Mono and Stereo hang Plug-in Manager and can't be enabled

  • P4 1568 - Windows: VST - PhaseBug Mono and Stereo hang Plug-in Manager and can't be enabled

Initially reported: 25Dec2016

Warning icon The original author and supplier of these PhaseBug plug-ins appears to be no longer in existence. There are several privateer sites you can find on the Internet that still host these plug-ins - approach such sites with care.


LV2 plug-ins: Recalling User Presets and setting defaults does not work correctly

  • P4 1604 - LV2 plug-ins: Recalling User Presets and setting defaults does not work correctly

Initially reported: 07Mar2017


VST Instruments and VST3 Effects listed in Plug-in Manager

  • P4 1929 - VST Instruments and VST3 Effects listed in Plug-in Manager

Initially reported: 11Aug2018


Mac: some Audio Unit plug-ins fail to enable

Not all of the Audio Unit effects that Apple supplies can be enabled in Audacity. They will show listed as available in the New section of the Plug-in Manager but if you try to enable them you will get an error message telling you that they failed to register. This is an Apple issue and not an Audacity bug.

This only affects a few of the Audio Unit plug-ins:

  • AUScheduledSoundPlayer
  • AUMultiSplitter
  • AUMultiChannelMixer
  • AUMixer3D
  • AUMIxer
  • AUMatrixMixer
  • AUAudioFilePlayer
  • AUSpeechSynthesis

Also documented in the Manual in 2018