Difference between revisions of "Ppa and Distro Issues"

From Audacity Wiki
Jump to: navigation, search
(New page.)
 
(Clearer text.,)
Line 17: Line 17:
 
* [https://github.com/wxWidgets/wxWidgets/commit/72aad0d6ea0c11c7cbb722eefb6106a7f1bdd203 The fix to bug in wxWidgets]
 
* [https://github.com/wxWidgets/wxWidgets/commit/72aad0d6ea0c11c7cbb722eefb6106a7f1bdd203 The fix to bug in wxWidgets]
  
Three bugs in our Bugzilla database believed to be caused by the wxWeakRef bug:
+
Three bugs in our Bugzilla database believed to be caused by the wxWeakRef bug.  They are RESOLVED from our point of view, because we use wx3.1.3.  They aren't RESOLVED for the distros which continue to link against an unpatched wxWidgets 3.0.x.
  
 
{{#bugzilla:
 
{{#bugzilla:
Line 24: Line 24:
 
|columns=id,priority,status,summary,id
 
|columns=id,priority,status,summary,id
 
}}
 
}}
 +
 +
  
 
==Sizing==
 
==Sizing==
  
 
* The selection toolbar comes out treble height on some linux distributions, rather than the intended double height.
 
* The selection toolbar comes out treble height on some linux distributions, rather than the intended double height.
 +
  
 
==PPA for Ubuntu 20.04==
 
==PPA for Ubuntu 20.04==

Revision as of 17:50, 1 June 2020

General Points

Redistribution of Audacity on Linux is sometimes buggy because the distributors have used libraries we don't support.

Audacity should be built:

  • Using our patched wx3.1.3 widgets.
  • Using the version of libraries that we provide in our source code.


wx3.0.x

wxWidgets 3.0.x has a bug with wxWeakRef.

Three bugs in our Bugzilla database believed to be caused by the wxWeakRef bug. They are RESOLVED from our point of view, because we use wx3.1.3. They aren't RESOLVED for the distros which continue to link against an unpatched wxWidgets 3.0.x.

IDPStatusSummary (3 tasks) ID
2230P1RESOLVEDLinux: Audacity crashes on selecting "Resample"2230
2228P1RESOLVEDLinux: Crash on quit (release build)2228
2421P1RESOLVEDLinux: Crash on "Fit to Height"2421


Sizing

  • The selection toolbar comes out treble height on some linux distributions, rather than the intended double height.


PPA for Ubuntu 20.04

  • It is impossible to activate and install Effects Plugins. Both at startup and with an open project.

The Add / Remove dialog box does not save the enabled / disabled state of the plugins, it only shows the default plugins. When changing to activated and closing them they are unchecked again.

  • Splash Screen is not shown