Difference between revisions of "Release Checklist"

From Audacity Wiki
Jump to: navigation, search
(Watching Brief: remove confirmed working check)
(Highlighting the work needed on help/manual - not just for developers.)
Line 59: Line 59:
  
  
* Needed for when we release 1.3.5:
+
* '''Help/Manual issues'''.  These are needed for when we release 1.3.5:
 
** Script to extract html help from the Manual Wiki.  
 
** Script to extract html help from the Manual Wiki.  
 
** Installer to be modified to also install Html help.
 
** Installer to be modified to also install Html help.
 
** Need to decide if use external browser for local Help files or resurrect/tweak the 1.2.6 help browser (this had no backwards navigation without using the tree, and was not able to raise external browser when clicking external links, but has image support). The old help browser would be better than an external browser for users on slow machines with unreliable internet connections. For example IE tries to initiate a net connection on launching even if retrieving purely local files (unless previously set to work offline).   
 
** Need to decide if use external browser for local Help files or resurrect/tweak the 1.2.6 help browser (this had no backwards navigation without using the tree, and was not able to raise external browser when clicking external links, but has image support). The old help browser would be better than an external browser for users on slow machines with unreliable internet connections. For example IE tries to initiate a net connection on launching even if retrieving purely local files (unless previously set to work offline).   
 
** Subject to discussion and agreement on devel list (there has been no disagreement): Installer for LAME for Windows users. Note Audacity 1.3.3+ already checks at least its own installation folder, System 32 and the 1.2.6 registry settings for the existence of lame-enc.dll, so no further checks should be needed. Presumably "the "Download Free Copy of LAME" button should be changed to "Install Free Copy of LAME" as part of the change. '''<font color="orange">Justification for change: up to 20 hours of support time per month have been found to go on helping Windows users install LAME. A few hours' developer time now before 1.4.0 release is much cheaper in the long-run.</font>'''
 
** Subject to discussion and agreement on devel list (there has been no disagreement): Installer for LAME for Windows users. Note Audacity 1.3.3+ already checks at least its own installation folder, System 32 and the 1.2.6 registry settings for the existence of lame-enc.dll, so no further checks should be needed. Presumably "the "Download Free Copy of LAME" button should be changed to "Install Free Copy of LAME" as part of the change. '''<font color="orange">Justification for change: up to 20 hours of support time per month have been found to go on helping Windows users install LAME. A few hours' developer time now before 1.4.0 release is much cheaper in the long-run.</font>'''
** Also address the other required [[Documentation Checklist|documentation]] issues for 1.3.5 such as completing the Manual.
+
** Also address the other required [[Documentation Checklist|documentation]] issues for 1.3.5 such as '''completing the Manual'''.  Getting all the issues sorted to have the manual/help distributed with 1.4 is likely to be the main thing that delays the release of the windows version of 1.4.
  
 
= Essential fixes: Platform Specific =
 
= Essential fixes: Platform Specific =

Revision as of 17:39, 2 December 2007


These are all for 1.4.0 release. There will be a 1.3.4 beta release, then a 1.3.5 as a 1.4.0 candidate.

To take ownership of an issue, add your initials before it like so:

  • [DM] for Dominic Mazzoni
  • [LL] for Leland Lucius
  • [JC] for James Crook
  • etc...

This is a companion list to the Documentation Checklist.


Please ensure cleared items from this page are moved to our new Release Checklist Done page.


Please also refer regularly to these pages:

Wording, where we track suggested changes to the exact words that appear on a dialogue

Pending website changes where we post suggested changes to our audacity.sourceforge.net and audacityteam.org sites (except the Wiki).

Unless indicated by discussion against particular items, these should be regarded as needing attention. When processed, please move them to the "Done" section of those pages.


Patches are added and tracked on the Sourceforge Patch Tracker .


Essential fixes

Fixes are the top category, since it is difficult to estimate how long bugs will take to fix. See a discussion of what constitutes essentials on the discussion page.

Once these essential items are cleared, please use any time remaining to clear the blue-marked items in the Priority Aim To section, which will otherwise need release noting in 1.4.0.


  • With foreign languages (at least French and German) selected, MP3 metadata tags for "Artist Name", "Track Title", "Album Title" and "Track Number" are not filled, so not seen by media applications. Instead, duplicated custom tags with these identifiers are created. MM suggests some strings are marked for translation but used as keys.
  • If you open another file when the first is playing, the first stops playing and starts again from time zero.
  • Issues where translation of bits of Audacity doesn't work, notably:
    • Strings in static intialisers. There are several places where static arrays of strings are initialised using _(). This simply doesn't work (may be a compile error), because although the strings are extracted for translation, the wxGetTranslation call that the _() macro expands into never gets run, and the array is always statically initialised to the untranslated string. The main culprit is in the MP3 export dialogue, where all the preset names are like this at the moment, but there are others.
    • Timetextctrls - most obviously all the selection bar ones, but also generate effects. Translating statics can be done by making them not statics. Generally this will mean a flag so that we initialise them just once.
  • Ensure Metadata editor appears of its own accord more often than only for first export. The least work solution is to have it always appear for each export in a session, which will improve things for far more users than not. Other solutions seem to depend on it being aware of how many times an export has been made and for what formats, or to have a way of being told not to appear again in that session.
  • Opening 1.0.0 project files show no dire warning, just confirmation project is being converted to the new format and a backup copy of the original saved. 1.1.x projects still gives the dire warning. Of four Projects saved in 1.0.0 (simple import of a WAV only), all gave consistency errors in 1.3.4. Two crashed when clicking "regenerate summary files". The original project file then can't be opened in 1.0.0 (error = "Audacity does not support opening Audacity Projects"), but the backups open in 1.0.0 fine.

Essential changes

These are other changes to source code that are deemed essential. We will do all of these for 1.3.5 release.


  • Agreement reached for 1.3.4:
    • Update location for local help in Filenames.cpp to /Data_directory/Help/. This reduces danger of user interference with the files, which happened more than a few times in 1.2.x
    • All agreed on Wording changes as of 12 Nov 07 that can be made are in. Changing Directories Preferences to "Auto save every [ ] minutes" depends on changing the code to strict interval time saving, which may not be done for 1.4.


  • Help/Manual issues. These are needed for when we release 1.3.5:
    • Script to extract html help from the Manual Wiki.
    • Installer to be modified to also install Html help.
    • Need to decide if use external browser for local Help files or resurrect/tweak the 1.2.6 help browser (this had no backwards navigation without using the tree, and was not able to raise external browser when clicking external links, but has image support). The old help browser would be better than an external browser for users on slow machines with unreliable internet connections. For example IE tries to initiate a net connection on launching even if retrieving purely local files (unless previously set to work offline).
    • Subject to discussion and agreement on devel list (there has been no disagreement): Installer for LAME for Windows users. Note Audacity 1.3.3+ already checks at least its own installation folder, System 32 and the 1.2.6 registry settings for the existence of lame-enc.dll, so no further checks should be needed. Presumably "the "Download Free Copy of LAME" button should be changed to "Install Free Copy of LAME" as part of the change. Justification for change: up to 20 hours of support time per month have been found to go on helping Windows users install LAME. A few hours' developer time now before 1.4.0 release is much cheaper in the long-run.
    • Also address the other required documentation issues for 1.3.5 such as completing the Manual. Getting all the issues sorted to have the manual/help distributed with 1.4 is likely to be the main thing that delays the release of the windows version of 1.4.

Essential fixes: Platform Specific

I put these in a separate category as we could be 'Windows 1.4 ready' but not 'Mac/Linux 1.4 ready', if these are not cleared.

Mac

  • [LL] Fix: Unavailable items in application menu on the Mac. How to reproduce 
  • Fix: Mac CoreAudio crash when input device's sample rate is 44100 and the output device's sample rate is 48000.
  • Fix: Mac OS X crash on opening 1.2 project files. Is this still an issue?
  • Fix: Mac OS X crash on recovering files. Is this only a Mac issue, and if so do we have any idea why it is Mac specific? I think there are two issues 1) a freeze on Intel Macs (2) a non-crash situation on Intel and PPC where you recover, receive a "junk after document" warning and are presented with empty tracks. See here  and contact GA if you want an example auto save file and _data folder
  • Shift-P doesn't open the Panning dialog on the Mac because Pause catches the same key, so we should change that to another key.
  • Problem with inability to launch Audacity on non-admin accounts on Network Home ( see here) and on managed accounts - see here .
  • Test MJS's fix for: Fix crash on restart when noisegate.nrp is present (the nrp only seems to be written when in Clean Speech mode). Crashing on launch replicable in 1.3.3 on Windows and Linux when CleanSpeech enabled and .nrp present. Possibly related crashes reported on Mac when starting Noise Removal (1.3.2 on Windows crashes in this way - not on launch - when in CleanSpeech mode with nrp file present). See here  for more details. MJS's fix seems to have worked to stop crashing on Windows and Linux. Still needs testing in a new OS X build. NRP file has its own directory in the user's folder for application data - need to make make sure it actually gets written there. NRP file still only written for CleanSpeech mode at present
  • The old issue of envelope points not restoring properly when reopening never quite seems to go away on Macs -see here . MJS made some fixes for Windows. Perhaps they help here too?

Mac *and* Linux

  • [LL] Fix: Random bits of silence during recording (non-Jack version of this problem). [Mac only?] Progress: Udo tried smaller blocksize in linux/jack version of this problem and can now fault after 4 mins. Perhaps small blocksize will help us track down the problem on non-Jack set ups too. However, perhaps Udo's progress is only relevant to using Jack and no help to Mac?

Linux

  • Fix: Recovery action if project rate not supported by card. OK on Windows.
  • Support for OSS not functional (crashes). If we are releasing the tarball, as it looks like we will at least as beta, how do we address this? Do we need better release notes, something in the build system or what? We don't want zillions of repeat reports of a known limitation, or Linux users wasting their time trying to make Audacity do something it won't.
    • OSS issue/crash reported by SIEGERSTEIN: 'failed in 'src/hostapi/oss/pa_unix_oss.c', line: 1206'
    • Address Mihail's issue: PA19 uses oss; without load/compile oss support in alsa (snd-pcm-oss), audacity crashes on init PA19.

Watching Brief

These are issues which are inconsistent. They seem to come and go, or seem to appear on one machine but not another on the same or similar platform (e.g. Windows 98 versus XP). We keep them here to remind ourselves of them. When we ask our first round of testers for testing, we'll ask them that if they see such problems to note the exact scenario.

  • Where user has a multiple real playback and recording devices, not possible to scroll down through complete list in Device Toolbar using keyboard. Reported by GA on Windows XP where scroll won't go beyond Modem line#0. Could be related to Audacity problems when encountering devices with no associated mixer.
  • Nyquist generation plug-ins don't give the correct time generation. David S on Win 98 finds a 3 second pluck generates 8.5 seconds, for GA on XP it generates 2.756 seconds and GA finds all Nyquist generation is shorter than it's supposed to be by about 8.14%
  • Watch for speaker and mic backgrounds in Device and Mixer Toolbar being black or wrong colour, especially on Windows
  • Envelopes have been a major source of problems in the past. In particular, look for when you split a track that contains envelope edits, there may be no end points on a 'split', leading to envelope changes on a 'split'. GA is finding this problem intermittently on Windows XP SP2. MJS can only reliably reproduce it by zooming into sample level, put in an envelope point and then a split within 1.5 samples to the right (about 34 microseconds). It could be looked at after 1.4. Also keep an eye open for error cases that have not yet been covered, and report them. If problems are no worse than in 1.2.5. we may use as is, but we may want to release note them so that people know what to expect.
  • Intermittent failure to detect playback and recording clipping noted on Windows XP SP2 machine, currently no longer reproducible (GA to report if recurs)
  • Intermittent failure to snap shifted tracks or dragged selections on Windows XP SP2 machine (this is a consistent problem, it works only about every other time Audacity is launched)
  • Keep an eye out for autosave files that open incorrectly for example due to mismatched tags. Autosave files themselves don't have or need a matching </project> tag because Audacity adds this when saving the project, and because the </project> tag would have to be removed and added back at the bottom when the autosave file was added to.
  • Keep eye out for abnormal silence added when exporting selection as MP3 - see Bug 271. Possibly related problem found in 1.3.3 released build with silenced audio in MP3s when exporting multiple with labels. See steps to reproduce. Repeating this test when exporting multiple with tracks instead of labels gives a normal export, as does Export Selection as. None of the above problems yet replicated in CVS. Should be added to Beta 1.3.4 test notes to look out for if not resolved.
  • Unduly slow MP3 export compared to 1.3.2. Confirmed by GA on 1.6 GHz 1 GB RAM Win XP single machine, MJS did not see the problem on a faster dual core machine. Thread and user complaints about it here .
  • Unduly slow processing of AutoDuck - GA finds on his Windows XP set up that processing consistenly takes 16 - 20 times the length of the audio.



Priority Aim to

These are items which were in the aim-to list which are being prioritised. None of them are show stoppers which can hold up the release. Items which are still in this list at time of release will in all probability be noted in release notes, so there is an incentive to clear them if we can.

After discussion on devel-list, the items in blue have been deemed to be the most important to be cleared after outstanding essential fixes have been made. The intention should be to pay attention to these if time is available before help and translation issues are resolved.

These ones should be in release notes and documented as known issues in 1.4.0 if not cleared.

  • Speaker and Mic icons display with wrong coloured backgrounds in mixer and devices toolbars. Win 2000 issue? GA:This problem is not seen on my Win XP system - any idea why not? It is not a problem on Linux either, according to RA. JC: Seems to be a wxBitmap issue, not a theming issue. May be a machine/timing specific bug in when things get cleared and when repainted. Demoted from 'essential' as now believed to be a hard to track down bug, intermittent (some machines not others with the same exe), and not a newly introduced bug. Marked on Documentation Checklist to be release noted as a Windows 2000 issue at least.
  • Fix: When you close all your tracks and File > Save or Save Project As.., no warning is given. Save Project As.. with no tracks open is legitimate if there have never have been any changes, so it's suggested the warning should be given only if there is an Undo history. Promoted from standard "aim to", as currently there is no protection in place for the user inadvertently saving an empty project.
  • [JC] Select-all-when-none wherever a selection area is valid is not enabled for Edit > Cut and Edit > Copy.
  • Ensure other edit menu items (not just cut and copy) are consistently enabled and work consistently. See here 
  • Fix: Old projects open incorrectly - reported by Monty. With CVS Head, sample project created in 1.1.0 now correctly identifying the real orphans (there are 10), but the waveform is still opening as blank. Needs more investigation. GA tried a 1.1.3 Project with envelope edits in 180907 build and it opened fine. There are no envelope points, but there aren't any after saving/reopening the Project in 1.1.3 either.
  • Project irrecoverable after crash if a track is imported then another track of *any* description is added after the autosave interval (even a recorded or Label Track). The problem is that when the second track is added to the updated autosave file, "_data" in "projname" is prepended with the name of the first imported file (what you see in the Audacity title bar). After that the project is irrecoverable, until you change the "projname" back to "_data", then it recovers perfectly. Must be release noted if not fixed, as users often delete files once they are imported into Audacity.
  • Beep on completing long process is not working on Windows XP and 98 for GA and DJS respectively. If not fixed, problem should be release noted. Beep is using the wxWindows function wxBell(), which on some systems uses an internal speaker and does nothing on others. Changing to a user selected sound or other way of producing sound is probably not sensible for 1.4. Release noting is best.--JC wxBell() seems only to call the system noise from pre-soundcard days, not one of the system WAV files. This system noise is often reported to be inaudible when called by wxBell(). As it seems this can't be fixed for 1.4, have marked to release note this on Documentation Checklist [GA]

  • Fix: Make all platforms consistently force Project Rate to the rate of imported file irrespective whether that rate is supported or not. Currently this does not work on Windows and results vary on Linux. Is Michael's issue "1.3.3-beta and newer fill the "Project Rate" combo box with several invalid frequencies, most likely picking them from a hardcoded list without making sure the audio hardware can handle them" related? When done, add a Preference to always have Project Rate remain as per its Default Sample Rate Preference setting irrespective of the file being imported (this is currently "not aiming for 1.4.0").
  • Ability to add a label anywhere in a label track by just typing without ctrl-B first, when a selection region of any size is on a single track and the track is a label track. (used to work in beta builds).
  • Strongly consider re-enabling PA19 automatic latency correction. If not re-enabled, then what should default correction be? MM thinks it should be zero (as now) given the "audio to buffer" default is 100ms , but GA thinks that means that almost no-one will get their tracks aligned without setting the latency correction in Preferences, and that this would be a regression on 1.2.x where people quite often do get their tracks aligned without needing Time Shift Tool. Users of 1.3.3+ quite widely believe latency correction "does not work" where it used to in 1.2.x (see Help list and Forum archives). It seems to me users will almost always need to go into Preferences if they want synchronised tracks without using Time Shift Tool (because current set up is no automatic correction enabled and Preferences default set to no correction).-GA


These ones probably do not need release noting:

  • Dependencies Dialogue: If you click on "Copy Selected Audio Into Project" in error, the copying cannot be cancelled from the progress dialogue. This can probably be left for after 1.4 unless it's an easy fix
  • [JC] Welcome (splash screen) to open all html links on first screen in a browser when clicked, if the files are available, and fall back to opening all links in the welcome screen otherwise (subject to discussion - may be better to use built in browser for local files, but make it work better).
  • Move "When importing audio files, normalize all tracks in project" from Batch tab of Preferences to Audio Files tab. GA believes this is a good move, as it affects all imported tracks (not just those imported in a chain) and meets requests for such a feature, which is available but not easily discoverable. It *could* be demoted if the work involved is significant. Note: while Audio Files seems to be the best place to move it to now, it may be better long term to remove Audio Files tab altogether, in which case a new "Importing Behaviours" section in Interface tab could be the ultimate destination. See the discussion in Not aiming for 1.4
  • Re-enable file writing within Nyquist so that Nyquist plug-ins can remember user settings, but be careful about the permissions with file writing, and whether and when we allow over-writing of existing files. Needs someone with detailed LISP knowledge to look at it. Assumption is that we need to re-enable code intentionally disabled, not write new code. JC says xlisp functions such as xwrchar, xprint and xopen :OUTPUT seem to be already present and correct. Can't find disabled code. DS hypothesises it is code missing in 'the bridge', whatever that is.
  • When writing a file as a result of a Nyquist prompt, file either is not written or is written to a location that is not asked for (the same one that Audacity was using to write noisegate.nrp to before it was fixed). See here  for details.



Aim to

  • Commit Andreas' memory leak fixes, as soon as he is satisfied they are safe.
  • Fix: Adjusting the meter update frequency seems to make no difference whatever, whether it is 100, 30 or 1.
  • Prevent latency correction occurring when append-recording, even if set in Preferences, to prevent possibility of "real" audio being shifted behind zero. MJS fixed so that only the newly recorded section of audio is shifted. This works but if audio is truncated it is irrecoverable. GA has suggested backwards shifting only up to the point where truncation would otherwise occur. New behaviour must be documented in Manual (noted on Documentation Checklist).
  • (low priority) Latency correction dialogue should not appear twice for an unsplit stereo track
  • Fix problem when recording stereo mix from a track in Audacity, about 100ms of the recording is truncated at the end (irrespective of latency correction setting in Preferences).
  • Fix: Envelope bug where two tracks in a stereo pair can show different envelopes; they should always be the same. Also fix any sync issues of envelope editing with a stereo pair - the current implementation is prone to error if the tracks are not the same size and don't have synced envelopes to begin with.
  • Fix: Waveform (dB) display: If audio track is shrunk vertically, the horizontal marks on the vertical ruler are marked 0 at the top and 0 in the middle (instead of -36).
  • (low priority) consider greater prominence / bright colour for arrows indicating shifting behind zero.
  • Ensure grey out Edit > Split New when no audio is selected, and grey out Edit > Split when no audio tracks are open.
  • In "Save Changes?" Dialogue with empty Project, change wxMessageDialog so that the default button is Cancel, not Yes. GA: We need to remember the possible stress of such a situation for the user, which means they may not be thinking clearly or understand anyway. In the case of saving an empty project, "Yes" is the wrong and unsafe choice for default button. GA prefers to change the dialogue text from the current "To save the tracks that were previously open, click Cancel, Edit > Undo until all your tracks are open, then File > Save Project", so as to add "(highlighted)" after "Cancel". JC says if cancel is highlighted, you don't need to tell the user that it is highlighted, but GA says that is exactly what you do need to do. It provides reassurance, is the safest change for the user and keeping their data safe should be the number one concern.
  • Mute/Solo: (low priority) Add hotkey so that can unmute all and mute all from keyboard.
  • Reinstate (low priority) each importing dialogue says "file" singular, as per how it worked properly in 1.3.3 Release.
  • Timer Record needs to remember the last scheduled duration
  • Fix: (low priority) Snapping on playback region - when you enable in 1.3.3)snapping the playback region jumps to the selection, rather than snapping to the nearest points.
  • Fix: (low priority) Playback region lost. The particular scenario is setting a playback region in the ruler different to the selection, then clicking play. On completion of playback, the playback region reverts to the selection.
  • Either warn when Prefs closed with autosave turned off, or ensure that Audacity warns when restarting after crash with autosave disabled: (1) that temp files are present (2) does not let you exit without reminding of you of those files. Users experienced enough to turn off autosave aren't total newbies. Should expect that turning off autosave reduces likelihood of recovery from errors. Fix not essential. JC This does miss the point that you can accidentally turn off autosave especially if using the keyboard - IMHO though not quite essential it is very important given Audacity gives you no help at all when you restart after a crash with autosave off.(GA)
  • Reinstate ability to import multiple files from the command line into the same Project. Check if doing this results in right-click > "Open with" from a file manager changing its current behaviour, which is that import of subsequent files are into different Projects. In view of our stated comment in the Unix Manual that importing files into the same Project is convenient, consider in any case if there should be a Preference to choose behaviour when importing subsequent files, and whether the better default would be to import into the same Project.
  • Fix: Selecting inhibits movement of clip onto another track. Only if you click within the selection. Clicking outside allows you to move the clip. Also, shouldn't the selection area should get dragged with the track?
  • Fix: a track or clip can't be dragged further left or right once the time shift arrows reach the end of the screen
  • Change the yellow snapping colour (white has been suggested by DM) or allow users to choose from a limited number of suitable colours. A suggestion based on a cyan colour is here . GA delighted to help or make more mockups.
  • Discuss test harnesses. Possibly write some more test code.
  • Springclean docs in root directory, e.g. buglist.txt - delete.
  • Ruler to use same units as selected in selection bar.
  • Use orange for high-water-bar in sound level meter, not blue. Is it not better to use orange for the RMS and red for the peak on both record and playback meters? The confusion is the red for RMS in Recording meter when red is colour for clipping in both meters (GA)
  • Fix all effects so that ALT + V always applies a Preview without having to change the effect settings first (EQ is one of the few effects where ALT + V works with the parameters that load). After Preview completes, ensure focus returns to the effect window rather than drifting to the Project window.
  • Determine why ALT+ menubar access key doesn't work when label track has the focus.
  • Hide all warnings except the first when exporting multiple MP3s with illegal sample rate/bit rate combination.
  • Once suitable modification in place, consider a Nyquist plug-in for creating a cue sheet or possibly direct Export as Cue Sheet, as discussed with Leland (but can be moved to "not aiming" if needs be)
  • When selecting a region over a label and cutting or copying, ensure label text, not the system clipboard content, is pasted into the text of the label
  • When selecting a region over a label that denotes a selection area and cutting or copying, ensure the pasted label is of the selection region, not a cursor point (this is a regression on 1.2.6)
  • Prevent Edit > Silence removing a label, it should only silence the referenced audio
  • Ensure proper saving of exported audio file when Audacity runs out of space and warn what was done, especially on Linux (seems on Windows that a clean file is saved). Consider checking free space before starting export
  • [MM] Auto Save procedure to save strictly every x minutes to preserve changes made inside saving period. Note Autosave can only be done when no editing is going on, and no edit can be performed until auto-save has finished. Consider "Auto Saving Project" progress bar or Status Bar message to show this. Consider reducing default autosave interval to reduce risk of loss if strict time saving isn't implemented.
  • Fix deleting entire area of a Label track between two labels deletes the right-hand label
  • Check labels consistently allow entry of z (reported by Julian on Linux and by user on OS X 10.4.10 with released 1.3.3)
  • Check typing square brackets in labels bring up a "move the audio cursor to start/end" dialogue rather than inserting as text (reported by Julian on Linux also by by user on OS X 10.4.10 with released 1.3.3, but not apparent to GA on Windows)
  • Label text editing: Selecting part of label text by dragging with the mouse doesn't start selection at beginning of drag, but at wherever the text cursor was previously
  • Left single-clicking no longer removes cut lines and clip boundaries, but left double-clicking does. Ensure that click or double-click close to the line snaps to it.
  • Prevent Effect > Repeat drawing clip boundaries at each repeat and ensure no undo history written for each repeat.
  • [MS]Change cut line colour from red as this is now the colour for View Clipping
  • Find Zero Crossings doesn't work properly. I checked this by fully zooming the waveform horizontally and vertically so that I can see every data point. The beginning and ending points of the selection after Find Zero Crossings might be as far off as +/-0.01 (out of 1) on the vertical scale, and they are not necessarily on a positive slope. Repeating the Find Zero Crossings produces unpredictable results and sometimes results in a change in the selection and sometimes doesn't. This occurs on both 1.2.6 and 1.3.3 beta. I'm using Mac OS X 10.4.10, but the problem has also occurred on older versions of Mac OS X 10.4. (reported by Menasheh Steiglitz (( steig _AT_ cs_DOT_stanford_DOT_edu)) on audacity-users)

Aim to release at same time

  • The new Nyquist plug ins. See: this discussion 
  • Consider as suggested by Markus including the Nyquist "Center Pan Remover" plug-in inside Audacity, rebranded as Vocal Removal" - see so-called Bug 205 
  • Strongly consider including ports of GVerb for both the Windows and Mac builds (getting them in the SWH collection is awkward). GA has a Mac version if needed

Not aiming to do for 1.4.0

This has moved to release checklist not aiming for 1.4 in order to make the Checklist more easily scannable again. but ones that were recently aim tos can be parked here temporarily, if there aren't too many...