Release Checklist

From Audacity Wiki
Revision as of 15:02, 9 April 2009 by Llucius (talk | contribs)
Jump to: navigation, search


This is the de facto bug list for all Stable and Beta releases of Audacity. The current suggestion is that Beta releases are blocked until all P1 bugs are fixed, and Stable blocked until all P1 and P2 bugs are fixed. There is no pre-determined plan for dealing with lower priority bugs.



  • Items added as Priority P1, P2 or P3 should be added to Known Issues, unless they are absent from the published release that page refers to. When cleared, move the items down to the "Cleared in CVS" section of that page.


Please also refer regularly to these pages:

Documentation Checklist, for documentation changes needed for 1.4 Manual and any developer recruitment drive.

Wording, where we track suggested changes to the exact words that appear on a dialogue

Pending website changes where we post suggested wording or layout changes to our audacity.sourceforge.net and audacityteam.org sites (except the Wiki).

Unless indicated by discussion against particular items, these should be regarded as needing attention. When processed, please move them to the "Done" section of those pages.


  • There are companion pages to discuss and monitor development of our audacityteam.org sites: Wiki Development Checklist (for both this Wiki and the Manual Wiki) and Forum Development Checklist. Relevant items include security issues, bug fixes and enhanced functionality through installing additional extensions.


Essential changes

These are other changes to source code that are deemed essential We will do all of these for final 1.3.7 release candidate or 1.4.0 release as noted below.

  • Help/Manual issues. These are needed for 1.3.7 rc:
    • Repair the script to extract zipped html help from the Manual Wiki. If this is impossible, James could make a snapshot zip using Wget and a file rename script .
    • Installer to be modified to also install Html help. Consider giving Windows installer an option to install help for all users, not just current user.
    • Address documentation issues, including website updates.
    • For 1.4, "completing the Manual". Needed before we can release any versions of 1.4.
  • Nyquist plug-ins (for 1.4): Gale to keep an eye on the Nyquist plug-ins provided in the Audacity Plug-Ins folder, possibly commit others requested by users if they work satisfactorily, such as binaural tones and Sequencer. On Windows/Mac, add the src/plug-ins folder to the installer but also add latest versions of GVerb.dll, Hard Limiter.dll and sc4.dll which are not in CVS. No special action is needed on Linux, as any *.ny plug-ins from the plug-ins dir are installed, except those deleted when the tarball is created using scripts/maketarball.sh.


Rating Keys for Issues

All issues are given a Priority Rating of 1 to 5 as follows:
P1 Blocks any Release - See the discussion page for a guide to what may be deemed an issue that blocks release.
P2 Blocks a Stable Release, but not a Beta. Maybe only affects a limited number of users.
P3 Not a blocker, but deemed worthy of release-noting if unfixed, so should not be ignored and left to mount up.
P4 Clear benefits from fixing, but not sufficiently important to release note. May include easy fixes giving considerable benefit relative to the time involved.
P5 Only just important enough to be fixed. It could be done in "spare time", or by someone learning the code.
Believed fixed but awaiting confirmation (cross-platform issues should be tested on at least two platforms)
R Regression on 1.2.6. Mainly used as an indication that a lower priority item could be promoted. Many issues not marked as regressions may well be so.


Blocking Issues

P2 (Stable Release Blockers)

P2 Nyquist effects, SoundTouch, SBSMS and Generators remove or corrupt cut and split lines in the modified region. Cut lines are completely removed, split lines are replaced with new, unwanted split lines at the left and right region boundaries. Probably any effect using HandleClear() will exhibit the same problem.
  • LLL: I believe this to be fixed now...just needs some verification.
P2 Preferences menu in some locales overflows using smaller screen sizes/larger fonts, or default Mac at 1024x768. See Preferences Improvements
  • GA: Seems fixed apart from minor polishing, except that the meaning of checking/unchecking the boxes on the Warnings tab is reversed. You get the warning about saving a project if you uncheck the box "Show Warnings/Prompts When saving projects, and if you check "Don't show again" in that warning, this checks the box in Preferences.
P2 Ensure all Edit menu items consistently enabled and work consistently when select-all-on-none enabled. See here .
  • JC: Is it really what we want? E.g click split-new twice, and we get four tracks. Is it not less confusing to leave it greyed out?
  • GA: If you turn off select-all-on-none, and with one track on screen, Select All, Split New, Select All and Split New, you also get four tracks, so I think it is what we want. Now, if you have a track selected with no time area selected, nothing on the clipboard and click the Edit menu, all the edit menu is enabled except Paste. But if we click outside the track(s) so that none are selected, we lose ability to click on Split Cut, Trim, Delete, Split Delete, Silence, Join, Disjoin, Duplicate and Find Zero Crossings - yet we could still Cut, Copy and Split (FWIW) and Split New. I think that will be very confusing as it's a halfway house between Select-all-on-none and not. So all Edit menu items, and File > Export Selection to be available even if no tracks are selected and when clicking outside the tracks.
  • David B. suggests longer term having two independent preference options for selecting all tracks and selecting all audio to give more control.
  • MJS: I suggest (after reviewing the menus):
    • Leave grey:
      • "Export Selection..." - there isn't a selection.
      • "Split Cut" / "Trim" / "Split Delete" / "Split" / "Split New" - they make little sense without a selection.
    • Allow with "select all":
      • "Cut" and "Copy" - to cut/copy the whole lot and paste into another project, maybe?
      • "Delete"
      • "Silence Audio" I note it deletes labels as well (and perhaps shouldn't).
      • "Join" - to join up everything
      • "Detach at Silences" - as above
      • "Duplicate" - as above
      • "Mix and Render" - makes sense
      • "Resample" - makes sense
      • "Remove Tracks" - makes sense
      • All (most?) of the effects.
P2 (was P3) R   Export Multiple fails with no export or warning if an empty label is encountered.
  • GA: To reproduce:
    1. Generate a tone
    2. Click in track, CTRL + B, click, CTRL + B along the track
    3. File > Export Multiple and hit Export
    4. Click Export button but nothing happens
    If "Include audio before first label" is checked, the metadata window appears for the "audio before" file, then returns on OK to the Export Multiple dialogue.

    In 1.2.6, export multiple with empty labels creates files ".wav", "-2.wav", "-3.wav" (or whatever format) and so on. Maybe that should be followed here (except "-1.wav" for the first automatically generated file might be better).

  • LLL: Or would it be better to ask the user to specify a name if it encounters a blank label? Similar to the dialog you get if you have a ":" or "/" in the label.
  • GA: It's a good idea, but the case for it is not so clear as it is with illegal characters. I know some users who always export empty labels to save typing and are happy with the autonaming, so would not welcome a large number of prompts. Could the prompt include a checkbox "Always export empty labels automatically" and that is then set in .cfg?
  • LLL: If that's the concern, then they should be just as happy with us providing a name for them, like "untitled" or "unnamed" or "empty" or "Automatically Generated Name Because It Was Blank". The empty name causes unnecessary coding hackage to create the "-1" file and on at least OSX, a file beginning with a "." will be hidden and not seen if the user tries to open it.
  • GA: Obviously I assumed recreating the 1.2.6 behaviour did not have such problems. The issue is not the name itself, but that user will not want prompts for every track (as happens with the "illegal" prompt) if they prefer to use empty labels. So are you OK with one prompt, they choose what it is (or use our default), then we append a suffix as per "numbering consecutively")?

    Just remembered: the "numbering consecutively" suffix is described as a "prefix" in the Export Multiple dialogue, and a few have been complaining about that misnomer. Some users think it should actually be a prefix but looks as if too much work (?). Either way, I'd like to see the "nn" form as per standard on audio CDs, so we lose the problem with folks who don't have natural number sort. Or, it could be an option, default is "nn".

  • LLL: Give it a try. I applied Rupinder's patch to correct this P2 and instead of blank names they'll be called "untitled" and I added a list of files exported on the final status dialog to let the users know what the final names were. See how it feels. It can be easily removed.
  • GA: I like it. Since there is no other specific information to help users who have left just one label blank, I wondered if we should replace "untitled" with "empty_label" which makes it clear? I think people would prefer that the second and subsequent files included "empty_label" or "untitled" though. So, "empty_label.wav", "empty_label-2.wav" and so on. Is that easily done? I do think "empty_label-1.wav" for the first file "would" have been better, given we adopt this -1, -2, -3 ... scheme for "numbering consecutively".
  • LLL: Not sure if "empty_label" would work if there are other cases when a blank filename were possible. I can't think of any off hand though, so if you can't either, we'll change it to "empty_label". The problem with having "-1" is that it really isn't a counter of the label being exported, it's a counter of what files already exist with the name. But, let me fiddle with it a bit. I think I have a solution.
P2 (was P3) Labels should move with all the timeline changing effects. They do not move with Effect > Repeat, Reverse, and Truncate Silence.

Non-blockers

P3 Release Noted (Prioritised non-blockers)

P3 Exporting audio with a length of 22,752072 samples or multiples thereof causes samples to be missing from the end of the exported file.
  • GA: To reproduce, create a tone of 22,752072 samples, and use Draw Tool to modify the last sample so you can recognise it. Export as PCM 16-bit WAV, and re-import. The modified last sample will be missing. Now exit and restart and create a tone of 45504144 samples (22752072 * 2), modify the last two samples, export and re-import. The last two modified samples will be missing.
  • LLL: I believe this to be fixed now...just needs some verification.
P3 R  Unreliable project re-opening with orphaned and missing blockfile errors.
  • GA: There are reports every week of users losing data correctly reopening a 1.3 .aup file in the exact same 1.3 version they created it in. "Orphaned" or "missing" blockfile errors are received and when users accept the "recommended" course to delete, the project is silenced. This frequency of data loss is not acceptable in 1.4.0. We should be on the alert for these issues, and as soon as steps to reproduce are found, escalate the specific problem to P2. One definite scenario where this has been reported is having multiple projects open, and blockfiles are saved to the wrong _data folder. GA has not yet managed to replicate it, though still has some more reported steps to try and do so...
P3 Unreliable Automatic Crash Recovery.
  • LL: I've seen some really strange (attempted) recoveries. I haven't yet looked into them, but I shall soon since my wife is complaining about it as well.
  • GA: These known problems have been reported. They should be verified and escalated to P2 if valid:
    • If a crash occurs with two tracks open, multiple projects are recovered
    • Recovery fails if a track is imported then another added after the autosave interval
    • Complete recovery failures (empty projects) seen on single tracks which are only generated tones.
    • (Mac) freeze on Intel Macs when starting recovery
    • (Mac) (Intel and PPC) "Junk after document" warnings then recovered project is empty. See here and download here an example auto save file and _data folder.
P3 R  AIFF files created by Audacity from recorded or generated data import intermittently (but at times very frequently) as noise - files play fine in other software.
  • GA: Much of the time, 1.3.7 or later on Windows cannot be relied on to import files exported with the explicit "AIFF (Apple) signed 16 bit PCM" filter. Appears to affect exports from recorded data (at any Defauit Sample Rate), or from tones generated at 24-bit. Same problem occurs with the AIFF 24-bit option accessed with "Options" button, but not apparently the comparable 16-bit option. Export Multiple seems affected the same way as regular export. Tested at 44100 Hz, reading directly. On Mac, a user 22 March 09 reports 1.3.7 "suddenly" producing noise when importing AIFF files where it did not before in many similar imports - user changed default sample format to 24-bit at about the same time. More details here.
  • LL: Gale, have you been able to find a pattern to recreate this? I've tried numerous variations on OSX and Windows and it always seems to import ok.
  • GA: Are you using a release build? In ANSI Release from HEAD, I created a chirp tone in 24-bit quality, recorded it using stereo mix then exported only the recorded track using the explicit (no options available) AIFF (Apple) signed 16-bit PCM choice. I changed Quality to 32-bit, closed the tracks and repeated the generation, record and export. I am not getting noise on importing the files back into Audacity but what I can replicate is that about half the time the files will crash both HEAD and 1.3.7 Unicode Release; if they don't crash they import properly. So behaviour compared to when I last tested is not the same. I have tried importing with the "All supported files" and "FFmpeg-compatible files" filter and the problem is identical. In 1.2.6 I can import these files dozens of times without problem.
P3   MP3s exported with Unicode metadata tags can't be played by Windows Media Player (WMP) and neither WMP or Explorer can see or edit the tags.
  • LL: It's because libid3tag exports Unicode data as big-endian and Explorer/WMP seem to require little-endian. And I don't see a way to coax libid3tag into writing in little-endian format without change the library...which I may just do since it will be short lived due to taglib coming post-1.4.
  • GA: Well as an interim fix that would of course make Windows users who only use WMP much happier - but would that then break MP3 export on Mac, or on iTunes on either platform? And how does taglib avoid this issue?
  • LL: I've changed it...give it a try. WMP, Explorer and iTunes on Intel Mac sees them just fine. Looks like taglib write little endian tags by default.
  • GA: Looks fine to me. Will be cleared unless Forum complainants find a problem with the fix.
P3 Advanced Mixing Options dialogue displays and permits routeing of all tracks in project even if they are muted (and thus won't be exported).
  • zachelko: How are you getting to the Advanced Mixing Options dialog? I'd like to look into this and submit a patch. Thanks.
  • GA: Thanks. Multi-channel export is enabled on the Import / Export tab of Preferences by checking "Use custom mix..." in the "When exporting tracks..." panel.
  • zachelko: Submitted patch to mailing list on 3/17/2009
P3 Modal block circumventable using File > New (Mac only) or shortcuts, leading to risk of crash. See this thread.
P3 Files > Recent Files drops file paths when list used or updated. Path returns on restart.
  • LLL: The wx class does this on purpose. I've been considering doing our own class to handle history since there's an issue with Unicode characters in filenames on the Mac in regards to the wx history class. There's no easy way to override that class to get around the problem and there's no easy way to stop it from removing the path, so maybe our own class is in order.
P3 (was P2) If shortcut for "Add label at playback position" is an unmodified character, the second time the label is confirmed by ENTER, that shortcut will be entered in a label placed at the start cursor. Using up arrow instead of ENTER avoids this problem.
P3 Muting specific time-shifted mono tracks when exporting produces audio at wrong point on timeline in exported file if muted tracks are to left of unmuted.
P3 WAVEX (Microsoft) headers: GSM 6.10 files cannot be exported, and U-Law/A-Law files may not be playable.
P3 LADSPA Multiband EQ may not be visible in Effect menu (occurs on Windows XP), and crashes soon after opening. VJ: The logic needs to be fixed to set rstart to a valid value in all cases, because after initializing rstart to 0, it crashes in LadspaEffect::ProcessStereo().
P3 When a Time Track and Label Track is present, audio is not pasted into all tracks, leading to desynchronisation.
P3 Residual FFmpeg issues:
  • "Select file(s) for batch processing..." dialogue lacks "All Supported files" and "FFmpeg-compatible files" filters
  •   Importing FFmpeg formats when FFmpeg library missing should raise the "FFmpeg not found" error, not the generic "not supported" error. Provisional fix in place, but throws multiple FFmpeg errors per file, then the relevant error for the particular format
  • In non-FFmpeg builds, attempting to import FFmpeg-supported formats should give an error that suggests downloading FFmpeg. Impossible to fix completely without breaking Importer abstraction: in non-FFmpeg builds ImportFFmpeg plugin does not exists and cannot suggest anything to user, while Importer should not know which formats are supported by ImportFFmpeg, thus being unable to suggest anything either.
P3 On-Demand: when importing a mixture of uncompressed and compressed files, on-demand loading does not start until normal import of the compressed files completes, if the names of the compressed files come earlier in the alphabet.
  • GA: On Windows, video files with a preceding name which similarly held up on-demand loading are as of 07 Oct 08 now importing second when dragged in, so the OD file is not delayed, but the tracks are now out of alphabetical order in the track list. Also, correct alphabetical order when using File > Open or Import now depends (on Windows) on the order the files are selected in. GA suggests therefore we could prioritise OD files to import first, then re-order the non-OD files in the track list if needed.
  • MC: Fixed 14 Dec 08.
  • GA: 24 Jan 08 - not fixed on Windows, except that files now import in alphabetical order irrespective of the order they were selected in. The basic problem remains: using "All supported files" filter, any compressed file (audio or video) that has a preceding name prevents OD loading of an uncompressed file with a following name. until the compressed file has loaded. So, much of the benefit of OD loading is lost.
  • MC: Discussed in Feb. 09 as resolved for the time being, but the discussion is still open. The implemented solution is different from planned to minimize UI blockage: Order of sort depends on loading method (open vs import).
  • GA: Order of sort depends on loading method on Mac, but on Windows the non-OD file always comes first with both drag/import and open. Therefore, sort order is always wrong if the non-OD file comes later in the alphabet, and we're not getting any benefit on Windows of OD files loading first. Do you see a way of getting OD to come first on Windows when using Open or context-menu opening? And is a resort after load practical? Out of order loading remains I think a P3 issue in itself.
  • MC: I forgot about the windows open behavior - it should be different. I just verified it on the mac, so I will need help or access to a windows machine to debug this. But in general the non OD files come first so that the UI isn't blocked while the OD files are being loaded, and thus the user can have the most time interacting with with the project while the files are being loaded. The new method still has sorted order, but its new sort hierarchy is filetype first, then name second, which seems like a reasonable behavior to me. A post-resort of the tracks seems actually disorienting, since the user is watching them being placed in this order as the files import. Thoughts?
  • GA: Yes thinking about it, I agree a post-load resort probably would be disorienting. I'm just conscious though of complaints about not importing in file name order, which I think is what the user will be aware of. If we drag in B.mp3 and A.wav, can we place A.wav above B.mp3 to begin with, when it starts to load?
P3 Preferences window: OK button does not work when a tab is selected in the left-hand panel.
P3 When changing language in Preferences, some elements don't change until restart. Affects Audio Track at the top of the Track Drop-down menu, and the toolbars tooltips (except Selection Bar).
  • LL: It looks like this has been partially fixed...the track menus now change, but tooltips are still an issue.
P3 R Pressing Play (but not spacebar) or clicking on the timeline in a second project when another is already playing stops playback of the first project.
  • zachelko: On Windows with Audacity 1.2.6 I'm not experiencing this. However, what seems to happen is that if a track in one project is playing and you attempt to play a track in another project, the play button does nothing and the track isn't started. Was this possibly the "fix" ?
  • GA: Because 1.2.6 does not have this problem, the bug is marked R , denoting it is a regression against 1.2.6. To replicate all issues on this list and Release checklist not aiming for 1.4, please test against latest CVS HEAD.
  • zachelko: This issue is deeper than just the "Play" function. Pressing Play, Pause, or Stop in another window while a track is playing in a different window behaves as if you hit those buttons in the window that has the playing tracks. I'm looking into a fix for this now. Was ControlToolbar.cpp over-hauled since the 1.2.6 release? By looking at it for the past 30 minutes or so, it would seem that a lot of these protections would have taken place in here...
  • zachelko: Submitted patch to mailing list 3/19/2009 to address Play/Pause/Stop spanning across all open windows. Timeline issue still exists.
P3 Calculation of "disk space remains for recording (time)" incorrect when recording in 24 bit quality. Macro now created by RA to return size on disk of 16/24/32 bit sample formats as 2, 3, 4 respectively as first part of a fix, but Audacity does not currently record in 24 bit.
P3 Tag import/export occasionally non-orthogonal. Some known specifics:
  • WAV fields only seen patchily by other apps. as their support is patchy, but Genre tag consistently not seen.
    • GA/LL: Although it's a valid WAV info tag (IGNR), we don't support it because current and next libsndfile doesn't. We could patch libsndfile locally, but may be better to switch to taglib when they next release, as that will have AIFF and WAV support. Also because AIFF is written to an ID3 RIFF chunk, that will support AIFF tags in iTunes as standard instead of the current ad hoc adding on to libidtag.
  • GA: OGG metadata seems perfect on Windows except VLC sees no tags at all. How is Linux/Mac? Taglib should improve compatibility with VLC, K3b and Amarok.
P3 (Windows only)

LADSPA plug-ins not categorisable despite compiling with USE_LIBLRDF defined and installing RDF data files in Audacity data directory. See this thread

P3 (Windows only) The slv2 library needed for LV2 support does not build.
  • GA: Is slv2 building on Linux?
  • DanH: For me it fails (on Linux) but can be fixed by running libtoolize.
P3 (Windows Vista only) System mixer level sliders and Audacity level sliders act independently. As a result, achieved recorded level only matches level indicated on the Recording VU meter if the Audacity input slider is at 100%. Reported by David Bailes. Should also be checked on Windows 7.
  • DB: Logitech USB desktop microphone gives similar behaviour with independent system and Audacity input sliders, and the Audacity slider applies a gain not reflected in the Recording VU meter. For the Logitech USB desktop microphone, the same problem also occurs on Windows XP.
  • GA: My experience with USB external sound cards and USB turntables on a number of XP machines shows no replicable problems as described. Needs further verification by others.
P3 (Linux only) JACK issues:
  • in 1.3.5 from Ubuntu repository, Audacity crashes as soon as play or record started if JACK device selected in preferences (not tested built from CVS)
  • JACK has to be shut down before starting Audacity
  • Connections in qjackctl not persistent in Audacity session: they only become visible when playback or recording starts, and close when playback or recording stops. Several Linux applications have this problem, but for example alsaplayer seems to have solved it by changing their code? See this Linux musicians thread and this Forum post
  • Recording dropouts - these are grouped together with similar Mac problems as a P4 issue, but they might not be related
  • Crashes when recording full duplex?
  • Audacity must have same sample rate as JACK (seen in 1.3.4 Ubuntu repository builds)
P3 (Linux only) After opening a sufficiently long audio file, opening a second file of any size leads to locked GUI/console messages until first file completes play. Reported by Michael Schwendt on Fedora 8 test rpms of Audacity CVS from 11 Jan 08 and Jim Cline on Debian 31 Jan 08.
  Expression 'ret' failed in 'src/hostapi/alsa/pa_linux_alsa.c', line: 1034
  Expression 'AlsaOpen( hostApi, parameters, streamDir, &pcm )' failed in
  'src/hostapi/alsa/pa_linux_alsa.c', line: 1066
  • DanH: Confirmed on Arch
  • JC: Therefore promoted from P4

P4 / P5 Other Issues (not Release Noted)

P4 (Windows only) Audacity executable does not appear in Explorer "Open With" dialogue when right-clicking over an .aup file, nor in the "Open With" list after browsing in the dialogue, selecting the .exe and clicking OK.
  • RS: Started to fix this bug 04 Apr 2009
P4 When Control Toolbar is undocked, its associated shortcuts only work if the main application has focus.
P4 Minimum and maximum frequency display in Spectrograms preferences don't work for spectrum log (f) view.
P4 Memory leaks:
P4 (Mac only) Command-modified shortcuts that are also system shortcuts always perform the system action. For example, Command-M does not add label at playback position, but minimises the app. List of system shortcuts.
P4 (Mac only) CoreAudio crash when input device's sample rate is 44100 and the output device's sample rate is 48000.
P4 (Mac only) Envelope points do not restore properly when reopening a saved project -see here .
  • BP: Reproduced on 1.3.3 - 10.5.1, PPC iBook G4 on 28 Mar 08, but *not* on Intel Mac
  • GA: Should be tested with CVS HEAD and PPC, and escalated to P2 if confirmed?
P4 [LL] (Mac *and* Linux only) Random bits of silence occur during recording (Jack and non-Jack versions of this problem).
  • JC: Progress: Udo tried smaller blocksize in linux/jack version of this problem and can now fault after 4 mins. Perhaps small blocksize will help us track down the problem on non-Jack set ups too. However, perhaps Udo's progress is only relevant to using Jack and no help to Mac? And this problem does not occur consistently on a given system?
P4 (Linux only) Defining EXPERIMENTAL_SCOREALIGN prevents building on Linux.
P5 Standardise per-platform behaviour after changing Default Sample Rate in Preferences: On Windows, changing the rate in Preferences changes the visible project rate at once, so affects all new tracks in current project. On other platforms, visible project rate does not change until opening a new project. This creates problems in the Manual. Windows users seem to like current behaviour and report a bug if the visible rate does not change. We need to decide. Similarly, on Windows, a new track in the current project takes the changed default sample format at once.
P5 Debug Log window and Help > Index... browser do not escape.
P5 Links from built-in text to Wiki to be locally over-ridable in the same way that links from built-in text to external html files can be. This way we can have a local copy of the relevant Wiki pages, if we want to.
P5 Dependencies Dialogue: If click on "Copy Selected Audio Into Project" in error, the copying cannot be cancelled from the progress dialogue.
P5 Re-enable file writing within Nyquist so that Nyquist plug-ins can remember user settings. Be careful about permissions with file writing, and whether and when we allow over-writing of existing files. Needs someone with detailed LISP knowledge to look at it. Assumption is that we need to re-enable code intentionally disabled, not write new code.
  • JC: xlisp functions such as xwrchar, xprint and xopen :OUTPUT seem to be already present and correct. Can't find disabled code. DS hypothesises it is code missing in 'the bridge', whatever that is.
  • LL: This isn't an issue. All XLisp and Nyquist functions are now available.
P5 When writing a file as a result of a Nyquist prompt, file either is not written, or written to a location that is not asked for. See here for details.
  • LL: I don't believe this to be a problem. In the first example, the file will go to whatever the current directory is. The Lisp function (setdir) can be used to discover/change what that is. In the second example, you'd have to use a double backslash "c:\\progr..." to get it work work properly.
P5 Issues believed to result from Audacity implementation of Nyquist:
  • Excessive memory usage
    • LL: This will have to be resolved by adding memory pool tracking to lib-src/libnyquist/nyquist/nyqsrc/falloc.c so it can be freed when needed.
  • Inaccurate length generation on first use of the plug-in at the default value offered. Correct duration obtainable by using slider or text box to change the value away from, then back to the default (example: pluck.ny)
    • LL: I'm unable to reproduce this and experimenting shows that it has probably been fixed.
  • Other inconsistent length generation issues which vary from time to time/one plug-in to another/one Audacity version to another for no apparent reason.
    • LL: This was probably related to the *WARP* variable not being set consistently and should now be fixed.
  • Values of sliders in the Audacity effect seem to be re-computed from the pixel values of the slider as visible on-screen, so the nearest value obtainable by using the slider is presented when launching/re-using the plug-in, rather than the coded default or last entered value (example: highpass.ny). Compute the value from the text field then set the slider? See this thread
    • LL: The first part of the issue "100 becomes 101" will have to be resolved and is happening at the lines mentioned in the report. However, this only occurs on redisplay of the dialog. So, if you enter 100 and click OK (or press ENTER), 100 is what will be used when applying the effect. The second part "1.0 = 0.997" is normal floating point behavior.
P5 (Windows only) Timer Record progress dialogue reappears underneath programs restored to the desktop after hiding the dialogue with "Show Desktop". Also the progress dialogue ought to disappear with the WIN + M equivalent shortcut, but doesn't.
P5 (Mac only) When Preferences set to "Update display", trying to change timeline position during playback (for example by dragging horizontal scrollbar) causes playback cursor to desynchronise until playback stopped.
P5 (Linux only) Reproducible (but not entirely consistent) crashes reported when using Undo command. Reported by Darren on Ubuntu Gutsy 7.10 with 2.5 GB projects. Also, adding a Label Track in any projects causes Edit > Paste to flicker (the code does currently enable it), then closing the Label Track causes a crash every time irrespective of the actions taken before.
  • GA: None of these crashes are reproducible on Windows XP, but retained on "Watching Brief" just in case (it could affect Mac as well?)
P5 (Linux only) Recovery action if project rate not supported by card. OK on Windows.
  • GA: What does this mean exactly? Is it that the project rate is not remembered when recovering as reported on -devel list in May 2007? As at May 08 it is set on Windows.
P5 (Linux only) Miscellaneous OSS crashes.
  • Crash reported by SIEGERSTEIN: 'failed in 'src/hostapi/oss/pa_unix_oss.c', line: 1206'
  • Mihail's issue: PA19 uses oss; without load/compile oss support in alsa (snd-pcm-oss), Audacity crashes on init PA19.
  • GA: Are these still replicable or are they fixed with the PA updates?

Not aiming to do for 1.4.0

This has moved to release checklist not aiming for 1.4 and now includes former "Aim tos" from this page. Many of these "Aim tos" are relatively small items but could nonetheless make a worthwhile difference for the time involved. Please do not forget them.

If you claim ownership to items in "Not Aiming", please cut them from that page and park them here:


Truncate Silence needs a "remove DC bias" before running the effect.

  • RS: Started to fix this bug 04 Apr 2009