Release Checklist

From Audacity Wiki
Revision as of 22:14, 7 August 2008 by Vaughan (talk | contribs) (I've been seeing this "Labels do not accept certain characters" bug on Windows Unicode builds from HEAD, so removed ''(Mac and Linux only)'' designation.)
Jump to: navigation, search


These are all for 1.4.0 release. There has been a 1.3.4 Windows/Linux beta release, and a 1.3.5 release for all platforms on May 8, 2008.

There will be a fortnightly series of internal 1.3.6a (alpha) releases starting from the end of May, and 1.3.6 will be tagged. It is not yet decided to what extent, if any, these will be advertised on web pages. 1.3.6 will be a modular build using wxWidgets 2.8.7. A final public 1.3.7 as a 1.4.0 release candidate will not occur until after GSoC.

To take ownership of an issue, add your initials before it like so:

  • [DM] for Dominic Mazzoni
  • [LL] for Leland Lucius
  • [JC] for James Crook
  • etc...


  • Items added as Priority P1, P2 or P3 should be added to Known Issues, unless they are absent from the published release that page refers to. When cleared, move the items down to the "Cleared in CVS" section of that page.


Please also refer regularly to these pages:

Documentation Checklist, for documentation changes needed for 1.4 Manual and any developer recruitment drive.

Wording, where we track suggested changes to the exact words that appear on a dialogue

Pending website changes where we post suggested changes to our audacity.sourceforge.net and audacityteam.org sites (except the Wiki).

Unless indicated by discussion against particular items, these should be regarded as needing attention. When processed, please move them to the "Done" section of those pages.


  • There is also a page here where we discuss ideas for developing both this Wiki and the Manual Wiki, and monitor their progress. This includes security issues, bug fixes and enhanced functionality through installing additional extensions.


Essential changes

These are other changes to source code that are deemed essential We will do all of these for final 1.3.7 release candidate or 1.4.0 release as noted below.

  • Help/Manual issues. These are needed for 1.3.7 rc:
    • Repair the script to extract zipped html help from the Manual Wiki. If this is impossible, James could make a snapshot zip using Wget and a file rename script .
    • Installer to be modified to also install Html help. Consider giving Windows installer an option to install help for all users, not just current user.
    • Address documentation issues, including website updates.
    • For 1.4, "completing the Manual". Needed before we can release any versions of 1.4.
  • Nyquist plug-ins (for 1.4): Gale to keep an eye on the Nyquist plug-ins provided in the Audacity Plug-Ins folder, possibly commit others requested by users if they work satisfactorily, such as binaural tones and Sequencer. On Windows/Mac, add the src/plug-ins folder to the installer but also add latest versions of GVerb.dll, Hard Limiter.dll and sc4.dll which are not in CVS. No special action is needed on Linux, as any *.ny plug-ins from the plug-ins dir are installed, except those deleted when the tarball is created using scripts/maketarball.sh.
  • Installer Update (Windows): To cater for using wxWidgets as a dll.
  • LAME Installer (Windows): Though it might not be deemed "essential", consideration should be given to a Windows installer for lame_enc.dll (and avformat.dll if FFmpeg goes into 1.4). This would considerably ease the support problem with Windows users, and no objections were raised on -devel list to the idea. A modest time investment for reducing the burden on our support helpers.


Rating Keys for Issues

All issues are given a Priority Rating of 1 to 5 as follows:
P1 Release Blocker - See the discussion page for a guide to what may be deemed an issue that blocks release.
P2 To be release-noted if unfixed, considered very important.
P3 To be release-noted if unfixed, considered less important than P2 (for example, affects fewer users).
P4 Clear benefits from fixing, but not sufficiently important to release note. May include easy fixes giving considerable benefit relative to the time involved.
P5 Only just important enough to be fixed for release. It could be done in "spare time", or by someone learning the code.
Any items with a "$" after the priority rating are believed fixed but awaiting confirmation (cross-platform issues should be tested on at least two platforms)


Release Issues

P1 (Release Blocker Issues)

P1 Crash when starting monitoring in Meter Toolbar after recording in another project window then closing it.

P2 / P3 (Release Noted Issues)

P2 Quitting Audacity in the Automatic Crash Recovery dialogue exits the GUI but leaves the Audacity process running. After launching the GUI again, it is then impossible to exit it, except by force quitting. Not an issue in 1.3.5 release.
P2 Code change restricting non-multi-channel devices to mono or stereo recording wrongly restricts some devices that used to record multi-channel. See this thread .
P2 Audacity can underestimate the peak sample in a longer selection region (or in the entire track) if it contains a relatively small number of different peaks. This then causes clipping if the audio is amplified to FS. A requirement to reproduce seems be that the selection crosses over a block boundary: if it does, a selection only a few seconds long can show the problem. See this thread .
P2 MP3 Export: (normal and export multiple): Bit Rate Mode and Quality choices in Options dialogue are non-functional, almost always producing a 128 kbps CBR file. Additionally, the reported length is often incorrect although the actual length is correct.
P2 After closing all tracks, File > Save or Save Project As.. gives no warning. The user needs protection against inadvertently saving an empty project. Save Project As.. with no tracks open is legitimate if there have never have been any changes, so it's suggested the warning should be given only if there is an Undo history.
P2 Old projects open incorrectly. Reported by Monty. With CVS HEAD, sample project created in 1.1.0 now correctly identifying the real orphans (there are 10), but the waveform is still opening as blank. Needs more investigation. GA tried a 1.1.3 Project with envelope edits in 180907 build and it opened fine. There are no envelope points, but there aren't any after saving/reopening the Project in 1.1.3 either.
P2 Ensure all Edit menu items consistently enabled and work consistently when select-all-on-none enabled. See here .
  • JC: Is it really what we want? E.g click split-new twice, and we get four tracks. Is it not less confusing to leave it greyed out?
  • GA: If you turn off select-all-on-none, and with one track on screen, Select All, Split New, Select All and Split New, you also get four tracks, so I think it is what we want. Now, if you have a track selected with no time area selected, nothing on the clipboard and click the Edit menu, all the edit menu is enabled except Paste. But if we click outside the track(s) so that none are selected, we lose ability to click on Split Cut, Trim, Delete, Split Delete, Silence, Join, Disjoin, Duplicate and Find Zero Crossings - yet we could still Cut, Copy and Split (FWIW) and Split New. I think that will be very confusing as it's a halfway house between Select-all-on-none and not. So all Edit menu items, and File > Export Selection to be available even if no tracks are selected and when clicking outside the tracks.
  • David B. suggests longer term having two independent preference options for selecting all tracks and selecting all audio to give more control.
P2 All platforms to consistently force Project Rate to the rate of first imported file irrespective whether that rate is supported. As of 1.3.5.rc builds, this works on Windows but not for Michael on Linux. When done, add a Preference to always have Project Rate remain as per its Default Sample Rate Preference setting irrespective of the file being imported (this is currently "not aiming for 1.4.0").
P2 MP3 tag import broken if genres.txt exists, and otherwise import/export only near complete for MP3, and in places non-orthogonal. Some known specifics:
  • If genres.txt exists (even if the genres list is unchanged), both ID3v1 and v2 genre tags are misinterpreted on import as other named genres from the list.
  • Audacity "Year" MP3 tags not seen by Windows Media Player or Winamp, and "Year" OGG tags not seen by Amarok on Linux, or VLC on Windows or Linux.
  • FLAC import needs rechecking: Gale created 2 FLAC files in CVS 22 Jun 08 and Audacity saw none or only some tags on re-import. Already known that Audacity's FLAC export tags are not seen by VLC on Windows or Linux.
  • WAV fields only seen patchily by other apps. as their support is patchy, but Genre tag consistently not seen though it is a valid WAV info tag.
  • GA: Are we using ID3 V2.4 or 2.3? With the two main Windows players not currently seeing the Year tag, we may have a big reason for users not to upgrade from 1.2.6. Can we use v2.2 where WMP and Winamp see the year tag?
  • GA: Leland thinks we can't hack further back than 2.3. The problem seems to be that Windows Explorer/Media Player and Winamp currently expect a frame called "TYER" to indicate the year of the recording. ID3v2.3 seems to recommend passing year as the "TDRC" frame in preference, which is what lame_enc.dll does, resulting in the Winamp/WMP problem. But if you use LAME.exe 3.97 for command line export and force ID3v2.3 with "--id3v2-only", "TYER" is used and WMP and Winamp have no problem. So is it possible to use "TYER", and is this less bad than the current situation?
P2 The preference for caching audio data may cause a crash either when making long recordings or opening large files or projects. Although it has been reworded to give a warning, consider a separate preference for caching recorded and other audio data. This lets users have the benefits of caching when recording without the more dangerous and possibly less generally useful caching of imported and changed project data. GA suggests the new preference for only caching recordings could discard the cache after recording stops since the data is already written to disk at that point.
P2 (GSoc) On-demand: saving a project during summarising, then cancelling the save causes a freeze if the save copies in the audio data
P2 (Windows only) Welcome Message: On some systems/browsers, links are not brought to top.
P2 Labels do not accept certain characters. Known characters: [, ], Z, J, K, L, P, R, Home, End. Behaviour can be intermittent. Reported that resetting Keyboard preferences to default (even if already default), and holding down ALT while typing are workarounds.
P3 LADSPA Multiband EQ may not be visible in Effect menu (occurs on Windows XP), and crashes soon after opening. VJ: The logic needs to be fixed to set rstart to a valid value in all cases, because after initializing rstart to 0, it crashes in LadspaEffect::ProcessStereo().
P3 (GSoC) Exported GSM-WAV and GSM-AIFF files cannot be played on most supported players, or may not play for the full length; RealAudio exports disabled because FFmpeg does not produce a playable file. Also as at 25 July08, MP4/M4A sample rates at or below 22050 Hz are doubled in the exported file; MP4 files renamed to MOV will not play in Windows iTunes or QuickTime; "Select file(s) for batch processing..." dialogue lacks "All Supported files" and "FFmpeg-compatible files" filters.
P3 (GSoC) On-demand: re-opening a project saved during summarising gives "orphaned blockfiles" error.
P3 When in Spectrum, Spectrum log or Pitch view, pasting in audio then zooming in causes the pasted content beyond the horizontal scroll to disappear.
P3 Preferences window: OK button does not work when a tab is selected in the left-hand panel.
P3 When "Split New" is used with more than one track selected, and the selected region includes white space, the split clip(s) perform unwanted alignments instead of remaining at the original time position. For an example, see this thread . Note that in this case the problem occurs because select-all-on-none is enabled, but the bug does not depend on this being enabled. It occurs whether or not the entire audio of a track is selected; where only part of the tracks is selected, alignment occurs with the clip remaining after the split.
P3 Export Multiple fails with no export or warning if an empty label is encountered.
P3 When changing language in Preferences, some elements don't change until restart. Affects Audio Track at the top of the Track Drop-down menu, and the toolbars tooltips (except Selection Bar).
P3 Pressing Play (but not spacebar) in a second project when another is already playing stops playback of the first project (is a regression on 1.2.6).
P3 Calculation of "disk space remains for recording (time)" incorrect when recording in 24 bit quality. Macro now created by RA to return size on disk of 16/24/32 bit sample formats as 2, 3, 4 respectively as first part of a fix, but Audacity does not currently record in 24 bit.
P3 Beep on completing long process is not working on many systems.
  • JC: Beep is using the wxWindows function wxBell(), which on some systems uses an internal speaker and does nothing on others. wxBell() seems only to call the system noise from pre-sound card days, not one of the system WAV files. This system noise is often reported to be inaudible when called by wxBell().
P3 (Windows only) (GSoC) The slv2 library needed for LV2 support does not build.
P3 (Windows only) Welcome Message: Some screen readers that otherwise work well with Audacity cannot read its text.
P3 (Mac only) Portable settings aren't picked up, and the default settings (in the default location) are always used.

P4 / P5 Other Issues (not Release Noted)

P4 Minimum and maximum frequency display in Spectrograms preferences don't work for spectrum log (f) view.
P4 Clipping detection may be inconsistent. RA: The same audio data seems to give different clipping indications from Analyse > Find Clipping, View > Show Clipping and the red marker at the top of the VU meters.The latter also sometimes hit red at start of playback regardless of the actual audio level. GA: Much of this may be because Find Clipping (by default) and the VU meters require a run of three consecutive samples to flag clipping, whereas View Clipping will flag single sample clipping.
P4 When using disallowed shortcuts during playing or recording with "select-all-on-none" enabled, audio is selected. All the project audio is selected when playing, or that from the recording cursor to zero if recording. If you had a selection region, it can't be restored in any way.
P4 (Mac only) CoreAudio crash when input device's sample rate is 44100 and the output device's sample rate is 48000.
P4 $ (Mac only) Crash on restart (or possibly when first grabbing noise profile) when noisegate.nrp is present (having been written and saved in Clean Speech mode). MJS fixed this and fix works on Windows and Linux but has never been tested on Mac.
P4 (Mac only) Envelope points do not restore properly when reopening a saved project -see here .
  • BP: Reproduced on 1.3.3 - 10.5.1, PPC iBook G4 on 28 Mar 08, but *not* on Intel Mac
  • GA: Should be tested with CVS HEAD and PPC, and escalated to P2 if confirmed?
P4 [LL] (Mac *and* Linux only) Random bits of silence occur during recording (Jack and non-Jack versions of this problem).
  • JC: Progress: Udo tried smaller blocksize in linux/jack version of this problem and can now fault after 4 mins. Perhaps small blocksize will help us track down the problem on non-Jack set ups too. However, perhaps Udo's progress is only relevant to using Jack and no help to Mac? And this problem does not occur consistently on a given system?
P4 (Linux only) After opening a sufficiently long audio file, opening a second file of any size leads to locked GUI/console messages until first file completes play. Reported by Michael Schwendt on Fedora 8 test rpms of Audacity CVS from 11 Jan 08 and Jim Cline on Debian 31 Jan 08.
  Expression 'ret' failed in 'src/hostapi/alsa/pa_linux_alsa.c', line: 1034
  Expression 'AlsaOpen( hostApi, parameters, streamDir, &pcm )' failed in
  'src/hostapi/alsa/pa_linux_alsa.c', line: 1066
  • GA: Should probably be promoted to P3 if this is replicable on other distros.
P5 "Audacity projects" filter in File > Open shows zip files in the file list. Regression on 1.2.6.
P5 Edit > Move Cursor > to Selection Start or .. to Selection End leaves the selection in situ and does not display the cursor. The equivalent left/right arrow keys work as intended.
P5 Debug Log window and Help > Index... browser do not escape.
P5 Memory leak in Effect::CountWaveTracks that could cause problems. Reported by LL.
P5 Firefox does not interpret "#" character in inner text URLs. For example the link to "Super" (http://www.erightsoft.com/SUPER.html#Dnload ) does not go to anchor.
P5 Links from built-in text to Wiki to be locally over-ridable in the same way that links from built-in text to external html files can be. This way we can have a local copy of the relevant Wiki pages, if we want to.
P5 Generate effects do not fit in window, whereas opening and importing audio does. Regression on 1.2.6, and presumed undesirable for most users. Serious nuisance if you want to create very short tones for analysis.
P5 Dependencies Dialogue: If click on "Copy Selected Audio Into Project" in error, the copying cannot be cancelled from the progress dialogue.
P5 Re-enable file writing within Nyquist so that Nyquist plug-ins can remember user settings. Be careful about permissions with file writing, and whether and when we allow over-writing of existing files. Needs someone with detailed LISP knowledge to look at it. Assumption is that we need to re-enable code intentionally disabled, not write new code.
  • JC: xlisp functions such as xwrchar, xprint and xopen :OUTPUT seem to be already present and correct. Can't find disabled code. DS hypothesises it is code missing in 'the bridge', whatever that is.
P5 When writing a file as a result of a Nyquist prompt, file either is not written or is written to a location that is not asked for. See here  for details.
P5 (Windows only) Timer Record progress dialogue reappears underneath programs restored to the desktop after hiding the dialogue with "Show Desktop". Also the progress dialogue ought to disappear with the WIN + M equivalent shortcut, but doesn't.
P5 (Linux only) Reproducible (but not entirely consistent) crashes reported when using Undo command. Reported by Darren on Ubuntu Gutsy 7.10 with 2.5 GB projects. Also, adding a Label Track in any projects causes Edit > Paste to flicker (the code does currently enable it), then closing the Label Track causes a crash every time irrespective of the actions taken before.
  • GA: None of these crashes are reproducible on Windows XP, but retained on "Watching Brief" just in case (it could affect Mac as well?)
P5 (Linux only) Recovery action if project rate not supported by card. OK on Windows.
  • GA: What does this mean exactly? Is it that the project rate is not remembered when recovering as reported on -devel list in May 2007? As at May 08 it is set on Windows.
P5 (Linux only) Miscellaneous OSS crashes.
  • Crash reported by SIEGERSTEIN: 'failed in 'src/hostapi/oss/pa_unix_oss.c', line: 1206'
  • Mihail's issue: PA19 uses oss; without load/compile oss support in alsa (snd-pcm-oss), Audacity crashes on init PA19.
  • GA: Are these still replicable or are they fixed with the PA updates?

Not aiming to do for 1.4.0

This has moved to release checklist not aiming for 1.4 and now includes former "Aim tos" from this page. Many of these "Aim tos" are relatively small items but could nonetheless make a worthwhile difference for the time involved. Please do not forget them.

If you claim ownership to items in "Not Aiming", please cut them from that page and park them here: