Difference between revisions of "Release Checklist"

From Audacity Wiki
Jump to: navigation, search
(Essential fixes)
(Essential fixes: remove show clipping - it works on Linux as well now)
Line 42: Line 42:
 
   
 
   
 
* Recording from a USB device such as turntable or external sound card gives "error opening sound device" on Windows XP machines.   
 
* Recording from a USB device such as turntable or external sound card gives "error opening sound device" on Windows XP machines.   
*'''$''' "Show Clipping" makes Audacity freeze when enabled with longer tracks (typically, in excess of 10 - 20 minutes). <font color="green">Fix written that uses the already available waveform min/max data rather than have it examine every sample. Works fine on Windows and OS X.  Awaiting confirmation on Linux before clearing.</font> 
 
 
* Recovery of projects is broken with more than 1 project open (on Windows at least (I don't see why the source of the bug should be platform specific; it may be that it only manifests itself on one platform due to what order wxDir enumerates files)), resulting in the wrong number of open projects when you recover.  Non-recovery of some tracks is due to the period of autosaves being limited.
 
* Recovery of projects is broken with more than 1 project open (on Windows at least (I don't see why the source of the bug should be platform specific; it may be that it only manifests itself on one platform due to what order wxDir enumerates files)), resulting in the wrong number of open projects when you recover.  Non-recovery of some tracks is due to the period of autosaves being limited.
 
I think I've fixed this.  Thought process and steps to reproduce below. (MJS)
 
I think I've fixed this.  Thought process and steps to reproduce below. (MJS)

Revision as of 16:12, 27 January 2008


These are all for 1.4.0 release. There has been a 1.3.4 beta release, and there will likely be a 1.3.5 release before 1.3.6 as a 1.4.0 candidate.

To take ownership of an issue, add your initials before it like so:

  • [DM] for Dominic Mazzoni
  • [LL] for Leland Lucius
  • [JC] for James Crook
  • etc...

This is a companion list to the Documentation Checklist.


  • Most items added as "Essential" or "Priority Aim-to" should be added to Known Issues unless there is reason not to.
  • Please ensure items on this page which have been cleared are moved to our new Release Checklist Done page, and where appropriate, moved down to the "Cleared in CVS" section of Known Issues.


Please also refer regularly to these pages:

Wording, where we track suggested changes to the exact words that appear on a dialogue

Pending website changes where we post suggested changes to our audacity.sourceforge.net and audacityteam.org sites (except the Wiki).

Unless indicated by discussion against particular items, these should be regarded as needing attention. When processed, please move them to the "Done" section of those pages.


  • There is also a page here where we discuss ideas for developing both this Wiki and the Manual Wiki, and monitor their progress. This includes security issues, bug fixes and enhanced functionality through installing additional extensions.


Essential fixes

Fixes are the top category, since it is difficult to estimate how long bugs will take to fix. See a discussion of what constitutes essentials on the discussion page.

Any items marked $ are believed fixed, awaiting testing

Once these essential items are cleared, please use any time remaining to clear the blue-marked items in the Priority Aim to section, which will otherwise need release noting in 1.4.0.

  • Recording from a USB device such as turntable or external sound card gives "error opening sound device" on Windows XP machines.
  • Recovery of projects is broken with more than 1 project open (on Windows at least (I don't see why the source of the bug should be platform specific; it may be that it only manifests itself on one platform due to what order wxDir enumerates files)), resulting in the wrong number of open projects when you recover. Non-recovery of some tracks is due to the period of autosaves being limited.

I think I've fixed this. Thought process and steps to reproduce below. (MJS)

  • Steps to reproduce (before) or see it does not happen in HEAD:
    • Launch Audacity under VS8
    • Generate > Tone at 1kHz, 20s (call this track 1)
    • File > New
    • Generate > Tone at 2kHz, 20s (call this track 2)
    • Tracks > Add New > Audio Track
    • (Optional step) Wait for 5 minutes (or whatever you have the 'Auto save interval:' set to in prefs).
    • Generate > Tone at 3kHz, 20s (call this track 3) or do some other edit.
    • Stop Audacity with the Stop Debugging button of VS8
    • Restart
    • Recover the 2 projects offered
    • You should get just what you had before. You can check which audio was recovered by looking at the frequency with either Spectrum view or Analyze > Plot Spectrum... . I only see track 3 if I follow the optional step above, since the .autosave file hasn't been updated. This is a feature, not a bug - if 'autosave' happened too often, it would use up all your resources.
      • AutoRecovery was iterating through the AutoSave directory, reading and recovering projects (which involves creating a new autosave file), then deleting the old autosave file. At the end it read one it just created and made another project. So the extra one was always the same as the first one (that checked out, according to the limited notes I made). I think it's fix now.

Essential changes

These are other changes to source code that are deemed essential. We will do all of these for 1.3.5/6 or 1.4.0 release as noted below.

  • Help/Manual issues. These are needed for when we release 1.3.6:
    • Script to extract html help from the Manual Wiki.
    • Installer to be modified to also install Html help.
    • Address documentation issues, including website updates.
    • For 1.4, "completing the Manual". Needed before we can release any versions of 1.4.
  • For 1.4, finalise the default additional plug-ins provided with Audacity and make them available on all platforms. No special action is needed on Linux for Nyquist plug-ins, as any *.ny plug-ins from the plug-ins dir are installed, except those deleted when the tarball is created using scripts/maketarball.sh. This should be the contents of the Audacity Plug-Ins folder after a fresh installation on Windows or Mac:
    • beat.ny
    • clicktrack.ny
    • crossfadein.ny
    • crossfadeout.ny
    • delay.ny
    • equalabel.ny
    • GVerb.dll ++
    • Hard Limiter.dll ++
    • highpass.ny
    • lowpass.ny
    • pluck.ny
    • rissetdrum.ny
    • sc4.dll ++
    • SilenceMarker.ny
    • tremolo.ny
    • vocalremover.ny +++
    • vocoder.ny
    • (Under discussion: should we add a chorus plug-in? We have a Nyquist flanger/chorus plug-in available for review, or should we port the simpler multivoice_chorus_1201.dll from the Steve Harris LADSPA set to Win and Mac?)
Notes:
++ These are not in source code but VJ and LL normally include them in Windows and Mac release builds
+++ not in source code currently. GA will resubmit a version for committing.


Essential fixes: Platform Specific

I put these in a separate category as we could be 'Windows 1.4 ready' but not 'Mac/Linux 1.4 ready', if these are not cleared.

Mac

  • Fix: Mac CoreAudio crash when input device's sample rate is 44100 and the output device's sample rate is 48000.
  • Fix: Mac OS X crash on recovering files. Is this only a Mac issue, and if so do we have any idea why it is Mac specific? I think there are two issues 1) a freeze on Intel Macs (2) a non-crash situation on Intel and PPC where you recover, receive a "junk after document" warning and are presented with empty tracks. See here  and contact GA if you want an example auto save file and _data folder
  • Problem with inability to launch Audacity on non-admin accounts on Network Home ( see here) and on managed accounts - see here .
  • Test MJS's fix for: Fix crash on restart when noisegate.nrp is present (the nrp only seems to be written when in Clean Speech mode). Crashing on launch replicable in 1.3.3 on Windows and Linux when CleanSpeech enabled and .nrp present. Possibly related crashes reported on Mac when starting Noise Removal (1.3.2 on Windows crashes in this way - not on launch - when in CleanSpeech mode with nrp file present). See here  for more details. MJS's fix seems to have worked to stop crashing on Windows and Linux. Still needs testing in a new OS X build. NRP file has its own directory in the user's folder for application data - need to make make sure it actually gets written there. NRP file still only written for CleanSpeech mode at present
  • The old issue of envelope points not restoring properly when reopening never quite seems to go away on Macs -see here . MJS made some fixes for Windows. Perhaps they help here too?

Mac *and* Linux

  • [LL] Fix: Random bits of silence during recording (non-Jack version of this problem). [Mac only?] Progress: Udo tried smaller blocksize in linux/jack version of this problem and can now fault after 4 mins. Perhaps small blocksize will help us track down the problem on non-Jack set ups too. However, perhaps Udo's progress is only relevant to using Jack and no help to Mac?

Linux

  • Reproducible problem reported by Michael Schwendt on Fedora 8 test rpms of Audacity CVS from 11 January 2008. "Open..." a sufficiently long audio file, start playback. then while playback is still active, "Open..." a second file of any size. Audacity GUI is locked for a long time. A long series of messages on the console is printed until playback of the first file is nearly done. Then everything returns to normal.
    Expression 'ret' failed in 'src/hostapi/alsa/pa_linux_alsa.c', line: 1034
    Expression 'AlsaOpen( hostApi, parameters, streamDir, &pcm )' failed in 'src/hostapi/alsa/pa_linux_alsa.c', line: 1066
    This could be demoted to a lower category if other Linux users can't reproduce it
  • Reproducible (but not entirely consistent) crashes reported by Darren on Ubuntu Gutsy 7.10 with 2.5 GB projects when using Undo command. Darren further reports that adding a Label Track in any projects causes Edit > Paste to flicker (the code does currently enable it), then closing the Label Track causes a crash every time irrespective of the actions taken before. None of these crashes are reproducible by Gale on Windows XP, but retained on "Watching Brief" just in case (it could affect Mac as well?)
  • Fix: Recovery action if project rate not supported by card. OK on Windows.
  • Support for OSS not functional (crashes). If we are releasing the tarball, as it looks like we will at least as beta, how do we address this? Do we need better release notes, something in the build system or what? We don't want zillions of repeat reports of a known limitation, or Linux users wasting their time trying to make Audacity do something it won't.
    • OSS issue/crash reported by SIEGERSTEIN: 'failed in 'src/hostapi/oss/pa_unix_oss.c', line: 1206'
    • Address Mihail's issue: PA19 uses oss; without load/compile oss support in alsa (snd-pcm-oss), audacity crashes on init PA19.

Watching Brief

These are issues which are inconsistent. They seem to come and go, or seem to appear on one machine but not another on the same or similar platform (e.g. Windows 98 versus XP). We keep them here to remind ourselves of them. When we ask our first round of testers for testing, we'll ask them that if they see such problems to note the exact scenario.

  • Force quit Audacity to test crash recovery ability, and if an unforced crash occurs try to note down at once the steps that preceded it, and note if recovery does not work. Problems are already known where crashing with two tracks open leads to multiple projects being recovered (essential); and where if a track is imported then another added after the autosave interval, recovery fails (priority aim to). Complete recovery failures (empty projects) have also been seen on single tracks which are only generated tones.
  • Test Chains extensively because we are unsure what problems there may be. Check especially for effects where requested parameters are not implemented in the exported file, or not correctly remembered after restarting Audacity.
  • Mac: open a few 1.2.x projects to see if a crash occurs, but believed no longer an issue
  • Mac: Force a crash, recover, then start and cancel any process and items in Audacity menu are unavailable. LL but can still reproduce this on Intel Mac and PPC on OS X 10.4. See: How to reproduce . Hardly anyone else can reproduce it, and there is no obvious fix. If it remains isolated on particular machines then it will remain as it now is, merely release noted.
  • Watch out for Undo or other actions e.g. removing a Label Track causing a crash in clean or unsaved projects which have not crashed (reported by Darren on Linux). See Linux-specific issues. Gale has tested these issues on Win XP and completely failed to reproduce. This may be a Linux only problem.
  • Keep an eye on Help > Audio Device Info for devices that wrongly report "0" channels, any behaviour in Audacity that is affected by this and any changes that occur in Audio Device Info when switching devices. Release versions of 1.3.4 have an issue where the slider in Advanced Mixing Options jams when exporting WAV/AIFF if the selected output device is reported as having "0" output channels. CVS fixes the jam by treating "0" channels as "2" but this does not fix the misreporting on a device that otherwise seems to work. GA found in 1.3.4 release that switching to an output device reporting "2" output channels freed the slider, and the slider remained free when switching back to the device previously reporting "0" channels, because it then reported "2" channels correctly.
  • All toolbar buttons completely unresponsive and have no effect on one Windows XP machine but not the other (reported by Gale - happened twice, does not necessarily resolve after reboot and no abnormal CPU or memory usage evident when it happens). Also test for sticking Control Toolbar buttons on Mac (often reported in 1.2.5/6 but usually better in 1.3.x).
  • Some reports on Windows that after running Find Clipping, Audacity is always slow or liable to freeze thereafter, even after restarting the computer or after reinstalling 1.3.4. One comment suggested that deleting audacity.cfg fixed the problem. Should be tested on a 10 minute or longer track.
  • Where user has a multiple real playback and recording devices, not possible to scroll down through complete list in Device Toolbar using keyboard. Reported by GA on Windows XP where scroll won't go beyond Modem line#0. Could be related to Audacity problems when encountering devices with no associated mixer.
  • Nyquist generation plug-ins don't give the correct time generation. David S on Win 98 finds a 3 second pluck generates 8.5 seconds, for GA on XP it generates 2.756 seconds and GA finds all Nyquist generation is shorter than it's supposed to be by about 8.14%
  • Windows: Watch for speaker and mic backgrounds in Device and Mixer Toolbar being black or wrong colour, especially on Windows 2000
  • Envelopes have been a major source of problems in the past. In particular, look for when you split a track that contains envelope edits, there may be no end points on a 'split', leading to envelope changes on a 'split'. GA is finding this problem intermittently on Windows XP SP2. MJS can only reliably reproduce it by zooming into sample level, put in an envelope point and then a split within 1.5 samples to the right (about 34 microseconds). It could be looked at after 1.4. Also keep an eye open for error cases that have not yet been covered, and report them. If problems are no worse than in 1.2.5. we may use as is, but we may want to release note them so that people know what to expect.
  • Windows: Intermittent failure to detect playback and recording clipping noted on one Windows XP SP2 machine, currently no longer reproducible (GA to report if recurs)
  • Windows:Intermittent failure to snap shifted tracks or dragged selections on one Windows XP SP2 machine (this is a consistent problem, it works only about every other time Audacity is launched)
  • Keep an eye out for autosave files that open incorrectly for example due to mismatched tags. Autosave files themselves don't have or need a matching </project> tag because Audacity adds this when saving the project, and because the </project> tag would have to be removed and added back at the bottom when the autosave file was added to.
  • Keep eye out for abnormal silence added when exporting selection as MP3 - see Bug 271. Possibly related problem found in 1.3.3 released build with silenced audio in MP3s when exporting multiple with labels. See steps to reproduce. Repeating this test when exporting multiple with tracks instead of labels gives a normal export, as does Export Selection as. None of the above problems yet replicated in CVS. Should be added to Beta 1.3.4 test notes to look out for if not resolved.
  • Unduly slow MP3 export compared to 1.3.2. Confirmed by GA on an older 1.6 GHz 1 GB RAM Win XP single machine, MJS did not see the problem on a faster dual core machine, nor GA on a faster XP machine. Thread and user complaints about it here .
  • Unduly slow processing of AutoDuck - GA finds on one Windows XP machine that processing consistently takes 16 - 20 times the length of the audio.



Priority Aim to

These are items which were in the aim-to list which are being prioritised. None of them are show stoppers which can hold up the release. Items which are still in this list at time of release will in all probability be noted in release notes, so there is an incentive to clear them if we can.


The following items have all been marked for release-notes. Of these we should try to clear the ones marked in blue which are deemed to be the most important ones to clear if time is available before help and translation issues are resolved. "Standardising all generators at 0.8 amplitude" and two "label pasting" issues (currently in the section "not marked for release notes") are also in blue. The first issue needs one remaining Nyquist plug-in to be fixed, and the pasting issues could be a significant irritation for some users.

Items marked with a '$' are believed cleared, waiting confirmation.

  • For all effects except Equalization, focus is lost to the main project window after preview, which is an issue for keyboard users (regression on 1.2.6)
    • m_pEffect->Preview();
  this->SetFocus();      <- new bit

in all the effects would fix this, but a fix in Effect::Preview() would be better, if somebody can figure out how to do it (I've tried and failed). This 'easy' fix would only take a few minutes. (MJS)

  • Pressing Play (but not spacebar) in a second project when another is already playing stops playback of the first project (is a regression on 1.2.6)
  • IE or Firefox not brought to top (on some Windows machines) on help system invoking external browser.
  • Links from built-in text to wiki to be locally over-ridable in the same way that links from built-in text to external html files can be. This way we can have a local copy of the relevant wiki pages, if we want to.
  • Speaker and Mic icons display with wrong coloured backgrounds in mixer and devices toolbars. Win 2000 issue? GA:This problem is not seen on my Win XP system - any idea why not? It is not a problem on Linux either, according to RA. JC: Seems to be a wxBitmap issue, not a theming issue. May be a machine/timing specific bug in when things get cleared and when repainted. Demoted from 'essential' as now believed to be a hard to track down bug, intermittent (some machines not others with the same exe), and not a newly introduced bug. Marked on Documentation Checklist to be release noted as a Windows 2000 issue at least. It does this on Win 98 laptop as well, with an exe that was fine on XP. Look like a bit-depth problem to me, but I can't go below 16-bit on XP and I don't have my laptop with me. MJS.

  • Fix: When you close all your tracks and File > Save or Save Project As.., no warning is given. Save Project As.. with no tracks open is legitimate if there have never have been any changes, so it's suggested the warning should be given only if there is an Undo history. Promoted from standard "aim to", as currently there is no protection in place for the user inadvertently saving an empty project.
  • $ Select-all-when-none wherever a selection area is valid is not enabled for Edit > Cut and Edit > Copy. Believed fixed. Works fine, but we'll clear together with the item below
  • $ Ensure other edit menu items (not just cut and copy) are consistently enabled and work consistently. See here . Believed fixed. However is it really what we want? E.g click split-new twice, and we get four tracks. Is it not less confusing to leave it greyed out?
    If you turn off select-all-on-none, select an area and "Split New" twice, you also get four tracks, so I think it is what we want. Now, if you have a track selected with no time area selected, nothing on the clipboard and click the Edit menu, all the edit menu is enabled except Paste. That's fine, if someone hits some item that has no meaning when all is selected like Split, Join or Trim, they just get the whole track selected which is arguably more useful than nothing happening, and we don't grey those items when all is selected with select-all-on-none off anyway.

    However ,if we click outside the track(s) so that none are selected, we lose ability to click on all of these (including ones that have no purpose with select all):

    -Split Cut
    -Trim
    -Delete
    -Split Delete
    -Silence
    -Join
    -Disjoin
    -Duplicate
    -Find Zero Crossings

    yet we could still Cut, Copy and Split (FWIW) and Split New. I think that will be very confusing as it's a halfway house between Select-all-on-none and not. So I think what I would like to clear these two items is for all Edit menu items to be available (except Paste if there is nothing on the clipboard) even if no tracks are selected.

    PS There is also File > Export Selection to consider which behaves like some of the Edit menu items above i.e. it is greyed out when clicking outside the tracks. You might I suppose make a case just for this and Selection Save being greyed out when no audio is selected, even with select-all-on-none "on". But it would be more consistent if they simply were enabled whenever a selection is valid, like Edit > Copy. - Gale
  • Fix: Old projects open incorrectly - reported by Monty. With CVS Head, sample project created in 1.1.0 now correctly identifying the real orphans (there are 10), but the waveform is still opening as blank. Needs more investigation. GA tried a 1.1.3 Project with envelope edits in 180907 build and it opened fine. There are no envelope points, but there aren't any after saving/reopening the Project in 1.1.3 either.
  • Project irrecoverable after crash if a track is imported then another track of *any* description is added after the autosave interval (even a recorded or Label Track). The problem is that when the second track is added to the updated autosave file, "_data" in "projname" is prepended with the name of the first imported file (what you see in the Audacity title bar). After that the project is irrecoverable, until you change the "projname" back to "_data", then it recovers perfectly. Must be release noted if not fixed, as users often delete files once they are imported into Audacity.
  • Beep on completing long process is not working on Windows XP and 98 for GA and DJS respectively. If not fixed, problem should be release noted. Beep is using the wxWindows function wxBell(), which on some systems uses an internal speaker and does nothing on others. Changing to a user selected sound or other way of producing sound is probably not sensible for 1.4. Release noting is best.--JC wxBell() seems only to call the system noise from pre-soundcard days, not one of the system WAV files. This system noise is often reported to be inaudible when called by wxBell(). As it seems this can't be fixed for 1.4, have marked to release note this on Documentation Checklist [GA]

  • Fix: Make all platforms consistently force Project Rate to the rate of imported file irrespective whether that rate is supported or not. Currently this does not work on Windows and results vary on Linux. Is Michael's issue "1.3.3-beta and newer fill the "Project Rate" combo box with several invalid frequencies, most likely picking them from a hardcoded list without making sure the audio hardware can handle them" related? When done, add a Preference to always have Project Rate remain as per its Default Sample Rate Preference setting irrespective of the file being imported (this is currently "not aiming for 1.4.0").
  • Strongly consider re-enabling PA19 automatic latency correction. If not re-enabled, then what should default correction be? MM thinks it should be zero (as now) given the "audio to buffer" default is 100ms , but GA thinks that means that almost no-one will get their tracks aligned without setting the latency correction in Preferences, and that this would be a regression on 1.2.x where people quite often do get their tracks aligned without needing Time Shift Tool. Users of 1.3.3+ quite widely believe latency correction "does not work" where it used to in 1.2.x (see Help list and Forum archives). It seems to me users will almost always need to go into Preferences if they want synchronised tracks without using Time Shift Tool (because current set up is no automatic correction enabled and Preferences default set to no correction).-GA
  • Tag import / export is near complete for MP3 but otherwise incomplete, and in places non-orthogonal. See description on Known Issues. This is not now language-dependent, and no issues which were regressions on 1.2.6 remain. Some known specifics: 1) Audacity "Year" MP3 tags not seen by Windows Media Player or Winamp, and "Year" OGG tags not seen by Amarok on Linux, or VLC on Windows or Linux. 2) No FLAC tags are seen by VLC on Windows or Linux. 3) WAV fields only seen patchily by other apps. as their support is patchy, but Genre tag consistently not seen though it is a valid WAV info tag. Gale: Are we using ID3 V2.4 or 2.3? With the two main Windows players not currently seeing the Year tag, we may have a big reason for users not to upgrade from 1.2.6. Can we use v2.2 where WMP and Winamp see the year tag? Update: Leland I believe thinks we can't hack further back than 2.3. The problem seems to be that Windows Explorer/Media Player and Winamp currently expect a frame called "TYER" to indicate the year of the recording. ID3v2.3 seems to recommend passing year as the "TDRC" frame in preference, which is what lame_enc.dll does, resulting in the Winamp/WMP problem. But if you use LAME.exe 3.97 for command line export and force ID3v2.3 with "--id3v2-only", "TYER" is used and WMP and Winamp have no problem. So is it possible to use "TYER", and is this less bad than the current situation?
  • Creating a temporary directory with a predictable name causes a freeze after stopping recording if directory ownership is changed before running Audacity. Steps to reproduce : 1. create the directory /tmp/audacity1.2-$LOGNAME using some different user, and change ownership of that directory 2. start Audacity 3. hit the record button 4. hit stop.
  • The current temporary-directory-name behaviour is a potential security risk as it could be exploited by malicious, local users to delete arbitrary files and directories by a symlink attack. Fixing by creating randomly generated temp directories at runtime is not feasible because Audacity needs to find the temp directory to recover data after a crash. A possible (but not simple) solution would be to require that the directory is owned and only accessible to the user running Audacity, and put some sort of symlink check in. The problem is that all of these are likely to be platform-specific and so messy to implement in a portable way. JC: Linux/Mac specific (no symlinks on Windows). Not a regression on 1.2.6. Security risk is of way lower significance than (say) buffer overflow issues in browsers/mail clients. I'm not convinced that this actually allows anyone to escalate their rights - though it may depend on how Audacity is installed (e.g. if the user installed Audacity themself, they don't get escalated rights). Do we need an advisory on what owner/group settings should be for Audacity installations? Alex has remarked that "Windows Vista supports symbolic links for both files and directories with the command line utility mklink by what is called an NTFS junction point" - Gale


These ones are not currently marked for release noting:

  • Change the default amplitude to 0.8 for the Nyquist generators in the release builds that have 1.0 amplitude. This is necessary as generation at 1.0 amplitude shows clipping in the waveform if Show Clipping is on. Gale: I presume then we can't/don't want to take the other route and fix the clipping instead? JC: The clipping code needs to be conservative and declare clipping when the waveform is at 0.999999. In my view the clipping code is not broken and shouldn't be changed to 'fix' this. I've found that brown noise at 0.8 amplitude actually creates occasional clipping, and I think this is OK. It's a statistical effect of the kind of noise that it is. Update: Rissetdrum.ny now fixed. Pluck.ny will have to be attenuated to 0.5 to ensure there is no clipping - GA has this in hand. Is the better solution to change Show Clipping so it only detects a run of three clipped samples like the meters? If we do this, the clipping with our built-in generators mostly would not show (it still would with a square wave tone).
  • When selecting a region over a label and cutting or copying, ensure label text, not the system clipboard content, is pasted into the text of the label (this is a regression on 1.2.6, and the 1.4 manual would need amendment if we can no longer cut/copy and paste multiple labels except by means of the Label Editor). System clipboard seems to get pasted because creating a label enables Paste in the edit menu (though this does not consistently happen, and Darren's observation of Paste flickering on Linux might be tied in with this).
  • When selecting a region over a label that denotes a selection area and cutting or copying, ensure the pasted label is of the selection region, not a cursor point (this is a regression on 1.2.6)
  • Generate effects do not fit in window, whereas opening and importing audio does (regression on 1.2.6, and presumed undesirable for most users. Serious nuisance if you want to create very short tones for analysis).
  • Dependencies Dialogue: If you click on "Copy Selected Audio Into Project" in error, the copying cannot be cancelled from the progress dialogue. This can probably be left for after 1.4 unless it's an easy fix
  • Re-enable file writing within Nyquist so that Nyquist plug-ins can remember user settings, but be careful about the permissions with file writing, and whether and when we allow over-writing of existing files. Needs someone with detailed LISP knowledge to look at it. Assumption is that we need to re-enable code intentionally disabled, not write new code. JC says xlisp functions such as xwrchar, xprint and xopen :OUTPUT seem to be already present and correct. Can't find disabled code. DS hypothesises it is code missing in 'the bridge', whatever that is.
  • When writing a file as a result of a Nyquist prompt, file either is not written or is written to a location that is not asked for (the same one that Audacity was using to write noisegate.nrp to before it was fixed). See here  for details.



Aim to

  • Generate tone in a new project, close track using "X" in the Track Panel, generate another tone, then Edit > Undo. The timeline is incorrectly highlighted with the former selection area.
  • Compressor attack and decay times produced are much shorter than those selected in the GUI.
  • Adjacent tracks of a split stereo pair are not seen as a stereo unit when running Nyquist effects. This is a nuisance when the effect only works on stereo tracks, as an error is thrown although to the user they have a legitimate stereo track where built-in effects work on both channels.
  • "Disk space remaining" calculation when recording 24 bit is identical to 32 bit. Not actually a regression on 1.2.6 which has the same issue.
  • Try to remove all un-necessary (or all) "Disallowed for some reason - try selecting some audio first?" error messages". Two known cases where it occurs: (1) using shortcuts which are not valid at time of use e.g. CTRL + V with empty clipboard (2) Unmodified ENTER on any selected Toolbar button
  • Add a Preference for "Label typing:" or "Labels:" - "Standard" (CTRL + B only required if label is at same place as an existing label) or "Manual" (CTRL + B always required).
  • Internal help browser - Keyboard back button does not work
  • Internal help browser - Ability to pin or keep the help browser on top, and ability for it to remember its resized position.
  • Internal help browser - Some will miss the tree I expect from 1.2.x help. Maybe longer term we should build into our Wiki pages conventional links back to the main parts of the structure. Could be generated automatically. Not a good thing to do by hand
  • Welcome Screen - what should be the best behavior when clicking a link to installed local text but Preference is "From Internet"? At the moment it opens the local file in the help browser. Maybe better it should open the file in web browser? Or redirect to the Wiki web site, just as the help browser redirects to the Manual Wiki web site when "From Internet" is chosen?
  • See if Welcome screen can have better screen reader support - currently JAWS and NVDA  (both Windows) cannot read it, but Window-Eyes can. JC: I doubt we'll ever make the browser built in to wxWidgets screen reader friendly. The best we could do is to provide some way to easily get to the same information in a standard web browser. Needs Leyland's input here.
  • In the Silence Generator, the first non-zero digit must be highlighted, not the last, both to be consistent with the other generators, and so that you can overtype more easily.
  • Discuss test harnesses. Possibly write some more test code.
  • If you "collapse all" tracks, click (but don't adjust) the resize area between the channels of a stereo track then "expand all", one or both channels of the stereo track don't expand (reported by LL).
  • $ [JC] Release a simplified.po at the same time as Audacity 1.4.0. This can give novice-wording for some features. If we use the convention that '#' before a menu item means 'hide it' could also be used to reduce the complexity of the menus - which have become rather extensive. GA: How is the simplified wording enabled in the program? JC: The least change to Audacity code is if it behaves 'exactly' like a language selection. Switching between views then happens in the same way that the windows calculator can be standard or scientific. The demand for simplified Audacity in schools is significant. This looks to be an easy way to allow a teacher to set Audacity up, and then reduce the interface so that students using it on their own have less confusion. For now I think we should aim it for that situation, rather than for newbies working on their own. Gale: I think you need to raise on devel-list. Random thoughts:
    • I think you're suggesting a reduced interface but with more "verbose" wordings? Or even more trimmed down wordings - which is the aim?
    • Can CleanSpeech be adapted for this purpose instead which might make it more generally useful (I am very unconvinced by it as it is now).
    • Have we got the time to play with wordings again before 1.4.0, and isn't what we're doing now (piecemeal) to try and make wordings both more concise and novice friendly better? Or are those aims incompatible? I don't think so unless we are saying "more than n words are unacceptable".
    • If the idea is to help novice users, is it not better to give such users working on their own machine an easy means of switching view?
      Has a bug where if you change language back from "Simplified" to "English" with en-simple folder still present, "Simplified View" still appears in View Menu until clicked on.
  • Fix: Adjusting the meter update frequency seems to make no difference whatever, whether it is 100, 30 or 1.
  • Prevent latency correction occurring when append-recording, even if set in Preferences, to prevent possibility of "real" audio being shifted behind zero. MJS fixed so that only the newly recorded section of audio is shifted. This works but if audio is truncated it is irrecoverable. GA has suggested backwards shifting only up to the point where truncation would otherwise occur. New behaviour must be documented in Manual (noted on Documentation Checklist).
  • (low priority) Latency correction dialogue should not appear twice for an unsplit stereo track
  • Fix problem when recording stereo mix from a track in Audacity, about 100ms of the recording is truncated at the end (irrespective of latency correction setting in Preferences).
  • Fix: Envelope bug where two tracks in a stereo pair can show different envelopes; they should always be the same. Also fix any sync issues of envelope editing with a stereo pair - the current implementation is prone to error if the tracks are not the same size and don't have synced envelopes to begin with.
  • Fix: Waveform (dB) display: If audio track is shrunk vertically, the horizontal marks on the vertical ruler are marked 0 at the top and 0 in the middle (instead of -36).
  • (low priority) consider greater prominence / bright colour for arrows indicating shifting behind zero.
  • Ensure grey out Edit > Split New when no audio is selected, and grey out Edit > Split when no audio tracks are open.
  • In "Save Changes?" Dialogue with empty Project, change wxMessageDialog so that the default button is Cancel, not Yes. GA: We need to remember the possible stress of such a situation for the user, which means they may not be thinking clearly or understand anyway. In the case of saving an empty project, "Yes" is the wrong and unsafe choice for default button. GA prefers to change the dialogue text from the current "To save the tracks that were previously open, click Cancel, Edit > Undo until all your tracks are open, then File > Save Project", so as to add "(highlighted)" after "Cancel". JC says if cancel is highlighted, you don't need to tell the user that it is highlighted, but GA says that is exactly what you do need to do. It provides reassurance, is the safest change for the user and keeping their data safe should be the number one concern.
  • Mute/Solo: (low priority) Add hotkey so that can unmute all and mute all from keyboard.
  • Reinstate (low priority) each importing dialogue says "file" singular, as per how it worked properly in 1.3.3 Release.
  • Timer Record needs to remember the last scheduled duration
  • Fix: (low priority) Snapping on playback region - when you enable in 1.3.3)snapping the playback region jumps to the selection, rather than snapping to the nearest points.
  • Fix: (low priority) Playback region lost. The particular scenario is setting a playback region in the ruler different to the selection, then clicking play. On completion of playback, the playback region reverts to the selection.
  • Either warn when Prefs closed with autosave turned off, or ensure that Audacity warns when restarting after crash with autosave disabled: (1) that temp files are present (2) does not let you exit without reminding of you of those files. Users experienced enough to turn off autosave aren't total newbies. Should expect that turning off autosave reduces likelihood of recovery from errors. Fix not essential. JC This does miss the point that you can accidentally turn off autosave especially if using the keyboard - IMHO though not quite essential it is very important given Audacity gives you no help at all when you restart after a crash with autosave off.(GA)
  • Reinstate ability to import multiple files from the command line into the same Project. Check if doing this results in right-click > "Open with" from a file manager changing its current behaviour, which is that import of subsequent files are into different Projects. In view of our stated comment in the Unix Manual that importing files into the same Project is convenient, consider in any case if there should be a Preference to choose behaviour when importing subsequent files, and whether the better default would be to import into the same Project.
  • Fix: Selecting inhibits movement of clip onto another track. Only if you click within the selection. Clicking outside allows you to move the clip. Also, shouldn't the selection area should get dragged with the track?
  • Fix: a track or clip can't be dragged further left or right once the time shift arrows reach the end of the screen
  • Change the yellow snapping colour (white has been suggested by DM) or allow users to choose from a limited number of suitable colours. A suggestion based on a cyan colour is here . GA delighted to help or make more mockups.
  • Springclean docs in root directory, e.g. buglist.txt - delete.
  • Ruler to use same units as selected in selection bar.
  • Use orange for high-water-bar in sound level meter, not blue. Is it not better to use orange for the RMS and red for the peak on both record and playback meters? The confusion is the red for RMS in Recording meter when red is colour for clipping in both meters (GA)
  • Fix all effects so that ALT + V always applies a Preview without having to change the effect settings first (EQ is one of the few effects where ALT + V works with the parameters that load).
  • Determine why ALT+ menubar access key doesn't work when label track has the focus.
  • Hide all warnings except the first when exporting multiple MP3s with illegal sample rate/bit rate combination.
  • Once suitable modification in place, consider a Nyquist plug-in for creating a cue sheet or possibly direct Export as Cue Sheet, as discussed with Leland (but can be moved to "not aiming" if needs be)
  • Prevent Edit > Silence removing a label, it should only silence the referenced audio
  • Ensure proper saving of exported audio file when Audacity runs out of space and warn what was done, especially on Linux (seems on Windows that a clean file is saved). Consider checking free space before starting export
  • [MM] Auto Save procedure to save strictly every x minutes to preserve changes made inside saving period. Note Autosave can only be done when no editing is going on, and no edit can be performed until auto-save has finished. Consider "Auto Saving Project" progress bar or Status Bar message to show this. Consider reducing default autosave interval to reduce risk of loss if strict time saving isn't implemented. When done, please change Preference wording to "Auto save interval every: [ ] minutes" and move this item to "Done" on Wording.
  • Fix deleting entire area of a Label track between two labels deletes the right-hand label
  • Check labels consistently allow entry of z (reported by Julian on Linux and by user on OS X 10.4.10 with released 1.3.3)
  • Check typing square brackets in labels bring up a "move the audio cursor to start/end" dialogue rather than inserting as text (reported by Julian on Linux also by by user on OS X 10.4.10 with released 1.3.3, but not apparent to GA on Windows)
  • Label text editing: Selecting part of label text by dragging with the mouse doesn't start selection at beginning of drag, but at wherever the text cursor was previously
  • Left single-clicking no longer removes cut lines and clip boundaries, but left double-clicking does. Ensure that click or double-click close to the line snaps to it.
  • Prevent Effect > Repeat drawing clip boundaries at each repeat and ensure no undo history written for each repeat.
  • [MS]Change cut line colour from red as this is now the colour for View Clipping
  • Find Zero Crossings doesn't work properly. I checked this by fully zooming the waveform horizontally and vertically so that I can see every data point. The beginning and ending points of the selection after Find Zero Crossings might be as far off as +/-0.01 (out of 1) on the vertical scale, and they are not necessarily on a positive slope. Repeating the Find Zero Crossings produces unpredictable results and sometimes results in a change in the selection and sometimes doesn't. This occurs on both 1.2.6 and 1.3.3 beta. I'm using Mac OS X 10.4.10, but the problem has also occurred on older versions of Mac OS X 10.4. (reported by Menasheh Steiglitz (( steig _AT_ cs_DOT_stanford_DOT_edu)) on audacity-users)

Not aiming to do for 1.4.0

This has moved to release checklist not aiming for 1.4 in order to make the Checklist more easily scannable again. but ones that were recently aim tos can be parked here temporarily, if there aren't too many...