Release Notes 2.0.6

From Audacity Wiki
Revision as of 06:47, 27 September 2014 by Galeandrews (talk | contribs) (Less Win/Mac-centric notice about FFmpeg)
Jump to: navigation, search
Example.png

In preparation


Audacity 2.0.6 is expected to be released shortly.
 
Related article(s):
Tip: You can use CTRL + F to search this page for different words to do with the issue you are looking for. Use Command - F on Mac.


Warning icon FFmpeg updated for 2.0.6:
Warning icon Extra notes for Windows:
  • The Windows installer for 2.0.x versions will replace 1.2.x or any previous 2.0.x installation, but install alongside legacy 1.3.x Beta versions. It is strongly recommended to uninstall previous Beta versions.
  • The language choice in the Windows EXE Audacity installer only selects the language for the installer. The language Audacity runs in is determined by the "Format" for date and time in the "Region and Language" section of the Windows Control Panel. To change the Audacity language, please see these instructions.
  • You may see the error Application configuration incorrect when launching Audacity after installation. This mainly affects some Windows XP or 2000 machines. This can be fixed by downloading and installing the appropriate Microsoft "Redistributable Package" as follows:
    Be sure to get the correct package according to whether you have 32-bit or 64-bit Windows. To check, right-click over My Computer and choose Properties. If 64-bit is not mentioned, you have 32-bit.
  • On first use of Audacity you need to confirm the new Install VST Effects dialog for detected effects before you can start the Audacity program.
  • Users upgrading to 2.0.x versions from 1.3.6 or earlier must download the latest version of the LAME MP3 encoder.

Changes since previous version

Improvements

* Interface:
  * Redesigned, searchable Keyboard Preferences with Tree, Name and Key views.  
  * Edit Menu: "Cut" and "Delete" are now in the top level of the menu.  
  * Transport Menu now includes "Play/Stop" and "Play/Stop and Set Cursor" 
     (use Keyboard Preferences to create shortcuts for "Play" and "Stop").
  * Tracks Menu now includes "Mix and Render to New Track". 
  * Track Drop-Down Menu now has Move Track To Top and Move Track To Bottom. 
  * New right-click menu choice "Delete Label" to remove single labels.
  * "Snap To" now offers choice of snap to the "closest" or "prior" position.
     Note: the previous "Snap To On" keyboard shortcut will no longer work.   
  * "Snap To" settings are now independent for each project.
* Effects:
  * Truncate Silence: redesigned with simpler option "Truncate Detected 
     Silence" to shorten to the specified length without compressing silence.
  * VST effects: New "Settings" dialog lets you specify buffer size (for 
     faster processing) and enable buffer delay compensation (to prevent
     inserted silence). Compensation may cause a crash in a few plug-ins. 
  * VST effects now support standard FXP presets.  
  * LV2 effects are now supported on all platforms (textual interface only).    
Peter 26Sep14: The Manual states FFmpeg 2.2.2 is required for "latest Audacity" and that is the version on Buanzo's site.
    "FFmpeg 2.2.2 for Windows and Mac should be used with the latest version of Audacity. The previous FFmpeg 0.6.2 for Audacity will not be recognized by Audacity 2.0.6 and later, and FFmpeg 2.2.2 will not be recognized by Audacity versions before 2.0.6." FFmpeg 1.2 will work, as it says in the instructions for Linux, but who is going to self-compile FFmpeg on Win and Mac when a ready build of 2.2.2 is available?
* Import or export using FFmpeg now requires FFmpeg 1.2 or later (or libav
   0.8 or later). For recommended downloads of recent FFmpeg please visit:
   http://manual.audacityteam.org/o/man/faq_installation_and_plug_ins.html#ffdown .
* New Tamil translation (largely complete). 
* (Windows) FLAC exports can now exceed 2 GB in size. 
* (OS X) Easier Audacity installation using the DMG: drag the Audacity folder
   to the /Applications shortcut, 
* (OS X) Audacity 2.0.6 will not officially support OS X 10.10 Yosemite when 
   released (in particular, Apple Audio Units may not open in Audacity).
* (Linux) Self-compiled builds of Audacity now search for system LADSPA 
   effects in /usr/lib/ladspa.

Bug fixes for

* Interface:
  * Region Restore did not restore the region after using Preferences. 
  * Dragging selections with the keyboard or Selection Toolbar digits 
     was very slow.  
  * (Windows) Help > About Audacity crashed when run in Magyar language.  
  * (OS X) Some full and reduced Menu Bar items were not translated.  
  * (OS X and Linux) Fixed various interface crashes.
* Effects:
  * Reverb and Paulstretch were missing from Chains.
  * Analyze > Contrast could report very inaccurate rms levels.
  * Noise Removal: Attack and decay times were half as long as set.  
  * (OS X and Linux) Nyquist effects ran much more slowly than on Windows. 
* Click or drag on the Timeline after Loop Play continued to loop.
* Transcription Toolbar did not play slower than 0.1x speed.
* (Linux) Audacity did not build if python 2 was not available.

Known Issues at Release

Headline issues

Large Projects

Projects with 2^31 samples or more (just over 13.5 hours at 44100 Hz) will not re-open correctly. Higher sample rates mean proportionally shorter times - so just over 6 hours at 96,000 Hz. We know the cause, and do intend to address this bug. Workaround: Before saving or closing the project, export to audio files of appropriate size, or cut and paste sections of audio containing less than 2^31 samples to new Audacity projects and save those.

Problems reopening, saving or crashing in projects

The following problems are very rare, but have the potential for losing data. The developers have not yet been able to reproduce these problems so please write to our feedback address if you encounter any of these symptoms.

  • When attempting to reopen the project normally:
    • The .aup project file was not saved (or incompletely saved, giving a "line number" error).
    • Audio that was there previously is silenced.
    • "Missing Audio Data Block File(s)", "Problems Reading Sequence Tags" or "Orphan Block File(s)" errors are reported. If you see these errors, please choose the options to "Treat missing audio as silence" or "Continue without deleting" the orphans.
To avoid any problems, export a WAV or AIFF file from your project before closing it, then you can import the WAV again if the project becomes damaged.
  • When working in the project:
    • Errors occur when saving the project or when Audacity autosaves, perhaps wrongly suggesting the disk is full or not writable (if this happens, try exporting the audio as WAV).
    • Unwanted renaming or moving of .au files within the project.
    • Multiple or duplicated .aup files or project folders appear within the same project.
    • Unexplained crashes or corrupted audio occurs (note this can happen if the computer is low on memory or disk space).

Please tell us all the actions you recall both the last time you had the project open and what happened this time, including error messages. We believe having multiple projects open at once, having projects open in file manager programs or long projects with many tracks are among the possible causes.

Warning icon As many as possible of the following will help us enormously if you can attach them to your report:
  • A copy of the saved .aup project file
  • A copy of the "autosave" (temporary project) file. The "autosave" file is stored inside the "AutoSave" folder in Audacity's application data folder.
  • For problems that occur when reopening or working in a project, the log file at Help > Show Log....

Effects (VST and Audio Units)