Template:All-menus

From Audacity Wiki
Revision as of 18:03, 10 April 2019 by James (talk | contribs) (Update for nyquist installation tool.)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to: navigation, search
This template has all menu images and their imagemaps in one place. It uses the parser function #switch to choose one of them to show on a page. The text of the big switch is auto generated. The net result of this is that we can change the image maps for all 56 menus by changing just this one page.

Example:


{{all-menus|menu=View}}
Zoom in/out on the horizontal axisControls the sizes of tracksMove forward/backwards through the audioBrings up the History window which can then be left open while using Audacity normallyBrings up the Karaoke window, which displays the labels in a "bouncing ball" scrolling displayMixer Board is an alternative view to the audio tracks in the main tracks windowToolbars can be used to determine which of the Audacity toolbars are displayedShows extra menus with many extra less-used commandsOption to show or not show audio that is too loud (in red) on the wave formViewMenu.png
Click for details
Click on the image to learn more


 


{{all-menus|menu=View-Toolbars}}
Zoom in/out on the horizontal axisControls the sizes of tracksMove forward/backwards through the audioBrings up the History window which can then be left open while using Audacity normallyBrings up the Karaoke window, which displays the labels in a "bouncing ball" scrolling displayMixer Board is an alternative view to the audio tracks in the main tracks windowToolbars can be used to determine which of the Audacity toolbars are displayedShows extra menus with many extra less-used commandsOption to show or not show audio that is too loud (in red) on the wave formUsing this command positions all toolbars in default location and size as they were when Audacity was first installedControls playback and recording and skips to start or end of project when neither playing or recordingChooses various tools for selection, volume adjustment, zooming and time-shifting of audioDisplays recording levels and toggles input monitoring when not recordingDisplays playback levelsAdjusts the recording and playback volumes of the devices currently selected in Device ToolbarCut, copy, paste, trim audio, silence audio, undo, redo, zoom toolsPlays audio at a slower or faster speed than normal, affecting pitchControls playback and recording and skips to start or end of project when neither playing or recordingSelects audio host, recording device, number of recording channels and playback deviceControls the sample rate of the project, snapping to the selection format and adjusts cursor and region position by keyboard inputDisplays and lets you adjust the current spectral (frequency) selection without having to be in Spectrogram viewView-ToolbarsMenu.png
Click for details
Click on the image to learn more


 


{{all-menus|menu=Edit}}
Undoes the most recent editing actionRedoes the most recently undone editing actionRemoves the selected audio data and/or labels and places these on the Audacity clipboardRemoves the selected audio data and/or labels without copying these to the Audacity clipboardCopies the selected audio data to the Audacity clipboard without removing it from the projectInserts whatever is on the Audacity clipboard at the position of the selection cursor in the project, replacing whatever audio data is currently selected, if anyCreates a new track containing only the current selection as a new clipFor more "advanced" removal of audioCreate or remove separate clips in the audio trackThese commands are to add and edit labelsLabeled Audio commands apply standard Edit Menu commands to the audio of one or more regions that are labeledThe Metadata Editor modifies information about a track, such as the artist and genrePreferences let you change most of the default behaviors and settings of AudacityEditMenu.png
Click for details
Click on the image to learn more


 


{{all-menus|menu=File-Export}}
Creates a new empty project window, to start working on new or imported TracksPresents you with a file selection dialog box to open filesLists the full path to the twelve most recently saved or opened projects or most recently imported audio filesCloses the current project window, prompting you to save your work if you have not savedSaves the current Audacity projectSame as "Save Project" above, but allows you to save a copy of an open project to a different name or locationFor exporting audio filesFor importing audio files or label files into your projectOpens the standard Page Setup dialog box prior to printingPrints all the waveforms in the current project window (and the contents of Label Tracks or other tracks), with the Timeline aboveCloses all project windows and exits AudacityExports to an MP3 fileExports to a WAV fileExports to an OGG fileExports to an audio fileExports selected audio to a fileExports audio at one or more labels to file(s)Exports multiple audio files in one process, one file for each track if there are multiple audio tracks, or labels can be added which then define the length of each exported fileExports MIDI (note tracks) to a MIDI fileAs for "Save Project", but compressed tooFile-ExportMenu.png
Click for details
Click on the image to learn more


 


{{all-menus|menu=Tools}}
The Tools Menu contains customisable toolsThe Extra menu provides access to additional Commands that are not available in the normal default Audacity menusThe Help Menu lets you find out more about the Audacity application and how to use it.  It also includes some diagnostic tools.Enable or disable particular Effects, Generators and AnalyzersCreates a new Macro or edits an existing MacroDisplays a menu with list of all your MacrosA tool, mainly used in documentation, to capture screenshots of AudacityA tool for measuring the performance of one part of AudacityBrings up a dialog where you can enter Nyquist commandstip about Nyquist Plug-in Installer...Places labels in a long track so as to divide it into smaller, equally sized  segmentsReads the values of successive samples from the selected audio and prints this data to a plain text, CSV or HTML fileReads numeric values from a plain ASCII text file and creates a PCM sample for each numeric value readThe MenusToolsMenu.png
Click for details
Click on the image to learn more


 


{{all-menus|menu=Extra-Scriptables_I}}
Extra commands related to play and recordTakes you to Screenshot tools and BenchmarkingExtra commands related to volumeExtra commands related to editingExtra commands related to play at speedExtra commands related to seekingExtra commands related to selecting a deviceExtra commands related to selectingExtra commands to set focus, usually focus on one trackExtra commands to move the cursorExtra commands to operate on a track that has focustip about Scriptables Itip about Scriptables IIToggle full screen mode with no title bartip about Select Time...tip about Select Frequencies...tip about Select Tracks...tip about Set Track Status...tip about Set Track Audio...tip about Set Track Visuals...Gets a single preference setting.Sets a single preference setting.  Some settings such as them changes require a reload (use Reload=1), but this takes time and slows down a script.Modify a clip by stating the track or channel a time within it. Colour and start position can be set.  Try to avoid overlapping clips, as Audacity will allow it, but does not like them.Modify an envelope by specifying a track or channel and a time within it.  You can't yet delete individual envelope points, but can delete the whole envelope using Delete=1.Modifies an existing label.  You must give it the label number.Sets the project window to a particular location and size.  Can also change the caption - but that is cosmetic and may be overwritten again  later by Audacity.Extra-Scriptables IMenu.png
Click for details
Click on the image to learn more


 


{{all-menus|menu=Bogus}}
This ednote will automagically be replaced by the Annotated menu Bogus.png, when it is ready