Difference between revisions of "Troubleshooting Recordings"

From Audacity Wiki
Jump to: navigation, search
(Recording cursor can be stuck in Beta due to Sound Activated Recording)
(All inputs except mic default-disabled on Vista/7)
Line 23: Line 23:
  
 
<ul>'''Exceptions:'''<P>
 
<ul>'''Exceptions:'''<P>
<li>'''Windows Vista or 7:''' The dropdown selector is always greyed out. Choose the specific input source/recording device combination required on the same tab of Preferences (for example, "Microphone: Realtek High Definition Device") then turn up the input level in Mixer Toolbar.  
+
<li>'''Windows Vista or 7:''' The dropdown selector is always greyed out. Choose the specific input source/recording device combination required on the same tab of Preferences (for example, "Microphone: Realtek High Definition Device") then turn up the input level in Mixer Toolbar. '''Note:''' By default, Vista/7 only enable the microphone input. You must exit Audacity, then go to [[Mixer Toolbar Issues#vistacp|Sound]] in the Windows Control Panel to show and enable other inputs before you can record from them.       
 
<li> '''OS X''': The dropdown selector will also probably be greyed out. Even if it isn't, you should always set up devices on Macs at {{menu|Hard Disk > Applications > Utilities > Audio MIDI Setup}}. An image of Audio MIDI Setup can be viewed [http://wiki.audacityteam.org/w/images/thumb/c/cf/AudioMidi.png/535px-AudioMidi.png here]. Click on the "Audio Devices" tab and make sure on the left-hand side that your required recording device (for example, "Built-in Audio") is selected in the "Default Input" and "Properties for" dropdowns. In Audio Input under that, set the "Source" to your physical input (for example, "Built-in Mic). Also ensure the volume slider is turned up. Set the sample rate in "Format" to the project rate bottom left of the Audacity window.  
 
<li> '''OS X''': The dropdown selector will also probably be greyed out. Even if it isn't, you should always set up devices on Macs at {{menu|Hard Disk > Applications > Utilities > Audio MIDI Setup}}. An image of Audio MIDI Setup can be viewed [http://wiki.audacityteam.org/w/images/thumb/c/cf/AudioMidi.png/535px-AudioMidi.png here]. Click on the "Audio Devices" tab and make sure on the left-hand side that your required recording device (for example, "Built-in Audio") is selected in the "Default Input" and "Properties for" dropdowns. In Audio Input under that, set the "Source" to your physical input (for example, "Built-in Mic). Also ensure the volume slider is turned up. Set the sample rate in "Format" to the project rate bottom left of the Audacity window.  
 
{{hint|On OS X 10.1 or earlier, there is no Audio-MIDI Setup: select the correct recording device and input source in {{menu|Apple Menu > System Preferences > Sound}}.}}         
 
{{hint|On OS X 10.1 or earlier, there is no Audio-MIDI Setup: select the correct recording device and input source in {{menu|Apple Menu > System Preferences > Sound}}.}}         

Revision as of 18:01, 29 October 2010

This page explains how to troubleshoot common recording problems by identifying the symptoms of the issue then fixing its cause.

For more general advice and information on all aspects of recording, see our Recording Tips.


No waveform being recorded

If the red recording cursor moves across the screen but no waveform (only a flat line) is drawn behind it, you need to start from the beginning and set up your recording device and input source properly.

First: Explicitly select the Recording Device you are using in the Audio I/O tab of Audacity Preferences (Devices tab in current Audacity Beta). If you are plugging a microphone or line-in input directly into the jacks on the computer, or recording computer playback such as internet radio, this will probably be your built-in sound device or sound card. If you are connecting an external device to the computer, such as a USB sound card, microphone or turntable, the "Recording Device" will appear as "USB Audio Codec" or similar. Do not choose "Microsoft Sound Mapper" or "Windows DirectSound" if you are on Windows.

Detecting USB and Firewire devices: If Audacity does not recognise the device, try exiting Audacity and relaunching it. If that does not help:
  1. Exit Audacity
  2. Unplug all other USB devices, then switch off and unplug the recording device at the USB connection and at the mains (on Windows, use the "Safely Remove Hardware" icon in the System Tray)
  3. Plug the recording device into a spare USB port (not a USB hub), and switch it on
  4. Wait a few minutes then completely shut down the computer and restart
  5. When the computer has finished rebooting, relaunch Audacity


Second: Choose your required input source (such as microphone or line-in) in the dropdown selector of the Audacity Mixer Toolbar, then turn up the input level using the slider to left of the dropdown that has the "microphone" symbol.

    Exceptions:

  • Windows Vista or 7: The dropdown selector is always greyed out. Choose the specific input source/recording device combination required on the same tab of Preferences (for example, "Microphone: Realtek High Definition Device") then turn up the input level in Mixer Toolbar. Note: By default, Vista/7 only enable the microphone input. You must exit Audacity, then go to Sound in the Windows Control Panel to show and enable other inputs before you can record from them.
  • OS X: The dropdown selector will also probably be greyed out. Even if it isn't, you should always set up devices on Macs at Hard Disk > Applications > Utilities > Audio MIDI Setup. An image of Audio MIDI Setup can be viewed here. Click on the "Audio Devices" tab and make sure on the left-hand side that your required recording device (for example, "Built-in Audio") is selected in the "Default Input" and "Properties for" dropdowns. In Audio Input under that, set the "Source" to your physical input (for example, "Built-in Mic). Also ensure the volume slider is turned up. Set the sample rate in "Format" to the project rate bottom left of the Audacity window.
    On OS X 10.1 or earlier, there is no Audio-MIDI Setup: select the correct recording device and input source in Apple Menu > System Preferences > Sound.
  • USB or Firewire single purpose recording devices: Devices such as a USB-connected turntable, microphone or interface will not have choices of inputs. Therefore the Mixer Toolbar dropdown selector will be greyed out and should be ignored. You should still adjust the input level on the Mixer Toolbar, or do so in the operating system mixer if the Mixer Toolbar input volume slider has no effect.
    Warning icon For a USB microphone or interface, it is important to set its sample rate to match with the project rate bottom left of the Audacity window. The rates must match in both the operating system mixer and in any settings in the device's control panel or on any controls on the device itself.


    Further Help:

    • Input source unavailable/unselectable, or records incorrectly: Try selecting it instead in the system mixer - see instructions for Windows and OS X. See also the Linux Mixer Toolbar help.
    • Recording computer playback: See the special help for Windows, Mac and Linux.


    Recording cursor stuck

    If the red recording cursor won't move from the position where you start to record, this usually means you are out of computer resources. Reboot the computer to solve the problem.

    The recording cursor can legitimately appear to be stuck in Audacity Beta if you have accidentally enabled Sound Activated Recording in the Transport Menu. You can tell this is the case because the blue Pause button will be depressed. To disable Sound Activated Recording, click the Transport Menu and uncheck Sound Activated Recording (on/off). To make a Sound Activated recording commence, increase the input level, or reduce the "Activation level" at Transport > Sound Activation Level.


    Clipping

    If you hear crackles, pops, or distortion when the recording is loud, or if the waveform is clearly touching the top and bottom edges of the track, you probably have clipping. Try lowering the record level using Audacity's I/O Sliders, or lower the volume of the input source (like the tape player or microphone, whatever is producing the sound, if it has its own volume control). Many sound card also have an independent volume control for each of the input connections, which gives you another place to adjust.


    Skips

    If it sounds like a second or a fraction of a second is occasionally missing, this means that Audacity is not able to write the audio to your disk fast enough to keep up with what it's recording. Things to try:

    • Redrawing the user interface uses up your CPU time. When you're going to be recording for a long time, try these steps to make sure that your CPU is mostly being used for recording, rather than updating the screen:
      • Zoom out so that you can see at least the entire length you'll eventually be recording; if you're going to be recording 15 minutes, zoom out until you can see 20 minutes on the ruler.
      • Turn off "Autoscroll while playing" in the Interface preferences.
      • Make the Audacity window small
    • Quit all other applications. For Windows users, this may include a lot of the programs that appear in the "System Tray" (in the task bar, near the clock). For example, you probably won't be needing instant messenger programs or the like while you're recording.
    • Don't record stereo unless you have to. Stereo requires your machine to handle twice as much data. A single instrument or solo vocal track should usually be recorded mono. You can position it in the stereo mix later.
    • Throwing hardware at the problem can help. More memory or a higher RPM hard drive might solve the problem. Also, make sure your hardware is optimized for performance (DMA for the hard drive, hardware acceleration for the video, no interrupt sharing for the sound card). Defragmenting your hard drive might help too.
    • If you're using Windows 98, upgrade to a more modern operating system. Windows 2000 / XP or any of the current versions of Linux (such as Ubuntu) have significant improvements in multi-tasking, which often results in no more lost data while running high-utilization programs. Linux in general is more efficient and performs better on hardware that Windows users would consider "slow".
    • Windows 2000 and XP users can create different "hardware profiles". Consider creating a recording profile that turns off all hardware not needed during the recording session. Turning off unneeded hardware keeps the drivers from being loaded, freeing memory and reducing CPU load overhead. Everybody's requirements are different, but possible candidates are:
      • network interface
      • serial and parallel ports
      • CD-ROM
      • USB (unless you're using a USB sound device or mouse)
      • Firewire
      • Floppy drive
    • If you are using a '''GNU/Linux''' system you may be able to fix this problem by running your programs with higher priority. By default, Linux programs run with medium (0) priority. The lower the number, the higher its priority is. Thus a priority 10 process is not as important as a priority -10 process. To set the priority of Audacity to be higher than normal, use a terminal (command line program) to start Audacity with the nice command. For example, to start Audacity with priority (-15), type:
      nice -15 audacity
    • You can also run audacity at a higher priority on Windows 2000 or XP by invoking the Task Manager (CTRL-ALT-DEL) and following these instructions: Click on the Processes Tab. Find the audacity.exe process and right click on it. Highlight Set Priority and set the process to AboveNormal. I don't very often set it to "High", the next highest priority unless I am going to walk away from audacity while it does whatever magic I want it to do and don't care about possibly pre-empting any other processes on the PC.
    • If this still doesn't work, you may want to look into using a different program. Audacity is a decent all-around audio editor, but it is not the most efficient at recording. There are other audio editors out there that are much more efficient and might do better at recording without skipping. See the Links page for some ideas for other audio recording programs, and also see the Other Programs page.


    Background hum or hiss

    see Improving recording quality and Reducing noise.


    Unbalanced stereo recording

    If you are recording a stereo source and the left or right channel is weak or non-existent, first make sure you have Audacity set to record in stereo. Do this by setting "Recording Channels" to "2 (stereo)" on the Audio I/O tab of Preferences. You recorded track will then say "Stereo". Make sure your physical recording connections are tight and that any balance controls on for example your mixer or amplifier are centrally placed. Make sure the left and right channels are balanced in the system mixer. On Windows this is the recording section of Sound, Sounds and Audio Devices or similar in the Windows Control Panel (access it by hitting the Windows key on your keyboard), or on Mac OS X 10.2 or later this is Mac hard disk > Applications > Utilities > Audio-MIDI Setup: Audio Devices.

    If you cannot correct the imbalance at the input stage, then in Audacity, click on the Track Panel above the mute/solo buttons to select all the audio of the track, and click Effect > Normalize. This will scale the volume of each channel independently to -3 dB (3 dB less than the distortion level), so they are at the same volume level. If you then want to adjust the tracks to a higher or lower level (keeping the newly adjusted balance between the channels), use Effect > Amplify. By default (simply click OK in the effect) this amplifies to -0 dB, so making both tracks as loud as they can be without distortion. Note: in the Beta 1.3.x version of Audacity, Effect > Normalize allows you to choose a custom level to normalise to, so you don't need to use Amplify afterwards if want a final level other than -3dB.

    If for any reason the result of normalisation does not sound as you would like it, you can alternatively click on the downward pointing arrow in the Track Panel to reveal the Track Pop-Down Menu  and and choose Split Stereo Track from the menu. This enables you to separately edit and control the left and right channels. Press the green Play button or spacebar and use the -....+ gain sliders on the Track Panels of the left and right channels to adjust the gain on each to your satisfaction as the track plays. Note this is not an edit of the waveform so it won't change appearance, although the gain changes are respected when you export the audio. To edit the waveform itself so you can see what the exported waveform will look like, use Project > Quick Mix (or Tracks > Mix and Render in the Beta version).

    If you are changing the gain on the tracks with the gain sliders, make sure before you export the audio that you don't apply too much gain so that the result distorts. You can check this by looking at the green VU Playback Meter in the Meter Toolbar . Enable this Toolbar on the Interface tab of Preferences if it is not visible: we always recommend using this Toolbar to test the recording level before you begin any recording, so that the overall input level is not too loud or too soft.

    If you prefer to adjust the gain on each track to a precise level avoiding any risk of output distortion, click in the Track Panel of the left channel to select it, Effect > Amplify it to your chosen "New Peak Amplitude" (the box underneath the slider), then repeat for the right channel and amplify that to your chosen New Peak Amplitude. You must amplify both channels separately if you want to change the balance between them.


    Swapping stereo channels, or errors that jump from one channel to the other

    This is occasionally reported by people using Linux who have ALSA installed natively, but are using the OSS version of Audacity. See Linux Issues for details on ALSA support.


    Periodic noise every 6 - 12 seconds

    Audacity writes to disk roughly every 6 or 12 seconds, depending on your settings. If you hear a funny noise in the background that's relatively consistent every 6 - 12 seconds, it means that your soundcard is picking up the noise from your hard drive. See Improving recording quality, because you'll probably need to find a better driver or update your hardware.


    Overdubbed recording drifts out-of-sync, or produces error or poor quality

    If you are overdubbing a recording while playing previous tracks, conflicts between the sample rate of the tracks being played and recorded are possible. There may be "error opening sound device" when starting the overdubbed recording, or the newly recorded track may gradually become more and more out-of-synchronisation with the beat of the existing tracks, or may be of poor quality. To fix this, try the following:

    • Use the same device for playback and recording (not a USB device for recording and the computer sound device for playback or vice-versa)
    • Set the project rate bottom left of the Audacity screen to 44100 Hz (or if your sound card only uses a particular rate such as 48000 Hz, set the project rate to that). Look at Help > Audio Device Info in Audacity Beta to see the rates the device claims to support.
    • If you are on Windows Vista or Windows 7, set the Audacity project rate to the same rate as the "Default Format" for your sound device. To view the "Default Format", go to the system mixer, select the Playback" and "Recording" tabs in turn, right-click over a device entry > Properties, and look in the "Advanced" tab. If the playback and recording format rates are different, make them the same. Also make sure the number of recording channels set in the Audacity Preferences matches with that specified in Default Format. If problems persist, try playing the audio in an application other than Audacity. Try using Audacity Beta if you are not already doing so, choosing Windows DirectSound as the "host" at Edit > Preferences: Devices.
    • Make sure the rate of the pre-existing tracks (as stated above the mute/solo buttons) is the same as the project rate. Select each track and click Project > Quick Mix (Tracks > Resample in Audacity Beta) to resample the track to the project rate.
    • Ensure your computer sound device has up-to-date drivers specifically intended for your particular computer model and operating system, as provided by the motherboard or sound device manufacturer. Driver problems can cause speed and other recording issues.
    • If you are recording with a USB or Firewire interface, sample rates and number of recording channels must be the same everywhere. Match the Audacity project rate and the number of recording channels set in the Audacity preferences with those specified:
    • If you suspect recording dropouts as the cause of loss of synchronisation, read our tips about managing computer resources.

    To fix recordings already made which are out of step with other tracks, you can use Effect > Change Speed; only a very modest speed change will be needed.


    Speed variation while recording

    This is rare, but if you have this problem, it's definitely not software! See Improving Recording Quality.


    HOWTO open a too large audacity project

    Recently i run into a problem where audacity just wouldn't open my 11GB gigantic project. I did a recording of a radio show for about 9 hours. What i did was to divide the project into smaller ones - each about 2 hours. My recording was in stereo, 44100kHz, 16Bit.


    HowTo

    • 1 - make a backup copy of your .aup file (name it project_orig.aup).
    • 2 - make a template copy of your .aup file (name it project_templ.aup).
    • 3 - open project_templ.aup and delete the contents between the <sequence ...></sequence> tags, contained in <wavetrack>. Note that there are 2 <wavetrack> tags in a stereo file!. You'll use this template to copy <waveblock> tags into.
    • 4 - copy project_templ.aup to project.aup, open it and find the attribute "numsamples" in the <sequence ...> tag you already know. divide numsamples value by the number of parts you will divide your project into. i got something like 309000000. i rounded it off to 300.000.000. delete this numsamples="xxx" attribute of the <sequence ...> tag in both channels. audacity seems not to need it.
    • 5 - copy the <waveblock ...> tags until their start attribute value exceed 300000000(x count of repetition) between each <sequence ...> </sequence> tags. note, for a stereo file you'll have to do this twice because there are two seperate channels (contained in wavetrack)... but i already mentioned this.
    • 6 - bhu.. quite large file.
    • 7 - open this project.aup file
    • 8 - When audacity ask you "Project check found XXXX orphaned blockfile[s]. ...", answer with "Continue without deleting" - because this this was just intended.
    • 9 - edit as you need. best thing is to export the file to a new aup project, flac, ogg or whatever.
    • 10 - repeat the steps 5-9 until you're done.
    • 11 - praise audacity because you wouldn't be able to record such a huge project with wavelab on windows.


    System information:

    • Audacity 1.3.7 (from Ubuntu repositories)
    • Ubuntu 9.04 Gnu/Linux
    • ext4 Filesystem