Difference between revisions of "Unitary Project - issue tracking"

From Audacity Wiki
Jump to: navigation, search
(UP-22 Import .aup projects {{done}}: Newly found bug and fix should be tested)
(Contents: 22 cjanged to {{todo}})
Line 25: Line 25:
 
#{{todo}} [[#up20|UP-20 Aliased Projects - Bugs 2188 & 2187]] - ''works fine on Win - yet to be tested on Mac and Linux''  
 
#{{todo}} [[#up20|UP-20 Aliased Projects - Bugs 2188 & 2187]] - ''works fine on Win - yet to be tested on Mac and Linux''  
 
#{{done}} [[#up21|UP-21 Backup command]]  
 
#{{done}} [[#up21|UP-21 Backup command]]  
#{{done}} [[#up22|UP-22 Import .aup projects]]
+
#{{todo}} [[#up22|UP-22 Import .aup projects]]
 
#{{done}} [[#up23|UP-23 Macro commands: Save Copy and Save Project2]]  
 
#{{done}} [[#up23|UP-23 Macro commands: Save Copy and Save Project2]]  
 
#{{done}} [[#up24|UP-24 Timer Record]]
 
#{{done}} [[#up24|UP-24 Timer Record]]

Revision as of 20:52, 22 July 2020

This page is to track the early issues with Unitary Project.
  • Later we may start using Bugzilla.

Contents

  1. Done.png UP-1 initial launch
  2. Done.png UP-2 Save Project grayed-out
  3. ToDo.png UP-3 Drag&Drop - OK on Win and Linux, almost OK on Mac (bug 2437 remains)
  4. Done.png UP-4 more on Save Project
  5. Done.png UP-5 Amplify crashes
  6. Done.png UP-6 Save location and name
  7. Done.png UP-7 new project save name and location
  8. ToDo.png UP-8 last-used location not remembered
  9. Done.png UP-9 error opening empty project
  10. ToDo.png UP-10 timing tests - an ongoing activity
  11. Done.png UP-11 MIDI
  12. ToDo.png UP-12 recent files list - looks OK on Win and Mac, needs testing on Linux
  13. Done.png UP-13 Move and Rename a closed project   Done.png UP-13a Move after Closing
  14. ToDo.png UP-14 Recovery - Needs retesting on all 3 platforms; ToDo.png UP-14a Recovery dialog should show all recoverable projects
  15. Done.png UP-15 cannot update a project
  16. Done.png UP-16 Nyquist EGATs crash
  17. ToDo.png UP-17 Projects can be larger on UP-3.0.0 - an ongoing activity - This should now be corrected as vacuuming at project close has been added.
  18. ToDo.png UP-18 Closing Audacity is slower with UP-3.0.0 - an ongoing activity - This should be much better now. It’s still possible that it will be somewhat slower that 2.4.2 since vacuuming may occur. But, when it doesn’t closing should be just about the same as 2.4.2.
  19. Done.png UP-19 Easier opening and deleting
  20. ToDo.png UP-20 Aliased Projects - Bugs 2188 & 2187 - works fine on Win - yet to be tested on Mac and Linux
  21. Done.png UP-21 Backup command
  22. ToDo.png UP-22 Import .aup projects
  23. Done.png UP-23 Macro commands: Save Copy and Save Project2
  24. Done.png UP-24 Timer Record
  25. ToDo.png UP-25 Test disk-space exhaustion
  26. ToDo.png UP-26 Stress Tests- an ongoing activity
  27. Done.png UP-27 Deleting, Moving renaming active project files
  28. ToDo.png UP-28 Use of OS to create a copy project - OK on Win and Mac just needs testing on linux
  29. ToDo.png UP-29 Save Project does not propagate project name to Audacity window - OK on Win and Mac, untested on Linux
  30. ToDo.png UP-30 On Mac second use of Save Project as has bad name/location - Leland 18Jul20: This seems to be working fine now.
  31. ToDo.png UP-31 X-platform compatibility of AUP3 project files
  32. Done.png UP-32 Backup Projects show error on opening
  33. ToDo.png UP-33 History window shows misleading "space used"
  34. ToDo.png UP-34 Dirty Project-1 Corrupted unopenable project
  35. ToDo.png UP-35 Dirty Project-2 bloat retention
  36. ToDo.png UP-36 Failure to Save new empty project - OK on Win needs retesting on Mac and testing on Linux
  37. Done.png UP-37 Crash with an empty project
  38. ToDo.png UP-38 Default File Save Location
  39. Done.png UP-39 First use of Save Project crashes Audacity and infinite recovery
  40. UP-40
  41. UP-41
  42. UP-42
  43. UP-43
  44. UP-44
  45. UP-45
  46. UP-46
  47. UP-47
  48. UP-48
  49. UP-49
  50. UP-50


UP-01 - initial launch Done.png

Done.png initial launch message

On initial launch I got a message asking if I wanted to associate .aup3 files with Audacity to click on for launch.

I never normally see such a message with any new versions. I don't get this on Mac Catalina. Leland says that this is expected behavior.


UP-02 - Save Project grayed-out Done.png

Done.png initial launch Save Project grayed-out on Win, Mac & Linux

This was a regression on 2.4.2 and earlier.


UP-03 - Drag&Drop ToDo.png

ToDo.png Drag&Drop

Done.png On Windows I can drag&drop an .aup3 file onto the Audacity app icon on my desktop and it launches - but I still can't drag&drop it onto an open Audacity project

  • Done.png Drag&Drop of an .aup3 file onto an audacity.exe in Windows Explorer or a desktop shortcut icon for it
  • Done.png Drag&Drop of an .aup3 file onto an open Audacity Window adds that project to the open project.
  • Done.png Drag&Drop of an .aup file onto an open Audacity Window succeeds (it adds to the open project)

ToDo.png On Mac I can't drag&drop onto either the Audacity icon in the apps bar or an open Audacity project

  • ToDo.png Drag&Drop of an .aup3 file onto an Audacity app in Finder or the Audacity icon in the apps bar
    Bill 17Jul2020: This behaviour is the same as 242 on Catalina. Drag&drop an AUP or audio file onto the Dock icon or Application icon when Audacity is not running (in 242) works. Do the same when Audacity is running and it does not work. Same now in 300. So it looks like we need to address the underlying issue on Catalina. This is bug 2347.
  • Done.png Drag&Drop of an .aup3 file onto an open Audacity Window fails
    Bill 17Jul2020: This now kind of works. Drag&drop an AUP3 into an empty Audacity window results in the project opening, but the project remains "untitled" (window title bar still reads "Audacity"). Closing the project window results in a "Save changes?" dialog. Surely this should just open the project, the same as File > Open.
    Bill 18Jul2020: Testing with e669b36, drag&drop an AUP3 file onto an empty project window results in the window taking on the name of the file. Closing the window gives a "save changes" dialog. I think this is OK - any drag&drop of any file into a project window (empty or not) should be considered an import.
  • Done.png Drag&Drop of an .aup file onto an open Audacity Window - behaviour unknown for now
    Bill 17Jul2020: Again, this kind of works. Drag&drop an AUP file into an empty project window and the AUP is imported, but the project window remains "Audacity". Seems to me the project name and window title should become the name of the AUP project that was imported. However you can drag&drop an AUP file into a non-empty project window and the AUP project will be imported into new tracks. So perhaps the project should remain untitled in these cases.
    Bill 18Jul2020: As above - this works. Any drag&drop of any file into a project window (empty or not) should be considered an import.
  • ToDo.png Bill 18Jul2020: In the above two cases, on closing and accepting to save changes, the file-save dialog box has no default name. I believe 242 would offer the window title as the default save file name. Shouldn't 300 do this?

Done.png On Linux: Steve wrote "I've tested drag & drop with simple AUP and AUP3 on Linux, and both work"



UP-04 - more on Save Project Done.png

Done.png Once the initial Save As has been made - the for subsequent saves the Save Project is no longer grayed out and I can use it to save.


UP-05 - Amplify crashes Done.png

Done.png Amplify works on Mac

Done.png Amplify works on Linux

Done.png Amplify works on W10 - and still does with Audacity 3.0.0 e7fd679



UP-06 - Save location and name Done.png

I imported a file with drag&drop from my desktop, when I went to Save the Project I was offered

a) a very unsuitable location "Session Data" folder - should be last used save location or default location if first ever save

b) a rather oddly constructed name ...

Done.png Windows - Location offered is Documents\Audacity and the offered name is left blank

Done.png Mac - Location offered is Documents - offered name is left blank.

BUT on Mac it's always Documents after relaunching Audacity. While Audacity remains open the last-used location is remembered, bur is lost when Audacity is closed. See UP-08 below.

Done.png Linux - Location offered is Documents - offered name is left blank.


UP-07 - new project save name and location Done.png

Done.png Saving a new project - odd name (based on temp file) and location (Session Data) offered

Done.png Windows

Done.png Mac

Done.png Linux


UP-08 - last-used location not remembered ToDo.png?

ToDo.png Windows: it's always \Documents\Audacity after relaunching Audacity. While Audacity remains open the last-used location is remembered, but is lost when Audacity is closed.

ToDo.png Mac it's always Documents after relaunching Audacity. While Audacity remains open the last-used location is remembered, but is lost when Audacity is closed.
Bill 19Jul2020:

  1. Start Audacity (I was using commit d2b4a0e)
  2. Import or generate some audio
  3. File > Save Project > Save Project
  4. Note the default location
  5. Save the project in a location other than the offered default location
  6. Close the project
  7. New project
  8. Import or generate some audio
  9. File > Save Project > Save Project
  10. Note that the default location is the one from step 4, NOT the one chosen in step 5

Shouldn't the default location be the last one used? In this situation the default location will never change from the one offered in step 4.

Note that if you save a project from 2.4.2, the default location is changed even for 3.0.0.

Is this just a simple oversight about writing to the CFG file?

Also note that for File > Import > Audio the last location used is offered as the default location for subsequent imports.

ToDo.png Linux - it's always Documents after relaunching Audacity. While Audacity remains open the last-used location is remembered, but is lost when Audacity is closed.


UP-09 - error opening empty project Done.png

Mac

Done.png On Mac now works with Audacity 3.0.0 51b3b0f

Linux

Done.png Linux can open an empty project.

Windows

Done.png works properly on W10 with Audacity 3.0.0 e7fd679


UP-10 - timing tests ToDo.png

ToDo.png further X-platform testing later

Done.png Some preliminary timing tests on W10 with Phase-1 build

UP-3.0.0 is a little slower than 2.4.2 right now 0 except for MP3 export which seems bang on the money.

Amplify takes more than double the time though.

Test file is a 3-hour stereo audio file

UP-3.0.0

  1. Import 3-hour WAV 1:31
  2. Amplify 3-hour audio 2:07
  3. Export 3-hour WAV 2:16
  4. Export as 3-hour MP3 4:36
  5. Import 3-hour MP3 2:07

2.4.2

  1. Import 3-hour WAV 0:50
  2. Amplify 3-hour audio 0.50
  3. Export 3-hour WAV 1:30
  4. Export as 3-hour MP3 4:35
  5. Import 3-hour MP3 1:12


Peter 15Jul20: I did some further timing tests on my Zurich PC today. Also an i7 256 SSD machine, but it seems faster than the HP Envy I have in Manchester for the 2.4.2 tests.

UP-3.0.0 2accd9e

  1. Import 3-hour WAV 0:35
  2. Amplify 3-hour audio 0:44
  3. Export 3-hour WAV 1:12
  4. Export as 3-hour MP3 3:37
  5. Import 3-hour MP3 1:03

2.4.2

  1. Import 3-hour WAV 0:15
  2. Amplify 3-hour audio 0.18
  3. Export 3-hour WAV 1:07
  4. Export as 3-hour MP3 3:40
  5. Import 3-hour MP3 0:45


UP-11 - MIDI Done.png

Done.png MIDI

On both W10 and macOS Catalina I can

  • import MIDI files
  • play MIDI tracks


UP-12 - recent files list ToDo.png

On Mac the Recent Files list is a bit iffy (Steve said the same about Linux)


Leland 07Jul20 Temporary filenames are showing up in the file history. Haven't looked into why as yet.

Leland 18Jul20 I believe the file history is behaving much better now. Paul fixed the temporary filename issue.

Done.png looks OK on W10

Done.png looks OK on Mac

ToDo.png to be tested on Linux


UP-13 - Move and Rename a closed projectDone.png

Done.png Move and Rename

On W10 and mcOS Catalina I can:

  • rename a .aup3 file
  • move a .aup3 file to a different folder

and in both cases Audacity successfully opens it.

This is GREAT - as this is a tangle with old projects where losers could trip up and lose/damage their projects.


UP-13a - Move after Closing Done.png

It's unclear if this is a bug or desired behaviour. It will go away if we clear the clipboard on closing a project. Paul is very very keen on keeping the clipboard around after closing the Audacity project.

Paul 07Jul20 I'm no longer very keen: I wanted to keep old behavior if it was not difficult to do safely, but now I have been persuaded that there are enough hidden difficulties.

And Paul has now fixed this. RM is fine with the tiny 'regression', that you can close a project and lose a clipboard that previously would have hung around until you close Audacity (and that caused all sorts of problems).


UP-14 - Recovery ToDo.png

Leland 18Jul20: This should all be retested since many changes have been made that would have affected Recovery.

Windows

Done.png Recovery needs retesting

Mac

Done.png Recovery needs retesting
Bill 22Jul2020: This is fixed with commit 0c14e61
Bill 21Jul2020:
With commit 73c6225

  1. Start Audacity
  2. Get some audio into the project
  3. Force Quit
  4. Start Audacity
  5. You get the “Automatic Crash Recovery” dialog
  6. Click Recover Projects
  7. You get the “Project Recovered” dialog - click OK
  8. The project is recovered and the title bar says “Audacity”
    - this looks like a typical “unsaved” project, so I should be able to do Cmd+S to save and name it
  9. Do Cmd+S
  10. You do not get a Save As dialog, instead the file is saved to the SessionData folder and the title bar displays “New Project <date time> N-1”
    Bill 22Jul2020: You now get a Save As dialog and the files in SessionData are deleted
  11. Session data contains two files one of which is "New Project <date time> N-1.aup3unsaved”
  12. Quit - no save required
  13. Start Audacity
  14. You get the “Automatic Crash Recovery” dialog - click “Recover Projects”
    Bill 22Jul2020: This is fixed
  15. The project is recovered and the title bar says “New Project <date time> N-1”
  16. Quit - no save required

Linux

ToDo.png Recovery needs retesting

ToDo.png Peter 19Jul20: Bill tested on Mac

  1. Create new AUP3 project
  2. Create or import some audio
  3. Save the project
  4. Make several edits
  5. Force quit Audacity
  6. Open the project
  7. Observe: “Project Recovered” dialog
  8. Observe: it seems to be recovered to the state where the Force Quit was done
  9. Do some more edits, or not - makes no difference
  10. Close the project without saving changes
  11. Observe: note that the WAL file is deleted
  12. Open the project
  13. Observe: “Message: Failed to retrieve samples" - project is now dead

Should there be a stern warning in the recovery dialog to save the project or it will be damaged forever? Maybe we could save it for them?

The project is useless unless saved, so I say do it for them.


UP-14a - Recovery dialog should show all recoverable projects ToDo.png

Use Case: user has five open projects, two are saved three are unsaved, Audacity crashes.

Peter 22Jul20: I also still have strong misgivings that in a recovery dialg after a crash the two saved projects are not listed as recoverable. If they were listed there in that recovery dialog, the recovering of all five projects and getting back (almost) to the state at crash would be simple acceptance of the recovery.

As it is with this use case the user has to get automatic recovery of there unsaved projects and then fanny around with extra clicks to open the two saved projects (I can hear dear ol' Gale complaining - "oh my poor old RSI" - and here I'm minded to agree with him).

The other reason for wanting to list all recoverable files (including saved projects) is that at Step 18 looking at the recovery dialog the poor old baffled user might think:

"Just now I had five open projects and now only three are recoverable
What's happened to the other two - have I lost them ?"

I foresee several anguishedForum posts from Mr./Mrs./Ms. A.Confused-User

"What's happened to my other projects after Audacity crashed ?"

I agree that for the use case of a single open project that is saved - then it would seem reasonable to think that it is not necessary for the user to see a recovery dialog. But in the Multi-Project-Wormcan use case I outlined above it is a different matter.

So now I *strongly* think that all recoverable projects should be listed in a recovery dialog that should be shown on Audacity relaunch after a crash.


UP-15 - cannot update a project Done.png

Windows

Done.png works properly with Audacity 3.0.0 e7fd679

Mac

Done.png works properly with Audacity 3.0.0 e08fb5e

Linux

Done.png works properly with Audacity 3.0.0 e08fb5e



UP-16 - Nyquist EGATs crash Done.png

Done.png With Phase-2 Audacity 3.0.0 e7fd679 these all now work. I'm guessing that the fix for Amplify crashing also cured all these.

Phase-1 On Windows and Mac most shipped Nyquist effects, generators, analyzers and tools crash Audacity.

The only three that work are

  • Tremolo
  • Vocoder
  • Rhythm track

Done.png All above the line effects, generators and analyzers work


Done.png Linux - All effects and generators tried so far (including the above three) work correctly.


UP-17 - Projects can be larger on UP-3.0.0 ToDo.png

Initially Projects in UP-3.0.0 could be much larger than the equivalent project in 2.4.2

Re-test later

ToDo.png we will need to retest later as the UP development project progresses

Projects are slightly larger as they develop on 3.0.0 than 2.4.2 - but on exiting Audacity 2.4.2 releases space whereas 3.0.0 does not. "Vacuuming" is what is needed, but when and with what trigger(s)

Leland 18Jul20: This should now be corrected as vacuuming at project close has been added.

Windows

Done.png testing on Audacity 3.0.0 6c2cd20 - the bloat-space is released on exit from Audacity (it is slow though seeUP-18)

Testing with a 5 hour mono chirp

  • Audacity 3.0.0 0fbabb0 the .aup3 file occupies 3.134GB
  • Audacity 2.4.2 the ,aup and data folder occupy 2.99GB

This for me is within acceptable limits

ToDo.png retest

Mac

Done.png testing on Audacity 3.0.0 6c2cd20 - the bloat-space is released on exit from Audacity (it is much quicker than Windows)

Done.png Bill 18Jul2020: Testing with e669b36: 2.4.2 AUP +_data is 100 KB + 675.2 MB; 3.0.0 AUP is 680.7 MB. Bloat is removed on close.

Linux

Done.png with Audacity 3.0.0 6c2cd20 - the bloat-space is released on exit from Audacity

ToDo.png retest


UP-18 - Closing Audacity is slower with UP-3.0.0 ToDo.png

ToDo.png further X-platform testing later

Leland 18Jul20: This should be much better now. It’s still possible that it will be somewhat slower that 2.4.2 since vacuuming may occur. But, when it doesn’t closing should be just about the same as 2.4.2.

Windows

Done.png Testing on W10 with Audacity 3.0.0 0fbabb0 - seems fast enough to me and with a good progress dialog

ToDo.png retest

Mac

Done.png But Exit or Quit on Mac is much faster than on W10 taking a mere 3-4 seconds cf. 20-plus seconds on W10 with the same project steps.

  • Is this acceptably fast for a one-hour mono project ?

Done.png retest Bill 18Jul2020: Testing with e669b36. 680 MB project, duplicate stereo track, amplify duplicated track (doubles project size), delete track, close and save. Vacuuming takes less than 2 seconds. Acceptable.

Linux

ToDo.png Better than before. It's still slower than 2.4.2, which was virtually instant, but nowhere near as slow as it was initially.

I've not tested this extensively, but closing a saved project seems to take a lot longer than closing an unsaved project.

Done.png retest


UP-19 - Easier opening and deleting Done.png

Done.png It's much easier to find projects for opening and for deleting them

I'm finding that just after a couple of days testing the UP is much easier to manage:

  • Open: only one thing to look for, you don't get confused trying to "Open" the data folder
  • Delete: also only one thing to look for - and on W10 at least the folders and files are always separated so tour aup could be a long way away from its data folder (which could lead to fumble-fingers trouble)


UP-20 - Aliased Projects ToDo.png

It is possible that some users may still have projects that are relying on aliased files - and note that ODL has been removed from 3.0.0

  • Done.png P1 Bug #2188 ENH: No warning is given on project opening that the project is not self-contained and relies on aliased file(s
  • P2 Bug #2187 - Silent crash with no error message when using a missing aliased audio file
    • Done.png Windows: works fine on W10 with Audacity 3.0.0 2accd9e
    • Done.png Mac: Bill 22Jul2020: With commit 7bb2417. With missing alias file, a warning is given. With alias file found it is silently copied in - is this what we want to do? In the manual perhaps note that this happens. 2.3.2 was the last version that supported alias files.
      • Peter 22Jul20:I think it's fine that we silently copy in and make a consolidated project in this opaque fashion.
    • ToDo.png Linux: still to be tested


UP-21 - Backup command Done.png

Done.png new Backup Project command

In 3.0.0 Save Compressed Copy of Project and Save Compressed Copy of Project

QA discussed the Backup Project issue and rapidly reached agreement.

1) QA likes the short form of the command File > Save Project > Backup Project

2) And QA agrees that there should be no overwrite of backup projects (or any other projects with the Backup command).

Accordingly the current error message used for the deprecated Save Lossless... and Save Compressed... can be used as-is:


UP-22 Import .aup projects ToDo.png

ToDo.png We need an import utility for .aup projects from Audacity 2.4.2 and earlier.
Bill 22Jul2020: There was an AUP import bug that was fixed in commit 7bb2417 so this should probably be retested
This is what I found.

  1. In Audacity 2.4.2, import or create a stereo track with exactly 5 minutes of audio
  2. Save the project
  3. Quit 2.4.2
  4. Start Audacity 3 commit 0c14e61
  5. Open the project from step 2
  6. Zoom into the end and play the last 10 seconds of the track
  7. Observe - there is audio missing from about 4m 57.215s to the end
  8. The waveform is there but if you zoom in far enough the waveform disappears - not even a flatline
  9. If you now zoom out and select the entire track and do Repeat with 3, you will see gaps between the repeats.
  • ToDo.png Windows - works properly - can be opened or imported
  • Done.png Mac - Bill tested the actual importing when he worked on UP-03. The only thing he did do was the “File -> Import…” bit.
    Bill 18Jul2020: Did File > Import > Audio, selected an AUP file, imported fine.
    Bill 22Jul2020: tested with commit 7bb2417 - working fine.
  • ToDo.png Linux - Steve reported by emails that this works properly

See UP-20 Aliased Projects


UP-23 - Macro commands Done.png

  • Done.png the new backup Macro command "Save Copy" offers a file with extension .aup and not .aup3
  • Done.png the existing Macro command "Save Project2" offers a file with extension .aup and not .aup3

The new backup Macro command "Save Copy" appears to effectively be a duplicate of "Save Project2"

  • Leland 07Jul20: it’s really not a duplicate (I had the feeling at first too). The difference is that once “Save Project2” writes out the new file, that file becomes the active one. With “Save Backup” the original file remains the active one.


UP-24 - Timer Record Done.png

Done.png Timer Record works fine.

Tested with Automatic save and Automatic Export


UP-25 - Test disk-space exhaustion ToDo.png

ToDo.png check that disk-space exhaustion error traps still work properly.

Paul indicates that this may have changed with SQLite 3.0.0 - so needs re-checking.

  • ToDo.png Recording
  • ToDo.png Save Project
  • ToDo.png File Export


Leland 07Jul20: On Windows we get an exception loop. On Linux we get an unhandled exception. On OSX it's a bit weird. We don't get a crash, but some of the menus no longer work...like I can't Quit even though the menu item appears to be available.

UP-26 Stress Tests ToDo.png

  • Done.png Very long projects
    • Peter 14Jul20: Overnight I tested a Timed Recording of 5 hours and dis the production work to whittle it down to the required 2 hours and exported - all on Audacity 3.0.0 0fbabb0. Audio was fine - I had a label track issue that I can't now reproduce.
  • Done.png Simultaneous playback and recording
    • James requested: Can you do some testing of play-through record please Peter? The point there is that we are both reading and writing the database, so there might possibly (low probability) be new issues around lock files. It's unlikely, but let's find out. So for worst results, play back a mix of 4 stereo channels, and record stereo and at the highest sampling rate your card offers at the same time. If we're unlucky this might get SQLite in a twist. It might try to do things in big batches and lock us out for too long.
    • This worked fine on W10 with my Edirol UA-1EX
  • ToDo.png Projects with many, many, tracks


UP-27 Deleting, Moving renaming active project files Done.png

Lelean 18Jul20: As I mentioned in some emails, there’s no real way to prevent the deleting or movement of “.aup3” or “.aup3-wal” files on Linux or OSX. Only thing you can do is give a stern warning in the manual.

Done.png make sure there is a stern warning in the Manual for Mac and Linux Peter 20Jul20: Done seethis page on managing Audacity projects

Windows

Done.png Audacity prevents Deleting, Moving or renaming active project files: .aup -wal and -shm while a project remains open

Mac

You can delete the AUP3, -wal and -shm

Linux

You can delete the AUP3, -wal and -shm on Linux.




UP-28 Use of OS to create a copy project ToDo.png

Leland 18Jul20: This should be the same on all platforms. You can copy the AUP3 file around all you like...just don't do it while Audacity has it open.

Done.png Windows: use Windows Explorer to copy a project. Open it with Audacity

Done.png Mac: use Finder to copy a project. Open it with Audacity - works OK

ToDo.png Linux: behavior unknown

ToDo.png issue a stern warning in the Manual for: "just don't do it while Audacity has it open"


UP-29 Save Project does not propagate project name to Audacity window ToDo.png

ToDo.png Save Project does not propagate project name to Audacity window This is a regression on 2.4.2

Done.png Windows: Testing on W10 with Audacity 3.0.0 2accd9e - this now works properly

Done.png Mac: Testing on macOS with earlier Audacity 3.0.0 b12fafb

  1. If I use Save Project
    • the project is saved with the correct name
    • but the project name does not propagate to the top banner of the Audacity window, ir remains as "Audacity"
  2. If I use Save Project As - then the project name does NOT propagate to renaming the banner.

Bill 22Jul2020: commit 7bb2417 - works fine now

  1. New project
  2. Record something
  3. Save
  4. Get Save-As dialog - name the project
  5. Window title bar is changed to the saved name
  6. Save Project As
  7. Get Save-As dialog - name the project
  8. Window title bar is changed to the new saved name

ToDo.png Linux: behavior unknown


UP-30 On Mac second use of Save Project As has bad name/location ToDo.png

Leland 18Jul20: This seems to be working fine now.

Done.png On Mac second use of Save Project as has bad name/location

Bill 18Jul2020: With build e669b36 the second Save As offers the project name as the default file name, and defaults to the folder where the project was last saved.

On Mac when I first use Save Project As I get a blank filename offered and Documents as the location (which is good)

When I next use Save Project As a) The location offered is Session Data (this is bad) b) The project name field has: New Project 2020-07-10 11-53-11N-2.aupunsaved.aup3 - which looks like a temp filename c) Pressing Save button saves it with that rubbishy file name

Windows is not similarly affected

ToDo.png Linux behavior is unknown.

Done.png Windows - works fine


UP-31 X-platform compatibility of AUP3 project files ToDo.png

Paul raised this issue by email.

James replied:

  • We do not expect it to be cross platform at the moment. Our integers are the wrong way round.
  • As RM I expect us to be revisiting the binary format and using a fixed endianness.
  • It will not hurt performance.
  • I also expect to use a more compact autosave format than now, but not zipped, better for recording, and to be doing that during 3.0.0.

Windows

  • ToDo.png Windows => Mac
  • ToDo.png Windows => Linux

Mac

  • ToDo.png Mac => Windows
  • ToDo.png Mac => Linux

Linux

  • ToDo.png Linux => Windows
  • ToDo.png Linux => Mac


UP-32 Backup Projects show error on opening Done.png

Steve wrote by email: I'm frequently seeing the error message when opening a backup:

"This project was not saved properly the last time Audacity ran.
It has been recovered to the last snapshot."

Steps to reproduce:

  1. Launch Audacity
  2. Generate "Chirp"
  3. "Save Project" - name it "a"
  4. "Amplify"
  5. "Backup Project" - name it "b"
  6. "Undo" (undo Amplify)
  7. "Undo" (Undo Chirp)
  8. Generate "Tone"
  9. "Save Project" (updates "a")
  10. Exit Audacity
  11. Relaunch Audacity
  12. "Open" -> select project "b".
  13. Observe: "This project was not saved properly the last time Audacity ran. It has been recovered to the last snapshot."

Steve 13Jul20: fixed in commit 6f233cbff

  • Peter 13Jul20: Confirmed on W10 with Audacity 3.0.0 6f233cb
  • Bill 22Jul2020: Confirmed fixed on Mac with commit 7bb2417


UP-33 History window shows misleading "space used" ToDo.png

The "Total space used" in the History window may indicate much less than the size on disk.

Steps to reproduce:

  1. Generate 1 hour Rhythm Track
  2. Save Project
  3. Undo
  4. Generate 1 second "pluck"
  5. Observe: The project size is over 600 MB with 1 second of audio and hardly any Undo history (only the "Pluck").
  6. Observe: "View menu > History" shows: "Total space used: 172.3 KB"

Proposal:

  1. For the History window to indicate both "total space used" and "size on disk" for the project.
  2. For the History window to provide an option to "compact project" (vacuum the project) to reclaim disk space.


Peter 16Jul20: Steve wrote by email: This is looking better, but I'm not sure that compacting is working correctly.

I've been playing with a project, adding long tracks and deleting them to build up a large database, then deleting all tracks and generating a 1 second "ping".

  • On saving and closing, the AUP3 file was 1.3GB.
  • On "compacting" with "DB Browser for SQLite", the file size went down to 524.3 kB (524,288 bytes).

The checkbox "Compact at close" is selected.


UP-34 Dirty Project-1 Corrupted unopenable projectToDo.png

Corrupted unopenable project

  1. Import some audio.
  2. Save and name the project - note file size
  3. Close the track.
  4. Generate something
  5. Close the project
  6. “Save Changes?” - No
  7. Observe: project is compacted - note file size has changed
  8. attempt to open the project
  9. Observe: "Message: failed to retrieve samples”

Reported by Bill on Mac, confirmed by Peter on Windows

Bill 17Jul2020: With build _1f87d4f, at step 7 the file size does not change significantly; at step 9 the project opens properly showing the audio imported in step 1.

UP-35 Dirty Project-2 bloat retentionToDo.png

Unremovable database bloat.

  1. Import some audio.
  2. Save and name the project - note file size
  3. Add new mono track
  4. Generate something (substantial - like 30 minutes) into it
  5. Close the project
  6. Observe: note file size has increased
  7. “Save Changes?” - No
  8. Observe: project is not compacted
  9. Observe: file size indicates that the samples for the generated track are stored in the file
  10. Open the project
  11. Observe: the generated track is not there, as expected

There seems to be no way to get rid of the bloat.

Reported by Bill on Mac and confirmed by Peter on W10

Bill 17Jul2020: with build 1f87d4f there is no bloat at step 9; seems fixed

later on Windows

Peter 21Jul20: Testing on W10 with Audacity 3.0.0 73c6225 However I managed to get bloat retention with testing bloat size.

  1. Open a 2-hour saved project: 2.49 GB
  2. Apply 5 effects - observe bloat groes 2.4/effect: 14.979 GB
  3. Save Project (no bloat removed, as expected): 14.979 GB
  4. Windows Explorer shows file still bloated: 14.979 GB
  5. Relaunch and Open project: 14.979 GB
  6. Save Project: 14.979 GB
  7. Exit - project size remains at: 14.979 GB
  8. Observe: massive bloat is retained


UP-36 Failure to Save new empty project ToDo.png

  1. Launch Audacity
  2. File > Save Project > Save Project (or Save Project As)
  3. Observe: error message disk full or unwritable
  4. Record a little, or import audio
  5. Delete the new track (to empty project)
  6. File > Save Project > Save Project
  7. Observe: warning - your project is empty
  8. Click "Yes"
  9. Observe: empty project is now saved (and tests Ok on reopening)

Note that at Step 4 if you just add a new empty track, this still fails at Step 9 with the error message disk full or unwritable

Tests were on W10 with Audacity 3.0.0 6ffced4

Done.png Windows: this now works fine on Windows with Audacity 3.0.0 d2b4a0e

Done.png Mac: Bill 17Jul2020: With build 1f87d4f, no error after step 2; at step 7 get warning "Your project is now empty..."; click Yes, project is saved.

ToDo.png Linux: current behavior unknown - needs testing

This is a regression on earlier 3.0.0 alpha builds - but there is a possibility that this may be a Microsoft issue - as they served me with yet another security upgrade this morning.

Bill 17Jul2020: Confirmed on Mac with build c174b25



UP-37 Crash with an empty project Done.png

Peter 20Jul20: Tested on W10 with Audacity 3.0.0 d2b4a0e

  1. Launch Audacity
  2. File > Save Project > Save Project
  3. Observe: crash
  4. Relaunch Audacity
  5. File > Open
  6. Note that the Save at step 2 produced an AUP3 file
  7. Open that file
  8. Observe: crash

Done.png Testing on W10 with Audacity 3.0.0 5652b9b - this works fine
Bill 22Jul2020: testing on Mac with commit 0c14e61 this works fine

UP-38 Default File Save Location ToDo.png

Bill 20Jul2020: If the audacity.cfg contains the preference "[SaveAs]<newline>Path=/Users/<etc>" then 3.0.0 will use that as the default save-as location.

Version 2.4.2 ignores this setting and instead uses "DefaultOpenPath=/Users/<etc>" for the default save-as location.

Furthermore, version 3.0.0 does not write to this setting when using a different save-as location. The upshot is that a user of 3.0.0 will always get the location from the "[SaveAs]" setting (if they have one - apparently starting with a virgin CFG this setting will never be created).

IMO 3.0.0 should behave the same as 2.4.2 unless we decide otherwise. In any case the current behaviour of 3.0.0 is unacceptable.

There may be a bugzilla enhancement request for user preferences for default Open / Save / Export / Export Multiple paths.

ToDo.png Mac


ToDo.png Linux


ToDo.png Windows

UP-39 First use of Save Project crashes Audacity and infinite recovery Done.png

Testing on W10 with Audacity 3.0.0 7e9a3f4

Using Save Project, first use of Save Project crashes Audacity.

  1. Launch Audacity 3.0.0 7e9a3f4
  2. Generate > Chirp
  3. Save Project
  4. Observe: Audacity crashes - leaves WAL and SHM files hanging around
  5. relaunch
  6. Observe: recovery dialog
  7. accept recovery
  8. Observe message "This project was not saved properly the last time Audacity ran. It has been recovered to the last snapshot."
  9. Observe: 30 minute chirp looks intact
  10. Save Project
  11. Observe: no crash this time
  12. Exit (project should be "clean")
  13. Observe: WAL and SHL files STILL hanging around
  14. relaunch
  15. Observe: recovery dialog again

And you can go round and round this recovery loop.

Plus, once again, when I try to use Save As or Backup I get offered "Session Data" as the location !

Bill 22Jul2020: with commit 0c14e61 this is fixed on Mac

Peter 22Jul20: Fixed with Audacity 3.0.0 7bb2417

UP-40

UP-41

UP-42

UP-43

UP-44

UP-45

UP-46

UP-47

UP-48

UP-49

UP-50